Message issued on Resolve of tickets

We have already run into an issue where users respond to email notifications indication their ticket has been resolved. Of course, being polite, they reply with a thank you which reopens the ticket. I’m interested in amending the message that goes out in that status change notification to include a DO NOT Reply to this email. Any idea where I can do this?

Admin>Global->Templates then you can find the email template the “on resolve” scrip or correspond scrip is using

This extension https://metacpan.org/pod/RT::Extension::RepliesToResolved might also be helpful.

In my resolve template scrip I have a giant 16-point bold font that says **PLEASE DO NOT REPLY TO THIS ** and people STILL do it all the time.

Just thinking out loud here, and I should hasten to say I’ve not tried this myself, but could you include an explicit Reply-To header in the template that points to something duff that won’t touch RT (such as no-reply-this-does-not-exist@yourorg.com)? Lots of mail user agents will use that header to reply to and you could direct them away from RT (unless of course RT overrides it, which it might - I’ve not checked!).

It’s tough to decide what to do (except to just generally put up with it and re-resolve) because I want to leave the option for requesters to reopen tickets if they do see the problem again but just not with a “thank you”. What I should really do is create a scrip that resolves “silently” without sending a message or just make that the default for resolving.

That’s the exact solution I’m looking for…something that would change the header from “name” VIA RT to “name” VIA DoNotReply! You wouldn’t happen to know who to do this would you?

I believe what GreenJim was suggesting is editing which ever resolve email template you use, for example “Resolved in HTML” and adding a header like this:

Subject: Resolved: {$Ticket->Subject}
Content-Type: text/html
Reply-To: not-a-real-address@example.com

Then the reply back should go to that nonexistant email, if that works though it causes the issue of users can’t re-open tickets once they are resolved

I didn’t test this too much, but I whipped up an extension really quick if people want to try this out:

It adds a new action to the tickets actions dropdown menu called “Resolve Silently”. When that action is clicked the ticket is set to status resolved and no scrips run

1 Like

Our solution was to just disable the script Correspondence on Inactive tickets…that way, the response still goes through to the ticket handler, but doesn’t change the status of the ticket