Mason unicode utf-8 BOM - junk in component output

I’ve been playing around with converting some of the mason components to
utf-8, but I’ve found I keep getting the BOM (byte-order-marker)
displayed on the page (as two rubbish characters preceeding the
components output). I can save files as BOMless (using ultraedit),
which seems to solve the problem, but it doesn’t seem like a very
sensible solution.

Does Mason support modules in utf-8 ? Is it a system setting (I’m using
freebsd)? I have the mason baboon book, but I can’t find anything about
unicode, utf-8 or internationalization there. I know the po files are
utf8, but since I’m (admittedly short-signtedly) writing only for a
German-language site, I’d prefer not to have to put everything in the po
files.

Any help much appreciated.

Boldra

Greencircle

As BOM is useless in UTF-8 files, since UTF-8 independand from
byte-order you can use files without BOM, but sure it looks more like
Mason problem and if BOM is required in your environment then it’s
better send question to mason’s lists.On 6/16/06, Boldra paul@boldra.com wrote:

I’ve been playing around with converting some of the mason components to
utf-8, but I’ve found I keep getting the BOM (byte-order-marker)
displayed on the page (as two rubbish characters preceeding the
components output). I can save files as BOMless (using ultraedit),
which seems to solve the problem, but it doesn’t seem like a very
sensible solution.

Does Mason support modules in utf-8 ? Is it a system setting (I’m using
freebsd)? I have the mason baboon book, but I can’t find anything about
unicode, utf-8 or internationalization there. I know the po files are
utf8, but since I’m (admittedly short-signtedly) writing only for a
German-language site, I’d prefer not to have to put everything in the po
files.

Any help much appreciated.

Boldra

Greencircle


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: http://bestpractical.com/about/jobs.html

Best regards, Ruslan.

Thanks Ruslan, I’ve found the setting (on by default) in ultraedit to
not automatically add BOMs unless asked for, and it’s now working fine.
(Advanced->Config->file handling->Save->Write utf-8 BOM header to ALL
utf-8 files when saved)

Boldra

Ruslan Zakirov wrote: