MASON_SESSION_PATH - Win32

Dear All,

I am trying to install RT on Win32. Whenever I try to access the RT i
get this error log in apache as “Can’t read and write
@MASON_SESSION_PATH@”. Please loet me know as to where am i supposed
to set the value for the MASON_SESSION_PATH.

Details:
Win 2000
Apace 1.3
MySQL 4.0.14
FCGI
RT 3.0.12

Thanks in advance.

Regards,
Murali

Just an educated guess that might lead you on the right path: if the
variable inside @.@ is an environment variable ( I know little about
Mason ), then you’d set this variable under My
Computer->Properties->Advanced->Environment Variables->System variables.
Now, my other guess is that your Apache service is running under a user
account called ‘Apache’ or something and that this user doesn’t
currently have write access to the path defined in the mentioned ENV
variable. Feh. I could be wrong, but hey, it couldn’t hurt to follow
my logic.

David Smithson

CLICK HERE FOR ONLINE SUPPORT-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Murali
Manohara
Sent: Friday, July 28, 2006 11:04 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] MASON_SESSION_PATH - Win32

Dear All,

I am trying to install RT on Win32. Whenever I try to access the RT i
get this error log in apache as “Can’t read and write
@MASON_SESSION_PATH@”. Please loet me know as to where am i supposed
to set the value for the MASON_SESSION_PATH.

Details:
Win 2000
Apace 1.3
MySQL 4.0.14
FCGI
RT 3.0.12

Thanks in advance.

Regards,
Murali
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical:

Hi David,

Thanks for the reply. But it still am getting the same reply. I think
i need to change the settings in the siteconfig.pm but i do not know
how to do the same.

Regards,
MuraliOn 7/29/06, David Smithson dsmithson@activsupport.com wrote:

Just an educated guess that might lead you on the right path: if the
variable inside @.@ is an environment variable ( I know little about
Mason ), then you’d set this variable under My
Computer->Properties->Advanced->Environment Variables->System variables.
Now, my other guess is that your Apache service is running under a user
account called ‘Apache’ or something and that this user doesn’t
currently have write access to the path defined in the mentioned ENV
variable. Feh. I could be wrong, but hey, it couldn’t hurt to follow
my logic.

David Smithson


CLICK HERE FOR ONLINE SUPPORT

-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Murali
Manohara
Sent: Friday, July 28, 2006 11:04 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] MASON_SESSION_PATH - Win32

Dear All,

I am trying to install RT on Win32. Whenever I try to access the RT i
get this error log in apache as “Can’t read and write
@MASON_SESSION_PATH@”. Please loet me know as to where am i supposed
to set the value for the MASON_SESSION_PATH.

Details:
Win 2000
Apace 1.3
MySQL 4.0.14
FCGI
RT 3.0.12

Thanks in advance.

Regards,
Murali


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical:
http://bestpractical.com/about/jobs.html

Having never installed RT on Windows, I can only guess that the Apache
installer creates an Apache user account for the Apache service and that
this account must have r/w access to particular directories in the
filesystem ( at least that’s what the feedback you get seems to indicate
). Have you checked that the MASON_SESSION_PATH is writable by the
Apache process?

David Smithson

CLICK HERE FOR ONLINE SUPPORTFrom: Murali Manohara [mailto:muralimanohara@gmail.com]
Sent: Friday, July 28, 2006 11:32 PM
To: David Smithson; rt-users@lists.bestpractical.com
Subject: Re: [rt-users] MASON_SESSION_PATH - Win32

Hi David,

Thanks for the reply. But it still am getting the same reply. I think
i need to change the settings in the siteconfig.pm but i do not know
how to do the same.

Regards,
Murali

Just an educated guess that might lead you on the right path: if the
variable inside @.@ is an environment variable ( I know little about
Mason ), then you’d set this variable under My
Computer->Properties->Advanced->Environment Variables->System
variables.
Now, my other guess is that your Apache service is running under a
user
account called ‘Apache’ or something and that this user doesn’t
currently have write access to the path defined in the mentioned ENV
variable. Feh. I could be wrong, but hey, it couldn’t hurt to follow
my logic.

David Smithson


CLICK HERE FOR ONLINE SUPPORT

-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Murali
Manohara
Sent: Friday, July 28, 2006 11:04 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] MASON_SESSION_PATH - Win32

Dear All,

I am trying to install RT on Win32. Whenever I try to access the RT i
get this error log in apache as “Can’t read and write
@MASON_SESSION_PATH@”. Please loet me know as to where am i supposed
to set the value for the MASON_SESSION_PATH.

Details:
Win 2000
Apace 1.3
MySQL 4.0.14
FCGI
RT 3.0.12

Thanks in advance.

Regards,
Murali


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical:
http://bestpractical.com/about/jobs.html