Many perl processes

I am trying to finish my setup of rt and am getting many processes
starting up.

Here is an excerpt from the apache error log:

[Thu Mar 18 13:17:26 2004] [notice] suEXEC mechanism enabled (wrapper:
/usr/sbin/suexec)
[Thu Mar 18 13:17:26 2004] [notice] Digest: generating secret for digest
authentication …
[Thu Mar 18 13:17:26 2004] [notice] Digest: done
[Thu Mar 18 13:17:27 2004] [notice] FastCGI: process manager initialized
(pid 18293)
[Thu Mar 18 13:17:27 2004] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 18298)
[Thu Mar 18 13:17:27 2004] [notice] Apache/2.0.46 (CentOS) configured –
resuming normal operations
[Thu Mar 18 13:17:28 2004] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 18303)
[Thu Mar 18 13:17:29 2004] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 18305)

… These lines were repeated MANY times …

[Thu Mar 18 13:18:25 2004] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 18405)
[Thu Mar 18 13:18:26 2004] [notice] caught SIGTERM, shutting down

It seemed to just keep adding perl processes until I shut down apache.

The processors were pegged and the ram was quickly filling up.

Here is my configuration:

Cent-OS 3.1 (RHEL 3 clone)
perl 5.8.3 (installed from fedora core 1 src rpm)
apache 2.0.46 (from RHEL 3)
MySQL 4.0.18 (from rpm at Mysql.com)
rt 3.0.9

All the perl modules are installed and check out with
sbin/rt-test-dependencies.

Also, to fix a seeming permissions issue with the
/etc/httpd/logs/fastcgi/dynamic/ directory, I replaced the
/etc/httpd/logs simlink with a real directory in its place.

The permissions for the applicable directories is:
ls -lR /etc/httpd/

/etc/httpd/:
total 12
lrwxrwxrwx 1 root root 25 Mar 17 14:16 build ->
…/…/usr/lib/httpd/build
drwxr-xr-x 2 root root 4096 Mar 15 10:25 conf
drwxr-xr-x 2 root root 4096 Mar 18 10:43 conf.d
drwxr-xr-x 3 root root 4096 Mar 18 11:11 logs
lrwxrwxrwx 1 root root 27 Mar 15 10:25 modules ->
…/…/usr/lib/httpd/modules
lrwxrwxrwx 1 root root 13 Mar 15 10:25 run ->
…/…/var/run

/etc/httpd/conf:
total 52
-rw-r–r-- 1 root root 35168 Mar 8 20:42 httpd.conf
-rw-r–r-- 1 root root 12959 Mar 8 20:42 magic

/etc/httpd/conf.d:
total 24
-rw-r–r-- 1 root root 311 Feb 28 06:53 mrtg.conf
-rw-r–r-- 1 root root 1800 Feb 29 17:02 perl.conf
-rw-r–r-- 1 root root 459 Feb 28 14:45 php.conf
-rw-r–r-- 1 root root 180 Mar 8 20:42 README
-rw-r–r-- 1 root root 550 Mar 18 10:43 rt.conf
-rw-r–r-- 1 root root 299 Mar 8 20:42 welcome.conf

/etc/httpd/logs:
total 28
-rw-r–r-- 1 root root 0 Mar 18 11:11 access_log
-rw-r–r-- 1 root root 23278 Mar 18 13:18 error_log
drwxrwxrwx 3 apache rt 4096 Mar 18 13:18 fastcgi

/etc/httpd/logs/fastcgi:
total 4
drwxrwxrwx 2 apache rt 4096 Mar 18 11:10 dynamic

/etc/httpd/logs/fastcgi/dynamic:
total 0

Best Regards,

Paul Eden

In your previous post you had this:

FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 150 -processes
120

That’s starting up 120 servers !

You might want to reduce that.

SH-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Paul D. Eden
Sent: Thursday, March 18, 2004 4:11 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Many perl processes

I am trying to finish my setup of rt and am getting many processes
starting up.

Here is an excerpt from the apache error log:

[Thu Mar 18 13:17:26 2004] [notice] suEXEC mechanism enabled (wrapper:
/usr/sbin/suexec)
[Thu Mar 18 13:17:26 2004] [notice] Digest: generating secret for digest
authentication …
[Thu Mar 18 13:17:26 2004] [notice] Digest: done
[Thu Mar 18 13:17:27 2004] [notice] FastCGI: process manager initialized
(pid 18293)
[Thu Mar 18 13:17:27 2004] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 18298)
[Thu Mar 18 13:17:27 2004] [notice] Apache/2.0.46 (CentOS) configured –
resuming normal operations
[Thu Mar 18 13:17:28 2004] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 18303)
[Thu Mar 18 13:17:29 2004] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 18305)

… These lines were repeated MANY times …

[Thu Mar 18 13:18:25 2004] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 18405)
[Thu Mar 18 13:18:26 2004] [notice] caught SIGTERM, shutting down

It seemed to just keep adding perl processes until I shut down apache.

The processors were pegged and the ram was quickly filling up.

Here is my configuration:

Cent-OS 3.1 (RHEL 3 clone)
perl 5.8.3 (installed from fedora core 1 src rpm)
apache 2.0.46 (from RHEL 3)
MySQL 4.0.18 (from rpm at Mysql.com)
rt 3.0.9

All the perl modules are installed and check out with
sbin/rt-test-dependencies.

Also, to fix a seeming permissions issue with the
/etc/httpd/logs/fastcgi/dynamic/ directory, I replaced the
/etc/httpd/logs simlink with a real directory in its place.

The permissions for the applicable directories is:
ls -lR /etc/httpd/

/etc/httpd/:
total 12
lrwxrwxrwx 1 root root 25 Mar 17 14:16 build ->
…/…/usr/lib/httpd/build
drwxr-xr-x 2 root root 4096 Mar 15 10:25 conf
drwxr-xr-x 2 root root 4096 Mar 18 10:43 conf.d
drwxr-xr-x 3 root root 4096 Mar 18 11:11 logs
lrwxrwxrwx 1 root root 27 Mar 15 10:25 modules ->
…/…/usr/lib/httpd/modules
lrwxrwxrwx 1 root root 13 Mar 15 10:25 run ->
…/…/var/run

/etc/httpd/conf:
total 52
-rw-r–r-- 1 root root 35168 Mar 8 20:42 httpd.conf
-rw-r–r-- 1 root root 12959 Mar 8 20:42 magic

/etc/httpd/conf.d:
total 24
-rw-r–r-- 1 root root 311 Feb 28 06:53 mrtg.conf
-rw-r–r-- 1 root root 1800 Feb 29 17:02 perl.conf
-rw-r–r-- 1 root root 459 Feb 28 14:45 php.conf
-rw-r–r-- 1 root root 180 Mar 8 20:42 README
-rw-r–r-- 1 root root 550 Mar 18 10:43 rt.conf
-rw-r–r-- 1 root root 299 Mar 8 20:42 welcome.conf

/etc/httpd/logs:
total 28
-rw-r–r-- 1 root root 0 Mar 18 11:11 access_log
-rw-r–r-- 1 root root 23278 Mar 18 13:18 error_log
drwxrwxrwx 3 apache rt 4096 Mar 18 13:18 fastcgi

/etc/httpd/logs/fastcgi:
total 4
drwxrwxrwx 2 apache rt 4096 Mar 18 11:10 dynamic

/etc/httpd/logs/fastcgi/dynamic:
total 0

Best Regards,

Paul Eden

rt-users mailing list
rt-users@lists.bestpractical.com
http://lists.bestpractical.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Wow! Thank you for pointing that out.

PaulOn Thu, 2004-03-18 at 14:28, Scott Hebert wrote:

In your previous post you had this:

FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 150 -processes
120

That’s starting up 120 servers !

You might want to reduce that.

SH