Mail looping on postfix

Not specifically an RT problem, but figured anyone having gone thru this
looping problem and use postfix may have an answer.

Someone emailed in a ticket w/ a from address being a listserve signup
control. So, loops.

I added this to my main.cf:

header_checks = regexp:/usr/local/etc/postfix/header_checks

And this to header_checks:

/^from: *@ummo-sciences.org$/i DISCARD discard ummo from
/^to: *@ummo-sciences.org$/i DISCARD discard ummo to

They’re still getting through. I even stopped/started postfix just to make
sure it wasn’t a “reload” issue. I’ve tried with and without the “i” to
ignore case.

Here is a log line:

Apr 22 18:51:05 tix postfix/smtp[44052]: 53C6B386:
to=ummo.open_request@ummo-sciences.org, relay=mx.online.net[212.27.35.93],
delay=3, status=sent (250 ok 1082674265 qp 533)

I’ve tried a few different formats and tried REJECT insteado of DISCARD and
using/not using words after the action (which from what I read is just added
to the logs).

Any idea what I’m missing or doing wrong?

I’m up to like 8000 tickets now and while its not killing my server, it is
really upsetting our support people… :slight_smile:

Thanks!
Brent

And this to header_checks:

/^from: *@ummo-sciences.org$/i DISCARD discard ummo from
/^to: *@ummo-sciences.org$/i DISCARD discard ummo to

They’re still getting through. I even stopped/started postfix just to make
sure it wasn’t a “reload” issue. I’ve tried with and without the “i” to
ignore case.

A . is missing before the *. These are regexes, not shell wildcard patterns

-- Niels.