LogDispatch error

Hi i have just setup rt3.0.4 with mysql and apache 1.3.27 and mod_perl
1.28. I have configured apache virtualhost just like it says in the RT3
docs and below are my RT_SiteConfig.pm. Yet while rt is running i get

"unix passed to setlogsock, but path not available at 

/opt/rt/perl/lib/site_perl/5.8.0/Log/Dispatch/Syslog.pm line 66" how do I
fix that?

Also there is a broken image in the upper lefthand corner how do I fix 

that?

RT conf in httpd.conf

ServerName rt.example.com
DocumentRoot /opt/rt/rt3/share/html
AddDefaultCharset UTF-8

PerlModule Apache::DBI
PerlRequire /opt/rt/rt3/bin/webmux.pl

SetHandler perl-script PerlHandler RT::Mason

RT_SiteConfig.pm
Set($rtname , “qctengdev”);
Set($Organization , “qualcomm.com”);
Set($Timezone , ‘US/Pacific’);
Set($OwnerEmail , ‘rt.qct.admin@qualcomm.com’);
Set($CorrespondAddress , ‘rt@qualcomm.com’);
Set($CommentAddress , ‘rtcom@qualcomm.com’);
Set($MailCommand , ‘sendmail’);
Set($SendmailArguments,"-oi -t -ODeliveryMode=b -OErrorMode=m");
Set($SendmailPath , “/usr/lib/sendmail”);
Set($DateDayBeforeMonth , 0);
1;

<>< Proverbs 3:5-6 “Trust in the Lord with all your heart and lean not on
your own understanding;
in all your ways acknowledge him, and he
will make your paths straight.”

John Gedeon wrote:

“unix passed to setlogsock, but path not available at
/opt/rt/perl/lib/site_perl/5.8.0/Log/Dispatch/Syslog.pm line 66” how do I
fix that?

You’re using Solaris or HP/UX, and $LogToSyslog in your RT config.
This has been asked several times on this list; the answers invariably
boil down to “hack your Log::Dispatch or Sys::Syslog modules”, or
"disable $LogToSyslog and use $LogToFile instead".

Also there is a broken image in the upper lefthand corner how do I fix
that?

Fix $WebImagesURL or $LogoURL in your RT config?
Phil Homewood, Systems Janitor, http://www.SnapGear.com
pdh@snapgear.com Ph: +61 7 3435 2810 Fx: +61 7 3891 3630
SnapGear - Custom Embedded Solutions and Security Appliances

At 12:30 AM 8/22/2003, Phil Homewood wrote:

John Gedeon wrote:

“unix passed to setlogsock, but path not available at
/opt/rt/perl/lib/site_perl/5.8.0/Log/Dispatch/Syslog.pm line 66” how do I
fix that?

You’re using Solaris or HP/UX, and $LogToSyslog in your RT config.

Yes (Solaris)

This has been asked several times on this list; the answers invariably
boil down to “hack your Log::Dispatch or Sys::Syslog modules”, or
"disable $LogToSyslog and use $LogToFile instead".

I tried disabling it in the RT config by setting Set($LogToSyslog, undef);
but it didn’t work.
I also tried commenting that line out but it still didnt work. How do I
disable it?

Also there is a broken image in the upper lefthand corner how do I fix
that?

Fix $WebImagesURL or $LogoURL in your RT config?

Seems I missed setting that Thought i did. Fixed now.


Phil Homewood, Systems Janitor, http://www.SnapGear.com
pdh@snapgear.com Ph: +61 7 3435 2810 Fx: +61 7 3891 3630
SnapGear - Custom Embedded Solutions and Security Appliances


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

<>< Proverbs 3:5-6 “Trust in the Lord with all your heart and lean not on
your own understanding;
in all your ways acknowledge him, and he
will make your paths straight.”

Fixed the logging problem. I had to change it in RT_Config.pm not just
RT_SiteConfig.pm to get rid of the error. Now its working fine.

Thanks
John
At 09:44 AM 8/22/2003, John Gedeon wrote:

At 12:30 AM 8/22/2003, Phil Homewood wrote:

John Gedeon wrote:

“unix passed to setlogsock, but path not available at
/opt/rt/perl/lib/site_perl/5.8.0/Log/Dispatch/Syslog.pm line 66” how do I
fix that?

You’re using Solaris or HP/UX, and $LogToSyslog in your RT config.

Yes (Solaris)

This has been asked several times on this list; the answers invariably
boil down to “hack your Log::Dispatch or Sys::Syslog modules”, or
"disable $LogToSyslog and use $LogToFile instead".

I tried disabling it in the RT config by setting Set($LogToSyslog, undef);
but it didn’t work.
I also tried commenting that line out but it still didnt work. How do I
disable it?

Also there is a broken image in the upper lefthand corner how do I fix
that?

Fix $WebImagesURL or $LogoURL in your RT config?

Seems I missed setting that Thought i did. Fixed now.


Phil Homewood, Systems Janitor, http://www.SnapGear.com
pdh@snapgear.com Ph: +61 7 3435 2810 Fx: +61 7 3891 3630
SnapGear - Custom Embedded Solutions and Security Appliances


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm


<>< Proverbs 3:5-6 “Trust in the Lord with all your heart and lean not on
your own understanding;
in all your ways acknowledge him, and he
will make your paths straight.”


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

<>< Proverbs 3:5-6 “Trust in the Lord with all your heart and lean not on
your own understanding;
in all your ways acknowledge him, and he
will make your paths straight.”