Log in Issues

I am have some difficulties staying logged in as root with Rt Tracker. I
have tried googling my problem but can’t seem to find a resolution. I am
running Gentoo and my browser (Firefox) has been set to accept all cookies

My Apache conf is below:

ServerName etcetc DocumentRoot /var/www/rttracker ServerAdmin support@gsc.cc AddDefaultCharset UTF-8 UserDir disabled PerlModule Apache::DBI PerlRequire SetHandler perl-script PerlHandler RT::Mason PerlSetEnv PERL5LIB /usr/lib Options Indexes FollowSymLinks AllowOverride None Order allow,deny Allow from all

and my Rt_siteconfig.pm is below:

Any help on this would be greatly appreciated.
View this message in context: http://www.nabble.com/Log-in-Issues.-tp15361064p15361064.html

I am have some difficulties staying logged in as root with Rt Tracker. I
have tried googling my problem but can’t seem to find a resolution. I am
running Gentoo and my browser (Firefox) has been set to accept all cookies

Dear RT user, can you give use more informations, RT version, Database
type? There is a problem of this kind before RT 3.6.6 with file sessions
(typical with Oracle database):

Emmanuel,

We resolved that problem by modifying Apache to lock at the transaction 

level. That solved the problem for us.

Kenn
LBNLOn 2/9/2008 12:06 AM, Emmanuel Lacour wrote:

On Fri, Feb 08, 2008 at 10:18:50AM -0800, aeternaleto wrote:

I am have some difficulties staying logged in as root with Rt Tracker. I
have tried googling my problem but can’t seem to find a resolution. I am
running Gentoo and my browser (Firefox) has been set to accept all cookies

Dear RT user, can you give use more informations, RT version, Database
type? There is a problem of this kind before RT 3.6.6 with file sessions
(typical with Oracle database):

Carbon60: Cloud Consulting - Services and Solutions


The rt-users Archives

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

At Monday 2/11/2008 01:19 PM, Kenneth Crocker wrote:

Emmanuel,

    We resolved that problem by modifying Apache to lock at the 

transaction
level. That solved the problem for us.

Kenn
LBNL

Kenn - you modified Apache? In what way?

Emmanuel - look in the list archives for Alexandr Ciornii’s mail from
December 30, 2007, subject “RT 3.6 requires two or three logins with
firefox and IE”. It includes a patch that solved the problem for us.

Thanks,
Steve

Stephen Turner
Senior Programmer/Analyst - SAIS
MIT Information Services and Technology (IS&T)

Stephen Turner,

Well, I'm not an Apache guy, but my understanding is that with IE and 

Firefox, the “second sign-in” problem could be resolved by adding the
“transaction” argument to the session parameter for creating a session.
This is what I have:

" > Did you tried adding ‘Transaction’ argument when creating session?

Patch is attached.

Very cool. It sounds like folks using file-locking are definitely
winning with this. I suspect it got skipped at the time sessions were
implemented because: (From the doc)

   Note that the Transaction argument has no practical effect 

on the MySQL

   and Postgres implementations.  The MySQL implementation only 

supports

   exclusive locking, and the Postgres implementation uses the 

transaction

   features of that database."
That's all I have. I handed this over to our support personnel and they 

took care of it. It’s been working since then. There are, however, a few
RT changes that can fix it. Jesse pointed them out after 3.6.4 came out:

"It’s almost certainly the case that you have multiple valid DNS domain
names for your RT server. And RT’s cookies are tied to a specific
domain.

Something like this:
http://rt/
http://rt.mycompany.com/
http://rt3.mycompany.com/
http://www.rt.mycompany.com/

If you start at one and RT canonicalizes it to another, you might be
fored to reauth.". Those are also possibilities. Hope this helps.

Kenn
LBNLOn 2/11/2008 10:38 AM, Stephen Turner wrote:

At Monday 2/11/2008 01:19 PM, Kenneth Crocker wrote:

Emmanuel,

    We resolved that problem by modifying Apache to lock at the 

transaction
level. That solved the problem for us.

Kenn
LBNL

Kenn - you modified Apache? In what way?

Emmanuel - look in the list archives for Alexandr Ciornii’s mail from
December 30, 2007, subject “RT 3.6 requires two or three logins with
firefox and IE”. It includes a patch that solved the problem for us.

Thanks,
Steve

Stephen Turner
Senior Programmer/Analyst - SAIS
MIT Information Services and Technology (IS&T)

Stephen,

AAAHHH. I found the Apache change. In the directory where you keep 

“SetupSessionCookie” do the following:
Modify SetupSessionCookie by changing the “my
$session_properties;” code by adding “Transaction => 1,” at end before
the “else” line. That’s what we did.

Kenn
LBNLOn 2/11/2008 10:38 AM, Stephen Turner wrote:

At Monday 2/11/2008 01:19 PM, Kenneth Crocker wrote:

Emmanuel,

    We resolved that problem by modifying Apache to lock at the 

transaction
level. That solved the problem for us.

Kenn
LBNL

Kenn - you modified Apache? In what way?

Emmanuel - look in the list archives for Alexandr Ciornii’s mail from
December 30, 2007, subject “RT 3.6 requires two or three logins with
firefox and IE”. It includes a patch that solved the problem for us.

Thanks,
Steve

Stephen Turner
Senior Programmer/Analyst - SAIS
MIT Information Services and Technology (IS&T)