Location instead of virtualhost

I setup rt3.03 with a VirtualHost httpd.conf setup which is working fine.

However what I’d prefer to do is use an Alias and Location setup (e.g.
access RT at http:\my.host.name\rt3 instead of http:\my.host.name) so
my other non-rt content on this server can also be available.

I have working sample code of my httpd.conf from my current rt3 server
and a previous rt2 server of mine below (that was using the
Location/Alias combo the way I want it to work on my new server).

I haven’t had much luck navigating the differences in my two setups to
make locations work with RT. Can someone please point out how to make
my rt3.0.3 httpd.conf file work as a Location/Alias combo (e.g.
http:\my.host.name\rt3) instead?

My current 3.0.3, Apache2.x, Fastcgi httpd.conf setup (which I want to
use location/alias combo instead)

ServerName my.host.name
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8
LoadModule fastcgi_module modules/mod_fastcgi.so
AddHandler fastcgi-script fcgi

     FastCgiServer /opt/rt3/bin/mason_handler.fcgi
     Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/
     ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

A previous rt2.017 httpd.conf setup (Apache1.x, FreeBSD, modperl)
Alias /rt2 /opt/rt2/WebRT/html/
PerlRequire /opt/rt2/bin/webmux.pl
<Location /rt2>
SetHandler perl-script
PerlHandler RT::Mason

<Directory “/opt/rt2/WebRT/html”>
Options FollowSymLinks
AllowOverride All

###end rt###

I just finished wrestling with this issue; the solution below worked for

Here is the excerpt from my httpd.conf for Apache 2, rt 3.05, fastcgi, on
Redhat 9.

FastCgiIpcDir /opt/rt3/bin/fastcgi
FastCgiServer /opt/rt3/bin/mason_handler.fcgi
ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi/

Alias /rt /opt/rt3/share/html
<Location “/rt”>
Options +ExecCGI
SetHandler fastcgi-script
AddHandler fastcgi-script .fcgi

I needed the FastCgiIpcDir directive to specify a location
to store the Unix
socket files used for communication between the applications and the web
server. I assigned ownership mywebuser:mywebuser and permissions 755 to
this directory. For some reason, the default location for this directory
was getting ‘permission denied’ errors which I couldn’t solve.

The current config works great.

– Michael A. Foster
Senior Research Associate
Center for Gravitational Wave Physics
Office address:
214F Computer Building
University Park, PA 16802
Office phone number: (814)865-8663
Department phone number: (814)863-9605
Email address: fgv@psu.edu