Localhost in url

I think this is a very simple problem with a simple answer, so please
bear with me.

I have installed RT3.6 using yum with Fedora Core 4 RC 5, i.e. the
package bundled with Fedora.

It appears to be running OK except.

I can raise calls but when go to amend them after selecting "resolve"
from the menu on page
http://192.168.123.140/rt3/Ticket/Display.html?id=8

Then the “Update Ticket” button from page

http://192.168.123.140/rt3/Ticket/Update.html?Action=Comment&DefaultStat
us=resolved&id=8

I get returned to page http://localhost/rt3/Ticket/Display.html?id=8
which does not work because it points to localhost.

The ticket gets updates OK and replacing the server IP in the url shows
the updated ticket.

I suspect that I need to update a conf file somewhere in /etc/httpd/conf
or /etc/httpd/conf.d any suggestions would be appreciated.

It is on VMWare server but I don’t think that should is the issue?

Kind Regards

Neil Baldwin
IT Manager - Kingspan Pollution Control

Tel: +44 1296 633000
Fax: +44 1296 633001
DDI: +44 1296 633256
Mob: +44 7713 189707

Hello!2006/7/24, Neil Baldwin neil.baldwin@kingspan.com:

Then the “Update Ticket” button from page

http://192.168.123.140/rt3/Ticket/Update.html?Action=Comment&DefaultStat
us=resolved&id=8

I get returned to page http://localhost/rt3/Ticket/Display.html?id=8
which does not work because it points to localhost.
Please, look at RT_SiteConfig.pm. It should be in the 'etc’
subdirectory of rt3 installation.
Do you have line
Set( $WebBaseURL , “http://localhost”);
?

In this case, you should change it to Set( $WebBaseURL ,
http://192.168.123.140”);
Restart Apache afterwards.

Alexandr Ciornii, http://chorny.net

I thought it might be that simple thanks for the tip.

My config as installed by Redhat Fedora only had one entry rtname$ so I
added $WebBaseURL

Kind Regards

NeilFrom: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Alexandr
Ciornii
Sent: Monday, July 24, 2006 1:09 PM
To: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Localhost in url

Hello!

I had something similar happening to me. Turned out I forgot to set the
WebBaseURL setting in RT_SiteConfig.pm .

Hope that helps-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Neil
Baldwin
Sent: Monday, July 24, 2006 7:54 AM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Localhost in url

I think this is a very simple problem with a simple answer, so please
bear with me.

I have installed RT3.6 using yum with Fedora Core 4 RC 5, i.e. the
package bundled with Fedora.

It appears to be running OK except.

I can raise calls but when go to amend them after selecting "resolve"
from the menu on page
http://192.168.123.140/rt3/Ticket/Display.html?id=8

Then the “Update Ticket” button from page

http://192.168.123.140/rt3/Ticket/Update.html?Action=Comment&DefaultStat
us=resolved&id=8

I get returned to page http://localhost/rt3/Ticket/Display.html?id=8
which does not work because it points to localhost.

The ticket gets updates OK and replacing the server IP in the url shows
the updated ticket.

I suspect that I need to update a conf file somewhere in /etc/httpd/conf
or /etc/httpd/conf.d any suggestions would be appreciated.

It is on VMWare server but I don’t think that should is the issue?

Kind Regards

Neil Baldwin
IT Manager - Kingspan Pollution Control

Tel: +44 1296 633000
Fax: +44 1296 633001
DDI: +44 1296 633256
Mob: +44 7713 189707

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: