LDAP External Authentication Issue

I have been trying to configure my RT to communicate with my ldap, but I have been running into problems. I did install the perl module below is my configuration and error after I restart apache (apache failed to restart):

THE BASICS:

Set($rtname, ‘TAG’);
Set($Organization, ‘TAG’);
Set($CorrespondAddress , ‘helpdesk@test.action.go’);
Set($CommentAddress , ‘webmaster@test.action.go’);
Set($Timezone , ‘EDT’); # obviously choose what suits you
Set($MinimumPasswordLength, “8”);

THE DATABASE:

Set($DatabaseType, ‘mysql’); # e.g. Pg or mysql

These are the settings we used above when creating the RT database,

you MUST set these to what you chose in the section above.

Set($DatabaseUser , ‘rtuser’);
Set($DatabasePassword , ‘wibble’);
Set($DatabaseName , ‘rt3’); # Ensure this is set to rt3!

THE WEBSERVER:

Set($WebPath , “”);
Set($WebBaseURL , “http://helpdesk.TAG.test.go”);

#THE EMAIL SERVER

Set($SendmailPath , “/usr/sbin/sendmail”);
Set($SendmailArguments,"-oi -t -ODeliveryMode=b -OErrorMode=m");
Set($UseFriendlyFromLine, 1);
Set($FriendlyFromLineFormat, “”%s via RT" <%s>");
Set($TruncateLongAttachments, undef);
#THE LDAP SERVER
Set(@Plugins, qw(RT::Authen::ExternalAuth));
Set($EmailCompletionUnprivileged,“privileged”);

Following is LDAP authorization block

Set($ExternalAuthPriority, [ ‘My_LDAP’ ]);
Set($ExternalInfoPriority, [ ‘My_LDAP’ ]);
Set($AutoCreateNonExternalUsers, 1);
Set($ExternalSettings, {
‘My_LDAP’ => { ## GENERIC SECTION
’type’ => ‘ldap’,
‘server’ => ‘192.168.5.0’,
‘user’ => ‘administrator’,
‘pass’ => ‘********’,
‘base’ => ‘dc=action,dc=test,dc=go’,
# The filter to use to match RT-Users
’filter’ => ‘(sAMAccountName=%u)’,
# A catch-all example filter: '(objectClass=
)’
# The filter that will only match disabled users
#‘d_filter’ => ‘(FILTER_STRING)’,
‘d_filter’ => ‘(&(objectCategory=person)(objectClass=user))’,
# A catch-none example d_filter: ‘(objectClass=FooBarBaz)’
‘net_ldap_args’ => [ version => 3 ],
# Does authentication depend on group membership? What group name?
#‘group’ => ‘GROUP_NAME’,
# What is the attribute for the group object that determines membership?
#‘group_attr’ => ‘GROUP_ATTR’,
## RT ATTRIBUTE MATCHING SECTION
# The list of RT attributes that uniquely identify a user
’attr_match_list’ => [ ‘Name’,
‘EmailAddress’
#‘RealName’
],
# The mapping of RT attributes on to LDAP attributes
’attr_map’ => { ‘Name’ => ‘cn’,
‘EmailAddress’ => ‘test.action.go’,
‘WorkPhone’ => ‘telephoneNumber’,
‘MobilePhone’ => ‘mobile’,
‘RealName’ => ‘displayName’,
‘NickName’ => ‘preferredName’,
‘Organization’ => ‘Location’,
‘Address1’ => ‘mailstop’,
‘City’ => ‘homeCity’,
‘State’ => ‘st’,
‘Zip’ => ‘postalCode’,
‘Country’ => ‘co’
}
}
}
);
1;

Error from log is:
[Wed Jun 09 16:26:50 2010] [notice] caught SIGTERM, shutting down
[Wed Jun 9 20:26:53 2010] [error]: The RTAddressRegexp option is not set in the config. Not setting this option results in additional SQL queries to check $
[Wed Jun 9 20:27:04 2010] [error]: The RTAddressRegexp option is not set in the config. Not setting this option results in additional SQL queries to check $
[Wed Jun 09 16:27:13 2010] [notice] Apache/2.2.11 (Ubuntu) PHP/5.2.6-3ubuntu4.5 with Suhosin-Patch mod_perl/2.0.4 Perl/v5.10.0 configured – resuming normal$
[Wed Jun 09 16:30:30 2010] [notice] caught SIGTERM, shutting down
[Wed Jun 9 20:30:33 2010] [error]: The RTAddressRegexp option is not set in the config. Not setting this option results in additional SQL queries to check $
[Wed Jun 9 20:30:44 2010] [error]: The RTAddressRegexp option is not set in the config. Not setting this option results in additional SQL queries to check $
[Wed Jun 09 16:30:53 2010] [notice] Apache/2.2.11 (Ubuntu) PHP/5.2.6-3ubuntu4.5 with Suhosin-Patch mod_perl/2.0.4 Perl/v5.10.0 configured – resuming normal$
[Wed Jun 09 16:49:20 2010] [notice] caught SIGTERM, shutting down
[Wed Jun 09 16:49:23 2010] [error] Can’t locate RT/Authen/ExternalAuth.pm in @INC (@INC contains: /opt/rt3/bin/…/local/lib /opt/rt3/bin/…/lib /etc/perl /u$
[Wed Jun 09 16:49:23 2010] [error] Can’t load Perl file: /opt/rt3/bin/webmux.pl for server UHC:80, exiting…
[Wed Jun 9 20:54:04 2010] [error]: The RTAddressRegexp option is not set in the config. Not setting this option results in additional SQL queries to check $
[Wed Jun 9 20:54:16 2010] [error]: The RTAddressRegexp option is not set in the config. Not setting this option results in additional SQL queries to check $

Thanks in advance for the help that you guys will provide…