Latest RT on RHEL 4 with FastCGI Install Procedure

YES!!! I actually got the RT login page to come up!!!

Ok, here’s where my experience went on a tangent.

I’m going to clip the detail out of the sections I had no issues with. And
expound on detail where necessary.

-----Original Message-----

Standard install of RHEL, then upgrade / up2date / whatever to get latest

versions. For me, that looks like:

httpd-2.0.52-9.ent

httpd-devel-2.0.52-9.ent

mysql-4.1.7-4.RHEL4.1

mysqlclient10-3.23.58-4.RHEL4.1

mysql-server-4.1.7-4.RHEL4.1

mysql-devel-4.1.7-4.RHEL4.1

libdbi-dbd-mysql-0.6.5-10.RHEL4.1

Install FastCGI…

  No problems here

Turn on MySQL server, Apache server, set MySQL root password…

  No problems here

Set up CPAN initially…

  Done.

Install RT…

  This went OK.

Edit your Apache config file as well:

edit /etc/httpd/conf/httpd.conf

###Restart Apache:

  OK.

WARNING: Starting Apache now will result in a successful start, and an

abilty to serve non-RT related pages only.

     Your error_log file will fill up rapidly, approximatly one error

per second, similar to the following:

[timestamp] [crit] (13)Permission denied: FastCGI: can’t create server

“/opt/rt3/bin/mason_handler.fcgi”: bind() failed

[/var/log/fastcgi/362fab4db3d651b6d082c0358ebb4d83]

This leads me to believe its a permissions issue - FastCGI doesn’t have

permission to create files in /etc/httpd/logs/fastcgi/ for some reason.

Let’s check that:

ls -la /etc/httpd/logs/

returns drwxrwxrwx 3 apache apache 4096 Mar 16 12:28

fastcgi

So the fastcgi directory is owned by apache, and in apache’s group, and

has rwx access by absolutely everyone. So it shouldn’t be a permissions

issue…

Ok, here’s where my adventure begins…

I noticed that the permissions on “.” from within /etc/http/logs was 700. I
also noticed that I had selinux enabled.

Change permissions on /etc/httpd/logs from within

cd /etc/htttpd/logs ; chmod 755 .

Disabled selinux by editing /etc/selinux/config

Change the line that says either

SELINUX=enforcing

or

SELINUX=permissive

to be

SELINUX=disabled

reboot your machine.

When the system came back up, I had a whole different error in
/etc/httpd/logs/error_log

[Thu Mar 17 16:53:22 2005] [warn] FastCGI: server
"/opt/rt-3.0.12/bin/mason_handler.fcgi" started (pid 4309)

Can’t do setuid (cannot exec sperl)

[Thu Mar 17 16:53:22 2005] [warn] FastCGI: server
"/opt/rt-3.0.12/bin/mason_handler.fcgi" (pid 4309) terminated by calling
exit with status ‘2’

[Thu Mar 17 16:53:27 2005] [warn] FastCGI: server
"/opt/rt-3.0.12/bin/mason_handler.fcgi" restarted (pid 4319)

Can’t do setuid (cannot exec sperl)

[Thu Mar 17 16:53:27 2005] [warn] FastCGI: server
"/opt/rt-3.0.12/bin/mason_handler.fcgi" (pid 4319) terminated by calling
exit with status ‘2’

[Thu Mar 17 16:53:32 2005] [warn] FastCGI: server
"/opt/rt-3.0.12/bin/mason_handler.fcgi" restarted (pid 4324)

Can’t do setuid (cannot exec sperl)

[Thu Mar 17 16:53:32 2005] [warn] FastCGI: server
"/opt/rt-3.0.12/bin/mason_handler.fcgi" (pid 4324) terminated by calling
exit with status ‘2’

[Thu Mar 17 16:53:37 2005] [warn] FastCGI: server
"/opt/rt-3.0.12/bin/mason_handler.fcgi" restarted (pid 4327)

Can’t do setuid (cannot exec sperl)

So, my instincts tell me that the good folks at redhat have a separate RPM
for suid perl and that it’s not installed by default under any
circumstances. Surprise surpise!!! This is the case. I mounted my RHEL
iso images and started searching for the something that looked like suid
perl.

On disc 4 (RHEL4-i386-ES-disc4.iso if you have the files) you’ll find an RPM
called perl-suidperl-5.8.5-12.1.i386.rpm. If you don’t have this installed
try doing what I did above and install this.

Let me know if you can now open the RT login page in a web browser.

Paul C.

Can’t do setuid (cannot exec sperl)

So, my instincts tell me that the good folks at redhat have a separate
RPM for suid perl and that it’s not installed by default under any
circumstances. Surprise surpise!!! This is the case. I mounted my
RHEL iso images and started searching for the something that looked
like suid perl.

You should have been able to use ‘upd2date -i perl-suidperl’ to install
over the internet, but as of RT 3.2 it is not recommended. Look at:
http://wiki.bestpractical.com/index.cgi?FastCGIConfiguration down the
page where it says 'Configuring RT to run with Apache.

Les Mikesell
les@futuresource.com