Large mails are truncated

Hi,

I’ve installed RT3 on a RedHat 8 machine, but have problems with large mails

I get the same result if I import the mail manually with:

/opt/rt3/bin/rt-mailgate --queue RT3-Test --action correspond --url
http://localhost/ < ticket-mail

The mail is sent from Outlook in plain text and consists of lines with:

AAAAAAAAAABBBBBBBBBBCCCCCCCCCCDDDDDDDDDDEEEEEEEEEE

adding up to a total of 10k.

Only 6.2k is inserted in the ticket in RT.

What could I have misconfigured?

Regards - Anders Ekstrand

Anders Ekstrand wrote:

I’ve installed RT3 on a RedHat 8 machine, but have problems with large mails
sent via the mailgate being truncated.

What’s mysql’s “max_allowed_packet” set to? What about the
following variables in your RT config?

$MaxAttachmentSize
$TruncateLongAttachments

?
�|� http://www.bestpractical.com/rt – Trouble Ticketing. Free.

my.cnf contains:

[mysqld]
set-variable = max_allowed_packet=16M

and RT_SiteConfig.pm contains:

Set($MaxAttachmentSize , 10000000);
Set($TruncateLongAttachments , undef);
Set($DropLongAttachments , undef);

It works fine to create large tickets tickets via the Web-UI. It also works
fine to import data from an existing RT2.0.15 database, with very large
tickets (up to 8M).

If I send a mail with 10k of text, just a bit more than 7 k gets inserted in
the ticket body. Along with headers etc. it seems like there are som limit
at 8k…

(I’m running with modperl2 and Apache2 on a RedHat 9.0 box.)

/Anders

Anders Ekstrand wrote:

I’ve installed RT3 on a RedHat 8 machine, but have problems with large =
mails

First, thanks to all for the help with my e-mail issue (as in, none being
sent, 'cause I didn’t realize there weren’t default settings) yesterday.
Much appreciated.

However, it still isn’t quite working. If I create a ticket as root in
queue “foo”, mail gets sent to foo’s watchers, as per the scrip I have set
up. On the other hand, if I create a ticket as any other user, the mail
does not get sent. I’ve gone so far as to grant all permissions to the
user creating the ticket, and it still doesn’t go. Is there some
queue-based permission setting or something that I’m missing?

Thanks!

-Ken D’Ambrosio