Language mess in rt3

Hello, rt-users,

I have set up rt3 from rt2, after 3 days of fight its done, somehow.
but I still cant figure out how to change language in web end. its
mixed in english/czech words, how to set it to only english. I have
Red Hat 7.3/Perl 5.6.1 ,
thnx a lot.

Miki

cee ya
Peter mailto:mikeska@alcatel.sk

RT uses a translation file to get the actual string translations and the
language preference in your browser to “guess” which language to use for
your pages.

If you want only English, you have two solutions :

  • set the preferences in your browser to English first (or at least, higher
    than Czech and any other language RT knows)
  • suppress the cz.po file in the lib/RT/I18N directory (I’ve never tried
    that, but it should work, if it doesn’t, empty it)

If you ever want Czech language everywhere, you just have to update the
translation file which must be missing some translations. This is why you
get a mixed interface.

Before translating, do a “make regenerate-catalogs” on a fresh installation
package. This will extract all strings from the source code and update the
translation file. You can then browse through it and translate all lines
that are not. When done, you can send the file to the original translator
and to Jesse.

Blaise

-----Message d’origine-----De : Peter Mikeska [mailto:mikeska@alcatel.sk]
Envoye : lundi 31 mars 2003 10:19
A : rt-users@lists.fsck.com
Objet : [rt-users] language mess in rt3

Hello, rt-users,

I have set up rt3 from rt2, after 3 days of fight its done, somehow.
but I still cant figure out how to change language in web end. its
mixed in english/czech words, how to set it to only english. I have
Red Hat 7.3/Perl 5.6.1 ,
thnx a lot.

Miki

cee ya
Peter mailto:mikeska@alcatel.sk

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

(I’ve actually got a new Czech translation which will be in 3.0.1)On Mon, Mar 31, 2003 at 02:06:12PM +0200, THAUVIN Blaise (Dir. Informatique) wrote:

RT uses a translation file to get the actual string translations and the
language preference in your browser to “guess” which language to use for
your pages.

If you want only English, you have two solutions :

  • set the preferences in your browser to English first (or at least, higher
    than Czech and any other language RT knows)
  • suppress the cz.po file in the lib/RT/I18N directory (I’ve never tried
    that, but it should work, if it doesn’t, empty it)

If you ever want Czech language everywhere, you just have to update the
translation file which must be missing some translations. This is why you
get a mixed interface.

Before translating, do a “make regenerate-catalogs” on a fresh installation
package. This will extract all strings from the source code and update the
translation file. You can then browse through it and translate all lines
that are not. When done, you can send the file to the original translator
and to Jesse.

Blaise

-----Message d’origine-----
De : Peter Mikeska [mailto:mikeska@alcatel.sk]
Envoye : lundi 31 mars 2003 10:19
A : rt-users@lists.fsck.com
Objet : [rt-users] language mess in rt3

Hello, rt-users,

I have set up rt3 from rt2, after 3 days of fight its done, somehow.
but I still cant figure out how to change language in web end. its
mixed in english/czech words, how to set it to only english. I have
Red Hat 7.3/Perl 5.6.1 ,
thnx a lot.

Miki


cee ya
Peter mailto:mikeska@alcatel.sk


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

http://www.bestpractical.com/rt – Trouble Ticketing. Free.