Lack of trailing slash causing porblems in IE

Hi there,

When submitting form information such as logging in, updating a page
etc. Internet Explorer (6) returns a ‘The page cannot be found’ error
intermittently.

This happens consistently if I first load my RT login page as

https://example.com/rt

But not if I load it as

https://example.com/rt/

With the trailng slash. I think this may not be exclusively linked to
RT since there have been reports that similar intermittent problems
have been encountered with our Phorum installation (a PHP bulletin
board), however the problem with RT is much more frequent.

Some stats,

Solaris 9
Apache 2.0.55 (also happened with 1.3)
RT 3.4.5 (also happened with 3.4.2)
Perl 5.8.5

httpd.conf

OVERVIEW

This is a httpd.conf file written from scratch for server burs-unx004

production.

The structure also loosely follows the FHS standard for location of

files etc. See http://www.pathname.com/fhs/ for details.

Load the modules

Used to allow password protected directories

LoadModule auth_module modules/mod_auth.so

PHP 4 used for performance

LoadModule php4_module modules/libphp4.so

Enable SSL

LoadModule ssl_module modules/mod_ssl.so

Allows AddType directive

LoadModule mime_module modules/mod_mime.so

Allows DirectoryIndex directive

LoadModule dir_module modules/mod_dir.so

access_module for 2.0, authz_host_module for 2.2

LoadModule access_module modules/mod_access.so

LoadModule authz_host_module modules/mod_authz_host.so

Allows TransferLog directive

LoadModule log_config_module modules/mod_log_config.so

Allows Alias directive

LoadModule alias_module modules/mod_alias.so

Allows CGI scripting

LoadModule cgi_module modules/mod_cgi.so

Improve CGI performance, currently not compiled

LoadModule fastcgi_module modules/mod_fastcgi.so

Let Apache run as a powerless user and powerless group for security

reasons

User www
Group www

Set the domain name for this server root

ServerName estates.bris.ac.uk

Set contact name

ServerAdmin webmaster-estates@bris.ac.uk

Set the system path to the server root

DocumentRoot /srv/www/htdocs

Set the location of the log relative to the ServerRoot

TransferLog logs/access_log

Set port on which main sets of static docs are listened on

Listen 80
Listen 443

Set it so links can be followed, hence cgi-bin etc. can be accessed

Don’t allow CGIs, indexing of directories and server side includes

#Options +FollowSymLinks -ExecCGI -Indexes -Includes

Configure so that the cgi-bin directory can be used and accessed

through ServerName/cgi-bin

#ScriptAlias /cgi-bin /srv/www/cgi-bin

make sure Apache knows to pass .php files though PHP before serving

AddType application/x-httpd-php .php

make sure Apache know what to do with certificate files

AddType application/x-x509-ca-cert .crt
AddType application/x-pkcs7-crl .crl

Server-wide FastCGI directives

FastCgiIpcDir /tmp
FastCgiServer /usr/local/rt3/bin/mason_handler.fcgi -idle-timeout 120
-processes 4

Ordinary content served on port 80

ServerAdmin webmaster@example.com DocumentRoot /srv/www/htdocs ServerName example.com Redirect /rt https://example.com/rt

Secure content served on port 443

    ServerAdmin webmaster@example.com
    DocumentRoot /srv/www/htdocs
    ServerName example.comk

    # Entry for Request Tracker, only for encrypted connections
    # More info found at

http://www.fastcgi.com/mod_fastcgi/docs/mod_fastcgi.html
AddHandler fastcgi-script fcgi
ScriptAlias /rt /usr/local/rt3/bin/mason_handler.fcgi
# Alias /rt/NoAuth/images /usr/local/rt3/html/NoAuth/images

    # The SSL configuration directives
    SSLEngine on
    # List the ciphers that the client is permitted to negotiate
    SSLCipherSuite

ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL
# List all locations for OpenSSL certificates
SSLCertificateFile /var/ssl/public/estates-public.crt
SSLCertificateKeyFile /var/ssl/private/estates-private.key
SSLCertificateChainFile /var/ssl/public/estates-public-chain.crt

SSL cache, uses DBM, may suffer reliability under high loads

SSLSessionCache dbm:/usr/local/apache-2.0.55/logs/ssl_scache

Configure the path to the mutual exclusion semaphore the

SSL engine uses internally for inter-process synchronization.

SSLMutex file:/usr/local/apache-2.0.55/logs/ssl_mutex

Random number source

SSLRandomSeed startup builtin
SSLRandomSeed connect builtin

Allow various type of file to be served as index file

DirectoryIndex index.php index.html index.cgi index.pl

Don’t serve up .htaccess and htpasswd files

<Files ~ “^.ht”>
Order Allow,Deny
Deny from all
Satisfy all

Don’t serve up directories called ‘no-serve’

<DirectoryMatch “/srv/www/(.+)/no-serve”>
Order Allow,Deny
Deny from all
Satisfy all

Regards,

Brendan

I may have found the solution. After including a RewriteRule directive
that adds a trailing slash to the end of the RT url it seems to work
OK.

Add this to your virtual host entry (or general server config)

RewriteEngine on RewriteRule /(rt)$ /$1/ [R} Redirect /rt https://example.com/rt ... RewriteEngine on RewriteRule /(rt)$ /$1/ [R] ...

If you use DSOs you need to load mod_rewrite

I am pretty sure that you should be able to combine the Redirect
directive into the RewriteRule however for some reason RewriteRule
/(rt)$ https://example.com/$1/ [R] does not work.On 4/20/06, Brendan Arnold brendanarnold@gmail.com wrote:

Hi there,

When submitting form information such as logging in, updating a page
etc. Internet Explorer (6) returns a ‘The page cannot be found’ error
intermittently.

This happens consistently if I first load my RT login page as

https://example.com/rt

But not if I load it as

https://example.com/rt/

With the trailng slash. I think this may not be exclusively linked to
RT since there have been reports that similar intermittent problems
have been encountered with our Phorum installation (a PHP bulletin
board), however the problem with RT is much more frequent.

Some stats,

Solaris 9
Apache 2.0.55 (also happened with 1.3)
RT 3.4.5 (also happened with 3.4.2)
Perl 5.8.5

httpd.conf

OVERVIEW

This is a httpd.conf file written from scratch for server burs-unx004

production.

The structure also loosely follows the FHS standard for location of

files etc. See http://www.pathname.com/fhs/ for details.

Load the modules

Used to allow password protected directories

LoadModule auth_module modules/mod_auth.so

PHP 4 used for performance

LoadModule php4_module modules/libphp4.so

Enable SSL

LoadModule ssl_module modules/mod_ssl.so

Allows AddType directive

LoadModule mime_module modules/mod_mime.so

Allows DirectoryIndex directive

LoadModule dir_module modules/mod_dir.so

access_module for 2.0, authz_host_module for 2.2

LoadModule access_module modules/mod_access.so

LoadModule authz_host_module modules/mod_authz_host.so

Allows TransferLog directive

LoadModule log_config_module modules/mod_log_config.so

Allows Alias directive

LoadModule alias_module modules/mod_alias.so

Allows CGI scripting

LoadModule cgi_module modules/mod_cgi.so

Improve CGI performance, currently not compiled

LoadModule fastcgi_module modules/mod_fastcgi.so

Let Apache run as a powerless user and powerless group for security

reasons

User www
Group www

Set the domain name for this server root

ServerName estates.bris.ac.uk

Set contact name

ServerAdmin webmaster-estates@bris.ac.uk

Set the system path to the server root

DocumentRoot /srv/www/htdocs

Set the location of the log relative to the ServerRoot

TransferLog logs/access_log

Set port on which main sets of static docs are listened on

Listen 80
Listen 443

Set it so links can be followed, hence cgi-bin etc. can be accessed

Don’t allow CGIs, indexing of directories and server side includes

#Options +FollowSymLinks -ExecCGI -Indexes -Includes

Configure so that the cgi-bin directory can be used and accessed

through ServerName/cgi-bin

#ScriptAlias /cgi-bin /srv/www/cgi-bin

make sure Apache knows to pass .php files though PHP before serving

AddType application/x-httpd-php .php

make sure Apache know what to do with certificate files

AddType application/x-x509-ca-cert .crt
AddType application/x-pkcs7-crl .crl

Server-wide FastCGI directives

FastCgiIpcDir /tmp
FastCgiServer /usr/local/rt3/bin/mason_handler.fcgi -idle-timeout 120
-processes 4

Ordinary content served on port 80

ServerAdmin webmaster@example.com DocumentRoot /srv/www/htdocs ServerName example.com Redirect /rt https://example.com/rt

Secure content served on port 443

    ServerAdmin webmaster@example.com
    DocumentRoot /srv/www/htdocs
    ServerName example.comk

    # Entry for Request Tracker, only for encrypted connections
    # More info found at

http://www.fastcgi.com/mod_fastcgi/docs/mod_fastcgi.html
AddHandler fastcgi-script fcgi
ScriptAlias /rt /usr/local/rt3/bin/mason_handler.fcgi
# Alias /rt/NoAuth/images /usr/local/rt3/html/NoAuth/images

    # The SSL configuration directives
    SSLEngine on
    # List the ciphers that the client is permitted to negotiate
    SSLCipherSuite

ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL
# List all locations for OpenSSL certificates
SSLCertificateFile /var/ssl/public/estates-public.crt
SSLCertificateKeyFile /var/ssl/private/estates-private.key
SSLCertificateChainFile /var/ssl/public/estates-public-chain.crt

SSL cache, uses DBM, may suffer reliability under high loads

SSLSessionCache dbm:/usr/local/apache-2.0.55/logs/ssl_scache

Configure the path to the mutual exclusion semaphore the

SSL engine uses internally for inter-process synchronization.

SSLMutex file:/usr/local/apache-2.0.55/logs/ssl_mutex

Random number source

SSLRandomSeed startup builtin
SSLRandomSeed connect builtin

Allow various type of file to be served as index file

DirectoryIndex index.php index.html index.cgi index.pl

Don’t serve up .htaccess and htpasswd files

<Files ~ “^.ht”>
Order Allow,Deny
Deny from all
Satisfy all

Don’t serve up directories called ‘no-serve’

<DirectoryMatch “/srv/www/(.+)/no-serve”>
Order Allow,Deny
Deny from all
Satisfy all

Regards,

Brendan

I think correct ScripAlias string is:
ScriptAlias /rt/ /usr/local/rt3/bin/mason_handler.fcgiOn 4/21/06, Brendan Arnold brendanarnold@gmail.com wrote:

I may have found the solution. After including a RewriteRule directive
that adds a trailing slash to the end of the RT url it seems to work
OK.

Add this to your virtual host entry (or general server config)

RewriteEngine on RewriteRule /(rt)$ /$1/ [R} Redirect /rt https://example.com/rt ... RewriteEngine on RewriteRule /(rt)$ /$1/ [R] ...

If you use DSOs you need to load mod_rewrite

I am pretty sure that you should be able to combine the Redirect
directive into the RewriteRule however for some reason RewriteRule
/(rt)$ https://example.com/$1/ [R] does not work.

On 4/20/06, Brendan Arnold brendanarnold@gmail.com wrote:

Hi there,

When submitting form information such as logging in, updating a page
etc. Internet Explorer (6) returns a ‘The page cannot be found’ error
intermittently.

This happens consistently if I first load my RT login page as

https://example.com/rt

But not if I load it as

https://example.com/rt/

With the trailng slash. I think this may not be exclusively linked to
RT since there have been reports that similar intermittent problems
have been encountered with our Phorum installation (a PHP bulletin
board), however the problem with RT is much more frequent.

Some stats,

Solaris 9
Apache 2.0.55 (also happened with 1.3)
RT 3.4.5 (also happened with 3.4.2)
Perl 5.8.5

httpd.conf

OVERVIEW

This is a httpd.conf file written from scratch for server burs-unx004

production.

The structure also loosely follows the FHS standard for location of

files etc. See http://www.pathname.com/fhs/ for details.

Load the modules

Used to allow password protected directories

LoadModule auth_module modules/mod_auth.so

PHP 4 used for performance

LoadModule php4_module modules/libphp4.so

Enable SSL

LoadModule ssl_module modules/mod_ssl.so

Allows AddType directive

LoadModule mime_module modules/mod_mime.so

Allows DirectoryIndex directive

LoadModule dir_module modules/mod_dir.so

access_module for 2.0, authz_host_module for 2.2

LoadModule access_module modules/mod_access.so

LoadModule authz_host_module modules/mod_authz_host.so

Allows TransferLog directive

LoadModule log_config_module modules/mod_log_config.so

Allows Alias directive

LoadModule alias_module modules/mod_alias.so

Allows CGI scripting

LoadModule cgi_module modules/mod_cgi.so

Improve CGI performance, currently not compiled

LoadModule fastcgi_module modules/mod_fastcgi.so

Let Apache run as a powerless user and powerless group for security

reasons

User www
Group www

Set the domain name for this server root

ServerName estates.bris.ac.uk

Set contact name

ServerAdmin webmaster-estates@bris.ac.uk

Set the system path to the server root

DocumentRoot /srv/www/htdocs

Set the location of the log relative to the ServerRoot

TransferLog logs/access_log

Set port on which main sets of static docs are listened on

Listen 80
Listen 443

Set it so links can be followed, hence cgi-bin etc. can be accessed

Don’t allow CGIs, indexing of directories and server side includes

#Options +FollowSymLinks -ExecCGI -Indexes -Includes

Configure so that the cgi-bin directory can be used and accessed

through ServerName/cgi-bin

#ScriptAlias /cgi-bin /srv/www/cgi-bin

make sure Apache knows to pass .php files though PHP before serving

AddType application/x-httpd-php .php

make sure Apache know what to do with certificate files

AddType application/x-x509-ca-cert .crt
AddType application/x-pkcs7-crl .crl

Server-wide FastCGI directives

FastCgiIpcDir /tmp
FastCgiServer /usr/local/rt3/bin/mason_handler.fcgi -idle-timeout 120
-processes 4

Ordinary content served on port 80

ServerAdmin webmaster@example.com DocumentRoot /srv/www/htdocs ServerName example.com Redirect /rt https://example.com/rt

Secure content served on port 443

    ServerAdmin webmaster@example.com
    DocumentRoot /srv/www/htdocs
    ServerName example.comk

    # Entry for Request Tracker, only for encrypted connections
    # More info found at

http://www.fastcgi.com/mod_fastcgi/docs/mod_fastcgi.html
AddHandler fastcgi-script fcgi
ScriptAlias /rt /usr/local/rt3/bin/mason_handler.fcgi
# Alias /rt/NoAuth/images /usr/local/rt3/html/NoAuth/images

    # The SSL configuration directives
    SSLEngine on
    # List the ciphers that the client is permitted to negotiate
    SSLCipherSuite

ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL
# List all locations for OpenSSL certificates
SSLCertificateFile /var/ssl/public/estates-public.crt
SSLCertificateKeyFile /var/ssl/private/estates-private.key
SSLCertificateChainFile /var/ssl/public/estates-public-chain.crt

SSL cache, uses DBM, may suffer reliability under high loads

SSLSessionCache dbm:/usr/local/apache-2.0.55/logs/ssl_scache

Configure the path to the mutual exclusion semaphore the

SSL engine uses internally for inter-process synchronization.

SSLMutex file:/usr/local/apache-2.0.55/logs/ssl_mutex

Random number source

SSLRandomSeed startup builtin
SSLRandomSeed connect builtin

Allow various type of file to be served as index file

DirectoryIndex index.php index.html index.cgi index.pl

Don’t serve up .htaccess and htpasswd files

<Files ~ “^.ht”>
Order Allow,Deny
Deny from all
Satisfy all

Don’t serve up directories called ‘no-serve’

<DirectoryMatch “/srv/www/(.+)/no-serve”>
Order Allow,Deny
Deny from all
Satisfy all

Regards,

Brendan


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: http://bestpractical.com/about/jobs.html

Best regards, Ruslan.

Hi there,

When submitting form information such as logging in, updating a page
etc. Internet Explorer (6) returns a ‘The page cannot be found’ error
intermittently.

Your scriptalias is wrong.

ScriptAlias  / /opt/rt/rt3.fsck.com/bin/mason_handler.fcgi/

is what we use. Note the slash after .fcgi

Hi there,

When submitting form information such as logging in, updating a page
etc. Internet Explorer (6) returns a ‘The page cannot be found’ error
intermittently.

Your scriptalias is wrong.

ScriptAlias  / /opt/rt/rt3.fsck.com/bin/mason_handler.fcgi/

is what we use. Note the slash after .fcgi

I think main problem is that he is using /rt as root with next alias:
ScriptAlias /rt /opt/rt/rt3.fsck.com/bin/mason_handler.fcgi

First part should contain trailing slash
ScriptAlias /rt/ /opt/rt/rt3.fsck.com/bin/mason_handler.fcgi
^^^^^^
I don’t think slash is required after “…in/mason_handler.fcgi”, but
he could try both variants.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: http://bestpractical.com/about/jobs.html

Best regards, Ruslan.

Hmm, it appears that the Rewrite rule did not save the day (the nature
of intermittent errors!). I still get the problem. I have since tried
all of the following combinations,

ScriptAlias /rt/ /usr/local/rt3/bin/mason_handler.fcgi/ (IE error persisted)
ScriptAlias /rt /usr/local/rt3/bin/mason_handler.fcgi/ (IE error persisted)
ScriptAlias /rt/ /usr/local/rt3/bin/mason_handler.fcgi (Images etc not
displayed, URLS do not work at all)
ScriptAlias /rt /usr/local/rt3/bin/mason_handler.fcgi (original with IE error)

Bu none, as noted, worked. I noticed at the foot of the IE error page
it listed this as a ‘Cannot find server or DNS Error’, I’m starting to
think it may be an SSL problem …

Regards,

BrendanOn 4/21/06, Ruslan Zakirov ruslan.zakirov@gmail.com wrote:

On 4/21/06, Jesse Vincent jesse@bestpractical.com wrote:

On Thu, Apr 20, 2006 at 07:02:20PM +0100, Brendan Arnold wrote:

Hi there,

When submitting form information such as logging in, updating a page
etc. Internet Explorer (6) returns a ‘The page cannot be found’ error
intermittently.

Your scriptalias is wrong.

ScriptAlias  / /opt/rt/rt3.fsck.com/bin/mason_handler.fcgi/

is what we use. Note the slash after .fcgi

I think main problem is that he is using /rt as root with next alias:
ScriptAlias /rt /opt/rt/rt3.fsck.com/bin/mason_handler.fcgi

First part should contain trailing slash
ScriptAlias /rt/ /opt/rt/rt3.fsck.com/bin/mason_handler.fcgi
^^^^^^
I don’t think slash is required after “…in/mason_handler.fcgi”, but
he could try both variants.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: http://bestpractical.com/about/jobs.html


Best regards, Ruslan.

We’ve discussed with Jesse this problem a little and have a conclusion that
ScriptAlias /rt/ /usr/local/rt3/bin/mason_handler.fcgi/
is right and you need both trailing slashes.

Also note that in this situation URL http://www.example.com/rt
(without trailing slash) is incorrect. You should use URL with
trailing slash everywhere on your site and/or could add reqrite rule
that convert ‘/rt’ into ‘/rt/’.

And of course this problem couldn’t be related to the “Cannot find
server or DNS Error” error message unless Web* options are not
properly configured in RT site config.On 4/27/06, Brendan Arnold brendanarnold@gmail.com wrote:

Hmm, it appears that the Rewrite rule did not save the day (the nature
of intermittent errors!). I still get the problem. I have since tried
all of the following combinations,

ScriptAlias /rt/ /usr/local/rt3/bin/mason_handler.fcgi/ (IE error persisted)
ScriptAlias /rt /usr/local/rt3/bin/mason_handler.fcgi/ (IE error persisted)
ScriptAlias /rt/ /usr/local/rt3/bin/mason_handler.fcgi (Images etc not
displayed, URLS do not work at all)
ScriptAlias /rt /usr/local/rt3/bin/mason_handler.fcgi (original with IE error)

Bu none, as noted, worked. I noticed at the foot of the IE error page
it listed this as a ‘Cannot find server or DNS Error’, I’m starting to
think it may be an SSL problem …

Regards,

Brendan

On 4/21/06, Ruslan Zakirov ruslan.zakirov@gmail.com wrote:

On 4/21/06, Jesse Vincent jesse@bestpractical.com wrote:

On Thu, Apr 20, 2006 at 07:02:20PM +0100, Brendan Arnold wrote:

Hi there,

When submitting form information such as logging in, updating a page
etc. Internet Explorer (6) returns a ‘The page cannot be found’ error
intermittently.

Your scriptalias is wrong.

ScriptAlias  / /opt/rt/rt3.fsck.com/bin/mason_handler.fcgi/

is what we use. Note the slash after .fcgi

I think main problem is that he is using /rt as root with next alias:
ScriptAlias /rt /opt/rt/rt3.fsck.com/bin/mason_handler.fcgi

First part should contain trailing slash
ScriptAlias /rt/ /opt/rt/rt3.fsck.com/bin/mason_handler.fcgi
^^^^^^
I don’t think slash is required after “…in/mason_handler.fcgi”, but
he could try both variants.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: http://bestpractical.com/about/jobs.html


Best regards, Ruslan.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: http://bestpractical.com/about/jobs.html

Best regards, Ruslan.

OK I have set ScriptAlias as suggested, although the problems still
persist on occasion.

The Web* vars from RT_SiteConfig are as follows,

Set($WebPath , “/rt”);
Set($WebBaseURL , “https://example.com”);
Set($WebURL , $WebBaseURL . $WebPath . “/”);

Should this be instead…

Set($WebPath , “/rt/”);
Set($WebBaseURL , “https://example.com”);
Set($WebURL , $WebBaseURL . $WebPath);

Regards,

Brendan

The first variant of the settings is correct.On 4/28/06, Brendan Arnold brendanarnold@gmail.com wrote:

OK I have set ScriptAlias as suggested, although the problems still
persist on occasion.

The Web* vars from RT_SiteConfig are as follows,

Set($WebPath , “/rt”);
Set($WebBaseURL , “https://example.com”);
Set($WebURL , $WebBaseURL . $WebPath . “/”);

Should this be instead…

Set($WebPath , “/rt/”);
Set($WebBaseURL , “https://example.com”);
Set($WebURL , $WebBaseURL . $WebPath);

Regards,

Brendan


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: http://bestpractical.com/about/jobs.html

Best regards, Ruslan.

Hi again,

I still have the problem. I have found out some more information
though. After checking the logs it seems that IE, when submitting the
form info, actually does not generate a log entry. Also the ‘Page
cannot be found’ error appears almost immediately which gives me the
impression that IE does not even attempt to connect to the server
before it gives the error. It also seems to happen more often if you
wait about 60 seconds or more before submitting the form.

Does anyone else have this problem as it is driving me crazy!

Regards,

BrendanOn 4/28/06, Ruslan Zakirov ruslan.zakirov@gmail.com wrote:

The first variant of the settings is correct.

On 4/28/06, Brendan Arnold brendanarnold@gmail.com wrote:

OK I have set ScriptAlias as suggested, although the problems still
persist on occasion.

The Web* vars from RT_SiteConfig are as follows,

Set($WebPath , “/rt”);
Set($WebBaseURL , “https://example.com”);
Set($WebURL , $WebBaseURL . $WebPath . “/”);

Should this be instead…

Set($WebPath , “/rt/”);
Set($WebBaseURL , “https://example.com”);
Set($WebURL , $WebBaseURL . $WebPath);

Regards,

Brendan


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: http://bestpractical.com/about/jobs.html


Best regards, Ruslan.

Quoth Brendan Arnold (brendanarnold@gmail.com):

Hi again,

I still have the problem. I have found out some more information
though. After checking the logs it seems that IE, when submitting the
form info, actually does not generate a log entry. Also the ‘Page
cannot be found’ error appears almost immediately which gives me the
impression that IE does not even attempt to connect to the server
before it gives the error. It also seems to happen more often if you
wait about 60 seconds or more before submitting the form.

Does anyone else have this problem as it is driving me crazy!

Regards,

Brendan

This is unrelated to RT, but I’ve been bashing my head against the
IE/mod_ssl/‘DNS Error’ problem for the past week or 2, with both apache
1.3.x and 2.0.x.

I don’t have the slightest clue at this point what it is. :confused:

Just thought you’d like to know you’re not alone.

JB
JB Segal 617-886-5575 www.smartertravel.com
Systems/Network Admin. 465 Medford St. Ste 400 www.bookingbuddy.com
Smarter Living, Inc. Boston, MA 02129 www.tripmania.com

Hi JB,

I’m glad its not just me! My boss is starting to put the pressure on
for me to fix this before I roll RT out to other people on our
network.

Just out of curiosity, does your server have multiple DNS aliases?
Ours for instance is known as ‘burs-unx004.wbd’ as well as ‘estates’.
Our SSL certificate was generated for the name ‘estates’ although
nslookup returns ‘burs-unx004.wbd’ as the computer name linked with
the IP.

I heard IE has trouble linking IPs with names, maybe this could be the cause?

Brendan
IOn 5/11/06, JB Segal jb@smarterliving.com wrote:

Quoth Brendan Arnold (brendanarnold@gmail.com):

Hi again,

I still have the problem. I have found out some more information
though. After checking the logs it seems that IE, when submitting the
form info, actually does not generate a log entry. Also the ‘Page
cannot be found’ error appears almost immediately which gives me the
impression that IE does not even attempt to connect to the server
before it gives the error. It also seems to happen more often if you
wait about 60 seconds or more before submitting the form.

Does anyone else have this problem as it is driving me crazy!

Regards,

Brendan

This is unrelated to RT, but I’ve been bashing my head against the
IE/mod_ssl/‘DNS Error’ problem for the past week or 2, with both apache
1.3.x and 2.0.x.

I don’t have the slightest clue at this point what it is. :confused:

Just thought you’d like to know you’re not alone.

JB

JB Segal 617-886-5575 www.smartertravel.com
Systems/Network Admin. 465 Medford St. Ste 400 www.bookingbuddy.com
Smarter Living, Inc. Boston, MA 02129 www.tripmania.com

Hi again,

I still have the problem. I have found out some more information
though. After checking the logs it seems that IE, when submitting the
form info, actually does not generate a log entry. Also the ‘Page
cannot be found’ error appears almost immediately which gives me the
impression that IE does not even attempt to connect to the server
before it gives the error. It also seems to happen more often if you
wait about 60 seconds or more before submitting the form.

Does anyone else have this problem as it is driving me crazy!

If the URL actually refers to a directory, expecting to hit the
default index page and you omit the trailing /, the server will
send a redirect with the slash to normalize the URL so
relative links on the page will work. The redirect should
be to the same hostname as the original URL contained, but
if you have UseCanonicalName on in your httpd.conf (and I
think it’s the default), it will instead be the name
specified in ServerName. If you are getting a client DNS
error on the redirects, maybe you have a typo in your
ServerName.

Les Mikesell
les@futuresource.com

I have changed all references in RT_SiteConfig and Apache config from
the commonly used DNS alias (estates) to the DNS entry that comes up
when performing an IP lookup. So far I have not experiecned any Page
Cannot be found errors. I will keep you updated.

So for others in a simiilar situation, try 'nslookup ’ to
find out what your default DNS domain name is and use that in the
config rather than a DNS alias.

BrendanOn 5/18/06, Les Mikesell les@futuresource.com wrote:

On Mon, 2006-05-08 at 11:34, Brendan Arnold wrote:

Hi again,

I still have the problem. I have found out some more information
though. After checking the logs it seems that IE, when submitting the
form info, actually does not generate a log entry. Also the ‘Page
cannot be found’ error appears almost immediately which gives me the
impression that IE does not even attempt to connect to the server
before it gives the error. It also seems to happen more often if you
wait about 60 seconds or more before submitting the form.

Does anyone else have this problem as it is driving me crazy!

If the URL actually refers to a directory, expecting to hit the
default index page and you omit the trailing /, the server will
send a redirect with the slash to normalize the URL so
relative links on the page will work. The redirect should
be to the same hostname as the original URL contained, but
if you have UseCanonicalName on in your httpd.conf (and I
think it’s the default), it will instead be the name
specified in ServerName. If you are getting a client DNS
error on the redirects, maybe you have a typo in your
ServerName.


Les Mikesell
les@futuresource.com

I’ve seen this issue before but all I had to do to fix it is to setup mod_rewrite to redirect https://rtserver.example.com/rt to https://rtserver.example.com/rt/

ChrisFrom: Brendan Arnold [mailto:brendanarnold@gmail.com]
Sent: Fri May 19 11:05:57 2006
To: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Lack of trailing slash causing porblems in IE

I have changed all references in RT_SiteConfig and Apache config from
the commonly used DNS alias (estates) to the DNS entry that comes up
when performing an IP lookup. So far I have not experiecned any Page
Cannot be found errors. I will keep you updated.

So for others in a simiilar situation, try 'nslookup ’ to
find out what your default DNS domain name is and use that in the
config rather than a DNS alias.

Brendan

Yeah I have set up mod_rewrite to do just that which solved some of
the ‘Page Cannot be Found’ errors, however there are other ‘Page
Cannot be Found’ errors which seem to be caused by something else.

It seems IE has additional porblems with DNS lookups. I have changed
all references in htttpd.conf and RT_SiteConfig (bar $rtname in
RT_SiteConfig) to the DNS name that returns from nslookup on a Windows
machine for my server (before it was configured for a DNS alias) which
has greatly reduced the number of errors. Unfortunately, I have seen
one of these errors manifest again but this could be due to
cache/legacy tickets.

BrendanOn 5/19/06, Covington, Chris Chris.Covington@plusone.com wrote:

I’ve seen this issue before but all I had to do to fix it is to setup mod_rewrite to redirect https://rtserver.example.com/rt to https://rtserver.example.com/rt/

Chris

-----Original Message-----
From: Brendan Arnold [mailto:brendanarnold@gmail.com]
Sent: Fri May 19 11:05:57 2006
To: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Lack of trailing slash causing porblems in IE

I have changed all references in RT_SiteConfig and Apache config from
the commonly used DNS alias (estates) to the DNS entry that comes up
when performing an IP lookup. So far I have not experiecned any Page
Cannot be found errors. I will keep you updated.

So for others in a simiilar situation, try 'nslookup ’ to
find out what your default DNS domain name is and use that in the
config rather than a DNS alias.

Brendan

On 5/18/06, Les Mikesell les@futuresource.com wrote:

On Mon, 2006-05-08 at 11:34, Brendan Arnold wrote:

Hi again,

I still have the problem. I have found out some more information
though. After checking the logs it seems that IE, when submitting the
form info, actually does not generate a log entry. Also the ‘Page
cannot be found’ error appears almost immediately which gives me the
impression that IE does not even attempt to connect to the server
before it gives the error. It also seems to happen more often if you
wait about 60 seconds or more before submitting the form.

Does anyone else have this problem as it is driving me crazy!

If the URL actually refers to a directory, expecting to hit the
default index page and you omit the trailing /, the server will
send a redirect with the slash to normalize the URL so
relative links on the page will work. The redirect should
be to the same hostname as the original URL contained, but
if you have UseCanonicalName on in your httpd.conf (and I
think it’s the default), it will instead be the name
specified in ServerName. If you are getting a client DNS
error on the redirects, maybe you have a typo in your
ServerName.


Les Mikesell
les@futuresource.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: http://bestpractical.com/about/jobs.html

!DSPAM:1,446dded5101048743255425!

I have tried changing the primary DNS hostname to that on our SSL
certificate, however this has had no effect.

I have just come across this article in the MS Knowledge base which
may be of some help. I am going to try disabling SSL 3.0 connections
as a result.

http://support.microsoft.com/?kbid=305217

I will keep you posted as to progress.

Brendan

I inlcuded this Aoache directive to remove SSLv3 negotiations

SSLProtocol all -SSLv3

Since then I have not had any errors, although the porblem is
intermittent. If I have any trouble I will let the group know.

BrendanOn 6/1/06, Brendan Arnold brendanarnold@gmail.com wrote:

I have tried changing the primary DNS hostname to that on our SSL
certificate, however this has had no effect.

I have just come across this article in the MS Knowledge base which
may be of some help. I am going to try disabling SSL 3.0 connections
as a result.

http://support.microsoft.com/?kbid=305217

I will keep you posted as to progress.

Brendan

For those that (very reasonably) don’t want to disable SSLv3 then try
doing the steps outlines on the mod_ssl FAQ,

http://www.modssl.org/docs/2.8/ssl_faq.html#ToC49

I am going to try this rather than disabling SSLv3 altogether and will
let you know.

Brendan

This seems to have solved the problem without the Draconian measure of
forcing SSLv2 connections.

RT connections are now updating consistently!

Brendan