Is this problem depending on my mysql-version?

Hi list,

during the installation of rt2 I get the following error:

/usr/bin/perl tools/initdb ‘mysql’ ‘/usr’ ‘localhost’ ‘rt’ 'rt2’
insert
Now populating database schema.
Enter the mysql password for rt:
Creating database schema.
DBD::mysql::st execute failed: Specified key was too long. Max key
length is 256 at tools/initdb line 160, chunk 258.
Problem with statement:
CREATE TABLE KeywordSelects (
id INTEGER NOT NULL AUTO_INCREMENT,
Name varchar(255) NULL ,
Keyword integer NOT NULL ,
Single integer NULL ,
Depth integer NOT NULL DEFAULT 0 ,
ObjectType varchar(32) NOT NULL ,
ObjectField varchar(32) NOT NULL ,
ObjectValue varchar(255) NOT NULL ,
Disabled int2 NOT NULL DEFAULT 0 ,
PRIMARY KEY (id),
INDEX (Keyword),
INDEX (ObjectType, ObjectField, ObjectValue)
)

Specified key was too long. Max key length is 256 at tools/initdb line
162, chunk 258.
make: *** [initdb.rtuser] Error 255

Unfortunately I�m using mysql-server version: 3.22.32 and I can�t
upgrade now.

Does this problem depend on the version, or there another thing to do?

Thanks for your help in advance.

Regards
Klaus
Klaus Hoffmann EMail: klaus.hoffmann@s3-med.de
HOFFMANN Consulting Tel.: +49-7161-989464
Unternehmensberatungs GmbH Fax: +49-7161-989466
Zeisigweg 1 Mobil: +49-170-2033183
D-73054 Eislingen Mobilfx:+49-170-132033230

At 16:38 13/07/2001, Klaus Hoffmann wrote:

Hi list,

during the installation of rt2 I get the following error:

/usr/bin/perl tools/initdb ‘mysql’ ‘/usr’ ‘localhost’ ‘rt’ 'rt2’
insert
Now populating database schema.
Enter the mysql password for rt:
Creating database schema.
DBD::mysql::st execute failed: Specified key was too long. Max key
length is 256 at tools/initdb line 160, chunk 258.
Problem with statement:
CREATE TABLE KeywordSelects (
id INTEGER NOT NULL AUTO_INCREMENT,
Name varchar(255) NULL ,
Keyword integer NOT NULL ,
Single integer NULL ,
Depth integer NOT NULL DEFAULT 0 ,
ObjectType varchar(32) NOT NULL ,
ObjectField varchar(32) NOT NULL ,
ObjectValue varchar(255) NOT NULL ,
Disabled int2 NOT NULL DEFAULT 0 ,
PRIMARY KEY (id),
INDEX (Keyword),
INDEX (ObjectType, ObjectField, ObjectValue)
)

Specified key was too long. Max key length is 256 at tools/initdb line
162, chunk 258.
make: *** [initdb.rtuser] Error 255

Unfortunately I´m using mysql-server version: 3.22.32 and I can´t
upgrade now.

I seem to recall Jesse saying that you need 3.23 - this bit me, too. And,
sadly,
I don’t think you can run two versions of MySQL at the same time. :frowning: We have
some in-house software that needs 3.22.32, and alas won’t run on 3.23. So,
we’re still using rt-1.0.7…

You could try, perhaps, install postgresql as well? And just having rt2 use
that?
Though, if you’re actually upgrading from 1.x to 2.x, I’m not sure how
you’d convert
the data from MySQL into PgSQL. If you’re doing a clean install, it
shouldn’t bother
you…

Chris

Does this problem depend on the version, or there another thing to do?

Thanks for your help in advance.

Regards
Klaus

Klaus Hoffmann EMail: klaus.hoffmann@s3-med.de
HOFFMANN Consulting Tel.: +49-7161-989464
Unternehmensberatungs GmbH Fax: +49-7161-989466
Zeisigweg 1 Mobil: +49-170-2033183
D-73054 Eislingen Mobilfx:+49-170-132033230


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Chris Waltham
Systems Administrator
HarvestRoad, Limited.
chris@harvestroad.com
phone: (08) 9338-3000