Is there an easy way to disable attach files?

Hi,

I’m being responsible to deploy RT on our institution. My boss doesn’t
want to allow the upload of attached files to tickets, so I’m disabling
it. I thought that it would be possible though etc/RT_SiteConfig.pm. I
have set MaxAttachmentSize to 0, but even with a 0 value the system let
me upload files which I can later retrieve (hence they are on the database).

I now that I can copy every share/html file where there is an “upload
field” to local/html and edit them to remove the code that shows this
field, but that means at least editing 3 pages (Ticket/Create.html,
Ticket/Update.html and Ticket/ModifyAll.html). Before I continue, I ask
myself, and want to ask you, if there is an easier/better way to disable
the upload of files.

Any advice is, as always, very welcome.

Regards, and Marry Christmas,
Carlos


| __ __ | Carlos Garc�a Montoro Ingeniero Inform�tico
|_Y/| Instituto de F�sica Corpuscular Centro Mixto CSIC - UV
|_] [
/| Servicios Inform�ticos
| [] | Edificio Institutos de Investigaci�n cgarcia@ific.uv.es
|C S I C| Apartado de Correos 22085 E-46071 Valencia Tel: +34 963543706
|
______| Espa�a / Spain Fax: +34 963543488

cgarcia.vcf (441 Bytes)

Hi,

I’m being responsible to deploy RT on our institution. My boss
doesn’t want to allow the upload of attached files to tickets, so
I’m disabling it. I thought that it would be possible though
etc/RT_SiteConfig.pm. I have set MaxAttachmentSize to 0, but even
with a 0 value the system let me upload files which I can later
retrieve (hence they are on the database).

What happens if you set this to 1 instead of 0 and also set
DropLongAttachments?

-kevin

Hi Kevin, list,

Sorry for the late answer. I was on holidays…

Your solution works. It prevents to upload files to RT but only if
DropLongAttachments is defined. The only complain that I have about it
is that it discard the file silently. The user sees that the upload of
file has been recorded thus s/he thinks that the file is there. Only if
s/he clicks the link of the file s/he can read “Large attachment
dropped”. It is not a big issue, but I would rather warm before and I
probably wouldn’t record this failed upload.

Thanking you for your help,
Carlos

Kevin Falcone wrote:> On Wed, Dec 23, 2009 at 11:29:37AM +0100, Carlos Garcia Montoro wrote:

Hi,

I’m being responsible to deploy RT on our institution. My boss
doesn’t want to allow the upload of attached files to tickets, so
I’m disabling it. I thought that it would be possible though
etc/RT_SiteConfig.pm. I have set MaxAttachmentSize to 0, but even
with a 0 value the system let me upload files which I can later
retrieve (hence they are on the database).

What happens if you set this to 1 instead of 0 and also set
DropLongAttachments?

-kevin

I now that I can copy every share/html file where there is an
"upload field" to local/html and edit them to remove the code that
shows this field, but that means at least editing 3 pages
(Ticket/Create.html, Ticket/Update.html and Ticket/ModifyAll.html).
Before I continue, I ask myself, and want to ask you, if there is an
easier/better way to disable the upload of files.



http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Spam detection software, running on the system “hal.ific.uv.es”, has
identified this incoming email as possible spam. The original message
has been attached to this so you can view it (if it isn’t spam) or label
similar future email. If you have any questions, see
the administrator of that system for details.

Content preview: On Wed, Dec 23, 2009 at 11:29:37AM +0100, Carlos Garcia
Montoro wrote: > Hi, > > I’m being responsible to deploy RT on our
institution. My boss > doesn’t want to allow the upload of attached
files to tickets, so > I’m disabling it. I thought that it would be
possible though > etc/RT_SiteConfig.pm. I have set MaxAttachmentSize to
0, but even > with a 0 value the system let me upload files which I can
later > retrieve (hence they are on the database). […]

Content analysis details: (5.5 points, 5.0 required)

pts rule name description


2.5 FORGED_RCVD_HELO Received: contains a forged HELO
3.0 KXLINKRR_BODY BODY: Body contains suspicious link


| __ __ | Carlos Garc�a Montoro Ingeniero Inform�tico
|_Y/| Instituto de F�sica Corpuscular Centro Mixto CSIC - UV
|_] [
/| Servicios Inform�ticos
| [] | Edificio Institutos de Investigaci�n cgarcia@ific.uv.es
|C S I C| Apartado de Correos 22085 E-46071 Valencia Tel: +34 963543706
|
______| Espa�a / Spain Fax: +34 963543488

cgarcia.vcf (441 Bytes)

Hi Kevin, list,

Sorry for the late answer. I was on holidays…

Your solution works. It prevents to upload files to RT but only if
DropLongAttachments is defined. The only complain that I have about
it is that it discard the file silently. The user sees that the
upload of file has been recorded thus s/he thinks that the file is
there. Only if s/he clicks the link of the file s/he can read “Large
attachment dropped”. It is not a big issue, but I would rather warm
before and I probably wouldn’t record this failed upload.

Unfortunately, thats going to require some coding to say that an
error occurred (RT doesn’t see it as an error, it just sees it as
trimming your attachment to a byte)

-kevin

Kevin,

Some time ago I asked the list if it is possible to disable the upload
of attached files. You suggested to set MaxAttachmentSize to 1 and to
define DropLongAttachments. I committed to you that it works, but
actually it doesn’t. This configuration prevents the upload of files,
but it also prevents to write any message in tickets (at least when the
rich text editor is activated).

Just in case anybody is interested: In the end I have taken the attached
files out of our RT by doing a local version of Ticket/Create.html,
Ticket/ModifyAll.html and Ticket/Update.html in which I comment the code
related to the upload of files (where the fields and buttons are drawn
and where the file is uploaded).

Hope to be helpful,
Carlos

Kevin Falcone wrote:> On Mon, Jan 04, 2010 at 09:13:38AM +0100, Carlos Garcia Montoro wrote:

Hi Kevin, list,

Sorry for the late answer. I was on holidays…

Your solution works. It prevents to upload files to RT but only if
DropLongAttachments is defined. The only complain that I have about
it is that it discard the file silently. The user sees that the
upload of file has been recorded thus s/he thinks that the file is
there. Only if s/he clicks the link of the file s/he can read “Large
attachment dropped”. It is not a big issue, but I would rather warm
before and I probably wouldn’t record this failed upload.

Unfortunately, thats going to require some coding to say that an
error occurred (RT doesn’t see it as an error, it just sees it as
trimming your attachment to a byte)

-kevin

Kevin Falcone wrote:

On Wed, Dec 23, 2009 at 11:29:37AM +0100, Carlos Garcia Montoro wrote:

Hi,

I’m being responsible to deploy RT on our institution. My boss
doesn’t want to allow the upload of attached files to tickets, so
I’m disabling it. I thought that it would be possible though
etc/RT_SiteConfig.pm. I have set MaxAttachmentSize to 0, but even
with a 0 value the system let me upload files which I can later
retrieve (hence they are on the database).
What happens if you set this to 1 instead of 0 and also set
DropLongAttachments?

-kevin

I now that I can copy every share/html file where there is an
"upload field" to local/html and edit them to remove the code that
shows this field, but that means at least editing 3 pages
(Ticket/Create.html, Ticket/Update.html and Ticket/ModifyAll.html).
Before I continue, I ask myself, and want to ask you, if there is an
easier/better way to disable the upload of files.



http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Spam detection software, running on the system “hal.ific.uv.es”, has
identified this incoming email as possible spam. The original message
has been attached to this so you can view it (if it isn’t spam) or label
similar future email. If you have any questions, see
the administrator of that system for details.

Content preview: On Mon, Jan 04, 2010 at 09:13:38AM +0100, Carlos Garcia
Montoro wrote: > Hi Kevin, list, > > Sorry for the late answer. I was
on holidays… > > Your solution works. It prevents to upload files to
RT but only if > DropLongAttachments is defined. The only complain that
I have about > it is that it discard the file silently. The user sees
that the > upload of file has been recorded thus s/he thinks that the
file is > there. Only if s/he clicks the link of the file s/he can read
"Large > attachment dropped". It is not a big issue, but I would rather
warm > before and I probably wouldn’t record this failed upload. […]

Content analysis details: (5.5 points, 5.0 required)

pts rule name description


2.5 FORGED_RCVD_HELO Received: contains a forged HELO
3.0 KXLINKRR_BODY BODY: Body contains suspicious link


| __ __ | Carlos Garc�a Montoro Ingeniero Inform�tico
|_Y/| Instituto de F�sica Corpuscular Centro Mixto CSIC - UV
|_] [
/| Servicios Inform�ticos
| [] | Edificio Institutos de Investigaci�n cgarcia@ific.uv.es
|C S I C| Apartado de Correos 22085 E-46071 Valencia Tel: +34 963543706
|
______| Espa�a / Spain Fax: +34 963543488

cgarcia.vcf (441 Bytes)