Internal Server error, when trying to acces RT4.0.5

Hello.

Sorry for all the messages. I´m very frustraring with this installation.

I install all the system, and install and initialize the database.
Configure /opt/rt4/etc/RT_SiteConfig.pm, reload Apache.
And get and 500 Interal Server Error.

This is my /var/log/httpd/error_log output.

[Wed Mar 14 12:20:20 2012] [crit]: Could not create
’/opt/rt4/var/mason_data/obj/.__obj_create_marker’: Permission denied
Stack:
[/usr/local/share/perl5/HTML/Mason/Interp.pm:222]
[/usr/local/share/perl5/HTML/Mason/Interp.pm:169]
[/usr/local/share/perl5/HTML/Mason/Interp.pm:155]
[/usr/local/share/perl5/Class/Container.pm:329]
[/usr/local/share/perl5/Class/Container.pm:53]
[/usr/local/share/perl5/HTML/Mason/CGIHandler.pm:48]
[/usr/local/share/perl5/HTML/Mason/PSGIHandler.pm:14]
[/opt/rt4/sbin/…/lib/RT/Interface/Web/Handler.pm:111]
[/opt/rt4/sbin/…/lib/RT/Interface/Web/Handler.pm:220]
[/opt/rt4/sbin/rt-server.fcgi:144] (/opt/rt4/sbin/…/lib/RT.pm:341)
Died at /opt/rt4/sbin/…/lib/RT.pm line 343.
[Wed Mar 14 13:20:20 2012] [warn] [client 172.16.5.39] (104)Connection
reset by peer: mod_fcgid: error reading data from FastCGI server
[Wed Mar 14 13:20:20 2012] [error] [client 172.16.5.39] Premature end of
script headers: rt-server.fcgi

Any help will be appreciated.
Kindest regards.

I install all the system, and install and initialize the database.
Configure /opt/rt4/etc/RT_SiteConfig.pm, reload Apache.
And get and 500 Interal Server Error.

This is my /var/log/httpd/error_log output.

[Wed Mar 14 12:20:20 2012] [crit]: Could not create
‘/opt/rt4/var/mason_data/obj/.__obj_create_marker’: Permission denied

The mailing list contains many examples of this problem. You need to
make sure /opt/rt4/var/mason_data/ and everything under it is
readable/writeable by the user/group the webserver runs as.

This isn’t generally a problem unless you’ve run a standalone server by
hand as root before running apache.

Sorry Selinux is the problem.

Disable it, restarted and works :smiley:

I believe there are solutions less drastic than disabling selinux in the
list archives, if you’re interested.