Int.characters in tickets: bug or config problem?

Dear all,

Regarding RT 3.0.1:

we still have severe problems with tickets containing
any international characters like ö ä ü ß é è ê â etc.

Tickets created by eMails containig such characters are
simply broken (only the subject line displays correctly)
and replies from the web interface do not work at all
(the reply mail seems to be truncated after the first
non-7-bit characters)

This is very sad because it keeps us from releasing RT
to public use.

So my question is:

  1. Is this a (known) bug?

  2. If not: How do I configure RT to handle this stuff correctly?

Many thanks für any help!

Jerry
Gerald Rüscher
Lt. Rechnerbetreuung Mathematik
ruescher@math.upb.de

Universität Paderborn
Fakultät V - Mathematik/Informatik/Elektrotechnik
Warburger Str. 100
D-33098 Paderborn
Tel : 05251/60-2600
Fax : 05251/60-3729

Dear all,

Regarding RT 3.0.1:

we still have severe problems with tickets containing
any international characters like ö ä ü ß é è ê â etc.

[snip]

This is very sad because it keeps us from releasing RT
to public use.

So my question is:

  1. Is this a (known) bug?

Yes. Most of the web-related i18n errors seem to have been fixed in RT
3.0.2 pre 5, which is the latest and greatest.

Regards,
Harald

Harald Wagener * FCB/Wilkens * An der Alster 42 * 20099 Hamburg

Quoting Gerald R�scher gruescher@gmx.de:

I also had similar issues.
However, after a bit of tweaking, the system
is now usable, with working international characters
both from e-mails and web interface.

I maintain a small patch here… What’s the best way
to “release” it and have Jesse take a look at it ?

In the hope this will be useful…

I also had similar issues.
However, after a bit of tweaking, the system
is now usable, with working international characters
both from e-mails and web interface.

I maintain a small patch here… What’s the best way
to “release” it and have Jesse take a look at it ?

In the hope this will be useful…

I’d recommend sending it to rt-3.0-bugs at fsck.com and rt-devel at
lists.fsck.com. But I’d a�lso appreciate it if you can verifya that it�s
still an issue with 3.0.2pre5. (Sorry for the german keyboard induced
typos)
jesse

lists.fsck.com. But I’d a�lso appreciate it if you can verifya that it�s
still an issue with 3.0.2pre5. (Sorry for the german keyboard induced

I recently upgraded from 3.0.0 to 3.0.2pre5, hoping norwegian characters
would work, but I am still seeing the same problems as I used to. I
noticed that during ‘make upgrade’ it failed to find some files in
’./local/’ somewhere, I don’t know if that could be part of the problem,
since that directory wasn’t in the tarball. (I can probably find the
full error-message(s) if you want.)

These are my emailencoding-options in RT_SiteConfig.pm:

@EmailInputEncodings = qw(iso-8859-1 utf-8 us-ascii) unless
(@EmailEncodings);
Set($EmailOutputEncoding , ‘iso-8859-1’);

And this is in my VirtualHost-section in httpd.conf:

AddDefaultCharset UTF-8

(Should this be changed to ISO-8859-1?)

A few other things I noticed after some testing is when viewing a ticket
where the requestors name has norwegian characters in it, the name shows
up as “More about Kristian =?ISO-8859-1?Q?R=F8nningen?=”

And an even stranger thing - I replied to a ticket with the text:

a æ a
b ø b
c å c

And when I get back to the ticket-page, my reply looks like this:

a æ a
ø b
å c

The first “b” and “c” are gone! (The space is still there, but doesn’t
show up in html, only in the mailed reply.)

Also, the From: header contains this:
=?ISO-8859-1?B?IktyaXN0aWFuIFL4bm5pbmdlbiB2aWEgUlQiIDxub3Jka2FwcEBub3Jka2FwcC5uZXQ+?=@sm1.nordkapp.net
Didn’t find anything in the docs that explains why it is like that.

Hope this helps in some way

Kristian Rønningen krmm@nordkapp.net

I experience similar problems, though they might be aggravated due to
my b0rked perl installation (I am going to replace perl by a self built
version soon).

  • Tickets that only contain special characters (for example ‘äöüß’ to
    test) will have an empty body.

  • Other characters don’t seem to be recoded correctly:

€€€€€€€€€€€€€€€€€€ EEEEEEEEEEEEEE
EEEEEEEEEEEEEEEEEE €€€€€€€€€€€€€€
E€E€E€E
?ßßßß?
ßßßß?

will become

€€€€€€€€€€€€€€€€€€ EEEEEEEEEEEEEE
EEEEEEEEEEEEEEEEEE €€€€€€€€€€€€€€
E€E€E€E
?ßßßß?
ßßßß?
Harald Wagener * FCB/Wilkens * An der Alster 42 * 20099 Hamburg

Harald Wagener:

I experience similar problems, though they might be aggravated due to
my b0rked perl installation (I am going to replace perl by a
self built version soon).

  • Tickets that only contain special characters (for example ‘äöüß’ to
    test) will have an empty body.

  • Other characters don’t seem to be recoded correctly:

€€€€€€€€€€€€€€€€€€ EEEEEEEEEEEEEE
EEEEEEEEEEEEEEEEEE €€€€€€€€€€€€€€
E€E€E€E
?ßßßß?
ßßßß?

will become

€€€€€€€€€€€€€€€€€€ EEEEEEEEEEEEEE
EEEEEEEEEEEEEEEEEE €€€€€€€€€€€€€€
E€E€E€E
?ßßßß?
ßßßß?

I desperately hope that Remy’s patch will fix these problems.

Frankly, has anyone managed to set up RT3 to work in an
"international" environment? RT2 was fine though.

Jerry

Gerald Rüscher
Lt. Rechnerbetreuung Mathematik
ruescher@math.upb.de

Universität Paderborn
Fakultät V - Mathematik/Informatik/Elektrotechnik
Warburger Str. 100
D-33098 Paderborn
Tel : 05251/60-2600
Fax : 05251/60-3729

Yes. Most of the web-related i18n errors seem to have been fixed in RT
3.0.2 pre 5, which is the latest and greatest.

I just upgraded RT 3.0.2 - from 3.0.1 - and I’m now having problems with
the international characters when I send an e-mail from the web interface

  • which was not an issue with 3.0.1.

I tried to change the /opt/rt3/etc/RT_Config.pm to
Set($EmailOutputEncoding , ‘iso-8859-1’);
but I’m still receiving this (I’m using Pine and spamcop webmail to
test):

[ The following text is in the "utf-8" character set. ]
[ Your display is set for the "ISO-8859-1" character set.  ]
[ Some characters may be displayed incorrectly. ]

Along with all international characters being changed.

(yes, I reloaded the Apache server)

Messages from e-mail into RT are well handled - no characters are being
changed. But it is impossible to reply to any message without messing up
everything.

Any clues?

RedHat 7.3, Apache 1.3.27 with mod_perl, Sendmail 8.12.6