Installing a rt-3.4.0 on fedora 3 - mysql issue during the make initialize-database

Hi all,

I’m trying a new install on a new box.
Fedora Core 3, full install.
I made the Mysql upgrade to a 4.1.9 standard version without any problem.
No missing dependancies at all.

Off course i’m root during the install.

make install ==> no problem.
make initialize-Database ==>

[root@rt2 rt-3.4.0]# make initialize-database
/usr/bin/perl //usr/local/rt3/sbin/rt-setup-database --action init --dba root --prompt-for-dba-password
In order to create or update your RT database,this script needs to connect to your mysql instance on localhost as root.
Please specify that user’s database password below. If the user has no database
password, just press return.

Password: I give the good password …

DBI connect(’;host=localhost’,‘root’,…) failed: Client does not support authentication protocol requested by server; consider upgrading MySQL client at //usr/local/rt3/sbin/rt-setup-database line 101
Failed to connect to dbi:mysql:;host=localhost as root: Client does not support authentication protocol requested by server; consider upgrading MySQL client at //usr/local/rt3/sbin/rt-setup-database line 101, line 1.
make: *** [initialize-database] Erreur 255

Ooops …

So I passed the following command : SET PASSWORD FOR ‘root’@‘localhost’ = OLD_PASSWORD(‘xxxxxxx’);
and tried a Make initialize-database again and now i have :

[root@rt2 rt-3.4.0]# make initialize-database
/usr/bin/perl //opt/rt3/sbin/rt-setup-database --action init --dba root --prompt-for-dba-password

In order to create or update your RT database,this script needs to connect to your mysql instance on localhost as root.
Please specify that user’s database password below. If the user has no database
password, just press return.

Password:xxxxxx
Now creating a database for RT.
Creating mysql database rt3.
Now populating database schema.
Creating database schema.
Done setting up database schema.
Now inserting database ACLs
Done setting up database ACLs.
Now inserting RT core system objects
[Tue Feb 1 22:44:29 2005] [crit]: Connect Failed Client does not support authentication protocol requested by server; consider upgrading MySQL client
at //opt/rt3/sbin/rt-setup-database line 384
(/opt/rt3/lib/RT.pm:285)
make: *** [initialize-database] Error 255

What can ( must) i do now ?

Best Regards and thanks for your help.

Max.

you should rebuild perl module DBD::mysql against your new mysql
libraries since the one came with FC3 is built against mysql 3.2.x
libraries.

Maxime Levasseur wrote:

Hi Maxime, if you look below, I have put in extra syntax and it will
work if you do this step…I had the same problem!

you should rebuild perl module DBD::mysql against your new mysql
libraries since the one came with FC3 is built against mysql 3.2.x
libraries.

Maxime Levasseur wrote:

Hi all,

I’m trying a new install on a new box.
Fedora Core 3, full install.
I made the Mysql upgrade to a 4.1.9 standard version without any
problem.
No missing dependancies at all.

Off course i’m root during the install.

make install ==> no problem.
make initialize-Database ==>

[root@rt2 rt-3.4.0]# make initialize-database
/usr/bin/perl //usr/local/rt3/sbin/rt-setup-database --action init --dba
root --prompt-for-dba-password
In order to create or update your RT database,this script needs to
connect to your mysql instance on localhost as root.
Please specify that user’s database password below. If the user has no
database
password, just press return.

Password: I give the good password …

DBI connect(’;host=localhost’,‘root’,…) failed: Client does not
support authentication protocol requested by server; consider upgrading
MySQL client at //usr/local/rt3/sbin/rt-setup-database line 101
Failed to connect to dbi:mysql:;host=localhost as root: Client does not
support authentication protocol requested by server; consider upgrading
MySQL client at //usr/local/rt3/sbin/rt-setup-database line 101,
line 1.
make: *** [initialize-database] Erreur 255

Ooops …
So I passed the following command :

log into mysql:
mysql -p
Enter root password
Type in the following commands
1.use rt3;
2.SET PASSWORD FOR ‘rt_user’@‘localhost’
= OLD_PASSWORD(‘rt_pass’); #this is the rt_user password

ravin.mathoora@virtualaccess.com wrote:

Hi Maxime, if you look below, I have put in extra syntax and it will
work if you do this step…I had the same problem!

you should rebuild perl module DBD::mysql against your new mysql
libraries since the one came with FC3 is built against mysql 3.2.x
libraries.

Maxime Levasseur wrote:

Hi all,

I’m trying a new install on a new box.
Fedora Core 3, full install.
I made the Mysql upgrade to a 4.1.9 standard version without any
problem.
No missing dependancies at all.

Off course i’m root during the install.

make install ==> no problem.
make initialize-Database ==>

[root@rt2 rt-3.4.0]# make initialize-database
/usr/bin/perl //usr/local/rt3/sbin/rt-setup-database --action init --dba
root --prompt-for-dba-password
In order to create or update your RT database,this script needs to
connect to your mysql instance on localhost as root.
Please specify that user’s database password below. If the user has no
database
password, just press return.

Password: I give the good password …

DBI connect(’;host=localhost’,‘root’,…) failed: Client does not
support authentication protocol requested by server; consider upgrading
MySQL client at //usr/local/rt3/sbin/rt-setup-database line 101
Failed to connect to dbi:mysql:;host=localhost as root: Client does not
support authentication protocol requested by server; consider upgrading
MySQL client at //usr/local/rt3/sbin/rt-setup-database line 101,
line 1.
make: *** [initialize-database] Erreur 255

Ooops …
So I passed the following command :

log into mysql:
mysql -p
Enter root password
Type in the following commands
1.use rt3;
2.SET PASSWORD FOR ‘rt_user’@‘localhost’
= OLD_PASSWORD(‘rt_pass’); #this is the rt_user password

and tried a Make initialize-database again and now i have :
[root@rt2 rt-3.4.0]# make initialize-database
/usr/bin/perl //opt/rt3/sbin/rt-setup-database --action init --dba root
–prompt-for-dba-password

In order to create or update your RT database,this script needs to
connect to your mysql instance on localhost as root.
Please specify that user’s database password below. If the user has no
database
password, just press return.

Password:xxxxxx
Now creating a database for RT.
Creating mysql database rt3.
Now populating database schema.
Creating database schema.
Done setting up database schema.
Now inserting database ACLs
Done setting up database ACLs.
Now inserting RT core system objects
[Tue Feb 1 22:44:29 2005] [crit]: Connect Failed Client does not
support authentication protocol requested by server; consider upgrading
MySQL client
at //opt/rt3/sbin/rt-setup-database line 384
(/opt/rt3/lib/RT.pm:285)
make: *** [initialize-database] Error 255

What can ( must) i do now ?

Best Regards and thanks for your help.

Max.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

RT Administrator and Developer training is coming to your town soon!
(Boston, San Francisco, Austin, Sydney) Contact
training@bestpractical.com for details.

Be sure to check out the RT Wiki at http://wiki.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

RT Administrator and Developer training is coming to your town soon!
(Boston, San Francisco, Austin, Sydney) Contact training@bestpractical.com
for details.

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Ravin,

My problem has been solved with the SET PASSWORD FOR
’rt_user’@‘localhost’= OLD_PASSWORD(‘rt_pass’); command : )
Thanks a lot and best regards.

Max.

Stephen : Thanks too.