Installation Woes

Any ideas/comments are appreciated.

I’ve been trying to get RT up for days. I’ve been through the mailing list
archives, logs over and over again with no avail. Hitting RT
(http://rt.ionts.net) I get

%# BEGIN LICENSE BLOCK %# %# Copyright © 1996-2003 Jesse Vincent %# %#
(Except where explictly superceded by other copyright notices) %# %# This
work is made available to you under the terms of Version 2 of %# the GNU
General Public License. A copy of that license should have %# been provided
with this software, but in any event can be snarfed %# from www.gnu.org. %#
%# This work is distributed in the hope that it will be useful, but %#
WITHOUT ANY WARRANTY; without even the implied warranty of %#
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU %# General
Public License for more details. %# %# Unless otherwise specified, all
modifications, corrections or %# extensions to this work which alter its
source code become the %# property of Best Practical Solutions, LLC when
submitted for %# inclusion in the work. %# %# %# END LICENSE BLOCK <&
/Elements/Header, Title=>loc(“RT at a glance”), Refresh =>
$session{‘home_refresh_interval’} &> <& /Elements/Tabs, current_toptab =>
’’, Title=>loc(“RT at a glance”) &> <& /Elements/MyTickets &> <&
/Elements/MyRequests &> <& /Elements/Quicksearch &>

<& /Elements/Refresh, Name => ‘HomeRefreshInterval’, Default => $session
{‘home_refresh_interval’} &>

<%init> if ( $ARGS{‘q’} ) { my $query = $ARGS{‘q’}; if ( $query =~
m/^\s*(\d+)\s*$/ ) { $m->redirect("$RT::WebPath/Ticket/Display.html?id=$1");
} $session{‘tickets’} = RT::Tickets->new( $session{‘CurrentUser’} ); if (
$query =~ m/@/ ) { $session{‘tickets’}->LimitRequestor( VALUE => $query,
OPERATOR => ‘=’, ); $m->redirect("$RT::WebPath/Search/Listing.html"); } # #
Any search on queue name or subject will be for new/open tickets # only. #
$session{‘tickets’}->LimitStatus( VALUE => $_, OPERATOR => ‘=’, ) for
qw(open new); my $queue = RT::Queue->new( $session{‘CurrentUser’} ); if (
$queue->Load($query) && $queue->Id ) { $session{‘tickets’}->LimitQueue(
VALUE => $queue->Id, OPERATOR => ‘=’, );
$m->redirect("$RT::WebPath/Search/Listing.html"); }
$session{‘tickets’}->LimitSubject( VALUE => $query, OPERATOR => ‘LIKE’ );
$m->redirect("$RT::WebPath/Search/Listing.html"); } if
($ARGS{‘HomeRefreshInterval’}) { $session{‘home_refresh_interval’} =
$ARGS{‘HomeRefreshInterval’}; }

Thanks,

David

david@gitman.net wrote:

I’ve been trying to get RT up for days. I’ve been through the mailing list
archives, logs over and over again with no avail. Hitting RT
(http://rt.ionts.net) I get

%# BEGIN LICENSE BLOCK %# %# Copyright (c) 1996-2003 Jesse Vincent %# %#

Your apache is not configured correctly. Perhaps you could post
your VirtualHost config to the list for diagnosis…
Phil Homewood, Systems Janitor, http://www.SnapGear.com
pdh@snapgear.com Ph: +61 7 3435 2810 Fx: +61 7 3891 3630
SnapGear - Custom Embedded Solutions and Security Appliances

Below is my current VitualHost. Thanks.

<VirtualHost 66.78.30.242>
ServerName rt.ionts.net
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

<IfModule mod_fastcgi.c>
    AddHandler fastcgi-script fcgi
    FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 3600
    Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/
    ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/
</IfModule>

[-d]-----Original Message-----
From: rt-users-admin@lists.fsck.com [mailto:rt-users-admin@lists.fsck.com]
On Behalf Of Phil Homewood Sent: Tuesday, September 02, 2003 1:51 AM To: rt-users@lists.fsck.com Subject: Re: [rt-users] Installation Woes david@gitman.net wrote:

I’ve been trying to get RT up for days. I’ve been through the mailing list
archives, logs over and over again with no avail. Hitting RT
(http://rt.ionts.net) I get

%# BEGIN LICENSE BLOCK %# %# Copyright (c) 1996-2003 Jesse Vincent %# %#

Your apache is not configured correctly. Perhaps you could post
your VirtualHost config to the list for diagnosis…
Phil Homewood, Systems Janitor, http://www.SnapGear.com
pdh@snapgear.com Ph: +61 7 3435 2810 Fx: +61 7 3891 3630
SnapGear - Custom Embedded Solutions and Security Appliances
rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

David,
I noticed you were missing a few options, so here is my virtual
setting:

<VirtualHost 172.16.3.221>
ServerName rt.intercept.net
DocumentRoot /opt/rt3/share/html
RedirectMatch permanent (.*)/$ http://rt.intercept.net$1/index.html
AddDefaultCharset UTF-8

# this line applies to Apache2+mod_perl2 
PerlModule Apache2 Apache::compat

PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Location />
    SetHandler perl-script
    PerlHandler RT::Mason
</Location>

MichaelFrom: david@gitman.net [mailto:david@gitman.net]
Posted At: Tuesday, September 02, 2003 9:40 AM
Posted To: RT
Conversation: [rt-users] Installation Woes
Subject: RE: [rt-users] Installation Woes

Below is my current VitualHost. Thanks.

<VirtualHost 66.78.30.242>
ServerName rt.ionts.net
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

<IfModule mod_fastcgi.c>
    AddHandler fastcgi-script fcgi
    FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 3600
    Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/
    ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/
</IfModule>

[-d]

From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com]

I’ve been trying to get RT up for days. I’ve been through the mailing
list
archives, logs over and over again with no avail. Hitting RT
(http://rt.ionts.net) I get

%# BEGIN LICENSE BLOCK %# %# Copyright (c) 1996-2003 Jesse Vincent %#
%#

Your apache is not configured correctly. Perhaps you could post
your VirtualHost config to the list for diagnosis…
Phil Homewood, Systems Janitor, http://www.SnapGear.com
pdh@snapgear.com Ph: +61 7 3435 2810 Fx: +61 7 3891 3630
SnapGear - Custom Embedded Solutions and Security Appliances
rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

I’m using fastcgi not modperl.

[-d]From: RT [mailto:RT@InterCept.Net]
Sent: Tuesday, September 02, 2003 11:27 AM
To: david@gitman.net
Cc: rt-users@lists.fsck.com
Subject: RE: [rt-users] Installation Woes

David,
I noticed you were missing a few options, so here is my virtual
setting:

<VirtualHost 172.16.3.221>
ServerName rt.intercept.net
DocumentRoot /opt/rt3/share/html
RedirectMatch permanent (.*)/$ http://rt.intercept.net$1/index.html
AddDefaultCharset UTF-8

# this line applies to Apache2+mod_perl2 
PerlModule Apache2 Apache::compat

PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Location />
    SetHandler perl-script
    PerlHandler RT::Mason
</Location>

Michael

From: david@gitman.net [mailto:david@gitman.net]
Posted At: Tuesday, September 02, 2003 9:40 AM
Posted To: RT
Conversation: [rt-users] Installation Woes
Subject: RE: [rt-users] Installation Woes

Below is my current VitualHost. Thanks.

<VirtualHost 66.78.30.242>
ServerName rt.ionts.net
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

<IfModule mod_fastcgi.c>
    AddHandler fastcgi-script fcgi
    FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 3600
    Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/
    ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/
</IfModule>

[-d]

From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com]

I’ve been trying to get RT up for days. I’ve been through the mailing
list
archives, logs over and over again with no avail. Hitting RT
(http://rt.ionts.net) I get

%# BEGIN LICENSE BLOCK %# %# Copyright (c) 1996-2003 Jesse Vincent %#
%#

Your apache is not configured correctly. Perhaps you could post
your VirtualHost config to the list for diagnosis…
Phil Homewood, Systems Janitor, http://www.SnapGear.com
pdh@snapgear.com Ph: +61 7 3435 2810 Fx: +61 7 3891 3630
SnapGear - Custom Embedded Solutions and Security Appliances
rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Are you sure fastcgi is configured/compiled correctly in apache?

Comment out the and lines, and then then do ‘apachectl configtest’. If it gives an ‘Invalid command’ error, then apache doesn’t have fastcgi available to it.

If it was compiled in statically, do httpd -l to check its there, otherwise make sure the following lines are in your httpd.conf:

LoadModule fastcgi_module libexec/apache/mod_fastcgi.so
AddModule mod_fastcgi.c

note, the path in LoadModule may be different, it should be whereever mod_fastcgi.so is relative to your ServerRoot.

-fr.On Tue, 2 Sep 2003 09:39:40 -0400 david@gitman.net wrote:

Below is my current VitualHost. Thanks.

<VirtualHost 66.78.30.242>
ServerName rt.ionts.net
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

<IfModule mod_fastcgi.c>
    AddHandler fastcgi-script fcgi
    FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 3600
    Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/
    ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/
</IfModule>

[-d]

-----Original Message-----
From: rt-users-admin@lists.fsck.com [mailto:rt-users-admin@lists.fsck.com]
On Behalf Of Phil Homewood Sent: Tuesday, September 02, 2003 1:51 AM To: rt-users@lists.fsck.com Subject: Re: [rt-users] Installation Woes david@gitman.net wrote:

I’ve been trying to get RT up for days. I’ve been through the mailing list
archives, logs over and over again with no avail. Hitting RT
(http://rt.ionts.net) I get

%# BEGIN LICENSE BLOCK %# %# Copyright (c) 1996-2003 Jesse Vincent %# %#

Your apache is not configured correctly. Perhaps you could post
your VirtualHost config to the list for diagnosis…

Phil Homewood, Systems Janitor, http://www.SnapGear.com
pdh@snapgear.com Ph: +61 7 3435 2810 Fx: +61 7 3891 3630
SnapGear - Custom Embedded Solutions and Security Appliances


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Feargal Reilly,
Systems Administrator,
The FBI.

I’ve tried that already. :slight_smile: I’ve gotten emails from a half a dozen people
directly; stating the same problem.

[-d]From: rt-users-admin@lists.fsck.com [mailto:rt-users-admin@lists.fsck.com]
On Behalf Of Feargal Reilly
Sent: Tuesday, September 02, 2003 12:55 PM
To: rt-users@lists.fsck.com
Subject: Re: [rt-users] Installation Woes

Are you sure fastcgi is configured/compiled correctly in apache?

Comment out the and lines, and then
then do ‘apachectl configtest’. If it gives an ‘Invalid command’ error, then
apache doesn’t have fastcgi available to it.

If it was compiled in statically, do httpd -l to check its there, otherwise
make sure the following lines are in your httpd.conf:

LoadModule fastcgi_module libexec/apache/mod_fastcgi.so
AddModule mod_fastcgi.c

note, the path in LoadModule may be different, it should be whereever
mod_fastcgi.so is relative to your ServerRoot.

-fr.

Below is my current VitualHost. Thanks.

<VirtualHost 66.78.30.242>
ServerName rt.ionts.net
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

<IfModule mod_fastcgi.c>
    AddHandler fastcgi-script fcgi
    FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 3600
    Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/
    ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/
</IfModule>

[-d]

-----Original Message-----
From: rt-users-admin@lists.fsck.com [mailto:rt-users-admin@lists.fsck.com]

I’ve been trying to get RT up for days. I’ve been through the mailing
list
archives, logs over and over again with no avail. Hitting RT
(http://rt.ionts.net) I get

%# BEGIN LICENSE BLOCK %# %# Copyright (c) 1996-2003 Jesse Vincent %# %#

Your apache is not configured correctly. Perhaps you could post
your VirtualHost config to the list for diagnosis…

Phil Homewood, Systems Janitor, http://www.SnapGear.com
pdh@snapgear.com Ph: +61 7 3435 2810 Fx: +61 7 3891 3630
SnapGear - Custom Embedded Solutions and Security Appliances


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Feargal Reilly,
Systems Administrator,
The FBI.
rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

I’ve tried that already. :slight_smile:

Also according to Upgrading to 2.0 from 1.3 - Apache HTTP Server

The AddModule and ClearModuleList directives no longer exist. These
directives were used to ensure that modules could be enabled in the correct
order. The new Apache 2.0 API allows modules to explicitly specify their
ordering, eliminating the need for these directives.

I’ve gotten emails from a half a dozen people directly; stating the same
problem.

[-d]From: rt-users-admin@lists.fsck.com [mailto:rt-users-admin@lists.fsck.com]
On Behalf Of Feargal Reilly
Sent: Tuesday, September 02, 2003 12:55 PM
To: rt-users@lists.fsck.com
Subject: Re: [rt-users] Installation Woes

Are you sure fastcgi is configured/compiled correctly in apache?

Comment out the and lines, and then
then do ‘apachectl configtest’. If it gives an ‘Invalid command’ error, then
apache doesn’t have fastcgi available to it.

If it was compiled in statically, do httpd -l to check its there, otherwise
make sure the following lines are in your httpd.conf:

LoadModule fastcgi_module libexec/apache/mod_fastcgi.so
AddModule mod_fastcgi.c

note, the path in LoadModule may be different, it should be whereever
mod_fastcgi.so is relative to your ServerRoot.

-fr.

Below is my current VitualHost. Thanks.

<VirtualHost 66.78.30.242>
ServerName rt.ionts.net
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

<IfModule mod_fastcgi.c>
    AddHandler fastcgi-script fcgi
    FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 3600
    Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/
    ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/
</IfModule>

[-d]

-----Original Message-----
From: rt-users-admin@lists.fsck.com [mailto:rt-users-admin@lists.fsck.com]

I’ve been trying to get RT up for days. I’ve been through the mailing
list
archives, logs over and over again with no avail. Hitting RT
(http://rt.ionts.net) I get

%# BEGIN LICENSE BLOCK %# %# Copyright (c) 1996-2003 Jesse Vincent %# %#

Your apache is not configured correctly. Perhaps you could post
your VirtualHost config to the list for diagnosis…

Phil Homewood, Systems Janitor, http://www.SnapGear.com
pdh@snapgear.com Ph: +61 7 3435 2810 Fx: +61 7 3891 3630
SnapGear - Custom Embedded Solutions and Security Appliances


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Feargal Reilly,
Systems Administrator,
The FBI.
rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm