Instalation problem

Hello guys,
I have problem with rt 2-0-8. After make instal i will get this error
message :frowning: This is full output from make install

If somebody have solved this problem, please help me.

Best regards
Vojtech Moravek

vojtech.moravek@cz.tiscali.com

make install
mkdir -p //opt/rt2/bin
mkdir -p //opt/rt2/WebRT/data
mkdir -p //opt/rt2/WebRT/sessiondata
mkdir -p //opt/rt2/etc
mkdir -p //opt/rt2/lib
mkdir -p //opt/rt2/WebRT/html
mkdir -p //opt/rt2/local/WebRT/html
/usr/bin/perl tools/initdb ‘mysql’ ‘/usr’ ‘localhost’ ‘’ ‘root’ ‘rt2’
create
Now creating a database for RT.
Enter the mysql password for root:
Creating mysql database rt2.
cp etc/acl.mysql ‘//opt/rt2/etc/acl.mysql’
/usr/bin/perl -p -i -e " s’!!DB_TYPE!!’“mysql”‘g;
s’!!DB_HOST!!’“localhost”‘g;
s’!!DB_RT_PASS!!’“rt_pass”‘g;
s’!!DB_RT_HOST!!’“localhost”‘g;
s’!!DB_RT_USER!!’“rt_user”‘g;
s’!!DB_DATABASE!!’“rt2”‘g;"
//opt/rt2/etc/acl.mysql
bin/initacls.mysql ‘/usr’ ‘localhost’ ‘’ ‘root’ ‘’ ‘rt2’
’//opt/rt2/etc/acl.mysql’
Enter the mysql administrator’s database password to create a new user
for RT
Enter password:
Enter the mysql administrator’s database password to nondestructively
reload the database
Enter password:
/usr/bin/perl tools/initdb ‘mysql’ ‘/usr’ ‘localhost’ ‘’ ‘rt_user’
‘rt2’ insert
Now populating database schema.
Enter the mysql password for rt_user:
Creating database schema.
DBI->connect(dbname=rt2;host=localhost) failed: Access denied for user:
‘rt_user@localhost’ (Using password: NO) at tools/initdb line 144
Access denied for user: ‘rt_user@localhost’ (Using password: NO) at
tools/initdb line 144, line 1.
make: *** [initdb.rtuser] Error 255
[root@tickets rt-2-0-8_01]#

Whats happening is the mysql script which creates and grants rights to the
"rt-user" needs to give rt-user a password which it probably does. Since,
the output did not ask you for a poassword and the database needs on to
log in the user it seems that either the script has a bug or you did not
give the user a password in your Makefile. Check to make sure 1. Your
rt-user is getting assigned a password in your Makefile 2. That your mysql
knows to ask your user for a password. (THis could be a versioning
issue.) in mysql and 3. That the user is even getting put into the
database. If none of these work try rt-2-0-8_02 (the most current
release) which worked for me with one little bug which was pretty easy to
resolve.

	Sincerely,					
		-James Adam Sigler-

James Adam Sigler
Research Scientist
College of Computing
Georgia Tech
Phone: 404-385-0391
Office: CoC 211
Email: hollow1@cc.gatech.eduOn 5 Nov 2001, Vojtech Moravek wrote:

Hello guys,
I have problem with rt 2-0-8. After make instal i will get this error
message :frowning: This is full output from make install

If somebody have solved this problem, please help me.

Best regards
Vojtech Moravek

vojtech.moravek@cz.tiscali.com

make install
mkdir -p //opt/rt2/bin
mkdir -p //opt/rt2/WebRT/data
mkdir -p //opt/rt2/WebRT/sessiondata
mkdir -p //opt/rt2/etc
mkdir -p //opt/rt2/lib
mkdir -p //opt/rt2/WebRT/html
mkdir -p //opt/rt2/local/WebRT/html
/usr/bin/perl tools/initdb ‘mysql’ ‘/usr’ ‘localhost’ ‘’ ‘root’ ‘rt2’
create
Now creating a database for RT.
Enter the mysql password for root:
Creating mysql database rt2.
cp etc/acl.mysql ‘//opt/rt2/etc/acl.mysql’
/usr/bin/perl -p -i -e " s’!!DB_TYPE!!’“mysql”‘g;
s’!!DB_HOST!!’“localhost”‘g;
s’!!DB_RT_PASS!!’“rt_pass”‘g;
s’!!DB_RT_HOST!!’“localhost”‘g;
s’!!DB_RT_USER!!’“rt_user”‘g;
s’!!DB_DATABASE!!’“rt2”‘g;"
//opt/rt2/etc/acl.mysql
bin/initacls.mysql ‘/usr’ ‘localhost’ ‘’ ‘root’ ‘’ ‘rt2’
’//opt/rt2/etc/acl.mysql’
Enter the mysql administrator’s database password to create a new user
for RT
Enter password:
Enter the mysql administrator’s database password to nondestructively
reload the database
Enter password:
/usr/bin/perl tools/initdb ‘mysql’ ‘/usr’ ‘localhost’ ‘’ ‘rt_user’
‘rt2’ insert
Now populating database schema.
Enter the mysql password for rt_user:
Creating database schema.
DBI->connect(dbname=rt2;host=localhost) failed: Access denied for user:
‘rt_user@localhost’ (Using password: NO) at tools/initdb line 144
Access denied for user: ‘rt_user@localhost’ (Using password: NO) at
tools/initdb line 144, line 1.
make: *** [initdb.rtuser] Error 255
[root@tickets rt-2-0-8_01]#


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Hi all

I had some problems with the Postgres, i tried to install the RT32 in a
FreeBSD 5.3 with apache-1.3.33, mod_perl-1.29_1 and postgresql-7.4.5

Everithing seems ok, but the make can’t conect into DB.

I type these five lines:

#make clean install INITIAL_INSTALL DB_TYPE=Pg DB_DATABASE=nexosrtdb
DB_DBA_USER=pgsql DB_DBA_PASSWORD=password

(give all correct but un the last line i receive “don’t know how to
INITIAL_INSTALL”)

#cat /root/RT/RT_SiteConfig.pm > /usr/local/rt3/etc/RT_SiteConfig.pm
#cat /root/RT/append.httpd.conf >> /usr/lo/usr/local/etc/apache/httpd.conf
#apachectl stop && apachectl start

make post-install -DINITIAL_INSTALL DB_TYPE=Pg DB_DATABASE=nexosrtdb

DB_DBA_USER=pgsql DB_DBA_PASSWORD=password
DBI connect(‘dbname=template1;host=localhost’,‘pgsql’,…) failed: could
not connect to server: Connection refused at
/usr/local/rt3/sbin/rt-setup-database line 118
could not connect to server: Connection refused at
/usr/local/rt3/sbin/rt-setup-database line 121.
Database doesn’t appear to exist. Aborting database drop. at
/usr/local/rt3/sbin/rt-setup-database line 122.
DBI connect(‘dbname=template1;host=localhost’,‘pgsql’,…) failed: could
not connect to server: Connection refused at
/usr/local/rt3/sbin/rt-setup-database line 80
Failed to connect to dbi:Pg:dbname=template1;host=localhost as pgsql:
could not connect to server: Connection refused at
/usr/local/rt3/sbin/rt-setup-database line 80.
*** Error code 255 (ignored)

To complete the installation of this port, please follow these steps:

  1. Edit /usr/local/rt3/etc/RT_SiteConfig.pm, by referring to
    the default config file (/usr/local/rt3/etc/RT_Config.pm).
  2. Configure the email and web gateways. Please refer to
    ’SETTING UP THE MAIL GATEWAY’ in /usr/local/rt3/README
  3. Restart Apache.
  4. Do remember to CHANGE the root’s password for the web interface.
    The default is “password” (without the quotes.)
  5. Configure RT per the instructions at http://www.fsck.com/rtfm/.

Does anyone knows what (or where I can found information) I need to set
up im my DB to make this work?

Thanks in advance.
Humberto Junior.

Humberto Junior wrote:

Hi all

I had some problems with the Postgres, i tried to install the RT32 in a
FreeBSD 5.3 with apache-1.3.33, mod_perl-1.29_1 and postgresql-7.4.5

Everithing seems ok, but the make can’t conect into DB.

I type these five lines:

#make clean install INITIAL_INSTALL DB_TYPE=Pg DB_DATABASE=nexosrtdb
DB_DBA_USER=pgsql DB_DBA_PASSWORD=password

(give all correct but un the last line i receive “don’t know how to
INITIAL_INSTALL”)

#cat /root/RT/RT_SiteConfig.pm > /usr/local/rt3/etc/RT_SiteConfig.pm
#cat /root/RT/append.httpd.conf >> /usr/lo/usr/local/etc/apache/httpd.conf
#apachectl stop && apachectl start

make post-install -DINITIAL_INSTALL DB_TYPE=Pg DB_DATABASE=nexosrtdb

DB_DBA_USER=pgsql DB_DBA_PASSWORD=password
DBI connect(‘dbname=template1;host=localhost’,‘pgsql’,…) failed: could
not connect to server: Connection refused at
/usr/local/rt3/sbin/rt-setup-database line 118
could not connect to server: Connection refused at
/usr/local/rt3/sbin/rt-setup-database line 121.
Database doesn’t appear to exist. Aborting database drop. at
/usr/local/rt3/sbin/rt-setup-database line 122.
DBI connect(‘dbname=template1;host=localhost’,‘pgsql’,…) failed: could
not connect to server: Connection refused at
/usr/local/rt3/sbin/rt-setup-database line 80
Failed to connect to dbi:Pg:dbname=template1;host=localhost as pgsql:
could not connect to server: Connection refused at
/usr/local/rt3/sbin/rt-setup-database line 80.
*** Error code 255 (ignored)

To complete the installation of this port, please follow these steps:

  1. Edit /usr/local/rt3/etc/RT_SiteConfig.pm, by referring to
    the default config file (/usr/local/rt3/etc/RT_Config.pm).
  2. Configure the email and web gateways. Please refer to
    ’SETTING UP THE MAIL GATEWAY’ in /usr/local/rt3/README
  3. Restart Apache.
  4. Do remember to CHANGE the root’s password for the web interface.
    The default is “password” (without the quotes.)
  5. Configure RT per the instructions at http://www.fsck.com/rtfm/.

=====================================================================
Does anyone knows what (or where I can found information) I need to set
up im my DB to make this work?

Thanks in advance.
Humberto Junior.
Can you connect to postgres from the command line? Have you edited
/usr/local/rt3/etc/RT_SiteConfig.pm to reflect your db name/user/passwd
choices?

Anne

Anne Ramey wrote:

Humberto Junior wrote:

Hi all

I had some problems with the Postgres, i tried to install the RT32 in
a FreeBSD 5.3 with apache-1.3.33, mod_perl-1.29_1 and postgresql-7.4.5

Everithing seems ok, but the make can’t conect into DB.

I type these five lines:

#make clean install INITIAL_INSTALL DB_TYPE=Pg DB_DATABASE=nexosrtdb
DB_DBA_USER=pgsql DB_DBA_PASSWORD=password

(give all correct but un the last line i receive “don’t know how to
INITIAL_INSTALL”)

#cat /root/RT/RT_SiteConfig.pm > /usr/local/rt3/etc/RT_SiteConfig.pm
#cat /root/RT/append.httpd.conf >>
/usr/lo/usr/local/etc/apache/httpd.conf
#apachectl stop && apachectl start

make post-install -DINITIAL_INSTALL DB_TYPE=Pg DB_DATABASE=nexosrtdb

DB_DBA_USER=pgsql DB_DBA_PASSWORD=password
DBI connect(‘dbname=template1;host=localhost’,‘pgsql’,…) failed:
could not connect to server: Connection refused at
/usr/local/rt3/sbin/rt-setup-database line 118
could not connect to server: Connection refused at
/usr/local/rt3/sbin/rt-setup-database line 121.
Database doesn’t appear to exist. Aborting database drop. at
/usr/local/rt3/sbin/rt-setup-database line 122.
DBI connect(‘dbname=template1;host=localhost’,‘pgsql’,…) failed:
could not connect to server: Connection refused at
/usr/local/rt3/sbin/rt-setup-database line 80
Failed to connect to dbi:Pg:dbname=template1;host=localhost as pgsql:
could not connect to server: Connection refused at
/usr/local/rt3/sbin/rt-setup-database line 80.
*** Error code 255 (ignored)

Does anyone knows what (or where I can found information) I need to
set up im my DB to make this work?

Thanks in advance.
Humberto Junior.

Can you connect to postgres from the command line? Have you edited
/usr/local/rt3/etc/RT_SiteConfig.pm to reflect your db name/user/passwd
choices?

Anne

Thanks all

We could solve the problem, it was a problem with the conection to
postgres and a I did a litlle edit in the Makefile to force the
conection with the correct user and passord.

Humberto Junior - now configuring…