Instalation problem with rt32

Hi all

I had some problems with the Postgres, i tried to install the RT32 in a
FreeBSD 5.3 with apache-1.3.33, mod_perl-1.29_1 and postgresql-7.4.5

Everithing seems ok, but the make can’t conect into DB.

I type these five lines:

#make clean install INITIAL_INSTALL DB_TYPE=Pg DB_DATABASE=nexosrtdb
DB_DBA_USER=pgsql DB_DBA_PASSWORD=password

(give all correct but un the last line i receive “don’t know how to
INITIAL_INSTALL”)

#cat /root/RT/RT_SiteConfig.pm > /usr/local/rt3/etc/RT_SiteConfig.pm
#cat /root/RT/append.httpd.conf >> /usr/lo/usr/local/etc/apache/httpd.conf
#apachectl stop && apachectl start

make post-install -DINITIAL_INSTALL DB_TYPE=Pg DB_DATABASE=nexosrtdb

DB_DBA_USER=pgsql DB_DBA_PASSWORD=password
DBI connect(‘dbname=template1;host=localhost’,‘pgsql’,…) failed: could
not connect to server: Connection refused at
/usr/local/rt3/sbin/rt-setup-database line 118
could not connect to server: Connection refused at
/usr/local/rt3/sbin/rt-setup-database line 121.
Database doesn’t appear to exist. Aborting database drop. at
/usr/local/rt3/sbin/rt-setup-database line 122.
DBI connect(‘dbname=template1;host=localhost’,‘pgsql’,…) failed: could
not connect to server: Connection refused at
/usr/local/rt3/sbin/rt-setup-database line 80
Failed to connect to dbi:Pg:dbname=template1;host=localhost as pgsql:
could not connect to server: Connection refused at
/usr/local/rt3/sbin/rt-setup-database line 80.
*** Error code 255 (ignored)

To complete the installation of this port, please follow these steps:

  1. Edit /usr/local/rt3/etc/RT_SiteConfig.pm, by referring to
    the default config file (/usr/local/rt3/etc/RT_Config.pm).
  2. Configure the email and web gateways. Please refer to
    ’SETTING UP THE MAIL GATEWAY’ in /usr/local/rt3/README
  3. Restart Apache.
  4. Do remember to CHANGE the root’s password for the web interface.
    The default is “password” (without the quotes.)
  5. Configure RT per the instructions at http://www.fsck.com/rtfm/.

Does anyone knows what (or where I can found information) I need to set
up im my DB to make this work?

Thanks in advance.
Humberto Junior.

Try using INITIAL_INSTALL=YES instead of just INITIAL_INSTALL as in:

    make clean install INITIAL_INSTALL=YES etc...

A.On Fri, 2005-08-12 at 17:44 -0300, Humberto Junior wrote:

Hi all

I had some problems with the Postgres, i tried to install the RT32 in a
FreeBSD 5.3 with apache-1.3.33, mod_perl-1.29_1 and postgresql-7.4.5

Everithing seems ok, but the make can’t conect into DB.

I type these five lines:

#make clean install INITIAL_INSTALL DB_TYPE=Pg DB_DATABASE=nexosrtdb
DB_DBA_USER=pgsql DB_DBA_PASSWORD=password

(give all correct but un the last line i receive “don’t know how to
INITIAL_INSTALL”)

#cat /root/RT/RT_SiteConfig.pm > /usr/local/rt3/etc/RT_SiteConfig.pm
#cat /root/RT/append.httpd.conf >> /usr/lo/usr/local/etc/apache/httpd.conf
#apachectl stop && apachectl start

make post-install -DINITIAL_INSTALL DB_TYPE=Pg DB_DATABASE=nexosrtdb

DB_DBA_USER=pgsql DB_DBA_PASSWORD=password
DBI connect(‘dbname=template1;host=localhost’,‘pgsql’,…) failed: could
not connect to server: Connection refused at
/usr/local/rt3/sbin/rt-setup-database line 118
could not connect to server: Connection refused at
/usr/local/rt3/sbin/rt-setup-database line 121.
Database doesn’t appear to exist. Aborting database drop. at
/usr/local/rt3/sbin/rt-setup-database line 122.
DBI connect(‘dbname=template1;host=localhost’,‘pgsql’,…) failed: could
not connect to server: Connection refused at
/usr/local/rt3/sbin/rt-setup-database line 80
Failed to connect to dbi:Pg:dbname=template1;host=localhost as pgsql:
could not connect to server: Connection refused at
/usr/local/rt3/sbin/rt-setup-database line 80.
*** Error code 255 (ignored)

To complete the installation of this port, please follow these steps:

  1. Edit /usr/local/rt3/etc/RT_SiteConfig.pm, by referring to
    the default config file (/usr/local/rt3/etc/RT_Config.pm).
  2. Configure the email and web gateways. Please refer to
    ’SETTING UP THE MAIL GATEWAY’ in /usr/local/rt3/README
  3. Restart Apache.
  4. Do remember to CHANGE the root’s password for the web interface.
    The default is “password” (without the quotes.)
  5. Configure RT per the instructions at http://www.fsck.com/rtfm/.

=====================================================================
Does anyone knows what (or where I can found information) I need to set
up im my DB to make this work?

Thanks in advance.
Humberto Junior.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com