Increase size of attachment when using web interaface to attach items

Hello,

I need to know how to increase the size of attachments when using the web interface to attach items to the ticket.

Steps to follow:

Click any ticket number > click Actions in the top right corner >(drop down menu) click Reply

Click Browse underneath the big message box. Find your item , select it, and click open.

Then click Update Ticket.

The item I am trying to upload is a “.exe” file that is 34 MB

It doesn’t return an error on RT just doesn’t attach anything. I haven’t checked the Linux logs yet but I know there has to be an RT Config setting that will enable this.

PS#### I have already adjusted the settings for the mail and it doesn’t work for the web interface.

V/R,

Daniel Moore
IT Systems Technician
Osborne Wood Products, Inc.
[Description: http://hosting-source.bm23.com/9241/public/OsborneLogo111.jpg]
P: 706.282.5764
F: 888.777.4304
http://www.osbornewood.com

Here is the error in the logs:

mod_fcgid: error reading data, FastCGI server closed connection, referrer: https://rt.myserver.com/Ticket/Update.html?Action=Respond;id=(TicketNumber)

V/R,

Daniel Moore
IT Systems Technician
Osborne Wood Products, Inc.
[Description: http://hosting-source.bm23.com/9241/public/OsborneLogo111.jpg]
P: 706.282.5764
F: 888.777.4304
http://www.osbornewood.comFrom: rt-users [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Daniel Moore
Sent: Wednesday, August 05, 2015 9:57 AM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Increase size of attachment when using web interaface to attach items

Hello,

I need to know how to increase the size of attachments when using the web interface to attach items to the ticket.

Steps to follow:

Click any ticket number > click Actions in the top right corner >(drop down menu) click Reply

Click Browse underneath the big message box. Find your item , select it, and click open.

Then click Update Ticket.

The item I am trying to upload is a “.exe” file that is 34 MB

It doesn’t return an error on RT just doesn’t attach anything. I haven’t checked the Linux logs yet but I know there has to be an RT Config setting that will enable this.

PS#### I have already adjusted the settings for the mail and it doesn’t work for the web interface.

V/R,

Daniel Moore
IT Systems Technician
Osborne Wood Products, Inc.
[Description: http://hosting-source.bm23.com/9241/public/OsborneLogo111.jpg]
P: 706.282.5764
F: 888.777.4304
http://www.osbornewood.com

Here is the error in the logs:

mod_fcgid: error reading data, FastCGI server closed connection, referrer: https://rt.myserver.com/Ticket/Update.html?Action=Respond;id=(TicketNumber)

V/R,

Daniel Moore
IT Systems Technician
Osborne Wood Products, Inc.
[Description: http://hosting-source.bm23.com/9241/public/OsborneLogo111.jpg]
P: 706.282.5764
F: 888.777.4304
http://www.osbornewood.comFrom: rt-users [mailto:rt-users-bounces@lists.bestpractical.com]mailto:[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Daniel Moore
Sent: Wednesday, August 05, 2015 9:57 AM
To: rt-users@lists.bestpractical.commailto:rt-users@lists.bestpractical.com
Subject: [rt-users] Increase size of attachment when using web interaface to attach items

Hello,

I need to know how to increase the size of attachments when using the web interface to attach items to the ticket.

Steps to follow:

Click any ticket number > click Actions in the top right corner >(drop down menu) click Reply

Click Browse underneath the big message box. Find your item , select it, and click open.

Then click Update Ticket.

The item I am trying to upload is a “.exe” file that is 34 MB

It doesn’t return an error on RT just doesn’t attach anything. I haven’t checked the Linux logs yet but I know there has to be an RT Config setting that will enable this.

PS#### I have already adjusted the settings for the mail and it doesn’t work for the web interface.

V/R,

Daniel Moore
IT Systems Technician
Osborne Wood Products, Inc.
[Description: http://hosting-source.bm23.com/9241/public/OsborneLogo111.jpg]
P: 706.282.5764
F: 888.777.4304
http://www.osbornewood.com

Hello,

Thank you for the information.

I am just very confused on where to update this. The link you gave helps me understand why I need to make changes but doesn’t really tell me where.

I am not good with Linux so I don’t understand where mod_fcgi is?

Can you point me in the direction of where I need to make the change?

V/R,

Daniel Moore
IT Systems Technician
Osborne Wood Products, Inc.
[Description: http://hosting-source.bm23.com/9241/public/OsborneLogo111.jpg]
P: 706.282.5764
F: 888.777.4304
http://www.osbornewood.comFrom: Joanne McClintock [mailto:joanne.mcclintock@uwaterloo.ca]
Sent: Wednesday, August 05, 2015 10:30 AM
To: Daniel Moore
Subject: RE: Increase size of attachment when using web interaface to attach items

Have you checked the FcgidMaxRequestLength value for your server? In older versions of mod_fcgid, the value was set to 1GB-it’s much, much smaller by default in versions since 2.3.6. There’s a bit more information here:
https://bestpractical.com/docs/rt/latest/web_deployment.html#mod_fcgid

From: rt-users [mailto:rt-users-bounces@lists.bestpractical.com]mailto:[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Daniel Moore
Sent: Wednesday, August 05, 2015 10:08 AM
To: rt-users@lists.bestpractical.commailto:rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Increase size of attachment when using web interaface to attach items

Here is the error in the logs:

mod_fcgid: error reading data, FastCGI server closed connection, referrer: https://rt.myserver.com/Ticket/Update.html?Action=Respond;id=(TicketNumber)

V/R,

Daniel Moore
IT Systems Technician
Osborne Wood Products, Inc.
[Description: http://hosting-source.bm23.com/9241/public/OsborneLogo111.jpg]
P: 706.282.5764
F: 888.777.4304
http://www.osbornewood.com

From: rt-users [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Daniel Moore
Sent: Wednesday, August 05, 2015 9:57 AM
To: rt-users@lists.bestpractical.commailto:rt-users@lists.bestpractical.com
Subject: [rt-users] Increase size of attachment when using web interaface to attach items

Hello,

I need to know how to increase the size of attachments when using the web interface to attach items to the ticket.

Steps to follow:

Click any ticket number > click Actions in the top right corner >(drop down menu) click Reply

Click Browse underneath the big message box. Find your item , select it, and click open.

Then click Update Ticket.

The item I am trying to upload is a “.exe” file that is 34 MB

It doesn’t return an error on RT just doesn’t attach anything. I haven’t checked the Linux logs yet but I know there has to be an RT Config setting that will enable this.

PS#### I have already adjusted the settings for the mail and it doesn’t work for the web interface.

V/R,

Daniel Moore
IT Systems Technician
Osborne Wood Products, Inc.
[Description: http://hosting-source.bm23.com/9241/public/OsborneLogo111.jpg]
P: 706.282.5764
F: 888.777.4304
http://www.osbornewood.com

So I have checked my fcgid.conf file in mods-available and it is set properly

Is there any way to make the database bigger?

The logs speak about the database.

V/R,

Daniel Moore
IT Systems Technician
Osborne Wood Products, Inc.
[Description: http://hosting-source.bm23.com/9241/public/OsborneLogo111.jpg]
P: 706.282.5764
F: 888.777.4304
http://www.osbornewood.comFrom: rt-users [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Daniel Moore
Sent: Wednesday, August 05, 2015 10:45 AM
To: Joanne McClintock
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Increase size of attachment when using web interaface to attach items

Hello,

Thank you for the information.

I am just very confused on where to update this. The link you gave helps me understand why I need to make changes but doesn’t really tell me where.

I am not good with Linux so I don’t understand where mod_fcgi is?

Can you point me in the direction of where I need to make the change?

V/R,

Daniel Moore
IT Systems Technician
Osborne Wood Products, Inc.
[Description: http://hosting-source.bm23.com/9241/public/OsborneLogo111.jpg]
P: 706.282.5764
F: 888.777.4304
http://www.osbornewood.com

From: Joanne McClintock [mailto:joanne.mcclintock@uwaterloo.ca]mailto:[mailto:joanne.mcclintock@uwaterloo.ca]
Sent: Wednesday, August 05, 2015 10:30 AM
To: Daniel Moore
Subject: RE: Increase size of attachment when using web interaface to attach items

Have you checked the FcgidMaxRequestLength value for your server? In older versions of mod_fcgid, the value was set to 1GB-it’s much, much smaller by default in versions since 2.3.6. There’s a bit more information here:
https://bestpractical.com/docs/rt/latest/web_deployment.html#mod_fcgid

From: rt-users [mailto:rt-users-bounces@lists.bestpractical.com]mailto:[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Daniel Moore
Sent: Wednesday, August 05, 2015 10:08 AM
To: rt-users@lists.bestpractical.commailto:rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Increase size of attachment when using web interaface to attach items

Here is the error in the logs:

mod_fcgid: error reading data, FastCGI server closed connection, referrer: https://rt.myserver.com/Ticket/Update.html?Action=Respond;id=(TicketNumber)

V/R,

Daniel Moore
IT Systems Technician
Osborne Wood Products, Inc.
[Description: http://hosting-source.bm23.com/9241/public/OsborneLogo111.jpg]
P: 706.282.5764
F: 888.777.4304
http://www.osbornewood.com

From: rt-users [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Daniel Moore
Sent: Wednesday, August 05, 2015 9:57 AM
To: rt-users@lists.bestpractical.commailto:rt-users@lists.bestpractical.com
Subject: [rt-users] Increase size of attachment when using web interaface to attach items

Hello,

I need to know how to increase the size of attachments when using the web interface to attach items to the ticket.

Steps to follow:

Click any ticket number > click Actions in the top right corner >(drop down menu) click Reply

Click Browse underneath the big message box. Find your item , select it, and click open.

Then click Update Ticket.

The item I am trying to upload is a “.exe” file that is 34 MB

It doesn’t return an error on RT just doesn’t attach anything. I haven’t checked the Linux logs yet but I know there has to be an RT Config setting that will enable this.

PS#### I have already adjusted the settings for the mail and it doesn’t work for the web interface.

V/R,

Daniel Moore
IT Systems Technician
Osborne Wood Products, Inc.
[Description: http://hosting-source.bm23.com/9241/public/OsborneLogo111.jpg]
P: 706.282.5764
F: 888.777.4304
http://www.osbornewood.com

I’d suggest hosting the executable elsewhere and including a link in the ticket, rather than sending a 34MB executable via e-mail. Many mail servers won’t like the extension even if it accepts 34MB attachments.> On Aug 5, 2015, at 10:01 AM, Daniel Moore Daniel.Moore@osbornewood.com wrote:

So I have checked my fcgid.conf file in mods-available and it is set properly

Is there any way to make the database bigger?

The logs speak about the database.

V/R,

Daniel Moore
IT Systems Technician
Osborne Wood Products, Inc.
<image001.jpg>
P: 706.282.5764
F: 888.777.4304
http://www.osbornewood.com http://www.osbornewood.com/

From: rt-users [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Daniel Moore
Sent: Wednesday, August 05, 2015 10:45 AM
To: Joanne McClintock
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Increase size of attachment when using web interaface to attach items

Hello,

Thank you for the information.

I am just very confused on where to update this. The link you gave helps me understand why I need to make changes but doesn’t really tell me where.

I am not good with Linux so I don’t understand where mod_fcgi is?

Can you point me in the direction of where I need to make the change?

V/R,

Daniel Moore
IT Systems Technician
Osborne Wood Products, Inc.
<image001.jpg>
P: 706.282.5764
F: 888.777.4304
http://www.osbornewood.com http://www.osbornewood.com/

From: Joanne McClintock [mailto:joanne.mcclintock@uwaterloo.ca] mailto:[mailto:joanne.mcclintock@uwaterloo.ca]
Sent: Wednesday, August 05, 2015 10:30 AM
To: Daniel Moore
Subject: RE: Increase size of attachment when using web interaface to attach items

Have you checked the FcgidMaxRequestLength value for your server? In older versions of mod_fcgid, the value was set to 1GB—it’s much, much smaller by default in versions since 2.3.6. There’s a bit more information here:
https://bestpractical.com/docs/rt/latest/web_deployment.html#mod_fcgid https://bestpractical.com/docs/rt/latest/web_deployment.html#mod_fcgid

From: rt-users [mailto:rt-users-bounces@lists.bestpractical.com] mailto:[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Daniel Moore
Sent: Wednesday, August 05, 2015 10:08 AM
To: rt-users@lists.bestpractical.com mailto:rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Increase size of attachment when using web interaface to attach items

Here is the error in the logs:

mod_fcgid: error reading data, FastCGI server closed connection, referrer:https://rt.myserver.com/Ticket/Update.html?Action=Respond;id=(TicketNumber) https://rt.myserver.com/Ticket/Update.html?Action=Respond;id=(TicketNumber)

V/R,

Daniel Moore
IT Systems Technician
Osborne Wood Products, Inc.
<image001.jpg>
P: 706.282.5764
F: 888.777.4304
http://www.osbornewood.com http://www.osbornewood.com/

From: rt-users [mailto:rt-users-bounces@lists.bestpractical.com mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Daniel Moore
Sent: Wednesday, August 05, 2015 9:57 AM
To: rt-users@lists.bestpractical.com mailto:rt-users@lists.bestpractical.com
Subject: [rt-users] Increase size of attachment when using web interaface to attach items

Hello,

I need to know how to increase the size of attachments when using the web interface to attach items to the ticket.

Steps to follow:

Click any ticket number > click Actions in the top right corner >(drop down menu) click Reply

Click Browse underneath the big message box. Find your item , select it, and click open.

Then click Update Ticket.

The item I am trying to upload is a “.exe” file that is 34 MB

It doesn’t return an error on RT just doesn’t attach anything. I haven’t checked the Linux logs yet but I know there has to be an RT Config setting that will enable this.

PS#### I have already adjusted the settings for the mail and it doesn’t work for the web interface.

V/R,

Daniel Moore
IT Systems Technician
Osborne Wood Products, Inc.
<image001.jpg>
P: 706.282.5764
F: 888.777.4304
http://www.osbornewood.com http://www.osbornewood.com/

Aaron-

I think you might also need to change a setting in your RT config. This doc might be helpful: https://www.bestpractical.com/docs/rt/4.0/RT_Config.html

As a tangent, at one point, a colleague of mine mentioned looking at Dropbox integration with RT. I could put you in touch with them if you were interested in finding out more.

Hope this helps a little. Good luck.

-TeddyOn Wednesday, Aug 5, 2015 at 2:37 PM, Aaron McCormack aaron@backblaze.com, wrote:
I’d suggest hosting the executable elsewhere and including a link in the ticket, rather than sending a 34MB executable via e-mail. Many mail servers won’t like the extension even if it accepts 34MB attachments.

On Aug 5, 2015, at 10:01 AM, Daniel Moore Daniel.Moore@osbornewood.com wrote:

So I have checked my fcgid.conf file in mods-available and it is set properly

Is there any way to make the database bigger?

The logs speak about the database.

V/R,

Daniel Moore

IT Systems Technician

Osborne Wood Products, Inc.

<image001.jpg>

P: 706.282.5764

F: 888.777.4304

http://www.osbornewood.com

From: rt-users [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Daniel Moore
Sent: Wednesday, August 05, 2015 10:45 AM
To: Joanne McClintock
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Increase size of attachment when using web interaface to attach items

Hello,

Thank you for the information.

I am just very confused on where to update this. The link you gave helps me understand why I need to make changes but doesn’t really tell me where.

I am not good with Linux so I don’t understand where mod_fcgi is?

Can you point me in the direction of where I need to make the change?

V/R,

Daniel Moore

IT Systems Technician

Osborne Wood Products, Inc.

<image001.jpg>

P: 706.282.5764

F: 888.777.4304

http://www.osbornewood.com

From: Joanne McClintock [mailto:joanne.mcclintock@uwaterloo.ca]
Sent: Wednesday, August 05, 2015 10:30 AM
To: Daniel Moore
Subject: RE: Increase size of attachment when using web interaface to attach items

Have you checked the FcgidMaxRequestLength value for your server? In older versions of mod_fcgid, the value was set to 1GB—it’s much, much smaller by default in versions since 2.3.6. There’s a bit more information here:

https://bestpractical.com/docs/rt/latest/web_deployment.html#mod_fcgid

From: rt-users [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Daniel Moore
Sent: Wednesday, August 05, 2015 10:08 AM
To: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Increase size of attachment when using web interaface to attach items

Here is the error in the logs:

mod_fcgid: error reading data, FastCGI server closed connection, referrer:https://rt.myserver.com/Ticket/Update.html?Action=Respond;id=(TicketNumber)

V/R,

Daniel Moore

IT Systems Technician

Osborne Wood Products, Inc.

<image001.jpg>

P: 706.282.5764

F: 888.777.4304

http://www.osbornewood.com

From: rt-users [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Daniel Moore
Sent: Wednesday, August 05, 2015 9:57 AM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Increase size of attachment when using web interaface to attach items

Hello,

I need to know how to increase the size of attachments when using the web interface to attach items to the ticket.

Steps to follow:

Click any ticket number > click Actions in the top right corner >(drop down menu) click Reply

Click Browse underneath the big message box. Find your item , select it, and click open.

Then click Update Ticket.

The item I am trying to upload is a “.exe” file that is 34 MB

It doesn’t return an error on RT just doesn’t attach anything. I haven’t checked the Linux logs yet but I know there has to be an RT Config setting that will enable this.

PS#### I have already adjusted the settings for the mail and it doesn’t work for the web interface.

V/R,

Daniel Moore

IT Systems Technician

Osborne Wood Products, Inc.

<image001.jpg>

P: 706.282.5764

F: 888.777.4304

http://www.osbornewood.com

Hello,

I must have done something right going through all of the examples as I got this to work at the end of the day yesterday. Thank you all for your advice and knowledge as it proved helpful to resolve my issue.

V/R,

Daniel Moore
IT Systems Technician
Osborne Wood Products, Inc.
[Description: http://hosting-source.bm23.com/9241/public/OsborneLogo111.jpg]
P: 706.282.5764
F: 888.777.4304
http://www.osbornewood.comFrom: rt-users [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Teddy Thomas
Sent: Thursday, August 06, 2015 1:05 AM
To: Aaron McCormack
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Increase size of attachment when using web interaface to attach items

Aaron-

I think you might also need to change a setting in your RT config. This doc might be helpful: https://www.bestpractical.com/docs/rt/4.0/RT_Config.html

As a tangent, at one point, a colleague of mine mentioned looking at Dropbox integration with RT. I could put you in touch with them if you were interested in finding out more.

Hope this helps a little. Good luck.

-Teddy