Images do not show

Finally got RT up and running after fighting thru distribution issues with
perl and RHEL etc for quite a number of days.

Anyhow, we can login but the images do not show. I’m sure that the issue
is not with RT itself i.e. it is something probably with Apache but I
imagine that other RT users must have probably encountered this error and
therefore I am posting this issue here.

Help is appreciated.

-Charles

Using Opera’s revolutionary e-mail client: http://www.opera.com/m2/

hey mate,

what version did u instal? i had same prob when i installed rt2, check the
properties of the image and see where its trying to get it from, I had to
remove the $Webpath from the images link, as apache roots to the document
root., off memory had to change it to /NoAuth/images, just have a look and u
should be able to figure it out, if u have probs just email me, know the
feeling :wink:

michael----- Original Message -----
From: “Charles A. Monteiro” charles@datasof.com
To: rt-users@lists.bestpractical.com
Sent: Friday, July 16, 2004 3:59 AM
Subject: [rt-users] Images do not show

Finally got RT up and running after fighting thru distribution issues with
perl and RHEL etc for quite a number of days.

Anyhow, we can login but the images do not show. I’m sure that the issue
is not with RT itself i.e. it is something probably with Apache but I
imagine that other RT users must have probably encountered this error and
therefore I am posting this issue here.

Help is appreciated.

-Charles


Using Opera’s revolutionary e-mail client: http://www.opera.com/m2/


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT wiki at http://wiki.bestpractical.com

Michael:

I believe it is 3.0.2 ie. the latest of the RHEL installer site found on
the RT wiki. In the httpd.conf we do have a /NoAuth/image entry if that is
what you mean. My sysadmin is out for the day , I can confirm the version
tomorrow. At least we can start doing things with RT but obviously need
this fixed before we exposed the web interface to our customers.

thanks

CharlesOn Fri, 16 Jul 2004 04:04:42 +1000, michael-list michael-list@i4u.com.au wrote:

hey mate,

what version did u instal? i had same prob when i installed rt2, check
the
properties of the image and see where its trying to get it from, I had to
remove the $Webpath from the images link, as apache roots to the document
root., off memory had to change it to /NoAuth/images, just have a look
and u
should be able to figure it out, if u have probs just email me, know the
feeling :wink:

michael

----- Original Message -----
From: “Charles A. Monteiro” charles@datasof.com
To: rt-users@lists.bestpractical.com
Sent: Friday, July 16, 2004 3:59 AM
Subject: [rt-users] Images do not show

Finally got RT up and running after fighting thru distribution issues
with
perl and RHEL etc for quite a number of days.

Anyhow, we can login but the images do not show. I’m sure that the issue
is not with RT itself i.e. it is something probably with Apache but I
imagine that other RT users must have probably encountered this error
and
therefore I am posting this issue here.

Help is appreciated.

-Charles


Using Opera’s revolutionary e-mail client: http://www.opera.com/m2/


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT wiki at http://wiki.bestpractical.com

Using Opera’s revolutionary e-mail client: http://www.opera.com/m2/

Michael:

What we are assuming is happening is that Fastcgi is trying to run the
images as scripts and of course that is not good.
We are not the only ones experiencing this. I have been speaking with an
RT user in Canada that has the same problem and he has been running RT for
eight months i.e. just gave up :). I guess that you may have a workaround
but the question is hom many image links do I have to do this for? There
should be a better way. BTW, I tried several times to post to the FastCGI
mailing list and kept getting my post bounced apparently due to some DNS
loop issue. Point being, I have tried with the FastCGI group :).

thanks

CharlesOn Fri, 16 Jul 2004 04:04:42 +1000, michael-list michael-list@i4u.com.au wrote:

hey mate,

what version did u instal? i had same prob when i installed rt2, check
the
properties of the image and see where its trying to get it from, I had to
remove the $Webpath from the images link, as apache roots to the document
root., off memory had to change it to /NoAuth/images, just have a look
and u
should be able to figure it out, if u have probs just email me, know the
feeling :wink:

michael

----- Original Message -----
From: “Charles A. Monteiro” charles@datasof.com
To: rt-users@lists.bestpractical.com
Sent: Friday, July 16, 2004 3:59 AM
Subject: [rt-users] Images do not show

Finally got RT up and running after fighting thru distribution issues
with
perl and RHEL etc for quite a number of days.

Anyhow, we can login but the images do not show. I’m sure that the issue
is not with RT itself i.e. it is something probably with Apache but I
imagine that other RT users must have probably encountered this error
and
therefore I am posting this issue here.

Help is appreciated.

-Charles


Using Opera’s revolutionary e-mail client: http://www.opera.com/m2/


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT wiki at http://wiki.bestpractical.com

Using Opera’s revolutionary e-mail client: http://www.opera.com/m2/

Charles A. Monteiro wrote:

Michael:

What we are assuming is happening is that Fastcgi is trying to run the
images as scripts and of course that is not good.
We are not the only ones experiencing this. I have been speaking with
an RT user in Canada that has the same problem and he has been running
RT for eight months i.e. just gave up :). I guess that you may have a
workaround but the question is hom many image links do I have to do
this for? There should be a better way. BTW, I tried several times to
post to the FastCGI mailing list and kept getting my post bounced
apparently due to some DNS loop issue. Point being, I have tried with
the FastCGI group :).

At least for mod_perl I’ve add into httpd.conf:

disable mod_perl for images location

     <Location /NoAuth/images>
             SetHandler default-handler
     </Location>

I don’t know how to configure FastCGI.

			Best regards. Ruslan.

Charles A. Monteiro wrote:

Michael:

What we are assuming is happening is that Fastcgi is trying to run the
images as scripts and of course that is not good.
We are not the only ones experiencing this. I have been speaking with
an RT user in Canada that has the same problem and he has been running
RT for eight months i.e. just gave up :). I guess that you may have a
workaround but the question is hom many image links do I have to do
this for? There should be a better way. BTW, I tried several times to
post to the FastCGI mailing list and kept getting my post bounced
apparently due to some DNS loop issue. Point being, I have tried with
the FastCGI group :).
http://wiki.bestpractical.com/index.cgi?FastCGIConfiguration
# Pass through requests to display images
Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/

Does this lines do trick?
Under mod_perl it shouldn’t help.

			Ruslan.

What we are assuming is happening is that Fastcgi is trying to run the
images as scripts and of course that is not good.

What’s your httpd.conf look like? Did you look at the examples online?

seph

seph wrote:

What we are assuming is happening is that Fastcgi is trying to run the
images as scripts and of course that is not good.

What’s your httpd.conf look like? Did you look at the examples online?
If you talk about this examples
http://wiki.bestpractical.com/index.cgi?FastCGIFAQ
as I see request to images goes throught FastCGI.

We did look at the FastCGI related links and did check whatever was online
but perhaps we missed something. So if you could point us to whatever is
specific to FastCGI handling images we would appreciate it. However, as I
have mentioned I know one user which has RT installed and has lived with
this for about 8 months.

thanks

CharlesOn Fri, 16 Jul 2004 09:59:23 -0400, seph seph@directionless.org wrote:

What we are assuming is happening is that Fastcgi is trying to run the
images as scripts and of course that is not good.

What’s your httpd.conf look like? Did you look at the examples online?

seph

Using Opera’s revolutionary e-mail client: http://www.opera.com/m2/

At least for mod_perl I’ve add into httpd.conf:

disable mod_perl for images location

     <Location /NoAuth/images>
             SetHandler default-handler
     </Location>

I don’t know how to configure FastCGI.

Strange. I hit reply and my message only went to Ruslan; it never made
it to the list. Anyway, here’s what I wrote earlier and intended to
send to the list.

Well, we’re the ones that gave up on the broken image. :slight_smile: We tried a
number of things, but we didn’t really spend enough time with it.

Anyway, I was following this thread that Charles started, and I was
about to try your suggestion. But, Charles sent me an off-list email
with the fix and said that it was working for them.

I tried it out too, and sure enough it worked. However, I had to change
the ownership on the images in the …/NoAuth/images/ directory from
"root:bin" to “root:apache” in order to give Apache access to them.

I’m not sure if this represents any security problems. If you or anyone
else sees any problems with the image permissions (besides the fact that
they will have to be tweaked each time RT is upgraded), please let us
and the list know.

Hope this info helps others out, too.

Thanks,

Kanwar
Systems Aligned Inc.
www.systemsaligned.com