HTTP/HTTPS bug in 4.0?

Greetings,

We are running an RT instance under https only. I just noticed a small
issue - when you’re looking at a ticket, the links for a requestor’s
other tickets are non-https (http://…). On our system, that leads to
a 404. Other links in the ticket (creating links, last ticket
transaction, etc) all properly go to https://…

Cheers,
Dario

Dario Landazuri dario@astro.as.utexas.edu
Systems Administrator (512) 471-3334
McDonald Observatory

smime.p7s (6.4 KB)

We are running an RT instance under https only. I just noticed a small
issue - when you’re looking at a ticket, the links for a requestor’s
other tickets are non-https (http://…). On our system, that leads to
a 404. Other links in the ticket (creating links, last ticket
transaction, etc) all properly go to https://…

This does look to be a bug; I’ll bounce your mail into the
issues.bestpractical.com to track it.

  • Alex

Hi,On Wed, May 4, 2011 at 9:49 PM, Alex Vandiver alexmv@bestpractical.com wrote:

On Wed, 2011-05-04 at 14:27 -0500, Dario Landazuri wrote:

We are running an RT instance under https only. I just noticed a small
issue - when you’re looking at a ticket, the links for a requestor’s
other tickets are non-https (http://…). On our system, that leads to
a 404. Other links in the ticket (creating links, last ticket
transaction, etc) all properly go to https://…

This does look to be a bug; I’ll bounce your mail into the
issues.bestpractical.com to track it.

  • Alex

Playing around with a 4.0.0 test clone of a 3.8.10 RT instance I noticed
the same thing, both for the requestor’s other tickets links and for
the related tickets links.
Then I noticed that the 3.8.10 instance also exhibits the same
behaviour, only it was
masqueraded by the web server doing HTTP to HTTPS redirection :-}

Cheers, Stoned.

Hi,

are you talking about the “More about the requestors” section when viewing a ticket?

Our RT 4.0.0 test instance runs on https, but all the links (i.e. 10 most important active tickets)
are https, just as expected.

LarsAm 04.05.2011 23:06, schrieb Stoned Elipot:

Hi,

On Wed, May 4, 2011 at 9:49 PM, Alex Vandiver alexmv@bestpractical.com wrote:

On Wed, 2011-05-04 at 14:27 -0500, Dario Landazuri wrote:

We are running an RT instance under https only. I just noticed a small
issue - when you’re looking at a ticket, the links for a requestor’s
other tickets are non-https (http://…). On our system, that leads to
a 404. Other links in the ticket (creating links, last ticket
transaction, etc) all properly go to https://…

This does look to be a bug; I’ll bounce your mail into the
issues.bestpractical.com to track it.

  • Alex

Playing around with a 4.0.0 test clone of a 3.8.10 RT instance I noticed
the same thing, both for the requestor’s other tickets links and for
the related tickets links.
Then I noticed that the 3.8.10 instance also exhibits the same
behaviour, only it was
masqueraded by the web server doing HTTP to HTTPS redirection :-}

Cheers, Stoned.

Check rt config through the web UI.

Regards, Ruslan. From phone.

Hi,

are you talking about the “More about the requestors” section when viewing
a ticket?

Our RT 4.0.0 test instance runs on https, but all the links (i.e. 10 most
important active tickets)

I believe it’s a config issue too.

sunnavyOn 11-05-05 06:02, Ruslan Zakirov wrote:

Check rt config through the web UI.

Regards, Ruslan. From phone.
05.05.2011 3:56 пользователь “Lars Braeuer” lb@mpexnet.de написал:

Hi,

are you talking about the “More about the requestors” section when viewing
a ticket?

Our RT 4.0.0 test instance runs on https, but all the links (i.e. 10 most
important active tickets)
are https, just as expected.

Lars

Am 04.05.2011 23:06, schrieb Stoned Elipot:

Hi,

On Wed, May 4, 2011 at 9:49 PM, Alex Vandiver alexmv@bestpractical.com wrote:

On Wed, 2011-05-04 at 14:27 -0500, Dario Landazuri wrote:

We are running an RT instance under https only. I just noticed a small
issue - when you’re looking at a ticket, the links for a requestor’s
other tickets are non-https (http://…). On our system, that leads to
a 404. Other links in the ticket (creating links, last ticket
transaction, etc) all properly go to https://…

This does look to be a bug; I’ll bounce your mail into the
issues.bestpractical.com to track it.

  • Alex

Playing around with a 4.0.0 test clone of a 3.8.10 RT instance I noticed
the same thing, both for the requestor’s other tickets links and for
the related tickets links.
Then I noticed that the 3.8.10 instance also exhibits the same
behaviour, only it was
masqueraded by the web server doing HTTP to HTTPS redirection :-}

Cheers, Stoned.

Hi everyone,

I notice this in our 3.8.10 instance of RT as well. Our redirection of all
traffic to https picks it up and you continue to browse on port 443.

Ruslan mentions that it is a config issue,

Searching the Wiki and RT_Config.pm, I found that

Set($WebBasedURL, ‘https://yourrtinstance.com’);

Is what you need to set to ensure your links are formed correctly.

I’ve tested, works as expected.

Thanks!
Mike.On Wed, May 4, 2011 at 5:06 PM, Stoned Elipot stoned.elipot@gmail.comwrote:

Hi,

On Wed, May 4, 2011 at 9:49 PM, Alex Vandiver alexmv@bestpractical.com wrote:

On Wed, 2011-05-04 at 14:27 -0500, Dario Landazuri wrote:

We are running an RT instance under https only. I just noticed a small
issue - when you’re looking at a ticket, the links for a requestor’s
other tickets are non-https (http://…). On our system, that leads to
a 404. Other links in the ticket (creating links, last ticket
transaction, etc) all properly go to https://…

This does look to be a bug; I’ll bounce your mail into the
issues.bestpractical.com to track it.

  • Alex

Playing around with a 4.0.0 test clone of a 3.8.10 RT instance I noticed
the same thing, both for the requestor’s other tickets links and for
the related tickets links.
Then I noticed that the 3.8.10 instance also exhibits the same
behaviour, only it was
masqueraded by the web server doing HTTP to HTTPS redirection :-}

Cheers, Stoned.

Mike Johnson
Datatel Programmer/Analyst
Northern Ontario School of Medicine
955 Oliver Road
Thunder Bay, ON P7B 5E1
Phone: (807) 766-7331
Email: mike.johnson@nosm.ca

Hi,

Set WebDomain, WebPath and WebPort properly. In simple case (like
yours) you shouldn’t set WebBaseURL (it’s WebBaseURL, not
WebBasedURL). Don’t know what you found on the wiki, but information
is probably out of date.On Fri, May 6, 2011 at 5:17 PM, Mike Johnson mike.johnson@nosm.ca wrote:

Hi everyone,

I notice this in our 3.8.10 instance of RT as well. Our redirection of all
traffic to https picks it up and you continue to browse on port 443.

Ruslan mentions that it is a config issue,

Searching the Wiki and RT_Config.pm, I found that

Set($WebBasedURL, ‘https://yourrtinstance.com’);

Is what you need to set to ensure your links are formed correctly.

I’ve tested, works as expected.

Thanks!
Mike.

On Wed, May 4, 2011 at 5:06 PM, Stoned Elipot stoned.elipot@gmail.com wrote:

Hi,

On Wed, May 4, 2011 at 9:49 PM, Alex Vandiver alexmv@bestpractical.com wrote:

On Wed, 2011-05-04 at 14:27 -0500, Dario Landazuri wrote:

We are running an RT instance under https only. I just noticed a small
issue - when you’re looking at a ticket, the links for a requestor’s
other tickets are non-https (http://…). On our system, that leads to
a 404. Other links in the ticket (creating links, last ticket
transaction, etc) all properly go to https://…

This does look to be a bug; I’ll bounce your mail into the
issues.bestpractical.com to track it.

  • Alex

Playing around with a 4.0.0 test clone of a 3.8.10 RT instance I noticed
the same thing, both for the requestor’s other tickets links and for
the related tickets links.
Then I noticed that the 3.8.10 instance also exhibits the same
behaviour, only it was
masqueraded by the web server doing HTTP to HTTPS redirection :-}

Cheers, Stoned.


Mike Johnson
Datatel Programmer/Analyst
Northern Ontario School of Medicine
955 Oliver Road
Thunder Bay, ON P7B 5E1
Phone: (807) 766-7331
Email: mike.johnson@nosm.ca

Best regards, Ruslan.

Hi,

First, apparently I typed it wrong in the config.(added the ‘d’ to it).

The Wiki (http://requesttracker.wikia.com/wiki/ManualInstallation) says

"

$WebBaseURL = “http://not.configured:80 http://not.configured/”;

A variable used to help RT construct
URLshttp://requesttracker.wikia.com/index.php?title=URLs&action=edit&redlink=1that
point back to RT. $
WebBaseURLhttp://requesttracker.wikia.com/index.php?title=WebBaseURL&action=edit&redlink=1is
the base of the URL. it should usually include the scheme, the host,
and
the port if non-standard.
"
That is what led me to the suggestion of setting WebBaseURL.(by the way I
tested WebBasedURL as well… that actually works,) although both of these
are probably not recommended :smiley: as stated by Ruslan.

I then removed the above and set WebPort to 443.

Based on Ruslan’s comment, this sounds like the recommended way of doing it
:smiley:

Thanks Ruslan.On Fri, May 6, 2011 at 10:30 AM, Ruslan Zakirov ruz@bestpractical.comwrote:

Hi,

Set WebDomain, WebPath and WebPort properly. In simple case (like
yours) you shouldn’t set WebBaseURL (it’s WebBaseURL, not
WebBasedURL). Don’t know what you found on the wiki, but information
is probably out of date.

On Fri, May 6, 2011 at 5:17 PM, Mike Johnson mike.johnson@nosm.ca wrote:

Hi everyone,

I notice this in our 3.8.10 instance of RT as well. Our redirection of
all
traffic to https picks it up and you continue to browse on port 443.

Ruslan mentions that it is a config issue,

Searching the Wiki and RT_Config.pm, I found that

Set($WebBasedURL, ‘https://yourrtinstance.com’);

Is what you need to set to ensure your links are formed correctly.

I’ve tested, works as expected.

Thanks!
Mike.

On Wed, May 4, 2011 at 5:06 PM, Stoned Elipot stoned.elipot@gmail.com wrote:

Hi,

On Wed, May 4, 2011 at 9:49 PM, Alex Vandiver <alexmv@bestpractical.com wrote:

On Wed, 2011-05-04 at 14:27 -0500, Dario Landazuri wrote:

We are running an RT instance under https only. I just noticed a
small

issue - when you’re looking at a ticket, the links for a requestor’s
other tickets are non-https (http://…). On our system, that leads
to

a 404. Other links in the ticket (creating links, last ticket
transaction, etc) all properly go to https://…

This does look to be a bug; I’ll bounce your mail into the
issues.bestpractical.com to track it.

  • Alex

Playing around with a 4.0.0 test clone of a 3.8.10 RT instance I noticed
the same thing, both for the requestor’s other tickets links and for
the related tickets links.
Then I noticed that the 3.8.10 instance also exhibits the same
behaviour, only it was
masqueraded by the web server doing HTTP to HTTPS redirection :-}

Cheers, Stoned.


Mike Johnson
Datatel Programmer/Analyst
Northern Ontario School of Medicine
955 Oliver Road
Thunder Bay, ON P7B 5E1
Phone: (807) 766-7331
Email: mike.johnson@nosm.ca


Best regards, Ruslan.

Mike Johnson
Datatel Programmer/Analyst
Northern Ontario School of Medicine
955 Oliver Road
Thunder Bay, ON P7B 5E1
Phone: (807) 766-7331
Email: mike.johnson@nosm.ca