How to set the Queue Mailsender Realname

Hi all

I managed to partialy solve the sendmail envelope problem. Now mails get
sent out with a reachable hostname :slight_smile:

My rt users have brought two wishes to me:

Is is possible to alter the Queue Correspondence address Realname?

Now it is:From: “queuename” support@address.com

They would preffer something like:
From: “Foobar Support” support@address.com

second thingie.
When a supporter replies to a ticket the reply has the Address:

“Supporterrealname via RT” support@address.com

The same here, they would preffer:
“Foobar Support” support@address.com

-Benoit-

At 04:36 PM 26/02/2003 +0100, Panizzon Benoit wrote:

Is is possible to alter the Queue Correspondence address Realname?

Now it is:
From: “queuename” support@address.com

They would preffer something like:
From: “Foobar Support” support@address.com

I changed:

my $friendly_name=$self->TicketObj->QueueObj->Name;

     my $friendly_name=$self->TicketObj->QueueObj->Description;

in /opt/rt2/lib/RT/Action/Autoreply.pm so that the queue Description was
used rather than queue Name.

When a supporter replies to a ticket the reply has the Address:

“Supporterrealname via RT” support@address.com

The same here, they would preffer:
“Foobar Support” support@address.com

Search for:

$self->SetHeader(‘From’, “”$friendly_name via RT" <$replyto>");

within /opt/rt2/lib/RT/Action/SendEmail.pm

-Brook

= /// /// /// /// _/ _/ Brook Schofield =
= _/ _/ _/ _/ _/ _/ _/ _/ _/ / B.Schofield@mailbox.gu.edu.au =
= // //
/ _/ _/ _/ _/ // Ph: +61 7 387 53779 - WCN 0.28 =
= _/ _/ _/ _/ _/ _/ _/ _/ _/ / Directory Services Integration =
= //
/ / / /// /// _/ _/ Griffith University QLD 4111 =

I’ve found that I can put, as the first line in the template body, a header
like so:

You’d need to have separate templates for each queue, however. The other
suggestions posted of course will work great, too.

-=| Ben----- Original Message -----

From: “Panizzon Benoit” bpanizzon@iphpa.ch
To: rt-users@lists.fsck.com
Sent: Wednesday, February 26, 2003 10:36 AM
Subject: [rt-users] How to set the Queue Mailsender Realname

Hi all

I managed to partialy solve the sendmail envelope problem. Now mails get
sent out with a reachable hostname :slight_smile:

My rt users have brought two wishes to me:

Is is possible to alter the Queue Correspondence address Realname?

Now it is:
From: “queuename” support@address.com

They would preffer something like:
From: “Foobar Support” support@address.com

second thingie.
When a supporter replies to a ticket the reply has the Address:

“Supporterrealname via RT” support@address.com

The same here, they would preffer:
“Foobar Support” support@address.com

-Benoit-


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

I’ve found that I can put, as the first line in the template body, a header
like so:

From: RealName email@addr.ess

Don’t forget that the templates can take arbitrary perl inside of { },
so you can use { $Ticket->QueueObj->Description } instead of the
RealName…

http://www.bestpractical.com/rt – Trouble Ticketing. Free.

Actually I’ve found that if I put this as the first line in the template:

that if I create a new ticket via the web interface, the auto-reply message
sends the email with a from like so:

From: <>

As if $Ticket->QueueObj->CorrespondAddress() wasn’t set yet. Any ideas on
why? For now I’ve entered in straight text to get around the problem. It
does work for tickets created for email, however…

Thanks!

-=| Ben

I’ve found that I can put, as the first line in the template body, a
header

Ben Goodwin wrote:

Actually I’ve found that if I put this as the first line in the template:

From: <{$Ticket->QueueObj->CorrespondAddress()}>

that if I create a new ticket via the web interface, the auto-reply message
sends the email with a from like so:

From: <>

That’s odd. The stock Autoreply template uses that construct in the body,
and I’ve never seen it fail. Are you using said template, and if so,
does the address appear correctly after the “Thank you,” line?

Silly question: you’re absolutely sure that’s exactly what’s in
your template (cut-and-pasted?), and there’s no typo there?
�|� http://www.bestpractical.com/rt – Trouble Ticketing. Free.

That’s odd. The stock Autoreply template uses that construct in the body,
and I’ve never seen it fail. Are you using said template, and if so,
does the address appear correctly after the “Thank you,” line?

Silly question: you’re absolutely sure that’s exactly what’s in
your template (cut-and-pasted?), and there’s no typo there?

Yeah I dunno why … I ended up creating a new global config parameter
(because in our installation I only need one realname/address) and editing
Autoreply.pm to use the config parameter instead of the queue’s name … and
then of course removed the From line at the top of the template… oh well.
Oh, and yes, it was cut-n-paste…

-=| Ben

Yeah I dunno why … I ended up creating a new global config parameter
(because in our installation I only need one realname/address) and editing
Autoreply.pm to use the config parameter instead of the queue’s name … and
then of course removed the From line at the top of the template… oh well.
Oh, and yes, it was cut-n-paste…

Please note that there’s a difference between (header) from and
envelope-from.

Some MTA’s will build a from if not supplied or do other fun things with
it.

Not sure if this is what you’re triggering, but might be worth checking.

Jeroen Ruigrok van der Werven <asmodai(at)wxs.nl> / asmodai / a capoeirista
PGP fingerprint: 2D92 980E 45FE 2C28 9DB7 9D88 97E6 839B 2EAC 625B
http://www.tendra.org/ | http://www.in-nomine.org/~asmodai/diary/
Sometimes things stare us in the face and we are too blind to see…