How to limit a scrip per queue

Is there a way to limit one of the default scrips to not to act on a
queue? There are two default scrips that act on ticket creation. #4 and
#5. At least I think they are defaults as I don’t remember creating
these since they don’t have a description. I would like to disable one
of them as it is redundant.

Also along those lines if you want a global script to work for all
queues except maybe a few is there a way to add that condition?

All pointers to the Wiki or docs will be accepted.

I am using RT 3.6.6

TIA

John J. Boris, Sr.
JEN-A-SyS Administrator
Archdiocese of Philadelphia
"Remember! That light at the end of the tunnel
Just might be the headlight of an oncoming train!"

Hi John,
there are several methods, first (and most painfull) is to deactivate all
global scrips and define all again on queue level, second and my preferred
is Dirk Papes HideGlobalScrips (Search inside the wiki) this is running nice
under RT 3.6.x for RT 3.8.x you can find at github (
http://github.com/tbrumm/RT-Extension-QueueDeactivatedScrips) the same
solution ported to 3.82010/8/11 John BORIS jboris@adphila.org

Is there a way to limit one of the default scrips to not to act on a
queue? There are two default scrips that act on ticket creation. #4 and
#5. At least I think they are defaults as I don’t remember creating
these since they don’t have a description. I would like to disable one
of them as it is redundant.

Also along those lines if you want a global script to work for all
queues except maybe a few is there a way to add that condition?

All pointers to the Wiki or docs will be accepted.

I am using RT 3.6.6

TIA

John J. Boris, Sr.
JEN-A-SyS Administrator
Archdiocese of Philadelphia
"Remember! That light at the end of the tunnel
Just might be the headlight of an oncoming train!"
RT Training in Washington DC, USA on Oct 25 & 26 2010
Last one this year – Learn how to get the most out of RT!

MFG

Torsten Brumm

http://www.brumm.me

Thanks. I found the patch and will see about applying it.

Torsten Brumm torsten.brumm@googlemail.com 8/11/2010 12:34 PM

Hi John,
there are several methods, first (and most painfull) is to deactivate
all
global scrips and define all again on queue level, second and my
preferred
is Dirk Papes HideGlobalScrips (Search inside the wiki) this is running
nice
under RT 3.6.x for RT 3.8.x you can find at github (
http://github.com/tbrumm/RT-Extension-QueueDeactivatedScrips) the same
solution ported to 3.8

Is there a way to limit one of the default scrips to not to act on a
queue? There are two default scrips that act on ticket creation. #4
and
#5. At least I think they are defaults as I don’t remember creating
these since they don’t have a description. I would like to disable
one
of them as it is redundant.

Also along those lines if you want a global script to work for all
queues except maybe a few is there a way to add that condition?

All pointers to the Wiki or docs will be accepted.

I am using RT 3.6.6

TIA

John J. Boris, Sr.
JEN-A-SyS Administrator
Archdiocese of Philadelphia
"Remember! That light at the end of the tunnel
Just might be the headlight of an oncoming train!"
RT Training in Washington DC, USA on Oct 25 & 26 2010
Last one this year – Learn how to get the most out of RT!

MFG

Torsten Brumm

http://www.brumm.me

Hi,

We are using RT 3.8.7 with external authentication. When someone who is
not know to our LDAP server is Cced in a ticket and tries to reply s/he
gets permission denied error. This is creating problem for our users on
leave that have their email forwarded to a different institutes. Is this
the nature of the beast when an external authentication is used?

Our global permission for Everyone is set to:
ForwardMessage
ModifyTicket
OwnTicket
ReplyToTicket
SeeOwnDashboard
ShowOutgoingEmail
ShowSavedSearches
ShowTicket
ShowTicketComments

Cheers, – and many thanks in advance,
Hossein

_____ _____ _____ _ _ _ _ ____ Hossein Rafighi
|_ || _ \ | || | | || _/ || __|TRIUMF, 4004 Wesbrook Mall
| | | |
| ) | | | | | || || |__ Vancouver BC, Canada, V6T 2A3
| | | _ / | | | _/ || _/ || |Voice: (604) 222-1047
| | | | \ \ | | | || | | || | Fax: (604) 222-1074
|| || _|
_| _/ || |||_| Website: http://www.triumf.ca

We are using RT 3.8.7 with external authentication. When someone who

I assume you meant RT::Authen::ExternalAuth, not RT’s built-in
ExternalAuthentication

is not know to our LDAP server is Cced in a ticket and tries to
reply s/he gets permission denied error. This is creating problem
for our users on leave that have their email forwarded to a
different institutes. Is this the nature of the beast when an
external authentication is used?

Sounds like you’ve left the default of “don’t allow the creation of
user accounts who aren’t in LDAP” on in your RT::Authen::ExternalAuth
config.

-kevin

Hi Kevin,

Thanks for the reply. Please see the followings:

I assume you meant RT::Authen::ExternalAuth, not RT’s built-in
ExternalAuthentication
Yes. That’s correct. Sorry for not being clear.

is not know to our LDAP server is Cced in a ticket and tries to
reply s/he gets permission denied error. This is creating problem
for our users on leave that have their email forwarded to a
different institutes. Is this the nature of the beast when an
external authentication is used?
Sounds like you’ve left the default of “don’t allow the creation of
user accounts who aren’t in LDAP” on in your RT::Authen::ExternalAuth
config.
In my RT_SiteConfig.pm I have: Set($AutoCreateNonExternalUsers, 0);
Is this the one you’re referring to? If I set this to 1 to enable, do I
need to do anything, run any command to apply it? What is the
ramification of allowing this? Does that mean user(s) not known to our
LDAP will be created as local user? If yes, can this person login to our
RT? I hope not!!!

Thanks for your reply,
Hossein

_____ _____ _____ _ _ _ _ ____ Hossein Rafighi
|_ || _ \ | || | | || _/ || __|TRIUMF, 4004 Wesbrook Mall
| | | |
| ) | | | | | || || |__ Vancouver BC, Canada, V6T 2A3
| | | _ / | | | _/ || _/ || |Voice: (604) 222-1047
| | | | \ \ | | | || | | || | Fax: (604) 222-1074
|| || _|
_| _/ || |||_| Website: http://www.triumf.ca

Hi Kevin,

Sounds like you’ve left the default of “don’t allow the creation of
user accounts who aren’t in LDAP” on in your RT::Authen::ExternalAuth
config.
In my RT_SiteConfig.pm I have: Set($AutoCreateNonExternalUsers,
0); Is this the one you’re referring to? If I set this to 1 to
enable, do I need to do anything, run any command to apply it? What
is the ramification of allowing this? Does that mean user(s) not
known to our LDAP will be created as local user? If yes, can this
person login to our RT? I hope not!!!

I assume you’ve already googled the list archives to find the answer
to this.

Yes you want to set that.

Like all config setting changes you must restart apache.

No, the user will not be able to log into RT unless you give them a
password locally in RT or in your ldap server

-kevin

Dear Kevin,
Yes, I had googled it, but wanted to make sure I was on the right track.
Darn filters! Your reply was filed away and I didn’t see it til now.
Many thanks…
HosseinOn 8/17/2010 1:54 PM, Kevin Falcone wrote:

I assume you’ve already googled the list archives to find the answer
to this.

Yes you want to set that.

Like all config setting changes you must restart apache.

No, the user will not be able to log into RT unless you give them a
password locally in RT or in your ldap server

-kevin

RT Training in Washington DC, USA on Oct 25& 26 2010
Last one this year – Learn how to get the most out of RT!

_____ _____ _____ _ _ _ _ ____ Hossein Rafighi
|_ || _ \ | || | | || _/ || __|TRIUMF, 4004 Wesbrook Mall
| | | |
| ) | | | | | || || |__ Vancouver BC, Canada, V6T 2A3
| | | _ / | | | _/ || _/ || |Voice: (604) 222-1047
| | | | \ \ | | | || | | || | Fax: (604) 222-1074
|| || _|
_| _/ || |||_| Website: http://www.triumf.ca