How to : import data from rt2 to RT3

Here is the steps to load data from RT2 to RT3 :

The format of the export files has changed, but version 1.1 of the upgrade
package contains a mix of both formats. The exporter uses the new format
(one file per ticket) while the importer still uses the old one (on large
file for all)

Here is a workaround which will let you upload your data, and convert it to
the right code page.

Export data with the exporter with the exporter contained in V1.0. Do not
use the proposed syntax, but : ./rt2-to-dumpfile >your_large_file

Import the data with the importer contained in V1.1. Pass the file name as a
parameter : ./dumpfile-to-rt3 your_large_file

It worked for me.

Blaise

-----Message d’origine-----De : THAUVIN Blaise (Dir. Informatique FRP)
[mailto:bthauvin@clearchannel.fr]
Envoyé : dimanche 26 janvier 2003 00:10
À : 'Jesse Vincent’
Cc : rt-devel@lists.fsck.com
Objet : RE: [rt-devel] RT 2.1.63 and rt2-to-rt3 1.0

Just tried rt2-to-rt3-v1.1.tar.gz.

I managed to dump files properly.

When trying to load them, it seems the README files is sightly incorrect.
dumpfile-to-RT3 seems to expect the path to the metadata file itself rather
than the directory containing it. I had to use the following command line to
start the import : ./dumpfile-to-rt-3.0 dumpfiles/metadata

It loaded users, queues, ACLS… right, but then stops at the first ticket
with the following message :

Blaise

Adding 12 to 1841
Adding 13 to 1841
[Sat Jan 25 23:03:59 2003] [warning]: Use of uninitialized value in
concatenation (.) or string at /usr/local/rt3/lib/RT/URI/fsck_com_rt.pm line
95.

(/usr/local/rt3/lib/RT.pm:220)
[Sat Jan 25 23:03:59 2003] [warning]: Resolver RT::URI::fsck_com_rt could
not parse 263 (/usr/local/rt3/lib/RT/URI.pm:122)

[Sat Jan 25 23:03:59 2003] [warning]: Use of uninitialized value in
concatenation (.) or string at /usr/local/rt3/lib/RT/URI/fsck_com_rt.pm line
95.

(/usr/local/rt3/lib/RT.pm:220)
[Sat Jan 25 23:03:59 2003] [warning]: Resolver RT::URI::fsck_com_rt could
not parse 263 (/usr/local/rt3/lib/RT/URI.pm:122)

Can’t call method “Id” on an undefined value at
/usr/local/rt3/lib/RT/Link_Overlay.pm line 114.

-----Message d’origine-----
De : Jesse Vincent [ mailto:jesse@bestpractical.com
mailto:jesse@bestpractical.com ]
Envoyé : samedi 25 janvier 2003 19:28
À : THAUVIN Blaise (Dir. Informatique FRP)
Cc : rt-devel@lists.fsck.com
Objet : Re: [rt-devel] RT 2.1.63 and rt2-to-rt3 1.0

Hi,

Just a quick report on my first try with the new modules :

dump : Did not create the files in the directory provided, but sent on
stdout a large file very similar to the one created by the previous
version
of the dumper code. No errors encountered. Command was :
./rt-2.0-to-dumpfile /tmp/rt2-to-rt3/dumpfiles >log 2>log2& . The
directory
exists and is world writable.

Sorry. there’s a new verstion at rt2-to-rt3-v1.1.tar.gz that has the
right exporter in it. Give that one a shot.

import : could not run it. It complains it is missing a “Encode.pm” file.
I
tried to install the perl module, but couldn’t as it said it needed perl
5.7.3 and I run 5.6.1. I did not try to search for and install an older
version of the package. It seems more and more obvious that users who want

to use the new localized features should upgrade to the lastest perl…
this is now one more line on my the todo list :slight_smile:

Ah. I think I see what is going on and it should be fixed in the new
version.

Jesse, which version of perl is running on your developpement and/or test
machine? 5.6.1 or newer?

My dev box runs 5.8.0, my test box runs 5.6.1.

As soon as the upgrade’s done, I’ll try again and post a report

Blaise

-----Message d’origine-----
De : Jesse Vincent [ mailto:jesse@bestpractical.com
mailto:jesse@bestpractical.com ]
Envoyé : samedi 25 janvier 2003 10:08
À : rt-devel@lists.fsck.com
Objet : [rt-devel] RT 2.1.63 and rt2-to-rt3 1.0

In the two weeks since alpha 2, a fair amount of work has gone into
getting the codebase ready for beta. It’s very, very close. I’m headed
out of town for a couple days. If I was in fact stuck here in New
England over the weekend, I’d be busy converting fsck.com’s RT instance
to the latest 2.1 release, 2.1.63, though I wouldn’t recommend that you
run this one in production unless you’re very comfortable babysitting
perl code and like to live on the edge.

The past couple days have seen some important bug fixes to ticket
searching and a redone search results page. RT’s menuing has been redone
again, but it’s not likely that you’ll notice in a modern browser. A
nested table structure has been replaced with simple html markup and
CSS, which should render more cleanly, be easier to change and send
fewer bytes over the wire. (And that will be further reduced as we
continue to clean up some of the CSS)

We’ve done some profiling and performance tweaking. After importing a
15,600 ticket database (perl.org bug database), most page displays
rendered in < 2 seconds, with a significant fraction of them rendering
in under a second. (The host in question is a p3/800 with fairly fast
but not top of the line IDE disks and a gig of ram. It’s also serving a
couple dozen websites and about 8 RT2 instances. It’s runny Mysql
3.23.54 with InnoDB tables)

Right. Importing. Blaise Thauvin has been very patient as we’ve worked
out the RT2->RT3 migration tool, which is currently available at:

  http://www.fsck.com/pub/rt/devel/rt2-to-rt3.tgz

http://www.fsck.com/pub/rt/devel/rt2-to-rt3.tgz

I know it spews a bunch of “redefined” warnings on import. Don’t worry
about it.

RT 2.1.x’s internationalization is known to still be somewhat broken on
perl 5.6.1. At this point, if you need RT 2.1 in some language other
than English, we strongly recommend that you consider upgrading to perl
5.8, which has much better support for Unicode and non-US-ASCII
characters.

When I get back to a normal work schedule on Wednesday or Thursday, I’ll
be collecting the issues that folks have found in the 2.1.63, bundling
up 2.1.6x and inviting the world to beat on it before I call it RT 3.0
Beta 1.

Please report any weirdnesses you see with this release to
rt-devel@lists.fsck.com

  Best, 
  Jesse 


»|« http://www.bestpractical.com/rt http://www.bestpractical.com/rt
Trouble Ticketing. Free.


rt-devel mailing list
rt-devel@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-devel
http://lists.fsck.com/mailman/listinfo/rt-devel

»|« http://www.bestpractical.com/rt http://www.bestpractical.com/rt
Trouble Ticketing. Free.