How to have two RT instances set in apache?

I’ve been trying to setup two RT instances in apache, but only one works
at a time.
It may be some apache configuration issue, but can’t figure out what
it’s wrong.
Any help will be very appreciated.
Please find below both files:
::::::::::::::
rt-cpqd-commons.conf
::::::::::::::
Alias /cpqd-commons /l/disk0/tools/rt/cpqd-commons/share/html
AddDefaultCharset UTF-8
PerlModule Apache::DBI
PerlRequire /l/disk0/tools/rt/cpqd-commons/bin/webmux.pl
<Location /cpqd-commons>
Options None
SetHandler perl-script
PerlHandler RT::Mason


PerlFixupHandler Apache::SmallProf



<LocationMatch “/cpqd-commons/NoAuth”>
Satisfy Any
Allow from all

<Location /cpqd-commons/NoAuth/images>
SetHandler default-handler


<Location /cpqd-commons/perl-status>
SetHandler perl-script
PerlHandler Apache2::Status
PerlSetVar StatusOptionsAll On
PerlSetVar StatusTerse On
PerlSetVar StatusTerseSize On
PerlSetVar StatusTerseSizeMainSummary On
PerlSetVar StatusLexInfo On


::::::::::::::
rt-cpqd-gp.conf
::::::::::::::
Alias /cpqd-gp /l/disk0/tools/rt/cpqd-gp/share/html
AddDefaultCharset UTF-8
PerlModule Apache::DBI
PerlRequire /l/disk0/tools/rt/cpqd-gp/bin/webmux.pl
<Location /cpqd-gp>
Options None
SetHandler perl-script
PerlHandler RT::Mason


PerlFixupHandler Apache::SmallProf



<LocationMatch “/cpqd-gp/NoAuth”>
Satisfy Any
Allow from all

<Location /cpqd-gp/NoAuth/images>
SetHandler default-handler


<Location /cpqd-gp/perl-status>
SetHandler perl-script
PerlHandler Apache2::Status
PerlSetVar StatusOptionsAll On
PerlSetVar StatusTerse On
PerlSetVar StatusTerseSize On
PerlSetVar StatusTerseSizeMainSummary On
PerlSetVar StatusLexInfo On

Hi,

i’m not sure if this will work with mod_perl. i have used FastCGI or FCGI to
do this.

There is a very good wiki entry at wiki.bestpractical.com.

If you need more help, i can sent you my config (apache)

Torsten2006/8/15, Dario Luis Coneglian Oliveros oliveros@cpqd.com.br:

I’ve been trying to setup two RT instances in apache, but only one works
at a time.
It may be some apache configuration issue, but can’t figure out what
it’s wrong.
Any help will be very appreciated.
Please find below both files:
::::::::::::::
rt-cpqd-commons.conf
::::::::::::::
Alias /cpqd-commons /l/disk0/tools/rt/cpqd-commons/share/html
AddDefaultCharset UTF-8
PerlModule Apache::DBI
PerlRequire /l/disk0/tools/rt/cpqd-commons/bin/webmux.pl
<Location /cpqd-commons>
Options None
SetHandler perl-script
PerlHandler RT::Mason


PerlFixupHandler Apache::SmallProf



<LocationMatch “/cpqd-commons/NoAuth”>
Satisfy Any
Allow from all

<Location /cpqd-commons/NoAuth/images>
SetHandler default-handler


<Location /cpqd-commons/perl-status>
SetHandler perl-script
PerlHandler Apache2::Status
PerlSetVar StatusOptionsAll On
PerlSetVar StatusTerse On
PerlSetVar StatusTerseSize On
PerlSetVar StatusTerseSizeMainSummary On
PerlSetVar StatusLexInfo On


::::::::::::::
rt-cpqd-gp.conf
::::::::::::::
Alias /cpqd-gp /l/disk0/tools/rt/cpqd-gp/share/html
AddDefaultCharset UTF-8
PerlModule Apache::DBI
PerlRequire /l/disk0/tools/rt/cpqd-gp/bin/webmux.pl
<Location /cpqd-gp>
Options None
SetHandler perl-script
PerlHandler RT::Mason


PerlFixupHandler Apache::SmallProf



<LocationMatch “/cpqd-gp/NoAuth”>
Satisfy Any
Allow from all

<Location /cpqd-gp/NoAuth/images>
SetHandler default-handler


<Location /cpqd-gp/perl-status>
SetHandler perl-script
PerlHandler Apache2::Status
PerlSetVar StatusOptionsAll On
PerlSetVar StatusTerse On
PerlSetVar StatusTerseSize On
PerlSetVar StatusTerseSizeMainSummary On
PerlSetVar StatusLexInfo On


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

MFG

Torsten Brumm

http://www.torsten-brumm.de

Thanks for the info Torsten.
I will try FastCGI then.
If you can send your config file, it will be great and save me some time.
Thanks a lot,
D�rio

Torsten Brumm wrote:

Hi Dario,

no problem:

i’m running apache2 under RHEL3, here are the importent parts from my
httpd.conf:

LoadModule fastcgi_module /usr/lib/httpd/modules/mod_fastcgi.so

FastCgiServer /opt/rt3ast/bin/mason_handler.fcgi -idle-timeout 300
-processes 30 -listen-queue-depth 300 -priority 9 -appConnTimeout 240

FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 300 -processes
30 -listen-queue-depth 300 -priority 8 -appConnTimeout 240

and the virtual host section:

<VirtualHost *>
ServerName ast.int.kn
ServerAdmin support@company.com
DocumentRoot /opt/rt3ast/share/html
AddHandler fastcgi-script .fcgi
ExpiresActive On
ExpiresByType text/css A3600
ExpiresByType image/png A3600
ExpiresByType application/x-javascript A3600
ExpiresByType image/gif A3600
Alias /NoAuth/images/ /opt/rt3ast/share/html/NoAuth/images/
Alias /pics/ /opt/rt3ast/share/html/NoAuth/images/pics/
ScriptAlias / /opt/rt3ast/bin/mason_handler.fcgi/

<VirtualHost *>
ServerName ticket.int.kn
ServerAdmin support@company.com
DocumentRoot /opt/rt3/share/html
AddHandler fastcgi-script .fcgi
ExpiresActive On
ExpiresByType text/css A3600
ExpiresByType image/png A3600
ExpiresByType application/x-javascript A3600
ExpiresByType image/gif A3600
Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/
Alias /pics/ /opt/rt3/share/html/NoAuth/images/pics/
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

Important reading:

http://wiki.bestpractical.com/index.cgi?RHEL4InstallGuide
http://wiki.bestpractical.com/index.cgi?FastCGIFAQ
http://wiki.bestpractical.com/index.cgi?FastCGIConfiguration2006/8/16, Dario Luis Coneglian Oliveros oliveros@cpqd.com.br:

Thanks for the info Torsten.
I will try FastCGI then.
If you can send your config file, it will be great and save me some time.
Thanks a lot,
Dário

Torsten Brumm wrote:

Hi,

i’m not sure if this will work with mod_perl. i have used FastCGI or FCGI
to do this.

There is a very good wiki entry at wiki.bestpractical.com.

If you need more help, i can sent you my config (apache)

Torsten

2006/8/15, Dario Luis Coneglian Oliveros oliveros@cpqd.com.br:

I’ve been trying to setup two RT instances in apache, but only one works
at a time.
It may be some apache configuration issue, but can’t figure out what
it’s wrong.
Any help will be very appreciated.
Please find below both files:
::::::::::::::
rt-cpqd-commons.conf
::::::::::::::
Alias /cpqd-commons /l/disk0/tools/rt/cpqd-commons/share/html
AddDefaultCharset UTF-8
PerlModule Apache::DBI
PerlRequire /l/disk0/tools/rt/cpqd-commons/bin/webmux.pl
<Location /cpqd-commons>
Options None
SetHandler perl-script
PerlHandler RT::Mason


PerlFixupHandler Apache::SmallProf



<LocationMatch “/cpqd-commons/NoAuth”>
Satisfy Any
Allow from all

<Location /cpqd-commons/NoAuth/images>
SetHandler default-handler


<Location /cpqd-commons/perl-status>
SetHandler perl-script
PerlHandler Apache2::Status
PerlSetVar StatusOptionsAll On
PerlSetVar StatusTerse On
PerlSetVar StatusTerseSize On
PerlSetVar StatusTerseSizeMainSummary On
PerlSetVar StatusLexInfo On


::::::::::::::
rt-cpqd-gp.conf
::::::::::::::
Alias /cpqd-gp /l/disk0/tools/rt/cpqd-gp/share/html
AddDefaultCharset UTF-8
PerlModule Apache::DBI
PerlRequire /l/disk0/tools/rt/cpqd-gp/bin/webmux.pl
<Location /cpqd-gp>
Options None
SetHandler perl-script
PerlHandler RT::Mason


PerlFixupHandler Apache::SmallProf



<LocationMatch “/cpqd-gp/NoAuth”>
Satisfy Any
Allow from all

<Location /cpqd-gp/NoAuth/images>
SetHandler default-handler


<Location /cpqd-gp/perl-status>
SetHandler perl-script
PerlHandler Apache2::Status
PerlSetVar StatusOptionsAll On
PerlSetVar StatusTerse On
PerlSetVar StatusTerseSize On
PerlSetVar StatusTerseSizeMainSummary On
PerlSetVar StatusLexInfo On


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


MFG

Torsten Brumm

http://www.torsten-brumm.de

MFG

Torsten Brumm

http://www.torsten-brumm.de

Hi Torsten,
Thanks for your help.
I got fastcgi up and running without any problem.
I had to make some changes to your config file since I do not use
VirtualHost.
Hope someone find this (see snippet below) info useful.
Thanks a lot,
D�rio

AddHandler fastcgi-script fcgi
<Location “/rt/gp”>
Options FollowSymLinks ExecCGI
AllowOverride None
AddDefaultCharset UTF-8
SetHandler fastcgi-script

<LocationMatch “/rt/gp/NoAuth”>
Satisfy Any
Allow from all

<Location “/rt/gp/NoAuth/images”>
SetHandler default-handler

FastCgiServer /l/disk0/tools/rt/gp/bin/mason_handler.fcgi -idle-timeout
120 -processes 3
ScriptAlias /rt/gp /l/disk0/tools/rt/gp/bin/mason_handler.fcgi

Torsten Brumm wrote: