How to enable HTML trmplates in RT

Hi,

I am using RT 3.8 installed in Debian Lenny. I changed my default templates to html. but I am getting mails in plain text. When i receive mails, header shows ‘Content-Type: text/plain; charset=“utf-8”’.After a long search I came to know that due to security RT enabled only text/plain. how can i enable html email in RT.
Thanks for any help in advance

-Praveen-

Windows 7: Simplify what you do everyday. Find the right PC for you.
http://windows.microsoft.com/shop

All I did was setup the templates as shown in the example below;

Content-Type: text/html
Content:



Note: Any replies to this email will reopen the job

You logged a job (SR#) with the Sitel IT Service Desk which we believe we have now resolved, please take the time to complete a short survey in relation to that job.

Sitel users please click below Begin Survey
Genesis users please click below
Begin
Survey
If the job has not been resolved or you have any further questions or concerns, please reply to this message or call us on extension 7804 (+64 7 838 7804)
 


Sitel NZ Information Technology

Level 3, ASB Building
500 Victoria Street
Hamilton, New Zealand
+64 7 838 7804

Then clearly adjusted the scrips to fire off the amended template. This one
was for OnResolve.

Regards

AaronOn Mon, Nov 9, 2009 at 6:11 PM, Praveen Velu praveen.velu@hotmail.comwrote:

Hi,

I am using RT 3.8 installed in Debian Lenny. I changed my default templates
to html. but I am getting mails in plain text. When i receive mails, header
shows 'Content-Type: text/plain; charset=“utf-8”’.After a long search I
came to know that due to security RT enabled only text/plain. how can i
enable html email in RT.
Thanks for any help in advance

-Praveen-


http://windows.microsoft.com/shop Find the right PC for you.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Regards,

Aaron

Dear Aaron,

Thanks for your quick help. I added same template for testing. Still I am getting mails in text/plain format. Is there any settings I have to do for enable html in request tracker 3.8.

If I reply to a mail from rt web interface by adding any hyper-links to body. I am not getting any hyper-links at receiving end.

-Praveen-

All I did was setup the templates as shown in the example below;

Content-Type: text/html
Content:



Note: Any replies to this email will reopen the job


You logged a job (SR#) with the Sitel IT Service Desk which we believe we have now resolved, please take the time to complete a short survey in relation to that job.

Sitel users please click below

Begin Survey


Genesis users please click below

<img border=“0” src=“http://10.67.1.138:8004/images/buttons/begin_survey.gif” alt="Begin Survey"width=“150” height=“53”>


If the job has not been resolved or you have any further questions or concerns, please reply to this

message or call us on extension 7804 (+64 7 838 7804)

 


Sitel NZ Information Technology

Level 3, ASB Building

500 Victoria Street

Hamilton, New Zealand

+64 7 838 7804

Then clearly adjusted the scrips to fire off the amended template. This one was for OnResolve.

Regards

AaronOn Mon, Nov 9, 2009 at 6:11 PM, Praveen Velu praveen.velu@hotmail.com wrote:

Hi,

I am using RT 3.8 installed in Debian Lenny. I changed my default templates to html. but I am getting mails in plain text. When i receive mails, header shows ‘Content-Type: text/plain; charset=“utf-8”’.After a long search I came to know that due to security RT enabled only text/plain. how can i enable html email in RT.

Thanks for any help in advance

-Praveen-

http://windows.microsoft.com/shop Find the right PC for you.

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com

Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.

Buy a copy at http://rtbook.bestpractical.com

Regards,

Aaron

New Windows 7: Find the right PC for you. Learn more.
http://windows.microsoft.com/shop

Hi RT Users,
some of my users report the error below to me in some tickets (all created yesterday 3pm german time) if they try to take the ticket. Same occurs if they try to change the owner via Basics.

We are sti´ll under RT 3.6.5 on Centos. No changes to RT during the last weeks so far i can remember :wink:

Any idea what could happen to this tickets?!

Thanks
Torsten

error: Can’t call method “Delete” on an undefined value at /opt/rt3/lib/RT/Ticket_Overlay.pm line 3068.

context: …
3064:
3065: # Delete the owner in the owner group, then add a new one
3066: # TODO: is this safe? it’s not how we really want the API to work
3067: # for most things, but it’s fast.
3068: my ( $del_id, $del_msg ) = $self->OwnerGroup->MembersObj->First->Delete();
3069: unless ($del_id) {
3070: $RT::Handle->Rollback();
3071: return ( 0, $self->loc("Could not change owner. ") . $del_msg );
3072: }

code stack: /opt/rt3/lib/RT/Ticket_Overlay.pm:3068
/opt/rt3/local/lib/RT/Interface/Web.pm:1264
/opt/rt3/share/html/Ticket/Modify.html:72
/opt/rt3/share/html/autohandler:291

raw error http://ticket.int.kn/Ticket/Modify.html#raw

Can’t call method “Delete” on an undefined value at /opt/rt3/lib/RT/Ticket_Overlay.pm line 3068.

Trace begun at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/Exceptions.pm line 129
HTML::Mason::Exceptions::rethrow_exception(‘Can’t call method “Delete” on an undefined value at /opt/rt3/lib/RT/Ticket_Overlay.pm line 3068.^J’) called at /opt/rt3/lib/RT/Ticket_Overlay.pm line 3068
RT::ticket::SetOwner(‘RT::Ticket=HASH(0x9cc95f0)’, 3372372, ‘Give’) called at /opt/rt3/local/lib/RT/Interface/Web.pm line 1264
HTML::Mason::Commands::ProcessTicketBasics(‘TicketObj’, ‘RT::Ticket=HASH(0x9cc95f0)’, ‘ARGSRef’, ‘HASH(0x5e46f30)’) called at /opt/rt3/share/html/Ticket/Modify.html line 72
HTML::Mason::Commands::ANON(‘TimeWorked’, 0, ‘TimeEstimated-TimeUnits’, ‘minutes’, ‘Owner’, 3372372, ‘Object-RT::Ticket-2640283-CustomField-1344-Values-Magic’, 1, ‘FinalPriority’, 0, ‘TimeLeft’, 0, ‘TimeWorked-TimeUnits’, ‘minutes’, ‘Status’, ‘’, ‘id’, 2640283, ‘TimeLeft-TimeUnits’, ‘minutes’, ‘TimeEstimated’, 0, ‘Subject’, ‘edi orders not received yet’, ‘Priority’, 0, ‘Queue’, 495, ‘Object-RT::Ticket-2640283-CustomField-1344-Values’, ‘’) called at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/Component.pm line 135
HTML::Mason::Component::run(‘HTML::Mason::Component::FileBased=HASH(0x471c360)’, ‘TimeWorked’, 0, ‘TimeEstimated-TimeUnits’, ‘minutes’, ‘Owner’, 3372372, ‘Object-RT::Ticket-2640283-CustomField-1344-Values-Magic’, 1, ‘FinalPriority’, 0, ‘TimeLeft’, 0, ‘TimeWorked-TimeUnits’, ‘minutes’, ‘Status’, ‘’, ‘id’, 2640283, ‘TimeLeft-TimeUnits’, ‘minutes’, ‘TimeEstimated’, 0, ‘Subject’, ‘edi orders not received yet’, ‘Priority’, 0, ‘Queue’, 495, ‘Object-RT::Ticket-2640283-CustomField-1344-Values’, ‘’) called at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/Request.pm line 1284
eval {…} at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/Request.pm line 1274
HTML::Mason::Request::comp(undef, undef, undef, ‘TimeWorked’, 0, ‘TimeEstimated-TimeUnits’, ‘minutes’, ‘Owner’, 3372372, ‘Object-RT::Ticket-2640283-CustomField-1344-Values-Magic’, 1, ‘FinalPriority’, 0, ‘TimeLeft’, 0, ‘TimeWorked-TimeUnits’, ‘minutes’, ‘Status’, ‘’, ‘id’, 2640283, ‘TimeLeft-TimeUnits’, ‘minutes’, ‘TimeEstimated’, 0, ‘Subject’, ‘edi orders not received yet’, ‘Priority’, 0, ‘Queue’, 495, ‘Object-RT::Ticket-2640283-CustomField-1344-Values’, ‘’) called at /opt/rt3/share/html/autohandler line 291
HTML::Mason::Commands::ANON(‘TimeWorked’, 0, ‘TimeEstimated-TimeUnits’, ‘minutes’, ‘Owner’, 3372372, ‘Object-RT::Ticket-2640283-CustomField-1344-Values-Magic’, 1, ‘FinalPriority’, 0, ‘TimeLeft’, 0, ‘TimeWorked-TimeUnits’, ‘minutes’, ‘Status’, ‘’, ‘id’, 2640283, ‘TimeLeft-TimeUnits’, ‘minutes’, ‘TimeEstimated’, 0, ‘Subject’, ‘edi orders not received yet’, ‘Priority’, 0, ‘Queue’, 495, ‘Object-RT::Ticket-2640283-CustomField-1344-Values’, ‘’) called at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/Component.pm line 135
HTML::Mason::Component::run(‘HTML::Mason::Component::FileBased=HASH(0x3dd2940)’, ‘TimeWorked’, 0, ‘TimeEstimated-TimeUnits’, ‘minutes’, ‘Owner’, 3372372, ‘Object-RT::Ticket-2640283-CustomField-1344-Values-Magic’, 1, ‘FinalPriority’, 0, ‘TimeLeft’, 0, ‘TimeWorked-TimeUnits’, ‘minutes’, ‘Status’, ‘’, ‘id’, 2640283, ‘TimeLeft-TimeUnits’, ‘minutes’, ‘TimeEstimated’, 0, ‘Subject’, ‘edi orders not received yet’, ‘Priority’, 0, ‘Queue’, 495, ‘Object-RT::Ticket-2640283-CustomField-1344-Values’, ‘’) called at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/Request.pm line 1279
eval {…} at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/Request.pm line 1274
HTML::Mason::Request::comp(undef, undef, undef, ‘TimeWorked’, 0, ‘TimeEstimated-TimeUnits’, ‘minutes’, ‘Owner’, 3372372, ‘Object-RT::Ticket-2640283-CustomField-1344-Values-Magic’, 1, ‘FinalPriority’, 0, ‘TimeLeft’, 0, ‘TimeWorked-TimeUnits’, ‘minutes’, ‘Status’, ‘’, ‘id’, 2640283, ‘TimeLeft-TimeUnits’, ‘minutes’, ‘TimeEstimated’, 0, ‘Subject’, ‘edi orders not received yet’, ‘Priority’, 0, ‘Queue’, 495, ‘Object-RT::Ticket-2640283-CustomField-1344-Values’, ‘’) called at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/Request.pm line 473
eval {…} at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/Request.pm line 473
eval {…} at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/Request.pm line 425
HTML::Mason::Request::exec(‘HTML::Mason::Request::CGI=HASH(0xccd5000)’) called at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/CGIHandler.pm line 190
eval {…} at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/CGIHandler.pm line 190
HTML::Mason::Request::CGI::exec(‘HTML::Mason::Request::CGI=HASH(0xccd5000)’) called at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/Interp.pm line 342
HTML::Mason::Interp::exec(undef, undef, ‘TimeWorked’, 0, ‘TimeEstimated-TimeUnits’, ‘minutes’, ‘Owner’, 3372372, ‘Object-RT::Ticket-2640283-CustomField-1344-Values-Magic’, 1, ‘FinalPriority’, 0, ‘TimeLeft’, 0, ‘TimeWorked-TimeUnits’, ‘minutes’, ‘Status’, ‘’, ‘id’, 2640283, ‘TimeLeft-TimeUnits’, ‘minutes’, ‘TimeEstimated’, 0, ‘Subject’, ‘edi orders not received yet’, ‘Priority’, 0, ‘Queue’, 495, ‘Object-RT::Ticket-2640283-CustomField-1344-Values’, ‘’) called at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/CGIHandler.pm line 121
eval {…} at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/CGIHandler.pm line 121
HTML::Mason::CGIHandler::_handler(‘HTML::Mason::CGIHandler=HASH(0x380d2b0)’, ‘HASH(0xbac7070)’) called at /usr/lib/perl5/site_perl/5.8.8/HTML/Mason/CGIHandler.pm line 73
HTML::Mason::CGIHandler::handle_cgi_object(‘HTML::Mason::CGIHandler=HASH(0x380d2b0)’, ‘CGI::Fast=HASH(0x6cb07a0)’) called at /opt/rt3/bin/mason_handler.fcgi line 78
eval {…} at /opt/rt3/bin/mason_handler.fcgi line 78

Kuehne + Nagel (AG & Co.) KG, Geschaeftsleitung: Hans-Georg Brinkmann (Vors.), Dirk Blesius (Stellv.), Reiner Heiken (Stellv.), Bruno Mang, Alfred Manke, Christian Marnetté (Stellv.), Mark Reinhardt (Stellv.), Jens Wollesen, Rainer Wunn, Sitz: Bremen, Registergericht: Bremen, HRA 21928, USt-IdNr.: DE 812773878, Persoenlich haftende Gesellschaft: Kuehne & Nagel A.G., Sitz: Contern/Luxemburg Geschaeftsfuehrender Verwaltungsrat: Klaus-Michael Kuehne

Any idea what could happen to this tickets?!
Something in this chain is returning undef;

$self->OwnerGroup->MembersObj

Presumably there are no owners to begin with.
Cambridge Energy Alliance: Save money. Save the planet.

Hi Jerrad,

thanks for the hint, i look into all the tickets with this error (i’m happy, only 6 Tickets) and none of them have a owner, also not owned by NOBODY. After searching my log, i found someone from our operating has restartet one of our webservers at the time this tickets where created.

OK, i cloned them to a new, now all is fine.

Thanks

Torsten

Kuehne + Nagel (AG & Co.) KG, Geschaeftsleitung: Hans-Georg Brinkmann (Vors.), Dirk Blesius (Stellv.), Reiner Heiken (Stellv.), Bruno Mang, Alfred Manke, Christian Marnetté (Stellv.), Mark Reinhardt (Stellv.), Jens Wollesen, Rainer Wunn, Sitz: Bremen, Registergericht: Bremen, HRA 21928, USt-IdNr.: DE 812773878, Persoenlich haftende Gesellschaft: Kuehne & Nagel A.G., Sitz: Contern/Luxemburg Geschaeftsfuehrender Verwaltungsrat: Klaus-Michael Kuehne

-----Urspruengliche Nachricht-----Von: Jerrad Pierce [mailto:jpierce@cambridgeenergyalliance.org]
Gesendet: Dienstag, 10. November 2009 16:54
An: Brumm, Torsten / Kuehne + Nagel / Ham MI-ID
Cc: rt-users@lists.bestpractical.com
Betreff: Re: [rt-users] Strange Error in RT on Ownerchange

Any idea what could happen to this tickets?!
Something in this chain is returning undef;

$self->OwnerGroup->MembersObj

Presumably there are no owners to begin with.
Cambridge Energy Alliance: Save money. Save the planet.

This may have some bearing on things, unsure but worth a try.

In RT_SiteConfig.pm make sure to have, if you don’t then add these in.

Set($TrustHTMLAttachments, 1);
Set($PreferRichText, 1);

Another thing, not the empty line under Content: If you don’t have this
blank line the template will not work as HTML.

Regards

AaronOn Tue, Nov 10, 2009 at 6:45 PM, Praveen Velu praveen.velu@hotmail.comwrote:

Dear Aaron,

Thanks for your quick help. I added same template for testing. Still I am
getting mails in text/plain format. Is there any settings I have to do for
enable html in request tracker 3.8.

If I reply to a mail from rt web interface by adding any hyper-links to
body. I am not getting any hyper-links at receiving end.

-Praveen-

**All I did was setup the templates as shown in the example below;

Subject: Resolved: {$Ticket->Subject}
Content-Type: text/html
Content:



Note: Any replies to this email will reopen the job

You logged a job (SR#) with the Sitel IT Service Desk which we believe we have now resolved, please take the time to complete a short survey in relation to that job.

Sitel users please click below Begin Survey
Genesis users please click below
Begin
Survey
If the job has not been resolved or you have any further questions or concerns, please reply to this message or call us on extension 7804 (+64 7 838 7804)
 


Sitel NZ Information Technology

Level 3, ASB Building
500 Victoria Street
Hamilton, New Zealand
+64 7 838 7804

Then clearly adjusted the scrips to fire off the amended template. This
one was for OnResolve.


Regards

Aaron

On Mon, Nov 9, 2009 at 6:11 PM, Praveen Velu praveen.velu@hotmail.comwrote:

Hi,

I am using RT 3.8 installed in Debian Lenny. I changed my default templates
to html. but I am getting mails in plain text. When i receive mails, header
shows 'Content-Type: text/plain; charset=“utf-8”’.After a long search I
came to know that due to security RT enabled only text/plain. how can i
enable html email in RT.
Thanks for any help in advance

-Praveen-


http://windows.microsoft.com/shop Find the right PC for you.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Regards,

Aaron


New Windows 7: Find the right PC for you. Learn more.http://windows.microsoft.com/shop

Regards,

Aaron

Hi,

I have added these settings in RT_SiteConfig.pm. Still I am getting mails in plain/text format. I have installed Request tracker 3.8 in Debian Lenny

-Praveen-

This may have some bearing on things, unsure but worth a try.

In RT_SiteConfig.pm make sure to have, if you don’t then add these in.

Set($TrustHTMLAttachments, 1);
Set($PreferRichText, 1);

Another thing, not the empty line under Content: If you don’t have this blank line the template will not work as HTML.

Regards

AaronOn Tue, Nov 10, 2009 at 6:45 PM, Praveen Velu praveen.velu@hotmail.com wrote:

Dear Aaron,

Thanks for your quick help. I added same template for testing. Still I am getting mails in text/plain format. Is there any settings I have to do for enable html in request tracker 3.8.

If I reply to a mail from rt web interface by adding any hyper-links to body. I am not getting any hyper-links at receiving end.

-Praveen-

All I did was setup the templates as shown in the example below;

Subject: Resolved: {$Ticket->Subject}
Content-Type: text/html
Content:



Note: Any replies to this email will reopen the job


You logged a job (SR#) with the Sitel IT Service Desk which we believe we have now resolved, please take the time to complete a short survey in relation to that job.

Sitel users please click below

Begin Survey


Genesis users please click below

<img border=“0” src=“http://10.67.1.138:8004/images/buttons/begin_survey.gif” alt="Begin Survey"width=“150” height=“53”>


If the job has not been resolved or you have any further questions or concerns, please reply to this

message or call us on extension 7804 (+64 7 838 7804)

 


Sitel NZ Information Technology

Level 3, ASB Building

500 Victoria Street

Hamilton, New Zealand

+64 7 838 7804

Then clearly adjusted the scrips to fire off the amended template. This one was for OnResolve.

Regards

Aaron

On Mon, Nov 9, 2009 at 6:11 PM, Praveen Velu praveen.velu@hotmail.com wrote:

Hi,

I am using RT 3.8 installed in Debian Lenny. I changed my default templates to html. but I am getting mails in plain text. When i receive mails, header shows ‘Content-Type: text/plain; charset=“utf-8”’.After a long search I came to know that due to security RT enabled only text/plain. how can i enable html email in RT.

Thanks for any help in advance

-Praveen-

http://windows.microsoft.com/shop Find the right PC for you.

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com

Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.

Buy a copy at http://rtbook.bestpractical.com

Regards,

Aaron

New Windows 7: Find the right PC for you. Learn more.

Regards,

Aaron

Windows 7: Find the right PC for you. Learn more.
http://windows.microsoft.com/shop