Help with open ticket with email

Hello.

My system, 4.0.10 with postgreSQL on Centos 6.4

Works for all exitents users, not for new ones.

Im trying to open a new ticket on RT, with a new user. The user is created
and his email adress is fine. The user is a privileged users, with rights
to create new tickets.
The tiket is not created, and the admin of rt get and email, but doesn´t
show the email from was sended the email, only it email.

Log on messages.

Jul 22 16:29:14 rt RT: RT could not load a valid user, and RT’s
configuration does not allow#012for the creation of a new user for this
email (rtadmin@mydomain.com).#012#012You might need to grant ‘Everyone’ the
right ‘CreateTicket’ for the#012queue generalqueue.
(/opt/rt4/sbin/…/lib/RT/Interface/Email.pm:248)
Jul 22 16:29:14 rt RT: Could not record email: Could not load a valid user
(/opt/rt4/share/html/REST/1.0/NoAuth/mail-gateway:75)

Log on maillog.

Jul 22 16:29:13 rt sendmail[5987]: r6METDct005987: from=<
newuser@domain.com>, size=910, class=0, nrcpts=1, msgid=<
201307221429.r6METDct005987@rt.mydomain.com>, proto=ESMTP, daemon=MTA,
relay=vil-esxi01-ilo.itin.local [172.16.4.110]
Jul 22 16:29:14 rt sendmail[5990]: r6METEmO005990: Authentication-Warning:
rt.mydomain.com: apache set sender to <> using -f
Jul 22 16:29:14 rt sendmail[5990]: r6METEmO005990: from=<>, size=2300,
class=-60, nrcpts=1, msgid=201307221429.r6METEmO005990@rt.mydomain.com,
relay=apache@localhost
Jul 22 16:29:14 rt sendmail[5991]: r6METEvW005991: from=<>, size=2525,
class=-60, nrcpts=1, msgid=201307221429.r6METEmO005990@rt.mydomain.com,
proto=ESMTP, daemon=MTA, relay=rt [127.0.0.1]
Jul 22 16:29:14 rt sendmail[5990]: r6METEmO005990: to=rtadmin@mydomain.com,
delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=140300,
relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (r6METEvW005991 Message
accepted for delivery)
Jul 22 16:29:14 rt sendmail[5988]: r6METDct005987:
to="|/etc/smrsh/rt-mailgate --queue generalqueue --action correspond --url
http://rt.mydomain.com", ctladdr=generalqueue@support.mydomain.com (8/0),
delay=00:00:01, xdelay=00:00:01, mailer=prog, pri=31226, dsn=2.0.0,
stat=Sent
Jul 22 16:29:14 rt sendmail[5993]: r6METEvW005991: to=rtadmin@mydomain.com,
delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=230525, relay=
exchange.mydomain.com. [172.78.4.141], dsn=2.0.0, stat=Sent (<
201307221429.r6METEmO005990@rt.mydomain.com> Queued mail for delivery)

Any help?
Thanks in advance.

Kindest Regards.

Un saludo.
Juanjo

Un saludo.
Juanjo Corral

Im trying to open a new ticket on RT, with a new user. The user is
created and his email adress is fine.

The logs say otherwise; RT is not finding this user’s email in the database.

Try enabling debug logging. See if you can tell why the email isn’t
matching. Perhaps you have some address re-writing going on at some
stage in your system?

Craig Ringer http://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Training & Services