Help with Fetchmail

Hi Folks!

Need some help on the final step of an RT 3.6.7 installation on a
CentOS box and fetchmail.

Here’s what we did:

  1. Created a file called .fetchmailrc on /root/ with:
    #!/bin/sh
    set logfile /opt/rt3/fetchmail.log

30 sec:

set daemon 30
poll 192.168.100.1 proto pop3:
username peter there with password peter1 mda
"/opt/rt3/bin/rt-mailgate – url http://rt.domain.com/ --queue
’Peter’ --action correspond"

  1. On rc.local added:
    usr/bin/fetchmail
    su -c “fetchmail -d 60” root

Looking throw the fetchmail.log i get this:

No url provided to mail gateway!
fetchmail: reading message peter@192.168.100.1:3 of 3 (2399 octets)
(log message incomplete)fetchmail: MDA returned nonzero status 255
fetchmail: not flushed
fetchmail: 1 message for implementaciones at 192.168.100.1 (1460 octets).
/opt/rt3/bin/rt-mailgate invoked improperly

Any Clue?
I know i missed or mess something!

You have a space between the double dashes and url.

Joe Hartley | Sr. Linux SysAdmin
Retail Solutions, Inc. (formerly VeriSign RDS)
joe.hartley@retailsolutions.com-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of
sebsua@gmail.com
Sent: Friday, December 05, 2008 12:26 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Help with Fetchmail

Hi Folks!

Need some help on the final step of an RT 3.6.7 installation on a
CentOS box and fetchmail.

Here’s what we did:

  1. Created a file called .fetchmailrc on /root/ with:
    #!/bin/sh
    set logfile /opt/rt3/fetchmail.log

30 sec:

set daemon 30
poll 192.168.100.1 proto pop3:
username peter there with password peter1 mda
"/opt/rt3/bin/rt-mailgate – url http://rt.domain.com/ --queue
’Peter’ --action correspond"

  1. On rc.local added:
    usr/bin/fetchmail
    su -c “fetchmail -d 60” root

Looking throw the fetchmail.log i get this:

No url provided to mail gateway!
fetchmail: reading message peter@192.168.100.1:3 of 3 (2399 octets)
(log message incomplete)fetchmail: MDA returned nonzero status 255
fetchmail: not flushed
fetchmail: 1 message for implementaciones at 192.168.100.1 (1460
octets).
/opt/rt3/bin/rt-mailgate invoked improperly

Any Clue?
I know i missed or mess something!
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com