Help w/ WebExternalAuto: all users are created in the Privileged group

Hi,

I'm trying to authenticate users through Apache's

libapache-mod-auth-pam and I also set WebExternalAuto for autocreation
of missing accounts.
This works fine, except that all new users are created under the
privileged group instead of the unprivileged group.
I looked for any configuration option, try to Overload
User_Overload.pm, but it seems that code didn’t execute… Nothing
worked, or I don’t know what to change. Google web & groups didn’t help.

Is there any way of setting the default group for new auto-created

webusers to Unprivileged or another one?

MySetup:
Debian 3.0 woody (stable)
apache-1.3.26
libapache-mod-auth-pam 1.0a7

perl 5.8.4 compiled locally,  prefix=~user/local/
rt-3.0.11 compiled locally, prefix=~user/local/

VirtualHost using fastcgi:
ScriptAlias     /foo/ ~user/local/bin/mason_handler.fcgi/

<Location /foo/>
            AuthType Basic
            AuthName "Log on"
            require valid-user
            AuthPAM_Enabled on
    </Location>

Options from RT_SiteConfig.pm:

Set($rtname , “foo”);
Set($Organization , “foo”);
Set($MinimumPasswordLength , “0”);
Set($Timezone , ‘CL/Continental’);
Set($OwnerEmail , ‘foo@foo’);
Set($StoreLoops, 1);
Set($RTAddressRegexp, ‘^foo@.*foo$’);
Set($CorrespondAddress , ‘foo@foo’);
Set($CommentAddress , ‘foo@foo’);
Set($LogToFile, ‘debug’);
Set($WebPath , “/foo”);
Set($WebBaseURL , “http://foo”);
Set($WebImagesURL , $WebURL . “/foo”);
Set($WebExternalAuth , 1);
Set($WebFallbackToInternalAuth, 1);
Set($WebExternalGecos , 1);
Set($WebExternalAuto , 1);
@LexiconLanguages = qw(en fr es);
1;

Thanks,
Aldrin

I’m trying to authenticate users through Apache’s
libapache-mod-auth-pam and I also set WebExternalAuto for autocreation
of missing accounts.
This works fine, except that all new users are created under the
privileged group instead of the unprivileged group.
I looked for any configuration option, try to Overload
User_Overload.pm, but it seems that code didn’t execute… Nothing
worked, or I don’t know what to change.

Override WebExternalAutoInfo as defined by Interface/Web.pm.

seph

I'm trying to authenticate users through Apache's

libapache-mod-auth-pam and I also set WebExternalAuto for autocreation
of missing accounts.
This works fine, except that all new users are created under the
privileged group instead of the unprivileged group.
I looked for any configuration option, try to Overload
User_Overload.pm, but it seems that code didn’t execute… Nothing
worked, or I don’t know what to change.
Override WebExternalAutoInfo as defined by Interface/Web.pm.

Thanks to both, it worked great. I searched again and find that info in
the wiki.

Aldrin.