Help httpd.conf

Hi, Installed RT3.4.4 on RHEL3, modified httpd.conf:

ServerAdmin root
ServerName localhost
DocumentRoot /opt/rt3/share/html/
AddDefaultCharset UTF-8
# Adding the following for RT (the ticket tracker)
AddHandler fastcgi-script fcgi
<Directory “/opt/rt3/share/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

# Pass through requests to for noauth
Alias /NoAuth/images
/opt/rt3/share/html/NoAuth/images
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

FastCgiIpcDir /tmp
FastCgiServer /opt/rt3/bin/mason_handler.fcgi
-idle-timeout 120 -processes 4

Tried http://localhost, RT doesn’t work. Thanks for
help, Zhiming.

Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

This works for me.

<VirtualHost *:80>
ServerName tickets.localhost.com
DocumentRoot /www/apps/rt-3.4.5/share/html
AddDefaultCharset UTF-8

these four lines apply to Apache2+mod_perl2 only: {{{

RewriteEngine On
RewriteRule ^(.*)/$ $1/index.html

}}}

PerlModule Apache::DBI
PerlRequire /www/apps/rt-3.4.5/bin/webmux.pl

SetHandler perl-script PerlHandler RT::Mason

Thanks
Nazar

Zhiming Liu wrote:

This works for me:

NameVirtualHost *:80

<VirtualHost *:80>

ServerAdmin root

ServerName rt.example.com

ServerName localhost

ServerAlias localhost

DocumentRoot /var/www/html/

DocumentRoot /opt/rt3/share/html

AddDefaultCharset UTF-8

Adding the following for RT (the ticket tracker)

AddHandler fastcgi-script fcgi

<Directory “/opt/rt3/share/html”>

Options FollowSymLinks ExecCGI

AllowOverride None

Pass through requests to for noauth

Alias /NoAuth/ /opt/rt3/share/html/NoAuth/

FastCgiIpcDir /tmp

FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120 -processes 4

ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi

ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/----- Original Message -----
From: “Zhiming Liu” liuzmus@yahoo.com
To: rt-users@lists.bestpractical.com
Sent: Monday, June 19, 2006 8:01 AM
Subject: [rt-users] Help httpd.conf

Hi, Installed RT3.4.4 on RHEL3, modified httpd.conf:

ServerAdmin root
ServerName localhost
DocumentRoot /opt/rt3/share/html/
AddDefaultCharset UTF-8
# Adding the following for RT (the ticket tracker)
AddHandler fastcgi-script fcgi
<Directory “/opt/rt3/share/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

# Pass through requests to for noauth
Alias /NoAuth/images
/opt/rt3/share/html/NoAuth/images
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

FastCgiIpcDir /tmp
FastCgiServer /opt/rt3/bin/mason_handler.fcgi
-idle-timeout 120 -processes 4

Tried http://localhost, RT doesn’t work. Thanks for
help, Zhiming.

Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: http://bestpractical.com/about/jobs.html

Hi, Installed RT3.4.4 on RHEL3, modified httpd.conf:

ServerAdmin root
ServerName localhost
DocumentRoot /opt/rt3/share/html/
AddDefaultCharset UTF-8
# Adding the following for RT (the ticket tracker)
AddHandler fastcgi-script fcgi
<Directory “/opt/rt3/share/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

# Pass through requests to for noauth
Alias /NoAuth/images
/opt/rt3/share/html/NoAuth/images
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

FastCgiIpcDir /tmp
FastCgiServer /opt/rt3/bin/mason_handler.fcgi
-idle-timeout 120 -processes 4

Tried http://localhost, RT doesn’t work. Thanks for
help, Zhiming.

Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

Thanks for your email. I don’t install Apache2. I use
FastCGI. Zhiming.

This works for me.

<VirtualHost *:80>
ServerName tickets.localhost.com
DocumentRoot /www/apps/rt-3.4.5/share/html
AddDefaultCharset UTF-8

these four lines apply to Apache2+mod_perl2

only: {{{
RewriteEngine On
RewriteRule ^(.*)/$ $1/index.html

}}}

PerlModule Apache::DBI
PerlRequire /www/apps/rt-3.4.5/bin/webmux.pl

SetHandler perl-script PerlHandler RT::Mason

Thanks
Nazar

Zhiming Liu wrote:

Hi, Installed RT3.4.4 on RHEL3, modified
httpd.conf:

ServerAdmin root
ServerName localhost
DocumentRoot /opt/rt3/share/html/
AddDefaultCharset UTF-8
# Adding the following for RT (the ticket
tracker)
AddHandler fastcgi-script fcgi
<Directory “/opt/rt3/share/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

# Pass through requests to for noauth
Alias /NoAuth/images
/opt/rt3/share/html/NoAuth/images
ScriptAlias /
/opt/rt3/bin/mason_handler.fcgi/

FastCgiIpcDir /tmp
FastCgiServer /opt/rt3/bin/mason_handler.fcgi
-idle-timeout 120 -processes 4

Tried http://localhost, RT doesn’t work. Thanks
for
help, Zhiming.


Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam
protection around
http://mail.yahoo.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials
from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical:
http://bestpractical.com/about/jobs.html

Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

Got your email, thanks. I tried yours, it still
doesn’t work. Should I configure other files or
firewall? When I tried IP address instead of
http://localhost, I got connection refused alert.
Zhiming.

This works for me:

NameVirtualHost *:80

<VirtualHost *:80>

ServerAdmin root

ServerName rt.example.com

ServerName localhost

ServerAlias localhost

DocumentRoot /var/www/html/

DocumentRoot /opt/rt3/share/html

AddDefaultCharset UTF-8

Adding the following for RT (the ticket tracker)

AddHandler fastcgi-script fcgi

<Directory “/opt/rt3/share/html”>

Options FollowSymLinks ExecCGI

AllowOverride None

Pass through requests to for noauth

Alias /NoAuth/ /opt/rt3/share/html/NoAuth/

FastCgiIpcDir /tmp

FastCgiServer /opt/rt3/bin/mason_handler.fcgi
-idle-timeout 120 -processes 4

ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi

ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

----- Original Message -----
From: “Zhiming Liu” liuzmus@yahoo.com
To: rt-users@lists.bestpractical.com
Sent: Monday, June 19, 2006 8:01 AM
Subject: [rt-users] Help httpd.conf

Hi, Installed RT3.4.4 on RHEL3, modified httpd.conf:

ServerAdmin root
ServerName localhost
DocumentRoot /opt/rt3/share/html/
AddDefaultCharset UTF-8
# Adding the following for RT (the ticket
tracker)
AddHandler fastcgi-script fcgi
<Directory “/opt/rt3/share/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

# Pass through requests to for noauth
Alias /NoAuth/images
/opt/rt3/share/html/NoAuth/images
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

FastCgiIpcDir /tmp
FastCgiServer /opt/rt3/bin/mason_handler.fcgi
-idle-timeout 120 -processes 4

Tried http://localhost, RT doesn’t work. Thanks for
help, Zhiming.


Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam
protection around
http://mail.yahoo.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from
O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical:
http://bestpractical.com/about/jobs.html

Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

Hi, After rebooting my machine, your codes work. Thank
you very much, Zhiming.

This works for me:

NameVirtualHost *:80

<VirtualHost *:80>

ServerAdmin root

ServerName rt.example.com

ServerName localhost

ServerAlias localhost

DocumentRoot /var/www/html/

DocumentRoot /opt/rt3/share/html

AddDefaultCharset UTF-8

Adding the following for RT (the ticket tracker)

AddHandler fastcgi-script fcgi

<Directory “/opt/rt3/share/html”>

Options FollowSymLinks ExecCGI

AllowOverride None

Pass through requests to for noauth

Alias /NoAuth/ /opt/rt3/share/html/NoAuth/

FastCgiIpcDir /tmp

FastCgiServer /opt/rt3/bin/mason_handler.fcgi
-idle-timeout 120 -processes 4

ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi

ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

----- Original Message -----
From: “Zhiming Liu” liuzmus@yahoo.com
To: rt-users@lists.bestpractical.com
Sent: Monday, June 19, 2006 8:01 AM
Subject: [rt-users] Help httpd.conf

Hi, Installed RT3.4.4 on RHEL3, modified httpd.conf:

ServerAdmin root
ServerName localhost
DocumentRoot /opt/rt3/share/html/
AddDefaultCharset UTF-8
# Adding the following for RT (the ticket
tracker)
AddHandler fastcgi-script fcgi
<Directory “/opt/rt3/share/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

# Pass through requests to for noauth
Alias /NoAuth/images
/opt/rt3/share/html/NoAuth/images
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

FastCgiIpcDir /tmp
FastCgiServer /opt/rt3/bin/mason_handler.fcgi
-idle-timeout 120 -processes 4

Tried http://localhost, RT doesn’t work. Thanks for
help, Zhiming.


Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam
protection around
http://mail.yahoo.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from
O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical:
http://bestpractical.com/about/jobs.html

Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com