Having trouble installing 3.7.85 on fc8

I’ve been able to get as far as the page that says:

You’re almost there!

You haven’t yet configured your webserver to run RT

You appear to have installed RT’s web interface correctly, but haven’t yet
configured your web server to “run” the RT server which powers the web
interface.

The next step is to edit your webserver’s configuration file to instruct it
to use RT’s mod_perl, fastcgi or speedycgi handler.

I’m trying to configure it to use mod_perl but having no luck so far.

Here’s my /etc/httpd/conf.d/rt3.conf. As far as I can tell, I’m referring to
mod_perl, and when I restart the httpd daemon, it tells me that mod_perl is
already loaded.

I’d appreciate any insight.

Thanks,

Alias /rt3 “//opt/rt3/share/html”

LoadModule perl_module mod_perl.so

PerlModule Apache::DBI

PerlRequire /usr/sbin/webmux.pl

<Directory /opt/rt3/share/html>

AllowOverride All

Options ExecCGI FollowSymLinks

Order allow,deny

Allow from all

<Location /rt>

RewriteEngine On

RedirectMatch permanent (.*)/$ $1/index.html

AddDefaultCharset UTF-8

SetHandler perl-script

PerlHandler RT::Mason

ServerName localhost

DocumentRoot /opt/rt3/share/html

AddDefaultCharset UTF-8

PerlModule Apache2 Apache2::compat

PerlModule Apache::DBI

PerlRequire /usr/sbin/webmux.pl

  SetHandler perl-script

  PerlHandler RT::Mason

Elbert Lai

Network Operations Manager

Itiva Networks

530 Lytton Ave

2nd Floor

Palo Alto, CA 94301

650-521-3403 (cell)

650-560-6125 (fax)

elbertlai@itiva.com

Are there any errors in the RT log? I found it useful to enable debug in a similar situation like you have:

Try adding the following lines in your RT_SiteConfig.pm if you don’t have them yet:

Set($LogToFile , ‘debug’);
Set($LogDir, ‘/opt/rt3/var/log’);
Set($LogToFileNamed , “rt.log”);

File “rt.log” must be writable by your http daemon.

Thanks,

AlanFrom: rt-users-bounces@lists.bestpractical.com on behalf of Elbert Lai
Sent: Thu 5/8/2008 10:18 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Having trouble installing 3.7.85 on fc8

I’ve been able to get as far as the page that says:

You’re almost there!

You haven’t yet configured your webserver to run RT

You appear to have installed RT’s web interface correctly, but haven’t yet
configured your web server to “run” the RT server which powers the web
interface.

The next step is to edit your webserver’s configuration file to instruct it
to use RT’s mod_perl, fastcgi or speedycgi handler.

I’m trying to configure it to use mod_perl but having no luck so far.

Here’s my /etc/httpd/conf.d/rt3.conf. As far as I can tell, I’m referring to
mod_perl, and when I restart the httpd daemon, it tells me that mod_perl is
already loaded.

I’d appreciate any insight.

Thanks,

Alias /rt3 “//opt/rt3/share/html”

LoadModule perl_module mod_perl.so

PerlModule Apache::DBI

PerlRequire /usr/sbin/webmux.pl

<Directory /opt/rt3/share/html>

AllowOverride All

Options ExecCGI FollowSymLinks

Order allow,deny

Allow from all

<Location /rt>

RewriteEngine On

RedirectMatch permanent (.*)/$ $1/index.html

AddDefaultCharset UTF-8

SetHandler perl-script

PerlHandler RT::Mason

ServerName localhost

DocumentRoot /opt/rt3/share/html

AddDefaultCharset UTF-8

PerlModule Apache2 Apache2::compat

PerlModule Apache::DBI

PerlRequire /usr/sbin/webmux.pl

  SetHandler perl-script

  PerlHandler RT::Mason

Elbert Lai

Network Operations Manager

Itiva Networks

530 Lytton Ave

2nd Floor

Palo Alto, CA 94301

650-521-3403 (cell)

650-560-6125 (fax)

elbertlai@itiva.com

Is anyone having an issue where linked tickets default to the incorrect
server? When I mouseover the links, instead of defaulting to
http://myserver/Ticket/Display.html?id=xxxx", they default to
http://localhost/Ticket/Display.html?id=xxxx". This only happens with linked
tickets. I can still go to the ticket by clicking on it in the queue, or in
any other Tickets pane. Clicking on them in the links pane, however, ends up
with an error because there is no web server on localhost. This issue can be
repeated from multiple clients, multiple OS’.

Any thoughts on why the server is being translated incorrectly?

Thanks,

Elbert Lai

Network Operations Manager

Itiva Networks

530 Lytton Ave

2nd Floor

Palo Alto, CA 94301

650-521-3403 (cell)

650-560-6125 (fax)

elbertlai@itiva.comFrom: Alan Cheng [mailto:chenga@ias.edu]
Sent: Thursday, May 08, 2008 8:21 PM
To: Elbert Lai; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Having trouble installing 3.7.85 on fc8

Are there any errors in the RT log? I found it useful to enable debug in a
similar situation like you have:

Try adding the following lines in your RT_SiteConfig.pm if you don’t have
them yet:

Set($LogToFile , ‘debug’);
Set($LogDir, ‘/opt/rt3/var/log’);
Set($LogToFileNamed , “rt.log”);

File “rt.log” must be writable by your http daemon.

Thanks,

Alan

From: rt-users-bounces@lists.bestpractical.com on behalf of Elbert Lai
Sent: Thu 5/8/2008 10:18 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Having trouble installing 3.7.85 on fc8

I’ve been able to get as far as the page that says:

You’re almost there!

You haven’t yet configured your webserver to run RT

You appear to have installed RT’s web interface correctly, but haven’t yet
configured your web server to “run” the RT server which powers the web
interface.

The next step is to edit your webserver’s configuration file to instruct it
to use RT’s mod_perl, fastcgi or speedycgi handler.

I’m trying to configure it to use mod_perl but having no luck so far.

Here’s my /etc/httpd/conf.d/rt3.conf. As far as I can tell, I’m referring to
mod_perl, and when I restart the httpd daemon, it tells me that mod_perl is
already loaded.

I’d appreciate any insight.

Thanks,

Alias /rt3 “//opt/rt3/share/html”

LoadModule perl_module mod_perl.so

PerlModule Apache::DBI

PerlRequire /usr/sbin/webmux.pl

<Directory /opt/rt3/share/html>

AllowOverride All

Options ExecCGI FollowSymLinks

Order allow,deny

Allow from all

<Location /rt>

RewriteEngine On

RedirectMatch permanent (.*)/$ $1/index.html

AddDefaultCharset UTF-8

SetHandler perl-script

PerlHandler RT::Mason

ServerName localhost

DocumentRoot /opt/rt3/share/html

AddDefaultCharset UTF-8

PerlModule Apache2 Apache2::compat

PerlModule Apache::DBI

PerlRequire /usr/sbin/webmux.pl

  SetHandler perl-script

  PerlHandler RT::Mason

Elbert Lai

Network Operations Manager

Itiva Networks

530 Lytton Ave

2nd Floor

Palo Alto, CA 94301

650-521-3403 (cell)

650-560-6125 (fax)

elbertlai@itiva.com

Is this a typo?

Alias /rt3 “//opt/rt3/share/html”

Shouldn’t that read

Alias /rt3 “/opt/rt3/share/html”

John J. Boris, Sr.
JEN-A-SyS Administrator
Archdiocese of Philadelphia
222 North 17th Street
Philadelphia, Pa. 19103
Tel: 215-965-1714
Fax: 215-587-3525
"Remember! That light at the end of the tunnel
Just might be the headlight of an oncoming train!"

“Alan Cheng” chenga@ias.edu 05/08/08 11:21 PM >>>
Are there any errors in the RT log? I found it useful to enable debug
in a similar situation like you have:

Try adding the following lines in your RT_SiteConfig.pm if you don’t
have them yet:

Set($LogToFile , ‘debug’);
Set($LogDir, ‘/opt/rt3/var/log’);
Set($LogToFileNamed , “rt.log”);

File “rt.log” must be writable by your http daemon.

Thanks,

AlanFrom: rt-users-bounces@lists.bestpractical.com on behalf of Elbert Lai
Sent: Thu 5/8/2008 10:18 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Having trouble installing 3.7.85 on fc8

I’ve been able to get as far as the page that says:

You’re almost there!

You haven’t yet configured your webserver to run RT

You appear to have installed RT’s web interface correctly, but haven’t
yet
configured your web server to “run” the RT server which powers the web
interface.

The next step is to edit your webserver’s configuration file to instruct
it
to use RT’s mod_perl, fastcgi or speedycgi handler.

I’m trying to configure it to use mod_perl but having no luck so far.

Here’s my /etc/httpd/conf.d/rt3.conf. As far as I can tell, I’m
referring to
mod_perl, and when I restart the httpd daemon, it tells me that mod_perl
is
already loaded.

I’d appreciate any insight.

Thanks,

Alias /rt3 “//opt/rt3/share/html”

LoadModule perl_module mod_perl.so

PerlModule Apache::DBI

PerlRequire /usr/sbin/webmux.pl

<Directory /opt/rt3/share/html>

AllowOverride All

Options ExecCGI FollowSymLinks

Order allow,deny

Allow from all

<Location /rt>

RewriteEngine On

RedirectMatch permanent (.*)/$ $1/index.html

AddDefaultCharset UTF-8

SetHandler perl-script

PerlHandler RT::Mason

ServerName localhost

DocumentRoot /opt/rt3/share/html

AddDefaultCharset UTF-8

PerlModule Apache2 Apache2::compat

PerlModule Apache::DBI

PerlRequire /usr/sbin/webmux.pl

  SetHandler perl-script

  PerlHandler RT::Mason

Elbert Lai

Network Operations Manager

Itiva Networks

530 Lytton Ave

2nd Floor

Palo Alto, CA 94301

650-521-3403 (cell)

650-560-6125 (fax)

elbertlai@itiva.com

If you go to “Configuration” -> “Tools” -> “System Configuration”, you
should be able to see all the loaded perl modules and RT variables.

RT::WebBaseURL
RT::WebURL

Does either one say “localhost”?

I can’t remember which one does what, but I put the following two in my
RT_SiteConfig.pm:

Set($WebURL, ‘http://myserver.fqdn/’);
Set($WebBaseURL, ‘http://myserver.fqdn/’);

Thanks,

Alan

Elbert Lai wrote:

Thanks Alan. That was exactly it. I needed to populate RT::WebBaseURL in
RT_SiteConfig.pm. I was a bit surprised because it only affected a small (to
me) section of the tickets, just parents/children under the Links pane, and
now it’s resolved.

Thanks again!

Elbert Lai
Network Operations Manager
Itiva Networks
530 Lytton Ave
2nd Floor
Palo Alto, CA 94301
650-521-3403 (cell)
650-560-6125 (fax)
elbertlai@itiva.comFrom: Alan Cheng [mailto:chenga@ias.edu]
Sent: Friday, May 09, 2008 8:02 AM
To: Elbert Lai
Cc: rt-users@lists.bestpractical.com
Subject: Re: Links issue on 3.7.85 / 3.8 beta2

If you go to “Configuration” -> “Tools” -> “System Configuration”, you
should be able to see all the loaded perl modules and RT variables.

RT::WebBaseURL
RT::WebURL

Does either one say “localhost”?

I can’t remember which one does what, but I put the following two in my
RT_SiteConfig.pm:

Set($WebURL, ‘http://myserver.fqdn/’);
Set($WebBaseURL, ‘http://myserver.fqdn/’);

Thanks,

Alan

Elbert Lai wrote:

Is anyone having an issue where linked tickets default to the
incorrect server? When I mouseover the links, instead of defaulting to
http://myserver/Ticket/Display.html?id=xxxx", they default to
http://localhost/Ticket/Display.html?id=xxxx". This only happens with
linked tickets. I can still go to the ticket by clicking on it in the
queue, or in any other Tickets pane. Clicking on them in the links
pane, however, ends up with an error because there is no web server on
localhost. This issue can be repeated from multiple clients, multiple OS’.

Any thoughts on why the server is being translated incorrectly?

Thanks,

/Elbert Lai/

//Network Operations Manager//

//Itiva Networks//

//530 Lytton Ave//

//2nd Floor//

//Palo Alto////, CA 94301//

650-521-3403 (cell)

650-560-6125 (fax)

elbertlai@itiva.com


From: Alan Cheng [mailto:chenga@ias.edu]
Sent: Thursday, May 08, 2008 8:21 PM
To: Elbert Lai; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Having trouble installing 3.7.85 on fc8

Are there any errors in the RT log? I found it useful to enable debug
in a similar situation like you have:

Try adding the following lines in your RT_SiteConfig.pm if you don’t
have them yet:

Set($LogToFile , ‘debug’);
Set($LogDir, ‘/opt/rt3/var/log’);
Set($LogToFileNamed , “rt.log”);

File “rt.log” must be writable by your http daemon.

Thanks,

Alan

-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com on behalf of Elbert Lai
Sent: Thu 5/8/2008 10:18 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Having trouble installing 3.7.85 on fc8

I’ve been able to get as far as the page that says:

You’re almost there!

You haven’t yet configured your webserver to run RT

You appear to have installed RT’s web interface correctly, but haven’t yet
configured your web server to “run” the RT server which powers the web
interface.

The next step is to edit your webserver’s configuration file to
instruct it
to use RT’s mod_perl, fastcgi or speedycgi handler.

I’m trying to configure it to use mod_perl but having no luck so far.

Here’s my /etc/httpd/conf.d/rt3.conf. As far as I can tell, I’m
referring to
mod_perl, and when I restart the httpd daemon, it tells me that
mod_perl is
already loaded.

I’d appreciate any insight.

Thanks,

Alias /rt3 “//opt/rt3/share/html”

LoadModule perl_module mod_perl.so

PerlModule Apache::DBI

PerlRequire /usr/sbin/webmux.pl

<Directory /opt/rt3/share/html>

AllowOverride All

Options ExecCGI FollowSymLinks

Order allow,deny

Allow from all

<Location /rt>

RewriteEngine On

RedirectMatch permanent (.*)/$ $1/index.html

AddDefaultCharset UTF-8

SetHandler perl-script

PerlHandler RT::Mason

ServerName localhost

DocumentRoot /opt/rt3/share/html

AddDefaultCharset UTF-8

PerlModule Apache2 Apache2::compat

PerlModule Apache::DBI

PerlRequire /usr/sbin/webmux.pl

  SetHandler perl-script

  PerlHandler RT::Mason

Elbert Lai

Network Operations Manager

Itiva Networks

530 Lytton Ave

2nd Floor

Palo Alto, CA 94301

650-521-3403 (cell)

650-560-6125 (fax)

elbertlai@itiva.com