Having problems with a default install of 3.6.5

I configured and installed it, I can login with the default root account.
I click on Configuration and get sent back to the Home - RT at a glance
page.
I’m unable to get to the config page. I’ve been scouring the httpd
error and system messages log and not finding anything that helps.
I tried turning on the log file in SiteConfig, but that errored out,
stating that it couldn’t open/create rt.log. I should think the default
permissions to /opt/rt3/var/log would have allowed for this
automatically. I’m at a bit of a loss here.
I’m needing to solve this because I need to migrate a 3.0.12 database
from another machine to this one. I’ve already done the db import and
upgrades without error, but it does me no good if I can’t get in the
Configuration page.
Help?

Mike Gracy
www.MyPoints.com
Unix/Network Sysadmin

525 Market St.
34th Floor
San Francisco, Ca 94105

Desk-415.829.6174
Fax-415-829-6174

In my fc6 install of 3.6.5 the log directory is /var/log/rt3/
The httpd process runs as apache user and the permissions of the log directory are
[root@rt ~]# ll -d /var/log/rt3/
drwxrwxr-x 2 root apache 4096 Oct 5 12:49 /var/log/rt3/

Check with yours and report eventually

HIH,
Gianluca

Not sure about your other issues, but if you touch rt.log in
/opt/rt3/var/log, the error with logging will go away.

Mike Gracy wrote:

I was only able to read your answer some minutes ago… Next time please send messages to all the list, so that eventually other guys could give quicker replies…

The ‘Configuration’ link resolves to the same page as yours for me, so it doesn’t seem a problem about rt itself.
When you have a link pointing to a directory, it defaults to some kind of page into that directory, tipically index.hmtl.
You define it inside apache configuration file (/etc/httpd/conf/httpd.conf on my fc6).

Pehaps your apache config is different form the default one…
The directive inside httpd.conf is DirectoryIndex and it is this one below for me:

DirectoryIndex: sets the file that Apache will serve if a directory

is requested.

The index.html.var file (a type-map) is used to deliver content-

negotiated documents. The MultiViews Option can be used for the

same purpose, but it is much slower.

DirectoryIndex index.html index.html.var

I have also this in my rt3.conf file (see in particular the “RedirectMatch” entry) under /etc/httpd/conf.d/.
Don’t know if could be another source of problems if misconfigured:

Alias /rt3 “/usr/share/rt3/html”

PerlModule Apache::DBI
PerlRequire /usr/sbin/webmux.pl

<Directory “/usr/share/rt3/html”>
AllowOverride All
Options ExecCGI FollowSymLinks

<Location /rt3>
RewriteEngine On
RedirectMatch permanent (.*)/$ $1/index.html
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

Thanks for the feedback. I’ll remember to hit reply to all next time.
I’ll look at the apache config.
Gianluca Cecchi wrote:

I was only able to read your answer some minutes ago… Next time please send messages to all the list, so that eventually other guys could give quicker replies…

The ‘Configuration’ link resolves to the same page as yours for me, so it doesn’t seem a problem about rt itself.
When you have a link pointing to a directory, it defaults to some kind of page into that directory, tipically index.hmtl.
You define it inside apache configuration file (/etc/httpd/conf/httpd.conf on my fc6).

Pehaps your apache config is different form the default one…
The directive inside httpd.conf is DirectoryIndex and it is this one below for me:

DirectoryIndex: sets the file that Apache will serve if a directory

is requested.

The index.html.var file (a type-map) is used to deliver content-

negotiated documents. The MultiViews Option can be used for the

same purpose, but it is much slower.

DirectoryIndex index.html index.html.var

I have also this in my rt3.conf file (see in particular the “RedirectMatch” entry) under /etc/httpd/conf.d/.
Don’t know if could be another source of problems if misconfigured:

Alias /rt3 “/usr/share/rt3/html”

PerlModule Apache::DBI
PerlRequire /usr/sbin/webmux.pl

<Directory “/usr/share/rt3/html”>
AllowOverride All
Options ExecCGI FollowSymLinks

<Location /rt3>
RewriteEngine On
RedirectMatch permanent (.*)/$ $1/index.html
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

-----Messaggio originale-----
Da: Mike Gracy [mailto:mike.gracy@mypointscorp.com]
Inviato: venerd� 14 dicembre 2007 21.54
A: Gianluca Cecchi
Oggetto: Re: R: [rt-users] Having problems with a default
install of 3.6.5

Ok, I updated the logging path in RT_SiteConfig.pm and set up
the same dir below. Logging works now. Thanks.

I just discovered what is happening with the ‘Configuration’ link.
It is resolving as ‘rt./Admin/’. It should
have ‘index.html’ on the end of it. When I put the
‘index.html’ on the end, it works perfectly. Which file can
I edit to fix this?

Mike Gracy

Unix/Network Sysadmin

525 Market St.
34th Floor
San Francisco, Ca 94105

Desk-415.829.6174
Fax-415-829-6174

Ok, I’ll think about it. It’s just that in the menubar I found
inconsistencies. Some links had the /index.html, others didn’t. That’s
what led me to believe it was a minor typo.

Drew Barnes wrote:

I’m not sure that’s a bug, per se. I know some people use some rewrite
rules to add index.html to any path with no file (whether for security
reasons or for ease of use on a per-site basis), although you should be
able to set an option in httpd.conf to use that by default also (I think).

Jesse is very active on the list here, so you could always send a diff
-u to rt-devel if you feel it absolutely should be fixed for future
releases. I don’t have any problems on my site with that particular
file as it is, though.

Mike Gracy wrote:

Well I did finally get logging working to /var/log/rt3.
I also finally found and fixed the defective href link to the Admin
interface.

My diff for rt3/share/html/Elements/Tabs :
87c87
< path => ‘Admin/’,

                   path => 'Admin/index.html',

I’ve even downloaded the source again to make sure. 3.6.5 still has
this error in the tar.gz file.

I find it hard to believe that this simple error hasn’t been patched
yet. Do the developers monitor this list for these types of things?

Drew Barnes wrote:

Not sure about your other issues, but if you touch rt.log in
/opt/rt3/var/log, the error with logging will go away.

Mike Gracy wrote:

I configured and installed it, I can login with the default root
account.
I click on Configuration and get sent back to the Home - RT at a
glance page.
I’m unable to get to the config page. I’ve been scouring the httpd
error and system messages log and not finding anything that helps.
I tried turning on the log file in SiteConfig, but that errored out,
stating that it couldn’t open/create rt.log. I should think the
default permissions to /opt/rt3/var/log would have allowed for this
automatically. I’m at a bit of a loss here.
I’m needing to solve this because I need to migrate a 3.0.12 database
from another machine to this one. I’ve already done the db import and
upgrades without error, but it does me no good if I can’t get in the
Configuration page.
Help?

Mike Gracy

Unix/Network Sysadmin

525 Market St.
34th Floor
San Francisco, Ca 94105

Desk-415.829.6174
Fax-415-829-6174