Good Instruction for RT3 + Apache2 + FastCGI + MYSQL

Hey Guys!

Im frustrated already. I can’t make my RT3 installation work for Apache
1.3 + mod_perl1 (my precious 5 days already wasted). Since I don’t get
answer on my problem with Apache-Mason ("Bareword ‘REDIRECT’ error…), I
will push through to use Apache2 + FastCGI.

I need instruction on how to install everything (except MYSQL). I will
try I hope it works…

–rommie

This is still on your rh9 distro? I will try to walk through this with
you. Do a fresh install of rh9, then run up2date and make sure you are
current on everything, kernel as well. I will locate a box here that I
can do the same with and we will walk through the installation of 3.0.5.

Michael-----Original Message-----
From: request_tracker@acerhomes.com
[mailto:request_tracker@acerhomes.com]
Posted At: Thursday, September 18, 2003 10:44 AM
Posted To: RT
Conversation: [rt-users] Good Instruction for RT3 + Apache2 + FastCGI +
MYSQL
Subject: [rt-users] Good Instruction for RT3 + Apache2 + FastCGI + MYSQL

Hey Guys!

Im frustrated already. I can’t make my RT3 installation work for Apache
1.3 + mod_perl1 (my precious 5 days already wasted). Since I don’t get
answer on my problem with Apache-Mason ("Bareword ‘REDIRECT’ error…),
I
will push through to use Apache2 + FastCGI.

I need instruction on how to install everything (except MYSQL). I will
try I hope it works…

–rommie

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Thanks! Michael

So I will do it now. Since this is fresh install, our direction will be
Apache2 + FastCGI and Mysql (I prefer postgrest to use, is that ok?)

—rommie

Okay Michael. I re-install and update everything. Currently these are my
setups :

kernel-smp-2.4.20-20.9
httpd-2.0.40-21.5
sendmail-8.12.8-9.90

perl-5.8.0-88
perl-DateManip-5.40-30
perl-libxml-perl-0.07-28
perl-XML-Grove-0.46alpha-25
perl-DB_File-1.804-88
perl-Filter-1.29-3
perl-HTML-Tagset-3.03-28
perl-Parse-Yapp-1.05-30
perl-URI-1.21-7
perl-XML-Parser-2.31-15
perl-XML-Dumper-0.4-25
perl-libxml-enno-1.02-29
perl-XML-Twig-3.09-3
perl-DBI-1.32-5
perl-DBD-MySQL-2.1021-3
perl-DBD-Pg-1.21-2
mod_perl-1.99_07-5
perl-HTML-Parser-3.26-17
perl-libwww-perl-5.65-6
perl-XML-Encoding-1.01-23
perl-CPAN-1.61-88
perl-CGI-2.81-88

/usr/bin/perl ./sbin/rt-test-dependencies --with-postgres --with-fastcgi
perl:
5.8.0…found

MASON dependencies:

Params::Validate 0.02…MISSING
Cache::Cache …MISSING
Exception::Class …MISSING
HTML::Mason 1.16…MISSING
MLDBM …MISSING
Errno …found
FreezeThaw …MISSING
Digest::MD5 2.27…MISSING
Digest::MD5 version 2.27 required–this is only version 2.20 at (eval 13)
line 2.
CGI::Cookie 1.20…found
Storable …found
Apache::Session 1.53…MISSING

FASTCGI dependencies:
CGI …found
FCGI …MISSING
CGI::Fast …MISSING

MAILGATE dependencies:
HTML::TreeBuilder …MISSING
HTML::FormatText …MISSING
Getopt::Long …found
LWP::UserAgent …found

POSTGRESQL dependencies:
DBD::Pg …found

CLI dependencies:
Getopt::Long 2.24…found

CORE dependencies:
Digest::MD5 2.27…MISSING
Digest::MD5 version 2.27 required–this is only version 2.20 at (eval 29)
line 2.
DBI 1.37…MISSING
DBI version 1.37 required–this is only version 1.32 at (eval 30) line 2.
Test::Inline …MISSING
Class::ReturnValue 0.40…MISSING
DBIx::SearchBuilder 0.92…MISSING
Text::Template …MISSING
File::Spec 0.8…found
HTML::Entities …found
Net::Domain …found
Log::Dispatch 2.0…MISSING
Locale::Maketext 1.06…MISSING
Locale::Maketext version 1.06 required–this is only version 1.03 at
(eval 39) line 2.
Locale::Maketext::Lexicon 0.25…MISSING
Locale::Maketext::Fuzzy …MISSING
MIME::Entity 5.108…MISSING
Mail::Mailer 1.57…MISSING
Net::SMTP …found
Text::Wrapper …MISSING
Time::ParseDate …MISSING
File::Temp …found
Term::ReadKey …MISSING
Text::Autoformat …MISSING
Text::Quoted …MISSING

DEV dependencies:

Regexp::Common …MISSING
Time::HiRes …MISSING
Test::Inline …MISSING
WWW::Mechanize …MISSING

I’m about to update all perl modules. Is it better to update using the
CPAN or installing individually using tar?

—rommie

This is of great interest to me also. I have been trying to get RT 3
working for almost two weeks on RH9 default install with Apache 2,
MySQL, FastCGI (also attempted mod_cgi default and the one from rawhide
sources). Way too much mucking around. Is there a straight forward RH9
installation document?

Brian

Let me ask a similar question.

I’ve been trying to get RT3 going on a default install of RH9 too. I’ve
always just used RH. What distribution is the easiest/best way to go for
install. Should I quit with RH and go to Debian or something else? Or
should I try doing a bare RH9 install and installing everything from
stratch. I’m thinking my RH problems are all these RPMs.
Any help would be greatly appreciated. I’ve used RT2 in the past and
want to use it again but these install problems are a nightmare.

Bryan

Brian Zammit wrote:

Me too, I can’t get a good answer which distro should be used. Since I’m
new with RT and also with Linux, so I used RH9. But since Michael will
also try to use this kind setup, I hope we can make this work.

Right now, I trying to configure Apache2 (RH9 RPM) to work with FASTCGI
using tar (I could not find good RPM).

–rommie

Let me ask a similar question.

I’ve been trying to get RT3 going on a default install of RH9 too. I’ve
always just used RH. What distribution is the easiest/best way to go for
install. Should I quit with RH and go to Debian or something else? Or
should I try doing a bare RH9 install and installing everything from
stratch. I’m thinking my RH problems are all these RPMs.
Any help would be greatly appreciated. I’ve used RT2 in the past and
want to use it again but these install problems are a nightmare.

Bryan

Brian Zammit wrote:

This is of great interest to me also. I have been trying to get RT 3
working for almost two weeks on RH9 default install with Apache 2,
MySQL, FastCGI (also attempted mod_cgi default and the one from rawhide
sources). Way too much mucking around. Is there a straight forward RH9
installation document?

Brian

-----Original Message-----
From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com] On Behalf Of Rommie
Sent: September 19, 2003 12:36 PM
To: rt-users@lists.fsck.com
Cc: RT@InterCept.Net
Subject: RE: [rt-users] Good Instruction for RT3 + Apache2 +
FastCGI + MYSQL

Okay Michael. I re-install and update everything. Currently
these are my setups :

kernel-smp-2.4.20-20.9
httpd-2.0.40-21.5
sendmail-8.12.8-9.90

perl-5.8.0-88
perl-DateManip-5.40-30
perl-libxml-perl-0.07-28
perl-XML-Grove-0.46alpha-25
perl-DB_File-1.804-88
perl-Filter-1.29-3
perl-HTML-Tagset-3.03-28
perl-Parse-Yapp-1.05-30
perl-URI-1.21-7
perl-XML-Parser-2.31-15
perl-XML-Dumper-0.4-25
perl-libxml-enno-1.02-29
perl-XML-Twig-3.09-3
perl-DBI-1.32-5
perl-DBD-MySQL-2.1021-3
perl-DBD-Pg-1.21-2
mod_perl-1.99_07-5
perl-HTML-Parser-3.26-17
perl-libwww-perl-5.65-6
perl-XML-Encoding-1.01-23
perl-CPAN-1.61-88
perl-CGI-2.81-88

/usr/bin/perl ./sbin/rt-test-dependencies --with-postgres
–with-fastcgi
perl:
5.8.0…found

MASON dependencies:

Params::Validate 0.02…MISSING
Cache::Cache …MISSING
Exception::Class …MISSING
HTML::Mason 1.16…MISSING
MLDBM …MISSING
Errno …found
FreezeThaw …MISSING
Digest::MD5 2.27…MISSING
Digest::MD5 version 2.27 required–this is only version 2.20
at (eval 13) line 2. CGI::Cookie 1.20…found Storable
…found Apache::Session 1.53…MISSING

FASTCGI dependencies:
CGI …found
FCGI …MISSING
CGI::Fast …MISSING

MAILGATE dependencies:
HTML::TreeBuilder …MISSING
HTML::FormatText …MISSING
Getopt::Long …found
LWP::UserAgent …found

POSTGRESQL dependencies:
DBD::Pg …found

CLI dependencies:
Getopt::Long 2.24…found

CORE dependencies:
Digest::MD5 2.27…MISSING
Digest::MD5 version 2.27 required–this is only version
2.20 at (eval 29) line 2. DBI 1.37…MISSING DBI version 1.37
required–this is only version 1.32 at (eval 30) line 2.
Test::Inline …MISSING Class::ReturnValue 0.40…MISSING
DBIx::SearchBuilder 0.92…MISSING Text::Template …MISSING
File::Spec 0.8…found HTML::Entities …found Net::Domain
…found Log::Dispatch 2.0…MISSING Locale::Maketext 1.06…MISSING
Locale::Maketext version 1.06 required–this is only
version 1.03 at (eval 39) line 2. Locale::Maketext::Lexicon
0.25…MISSING Locale::Maketext::Fuzzy …MISSING MIME::Entity
5.108…MISSING Mail::Mailer 1.57…MISSING Net::SMTP …found
Text::Wrapper …MISSING Time::ParseDate …MISSING File::Temp
…found Term::ReadKey …MISSING Text::Autoformat …MISSING
Text::Quoted …MISSING

DEV dependencies:

Regexp::Common …MISSING
Time::HiRes …MISSING
Test::Inline …MISSING
WWW::Mechanize …MISSING

I’m about to update all perl modules. Is it better to update
using the CPAN or installing individually using tar?

—rommie

This is still on your rh9 distro? I will try to walk through

this with

you. Do a fresh install of rh9, then run up2date and make

sure you are

current on everything, kernel as well. I will locate a box

here that I

can do the same with and we will walk through the installation of
3.0.5.

Michael

-----Original Message-----
From: request_tracker@acerhomes.com
[mailto:request_tracker@acerhomes.com]
Posted At: Thursday, September 18, 2003 10:44 AM
Posted To: RT
Conversation: [rt-users] Good Instruction for RT3 + Apache2

  • FastCGI
  • MYSQL
    Subject: [rt-users] Good Instruction for RT3 + Apache2 + FastCGI +
    MYSQL

Hey Guys!

Im frustrated already. I can’t make my RT3 installation work for
Apache 1.3 + mod_perl1 (my precious 5 days already wasted). Since I
don’t get answer on my problem with Apache-Mason ("Bareword

‘REDIRECT’

error…), I will push through to use Apache2 + FastCGI.

I need instruction on how to install everything (except MYSQL). I
will try I hope it works…

–rommie


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at
http://fsck.com/rtfm _______________________________________________
rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at
http://fsck.com/rtfm


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at
http://fsck.com/rtfm


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

—rommie

Guys!

I just finished installing all missing perl modules for FastCGI + Postgres
(see my previous message) and I used the tarball so I will know
everything(WHEW!) These are my complete lists for your info.

Param-Validate-0.65 Dave Rolsky

Cache-Cache-1.02 DeWitt Clinton
Error-0.15 Arun Kumar U
Digest-SHA1-2.04 Gisle Aas
IPC-ShareLite-0.09 Maurice Aubrey

Exception-Class-1.15 Dave Rolsky
Class-Data-Inheritable-0.02 Michael G Schwern
Devel-StackTrace-1.03 Dave Rolsky *

HTML-Mason-1.23 Dave Rolsky *
Class-Container-0.10 Ken Williams
Apache-Filter-1.022 Ken Williams *

FreezeThaw-0.43 Ilya Zakharevich
MLDBM-2.01 Joshua Chamas
Digest-MD5-2.27 Gisle Aas
Apache-Session-1.54 Jeffrey Baker
HTML-Tree-3.18 Sean M. Burke
HTML-Parser-3.31 Gisle Aas
HTML-Tagset-3.03 Sean M. Burke

HTML-Format-2.03 Sean M. Burke
Font-AFM-1.18 Gisle Aas

DBI-1.38 Tim Bunce *
Test-Inline-0.15 Michael G Schwern
Class-ReturnValue-0.51 Jesse Vincent
DBIx-SearchBuilder-0.92 Jesse Vincent
Text-Template-1.44 Mark Jason Dominus
Log-Dispatch-2.06 Dave Rolsky
Module-Build-0.20_02 Ken Williams
YAML-0.35 Brian Ingerson
ExtUtils::ParseXS Ken Williams
Archive-Tar-1.05 Jos Boumans

Locale-Maketext-1.06 Sean M. Burke
I18N-LangTags-0.28 Sean M. Burke

Locale-Maketext-Fuzzy-0.02 Autrijus Tang
Locale-Maketext-Lexicon-0.28 Autrijus Tang
Regexp-Common-2.113 Abigail
Locale-Maketext-Gettext-1.10 imacat - mistakenly installed

MIME-tools-6.200_02 Eryq
MIME-tools-5.411a Eryq - i think this one is needed
IO-stringy-2.108 Eryq
MailTools-1.59 Mark Overmeer
Unicode-Map-0.112 Martin Schwartz
Unicode-Map8-0.12 Gisle Aas - I installed both (I’m not sure which one
is needed)

Text-Wrapper-1.000 Christopher J. Madsen
Time-modules-2003.0211 David Muir Sharnoff
TermReadKey-2.21 Jonathan Stowe *
Text-Autoformat-1.12 Damian Conway *
Text-Reform-1.11 Damian Conway

Text-Quoted-1.2 Simon Cozens
Time-HiRes-1.51 Jarkko Hietaniemi

WWW-Mechanize-0.59 Andy Lester *
libwww-perl-5.69 Gisle Aas
IO-Socket-SSL-0.95 Peter Behroozi
Net_SSLeay.pm-1.25 Sampo Kellomaki *

    • I ignored some minor errors.

So I end up here on this dependency test.

perl sbin/rt-test-dependencies --with-postgrsql --with-fastcgi

perl:
5.8.0…found

MASON dependencies:
Params::Validate 0.02…found
Cache::Cache …found
Exception::Class …found
HTML::Mason 1.16…found
MLDBM …found
Errno …found
FreezeThaw …found
Digest::MD5 2.27…found
CGI::Cookie 1.20…found
Storable …found
Apache::Session 1.53…found

FASTCGI dependencies:
CGI …found
FCGI …found
CGI::Fast …found

MAILGATE dependencies:
HTML::TreeBuilder …found
HTML::FormatText …found
Getopt::Long …found
LWP::UserAgent …found

POSTGRESQL dependencies:
DBD::Pg …found

CLI dependencies:
Getopt::Long 2.24…found

CORE dependencies:
Digest::MD5 2.27…found
DBI 1.37…found
Test::Inline …found
Class::ReturnValue 0.40…found
DBIx::SearchBuilder 0.92…found
Text::Template …found
File::Spec 0.8…found
HTML::Entities …found
Net::Domain …found
Log::Dispatch 2.0…found
Locale::Maketext 1.06…found
Locale::Maketext::Lexicon 0.25…found
Locale::Maketext::Fuzzy …found
MIME::Entity 5.108…found
Mail::Mailer 1.57…found
Net::SMTP …found
Text::Wrapper …found
Time::ParseDate …found
File::Temp …found
Term::ReadKey …found
Text::Autoformat …found
Text::Quoted …found

DEV dependencies:
Regexp::Common …found
Time::HiRes …found
Test::Inline …found
WWW::Mechanize …found

So, I will now work on my postgres database. (Hello! did I miss something?)

This is still on your rh9 distro? I will try to walk through this with
you. Do a fresh install of rh9, then run up2date and make sure you are
current on everything, kernel as well. I will locate a box here that I
can do the same with and we will walk through the installation of 3.0.5.

Michael

-----Original Message-----
From: request_tracker@acerhomes.com
[mailto:request_tracker@acerhomes.com]
Posted At: Thursday, September 18, 2003 10:44 AM
Posted To: RT
Conversation: [rt-users] Good Instruction for RT3 + Apache2 + FastCGI +
MYSQL
Subject: [rt-users] Good Instruction for RT3 + Apache2 + FastCGI + MYSQL

Hey Guys!

Im frustrated already. I can’t make my RT3 installation work for Apache
1.3 + mod_perl1 (my precious 5 days already wasted). Since I don’t get
answer on my problem with Apache-Mason ("Bareword ‘REDIRECT’ error…),
I
will push through to use Apache2 + FastCGI.

I need instruction on how to install everything (except MYSQL). I will
try I hope it works…

–rommie


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

—rommie

I just want to post these solutions (I got from different mailing lists) I
encoutered during my installation.

FastCGI + Apache2

Since I used Apache2 RPM, you need to change the Makefile of FastCGI from
tarball before you compile.

top_dir = /usr/lib/httpd
INCLUDES=-I/usr/include/httpd

Digest::MD5

Checking if your kit is complete…

Looks good
Writing Makefile for Digest::MD5
Makefile:83: *** missing separator. Stop.
/usr/bin/make – NOT OK

Before using the perl shell, run the following commands as root:

cd /etc/sysconfig

cp i18n i18n-orig

sed ‘s/LANG=.*/LANG=“en_US”/’ i18n-orig > i18n

. i18n

I hope this will help…

—rommie

Dear All,

I am new in RT and even perl and linux. Hoping that someone won’t mind
answering my question (even it may seems stupid question to you).

I’m trying to install RT 3.0.5 with the default settings in RH9. Appche and
mysql are default. I try to install the perl module with the CPAN provided
but some still missing.

[root@riclinux rt-3-0-5]# perl sbin/rt-test-dependencies --with-mysql
–with-modperl1
perl:
5.8.0…found
MASON dependencies:
Params::Validate 0.02…found
Cache::Cache …found
Exception::Class …found
HTML::Mason 1.16…found
MLDBM …found
Errno …found
FreezeThaw …found
Digest::MD5 2.27…MISSING
Digest::MD5 version 2.27 required–this is only version 2.20
at (eval 32) line 2.
CGI::Cookie 1.20…found
Storable …found
Apache::Session 1.53…found
MAILGATE dependencies:
HTML::TreeBuilder …found
HTML::FormatText …found
Getopt::Long …found
LWP::UserAgent …found
MODPERL1 dependencies:
CGI …found
Apache::Request …MISSING
Apache::DBI 0.92…found
CLI dependencies:
Getopt::Long 2.24…found
CORE dependencies:
Digest::MD5 2.27…MISSING
Digest::MD5 version 2.27 required–this is only version 2.20
at (eval 48) line 2.
DBI 1.37…found
Test::Inline …found
Class::ReturnValue 0.40…found
DBIx::SearchBuilder 0.92…found
Text::Template …found
File::Spec 0.8…found
HTML::Entities …found
Net::Domain …found
Log::Dispatch 2.0…MISSING
Locale::Maketext 1.06…found
Locale::Maketext::Lexicon 0.25…found
Locale::Maketext::Fuzzy …found
MIME::Entity 5.108…found
Mail::Mailer 1.57…found
Net::SMTP …found
Text::Wrapper …found
Time::ParseDate …found
File::Temp …found
Term::ReadKey …found
Text::Autoformat …found
Text::Quoted …found
DEV dependencies:
Regexp::Common …found
Time::HiRes …found
Test::Inline …found
WWW::Mechanize …found
MYSQL dependencies:
DBD::mysql 2.1018…found

So, i try this one
[root@riclinux rt-3-0-5]# perl -MCPAN -e ‘install Apache::Request::Install’
and it give me the result follows:

CPAN.pm: Going to build J/JO/JOESUF/libapreq-1.2.tar.gz

mod_perl 1.x ( < 1.99) is required at Makefile.PL line 29.
BEGIN failed–compilation aborted at Makefile.PL line 31.
Running make test
Make had some problems, maybe interrupted? Won’t test
Running make install
Make had some problems, maybe interrupted? Won’t install
[root@riclinux rt-3-0-5]#

How should I install those modules? using tar?
and what actually is the difference between modperl1, modperl2 and fasstcgi?

Thanks in advance for giving me some help.

Best Regards,
Ada Hui

No masks required! Use MSN Messenger to chat with friends and family.
http://go.msnserver.com/HK/25382.asp

I can’t comment on the linux distros – but on FreeBSD 4.8 it was a
snap. (Although I used apache1/mod_perl/postgresql, and used a mixture
of ports and manual installs.)

The most simple way is to use the port – cd /usr/ports/www/rt3; make
all install clean.

JimFrom: Bryan Pennington [mailto:bpennington@trevorn.com]
Sent: Saturday, September 20, 2003 4:34 PM
To: rt-users@lists.fsck.com
Subject: Re: [rt-users] Good Instruction for RT3 + Apache2 + FastCGI +
MYSQL

Let me ask a similar question.

I’ve been trying to get RT3 going on a default install of RH9 too. I’ve
always just used RH. What distribution is the easiest/best way to go for

install. Should I quit with RH and go to Debian or something else? Or
should I try doing a bare RH9 install and installing everything from
stratch. I’m thinking my RH problems are all these RPMs.
Any help would be greatly appreciated. I’ve used RT2 in the past and
want to use it again but these install problems are a nightmare.

Bryan

Brian Zammit wrote:

This is of great interest to me also. I have been trying to get RT 3
working for almost two weeks on RH9 default install with Apache 2,
MySQL, FastCGI (also attempted mod_cgi default and the one from rawhide

sources). Way too much mucking around. Is there a straight forward RH9
installation document?

Brian

-----Original Message-----
From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com] On Behalf Of Rommie
Sent: September 19, 2003 12:36 PM
To: rt-users@lists.fsck.com
Cc: RT@InterCept.Net
Subject: RE: [rt-users] Good Instruction for RT3 + Apache2 +
FastCGI + MYSQL

Okay Michael. I re-install and update everything. Currently
these are my setups :

kernel-smp-2.4.20-20.9
httpd-2.0.40-21.5
sendmail-8.12.8-9.90

perl-5.8.0-88
perl-DateManip-5.40-30
perl-libxml-perl-0.07-28
perl-XML-Grove-0.46alpha-25
perl-DB_File-1.804-88
perl-Filter-1.29-3
perl-HTML-Tagset-3.03-28
perl-Parse-Yapp-1.05-30
perl-URI-1.21-7
perl-XML-Parser-2.31-15
perl-XML-Dumper-0.4-25
perl-libxml-enno-1.02-29
perl-XML-Twig-3.09-3
perl-DBI-1.32-5
perl-DBD-MySQL-2.1021-3
perl-DBD-Pg-1.21-2
mod_perl-1.99_07-5
perl-HTML-Parser-3.26-17
perl-libwww-perl-5.65-6
perl-XML-Encoding-1.01-23
perl-CPAN-1.61-88
perl-CGI-2.81-88

/usr/bin/perl ./sbin/rt-test-dependencies --with-postgres
–with-fastcgi
perl:
5.8.0…found

MASON dependencies:

Params::Validate 0.02…MISSING
Cache::Cache …MISSING
Exception::Class …MISSING
HTML::Mason 1.16…MISSING
MLDBM …MISSING
Errno …found
FreezeThaw …MISSING
Digest::MD5 2.27…MISSING
Digest::MD5 version 2.27 required–this is only version 2.20
at (eval 13) line 2. CGI::Cookie 1.20…found Storable
…found Apache::Session 1.53…MISSING

FASTCGI dependencies:
CGI …found
FCGI …MISSING
CGI::Fast …MISSING

MAILGATE dependencies:
HTML::TreeBuilder …MISSING
HTML::FormatText …MISSING
Getopt::Long …found
LWP::UserAgent …found

POSTGRESQL dependencies:
DBD::Pg …found

CLI dependencies:
Getopt::Long 2.24…found

CORE dependencies:
Digest::MD5 2.27…MISSING
Digest::MD5 version 2.27 required–this is only version
2.20 at (eval 29) line 2. DBI 1.37…MISSING DBI version 1.37
required–this is only version 1.32 at (eval 30) line 2.
Test::Inline …MISSING Class::ReturnValue 0.40…MISSING
DBIx::SearchBuilder 0.92…MISSING Text::Template …MISSING
File::Spec 0.8…found HTML::Entities …found Net::Domain
…found Log::Dispatch 2.0…MISSING Locale::Maketext 1.06…MISSING
Locale::Maketext version 1.06 required–this is only
version 1.03 at (eval 39) line 2. Locale::Maketext::Lexicon
0.25…MISSING Locale::Maketext::Fuzzy …MISSING MIME::Entity
5.108…MISSING Mail::Mailer 1.57…MISSING Net::SMTP …found
Text::Wrapper …MISSING Time::ParseDate …MISSING File::Temp
…found Term::ReadKey …MISSING Text::Autoformat …MISSING
Text::Quoted …MISSING

DEV dependencies:

Regexp::Common …MISSING
Time::HiRes …MISSING
Test::Inline …MISSING
WWW::Mechanize …MISSING

I’m about to update all perl modules. Is it better to update
using the CPAN or installing individually using tar?

—rommie

This is still on your rh9 distro? I will try to walk through

this with

you. Do a fresh install of rh9, then run up2date and make

sure you are

current on everything, kernel as well. I will locate a box

here that I

can do the same with and we will walk through the installation of
3.0.5.

Michael

-----Original Message-----
From: request_tracker@acerhomes.com
[mailto:request_tracker@acerhomes.com]
Posted At: Thursday, September 18, 2003 10:44 AM
Posted To: RT
Conversation: [rt-users] Good Instruction for RT3 + Apache2

  • FastCGI
  • MYSQL
    Subject: [rt-users] Good Instruction for RT3 + Apache2 + FastCGI +
    MYSQL

Hey Guys!

Im frustrated already. I can’t make my RT3 installation work for
Apache 1.3 + mod_perl1 (my precious 5 days already wasted). Since I
don’t get answer on my problem with Apache-Mason ("Bareword

‘REDIRECT’

error…), I will push through to use Apache2 + FastCGI.

I need instruction on how to install everything (except MYSQL). I
will try I hope it works…

–rommie


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at
http://fsck.com/rtfm _______________________________________________
rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at
http://fsck.com/rtfm


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at
http://fsck.com/rtfm


rt-users mailing list
rt-users@lists.fsck.com http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

rt-users mailing list
rt-users@lists.fsck.com http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

httpd-2.0.40-21.5 and all other installed RPMs I posted already on my
previous messages under this thread.

—romie

Which version of Apache2 did u use?

Thanks,
Bryan
-----Original Message-----
From: Rommie [mailto:request_tracker@acerhomes.com]
Sent: Tuesday, September 23, 2003 10:21 AM
To: rt-users@lists.fsck.com
Cc: RT@InterCept.Net; bpennington@trevorn.com;
bzammit@systemsaligned.com
Subject: RE: [rt-users] Good Instruction for RT3 + Apache2 + FastCGI +
MYSQL

I just want to post these solutions (I got from different mailing lists)
I
encoutered during my installation.


FastCGI + Apache2

Since I used Apache2 RPM, you need to change the Makefile of FastCGI
from
tarball before you compile.

top_dir = /usr/lib/httpd
INCLUDES=-I/usr/include/httpd


Digest::MD5

Checking if your kit is complete…

Looks good
Writing Makefile for Digest::MD5
Makefile:83: *** missing separator. Stop.
/usr/bin/make – NOT OK

Before using the perl shell, run the following commands as root:

cd /etc/sysconfig

cp i18n i18n-orig

sed ‘s/LANG=.*/LANG=“en_US”/’ i18n-orig > i18n

. i18n


I hope this will help…

—rommie

This is still on your rh9 distro? I will try to walk through this with
you. Do a fresh install of rh9, then run up2date and make sure you are
current on everything, kernel as well. I will locate a box here that I
can do the same with and we will walk through the installation of
3.0.5.

Michael

-----Original Message-----
From: request_tracker@acerhomes.com
[mailto:request_tracker@acerhomes.com]
Posted At: Thursday, September 18, 2003 10:44 AM
Posted To: RT
Conversation: [rt-users] Good Instruction for RT3 + Apache2 + FastCGI

MYSQL
Subject: [rt-users] Good Instruction for RT3 + Apache2 + FastCGI +
MYSQL

Hey Guys!

Im frustrated already. I can’t make my RT3 installation work for
Apache
1.3 + mod_perl1 (my precious 5 days already wasted). Since I don’t get
answer on my problem with Apache-Mason ("Bareword ‘REDIRECT’
error…),
I
will push through to use Apache2 + FastCGI.

I need instruction on how to install everything (except MYSQL). I
will
try I hope it works…

–rommie


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at
http://fsck.com/rtfm

—rommie

Hi Ada!

Please read my previous postings under this thread. That might help you.

—romie

Dear All,

I am new in RT and even perl and linux. Hoping that someone won’t mind
answering my question (even it may seems stupid question to you).

I’m trying to install RT 3.0.5 with the default settings in RH9. Appche
and mysql are default. I try to install the perl module with the CPAN
provided but some still missing.

[root@riclinux rt-3-0-5]# perl sbin/rt-test-dependencies --with-mysql
–with-modperl1
perl:
5.8.0…found
MASON dependencies:
Params::Validate 0.02…found
Cache::Cache …found
Exception::Class …found
HTML::Mason 1.16…found
MLDBM …found
Errno …found
FreezeThaw …found
Digest::MD5 2.27…MISSING
Digest::MD5 version 2.27 required–this is only version
2.20
at (eval 32) line 2.
CGI::Cookie 1.20…found
Storable …found
Apache::Session 1.53…found
MAILGATE dependencies:
HTML::TreeBuilder …found
HTML::FormatText …found
Getopt::Long …found
LWP::UserAgent …found
MODPERL1 dependencies:
CGI …found
Apache::Request …MISSING
Apache::DBI 0.92…found
CLI dependencies:
Getopt::Long 2.24…found
CORE dependencies:
Digest::MD5 2.27…MISSING
Digest::MD5 version 2.27 required–this is only version
2.20
at (eval 48) line 2.
DBI 1.37…found
Test::Inline …found
Class::ReturnValue 0.40…found
DBIx::SearchBuilder 0.92…found
Text::Template …found
File::Spec 0.8…found
HTML::Entities …found
Net::Domain …found
Log::Dispatch 2.0…MISSING
Locale::Maketext 1.06…found
Locale::Maketext::Lexicon 0.25…found
Locale::Maketext::Fuzzy …found
MIME::Entity 5.108…found
Mail::Mailer 1.57…found
Net::SMTP …found
Text::Wrapper …found
Time::ParseDate …found
File::Temp …found
Term::ReadKey …found
Text::Autoformat …found
Text::Quoted …found
DEV dependencies:
Regexp::Common …found
Time::HiRes …found
Test::Inline …found
WWW::Mechanize …found
MYSQL dependencies:
DBD::mysql 2.1018…found

So, i try this one
[root@riclinux rt-3-0-5]# perl -MCPAN -e ‘install
Apache::Request::Install’ and it give me the result follows:

CPAN.pm: Going to build J/JO/JOESUF/libapreq-1.2.tar.gz

mod_perl 1.x ( < 1.99) is required at Makefile.PL line 29.
BEGIN failed–compilation aborted at Makefile.PL line 31.
Running make test
Make had some problems, maybe interrupted? Won’t test
Running make install
Make had some problems, maybe interrupted? Won’t install
[root@riclinux rt-3-0-5]#

How should I install those modules? using tar?
and what actually is the difference between modperl1, modperl2 and
fasstcgi?

Thanks in advance for giving me some help.

Best Regards,
Ada Hui


No masks required! Use MSN Messenger to chat with friends and family.
http://go.msnserver.com/HK/25382.asp


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

—rommie

I have problem initializing my postgres database when I issue

make initialize-database

/usr/bin/perl //usr/local/rt/sbin/rt-setup-database --action init --dba
root --prompt-for-dba-password
In order to create a new database and grant RT access to that database,
this script needs to connect to your Pg instance on localhost as root.
Please specify that user’s database password below. If the user has no
database
password, just press return.

Password: DBI connect(‘dbname=template1;host=localhost’,‘root’,…)
failed: could not connect to server: Connection refused at
//usr/local/rt/sbin/rt-setup-database line 80
Failed to connect to dbi:Pg:dbname=template1;host=localhost as root: could
not connect to server: Connection refused at
//usr/local/rt/sbin/rt-setup-database line 80, line 1.
make: *** [initialize-database] Error 255

I checked the postgres, it seems its working

2431 pts/0 S 0:00 postgres: stats buffer process
2432 pts/0 S 0:00 postgres: stats collector process

I checked the mailinglist and I found this entry>From jesse@bestpractical.com Wed Jul 2 19:24:56 2003
From: jesse@bestpractical.com (Jesse Vincent)
Date: Wed, 2 Jul 2003 14:24:56 -0400
Subject: [rt-users] make-initialize failure during DBI connect.connection
refused.
In-Reply-To: 3F03197B.6050604@visalia.k12.ca.us
References: 3F03197B.6050604@visalia.k12.ca.us
Message-ID: 20030702182456.GW12138@fsck.com

Perhaps you don’t have postgres set to listen to TCP connections?

I could use some help.

I am trying to install RT3, but can never get past the make
initialize-database step. I get the following error:

Password: DBI connect(‘dbname=template1;host=localhost’,‘postgres’,…)
failed: PQconnectPoll() – connect() failed: Connection refused at
//opt/rt3/sbin/rt-set
up-database line 80
Failed to connect to dbi:Pg:dbname=template1;host=localhost as postgres:
PQconnectPoll() – connect() failed: Connection refused at
//opt/rt3/sbin/rt-setup-data
base line 80, line 1.
make: *** [initialize-database] Error 255

I have Apache 1.2.34 and mod_perl 1.27. Everythings seems ok when I
check for intalled modules (see below), and I have a valid Postgresql
user and password defined in the ./configure statement. I can run
the psql client with no problem. I would appreciate any advice or help
on this problem.

Thanks,

Mat

Im not sure if we have the same problem. I quite new with postgres, so I
don’t know how to check and change this TCP connection.

–rommie

Guys!

I just finished installing all missing perl modules for FastCGI +
Postgres (see my previous message) and I used the tarball so I will know
everything(WHEW!) These are my complete lists for your info.

Param-Validate-0.65 Dave Rolsky

Cache-Cache-1.02 DeWitt Clinton
Error-0.15 Arun Kumar U
Digest-SHA1-2.04 Gisle Aas
IPC-ShareLite-0.09 Maurice Aubrey

Exception-Class-1.15 Dave Rolsky
Class-Data-Inheritable-0.02 Michael G Schwern
Devel-StackTrace-1.03 Dave Rolsky *

HTML-Mason-1.23 Dave Rolsky *
Class-Container-0.10 Ken Williams
Apache-Filter-1.022 Ken Williams *

FreezeThaw-0.43 Ilya Zakharevich
MLDBM-2.01 Joshua Chamas
Digest-MD5-2.27 Gisle Aas
Apache-Session-1.54 Jeffrey Baker
HTML-Tree-3.18 Sean M. Burke
HTML-Parser-3.31 Gisle Aas
HTML-Tagset-3.03 Sean M. Burke

HTML-Format-2.03 Sean M. Burke
Font-AFM-1.18 Gisle Aas

DBI-1.38 Tim Bunce *
Test-Inline-0.15 Michael G Schwern
Class-ReturnValue-0.51 Jesse Vincent
DBIx-SearchBuilder-0.92 Jesse Vincent
Text-Template-1.44 Mark Jason Dominus
Log-Dispatch-2.06 Dave Rolsky
Module-Build-0.20_02 Ken Williams
YAML-0.35 Brian Ingerson
ExtUtils::ParseXS Ken Williams
Archive-Tar-1.05 Jos Boumans

Locale-Maketext-1.06 Sean M. Burke
I18N-LangTags-0.28 Sean M. Burke

Locale-Maketext-Fuzzy-0.02 Autrijus Tang
Locale-Maketext-Lexicon-0.28 Autrijus Tang
Regexp-Common-2.113 Abigail
Locale-Maketext-Gettext-1.10 imacat - mistakenly installed

MIME-tools-6.200_02 Eryq
MIME-tools-5.411a Eryq - i think this one is needed
IO-stringy-2.108 Eryq
MailTools-1.59 Mark Overmeer
Unicode-Map-0.112 Martin Schwartz
Unicode-Map8-0.12 Gisle Aas - I installed both (I’m not sure which
one
is needed)

Text-Wrapper-1.000 Christopher J. Madsen
Time-modules-2003.0211 David Muir Sharnoff
TermReadKey-2.21 Jonathan Stowe *
Text-Autoformat-1.12 Damian Conway *
Text-Reform-1.11 Damian Conway

Text-Quoted-1.2 Simon Cozens
Time-HiRes-1.51 Jarkko Hietaniemi

WWW-Mechanize-0.59 Andy Lester *
libwww-perl-5.69 Gisle Aas
IO-Socket-SSL-0.95 Peter Behroozi
Net_SSLeay.pm-1.25 Sampo Kellomaki *

    • I ignored some minor errors.

So I end up here on this dependency test.

perl sbin/rt-test-dependencies --with-postgrsql --with-fastcgi

perl:
5.8.0…found

MASON dependencies:
Params::Validate 0.02…found
Cache::Cache …found
Exception::Class …found
HTML::Mason 1.16…found
MLDBM …found
Errno …found
FreezeThaw …found
Digest::MD5 2.27…found
CGI::Cookie 1.20…found
Storable …found
Apache::Session 1.53…found

FASTCGI dependencies:
CGI …found
FCGI …found
CGI::Fast …found

MAILGATE dependencies:
HTML::TreeBuilder …found
HTML::FormatText …found
Getopt::Long …found
LWP::UserAgent …found

POSTGRESQL dependencies:
DBD::Pg …found

CLI dependencies:
Getopt::Long 2.24…found

CORE dependencies:
Digest::MD5 2.27…found
DBI 1.37…found
Test::Inline …found
Class::ReturnValue 0.40…found
DBIx::SearchBuilder 0.92…found
Text::Template …found
File::Spec 0.8…found
HTML::Entities …found
Net::Domain …found
Log::Dispatch 2.0…found
Locale::Maketext 1.06…found
Locale::Maketext::Lexicon 0.25…found
Locale::Maketext::Fuzzy …found
MIME::Entity 5.108…found
Mail::Mailer 1.57…found
Net::SMTP …found
Text::Wrapper …found
Time::ParseDate …found
File::Temp …found
Term::ReadKey …found
Text::Autoformat …found
Text::Quoted …found

DEV dependencies:
Regexp::Common …found
Time::HiRes …found
Test::Inline …found
WWW::Mechanize …found

So, I will now work on my postgres database. (Hello! did I miss
something?)

This is still on your rh9 distro? I will try to walk through this with
you. Do a fresh install of rh9, then run up2date and make sure you are
current on everything, kernel as well. I will locate a box here that I
can do the same with and we will walk through the installation of
3.0.5.

Michael

-----Original Message-----
From: request_tracker@acerhomes.com
[mailto:request_tracker@acerhomes.com]
Posted At: Thursday, September 18, 2003 10:44 AM
Posted To: RT
Conversation: [rt-users] Good Instruction for RT3 + Apache2 + FastCGI

  • MYSQL
    Subject: [rt-users] Good Instruction for RT3 + Apache2 + FastCGI +
    MYSQL

Hey Guys!

Im frustrated already. I can’t make my RT3 installation work for
Apache 1.3 + mod_perl1 (my precious 5 days already wasted). Since I
don’t get answer on my problem with Apache-Mason ("Bareword ‘REDIRECT’
error…), I
will push through to use Apache2 + FastCGI.

I need instruction on how to install everything (except MYSQL). I
will try I hope it works…

–rommie


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at
http://fsck.com/rtfm

—rommie


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

—rommie

Rommie wrote:

I have problem initializing my postgres database when I issue

make initialize-database

/usr/bin/perl //usr/local/rt/sbin/rt-setup-database --action init --dba
root --prompt-for-dba-password
In order to create a new database and grant RT access to that database,
this script needs to connect to your Pg instance on localhost as root.
Please specify that user’s database password below. If the user has no
database
password, just press return.

Password: DBI connect(‘dbname=template1;host=localhost’,‘root’,…)
failed: could not connect to server: Connection refused at
//usr/local/rt/sbin/rt-setup-database line 80
Failed to connect to dbi:Pg:dbname=template1;host=localhost as root: could
not connect to server: Connection refused at
//usr/local/rt/sbin/rt-setup-database line 80, line 1.
make: *** [initialize-database] Error 255


Im not sure if we have the same problem. I quite new with postgres, so I
don’t know how to check and change this TCP connection.

–rommie

If the database is on the same box you are running RT on, then you don’t
need to start postgres with TCP connections enabled, unix sockets will
do. That said, you can start postgres with the “-i” option to make it
listen for TCP connections, on port 5432 by default.

I think your problem is more likely to be that the connection is being
tried as user root, which is the mysql database superuser. The
postgresql db superuser is “postgres”. Somewhere in the RT configure.in
or Makefile or however it’s config’ed, there is an option to specify the
db superuser. Change it from root to postgres.

HTH
Rick

Hi Richard!

Thanks for your response.

But I still got the same error. What I did, I changed an entry from
Makefile DB_DBA from root to postgres, so it did change the make
initialize-database
but this was still the message…

/usr/bin/perl //usr/local/rt/sbin/rt-setup-database --action init --dba
postgres --prompt-for-dba-password
In order to create a new database and grant RT access to that database,
this script needs to connect to your Pg instance on localhost as postgres.
Please specify that user’s database password below. If the user has no
database
password, just press return.

Password: DBI connect(‘dbname=template1;host=localhost’,‘postgres’,…)
failed: could not connect to server: Connection refused at
//usr/local/rt/sbin/rt-setup-database line 80
Failed to connect to dbi:Pg:dbname=template1;host=localhost as postgres:
could not connect to server: Connection refused at
//usr/local/rt/sbin/rt-setup-database line 80, line 1.
make: *** [initialize-database] Error 255

I checked again postgres and also password…

1054 ? S 0:00 postgres: stats buffer process
1055 ? S 0:00 postgres: stats collector process

Do you have any other ideas?

–rommie

Rommie wrote:

I have problem initializing my postgres database when I issue

make initialize-database

/usr/bin/perl //usr/local/rt/sbin/rt-setup-database --action init
–dba root --prompt-for-dba-password
In order to create a new database and grant RT access to that
database, this script needs to connect to your Pg instance on
localhost as root. Please specify that user’s database password below.
If the user has no database
password, just press return.

Password: DBI connect(‘dbname=template1;host=localhost’,‘root’,…)
failed: could not connect to server: Connection refused at
//usr/local/rt/sbin/rt-setup-database line 80
Failed to connect to dbi:Pg:dbname=template1;host=localhost as root:
could not connect to server: Connection refused at
//usr/local/rt/sbin/rt-setup-database line 80, line 1.
make: *** [initialize-database] Error 255


Im not sure if we have the same problem. I quite new with postgres, so
I don’t know how to check and change this TCP connection.

–rommie

If the database is on the same box you are running RT on, then you don’t
need to start postgres with TCP connections enabled, unix sockets will
do. That said, you can start postgres with the “-i” option to make it
listen for TCP connections, on port 5432 by default.

I think your problem is more likely to be that the connection is being
tried as user root, which is the mysql database superuser. The
postgresql db superuser is “postgres”. Somewhere in the RT configure.in
or Makefile or however it’s config’ed, there is an option to specify the
db superuser. Change it from root to postgres.

HTH
Rick


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

—rommie

Rommie wrote:

Hi Richard!

Thanks for your response.

But I still got the same error.

Do you have any other ideas?

Yeah, have you tried connecting to postgres from the psql client?

At the command line type “psql -U postgres template1”. If this gives an
error then there is no point trying with RT because postmaster isn’t
listening. If this connects alright then at least you know postmaster is
running OK.

Let me know what happens.

R

Yes. Its working.

[root@server2 rt-3-0-5]# psql -U postgres template1
Welcome to psql 7.3.2, the PostgreSQL interactive terminal.

Type: \copyright for distribution terms
\h for help with SQL commands
? for help on internal slash commands
\g or terminate with semicolon to execute query
\q to quit

template1=#

—rommie

From: “Rommie” request_tracker@acerhomes.com
Yes. Its working.

[root@server2 rt-3-0-5]# psql -U postgres template1
Welcome to psql 7.3.2, the PostgreSQL interactive terminal.

In the RedHat default setup postmaster only listens on local
unix domain sockets. Psql uses them but perl/DBI needs
tcp sockets even for local connections. You need to edit
/var/lib/pgsql/data/postgresql.conf and set
tcpip_socket = true, then restart postgresql. You will also
have to set the authentication mode in
/var/lib/pgsql/data/pg_hba.conf. A line like:
host all all 127.0.0.1 255.255.255.255 trust
will let anything work for testing but you’ll want to change
it from trust to password as soon as you can.

However, I’ve done all that, updated to postgresql 7.3.4 and
got the basics working but it still takes about a minute and a
half for the first screen to come up after importing the 13,000
tickets from an rt2/mysql system that is fairly fast. (And I
did do a vacuum analyze after the import.) I thought
at first it was from using perl 5.6.1 on a RH7.3 system but have
repeated the setup on RH9 with approximately the same results.
I haven’t had time to try switching to mysql yet.

Les Mikesell
les@futuresource.com

Yes, Its works…Thanks Les, Jim, Richard. But I’m not yet finished. I hope
you guys will stick with me.

I just post these messages for future reference
[root@server2 rt-3-0-5]# make initialize-database
/usr/bin/perl //usr/local/rt/sbin/rt-setup-database --action init --dba
postgres
Now creating a database for RT.
Creating Pg database rt3.
Now populating database schema.
Creating database schema.
NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index
’attachments_pkey’ for table ‘attachments’
NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index
’queues_pkey’ for table ‘queues’
NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index
’links_pkey’ for table ‘links’
NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index
’principals_pkey’ for table ‘principals’
NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index
’groups_pkey’ for table ‘groups’
NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index
’scripconditions_pkey’ for table ‘scripconditions’
NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index
’transactions_pkey’ for table ‘transactions’
NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index
’scrips_pkey’ for table 'scrips’
NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index 'acl_pkey’
for table ‘acl’
NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index
’groupmembers_pkey’ for table ‘groupmembers’
NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index
’cachedgroupmembers_pkey’ for table ‘cachedgroupmembers’
NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index
’users_pkey’ for table ‘users’
NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index
’tickets_pkey’ for table ‘tickets’
NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index
’scripactions_pkey’ for table ‘scripactions’
NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index
’templates_pkey’ for table ‘templates’
NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index
’ticketcustomfieldvalues_pkey’ for table ‘ticketcustomfieldvalues’
NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index
’customfields_pkey’ for table ‘customfields’
NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index
’customfieldvalues_pkey’ for table ‘customfieldvalues’
NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index
’sessions_pkey’ for table 'sessions’
schema sucessfully inserted
Now inserting database ACLs
Now inserting RT core system objects
Checking for existing system user…not found. This appears to be a new
installation.
Creating system user…done.
Now inserting RT data
Creating Superuser ACL…Creating groups…3.4.5.6.7.8.9.done.
Creating users…10.12.done.
Creating queues…1.2.done.
Creating ACL…2.3.done.
Creating ScripActions…1.2.3.4.5.6.7.8.9.10.11.12.13.14.15.done.
Creating ScripConditions…1.2.3.4.5.6.7.8.9.done.
Creating templates…1.2.3.4.5.6.7.8.9.10.11.12.done.
Creating scrips…1.2.3.4.5.6.7.8.9.10.11.12.13.done.

—rommie