GnuPG no default secret key

I am running 3.8.8 on RHEL5 and was trying to setup and use
gpg encryption and signing. I hoped to allow some users, on some
queues, to encrypt and/or sign messages (specifically for RTIR queues)

After setting up a key for myself, and setting my key in my Preferences,
I could not create a ticket.

The error log shows:

[Fri Dec 17 19:12:58 2010] [error]: gpg: no default secret key: secret
key not available
gpg: signing failed: secret key not available

So I moved aside the secring.gpg file, and dropped back to the old
(empty) one but
I still receive the error. In my preferences, it still shows my
Cryptography->Preferred Key.

Any ideas on how to change my Cryptography preferences back to NO KEY ?

My relevant options are:

GnuPG from rt1 setup

Set( %GnuPG,
Enable => 1,
OutgoingMessagesFormat => ‘RFC’, # Inline
AllowEncryptDataInDB => 0,

RejectOnMissingPrivateKey => 1,
RejectOnBadData           => 1,


homedir => ‘/usr/site/rt/var/data/gpg’,

URL of a keyserver

keyserver => 'hkp://',

enables the automatic retrieving of keys when encrypting

'auto-key-locate' => 'keyserver',

enables the automatic retrieving of keys when verifying signatures

'keyserver-options' => 'auto-key-retrieve',


Any info on setting up GnuPG and setting up keys for individual users
would be

Susan McClure