FW: Comments

Hi everyone,

I’m having issues with comments on RT, whereby someone in our company
that does not use the system replies using the comment address and this
comment goes off to the requester still.

I have set-up a comment address and as far as I can see it’s working
correctly, but sometimes it goes off to the requester.

I have been testing and when I do it the comment does not come back to
my test address, but if a customer emails, we send a comment to the
sales team, they reply (using outlook) and the comment goes off back to
the customer.

Can someone tell me how to overcome this issue?

I have this set -

Set($CorrespondAddress , ‘help@mydomain.co.uk’);

Set($CommentAddress , ‘help-int@mydomain.co.uk’);

I also have this set in fetchmail -

less /usr/local/etc/fetchmailrc

poll mail.mydomain.co.uk proto pop3:

username help0x023box password blahblah mda
"/usr/local/bin/rt-mailgate --url http://rt.mydomain.co.uk --queue Help
–action correspond --debug"

username richtesthelp password blahblah mda
"/usr/local/bin/rt-mailgate --url http://rt.mydomain.co.uk --queue Help
–action comment --debug"

What other information do you need?

Richard

Richard,

Have you checked ALL scrips to see if there is one that is initiated by
comments? Although this is not normal, someone could have created such a
scrip.

Kenn
LBNLOn Fri, May 14, 2010 at 2:59 AM, Richard Mealing richard@fastnet.co.ukwrote:

Hi everyone,

I’m having issues with comments on RT, whereby someone in our company that
does not use the system replies using the comment address and this comment
goes off to the requester still.

I have set-up a comment address and as far as I can see it’s working
correctly, but sometimes it goes off to the requester.

I have been testing and when I do it the comment does not come back to
my test address, but if a customer emails, we send a comment to the sales
team, they reply (using outlook) and the comment goes off back to the
customer.

Can someone tell me how to overcome this issue?

I have this set –

Set($CorrespondAddress , ‘help@mydomain.co.uk’);

Set($CommentAddress , ‘help-int@mydomain.co.uk’);

I also have this set in fetchmail –

less /usr/local/etc/fetchmailrc

poll mail.mydomain.co.uk proto pop3:

username help0x023box password blahblah mda “/usr/local/bin/rt-mailgate
–url http://rt.mydomain.co.uk --queue Help --action correspond --debug”

username richtesthelp password blahblah mda “/usr/local/bin/rt-mailgate
–url http://rt.mydomain.co.uk --queue Help --action comment --debug”

What other information do you need?

Richard

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Hi Kenn,

Hmm, I have this set -

8 On Comment Notify AdminCcs as Comment with template Admin
Comment

        On Comment Notify AdminCcs as Comment

9 On Comment Notify Other Recipients as Comment with template
Correspondence

        On Comment Notify Other Recipients as Comment

5 On Correspond Notify AdminCcs with template Admin
Correspondence

        On Correspond Notify AdminCcs

7 On Correspond Notify Other Recipients with template
Correspondence

        On Correspond Notify Other Recipients

6 On Correspond Notify Requestors and Ccs with template
Correspondence

        On Correspond Notify Requestors and Ccs

1 On Correspond Open Tickets with template Blank

        On Correspond Open Tickets

3 User Defined Autoreply To Requestors with template Autoreply

        On Create Autoreply To Requestors

4 On Create Notify AdminCcs with template Transaction

        On Create Notify AdminCcs

2 On Owner Change Notify Owner with template Transaction

        On Owner Change Notify Owner

10 User Defined Notify Requestors with template Resolved

        On Resolve Notify Requestors

11 On Transaction Extract Subject Tag with template Blank

        On transaction, add any tags in the transaction's subject to

the ticket’s subject

I have it working whereby if you send a comment it goes off to the
address and does not send the comment to the requester, but when they
reply that goes to the requester, which is likely the 5th or 6th script,
but when we correspond obviously we need that to go to the requester.

Would you be so kind as to let me know how you do this?

Would it be better if I configured this via a subdomain, where I could
tell RT to only reply if it did not come from submail.mydomain.com but
otherwise reply?

All I want to achieve is somehow any forwards and comments and replies
to the forward and comments don’t get sent to the requester or anyone
cc’d to them.

However, I want the requester to get replies and an auto reply as soon
as they send a new request.

Many thanks,

RichFrom: Kenneth Crocker [mailto:kfcrocker@lbl.gov]
Sent: 14 May 2010 18:10
To: Richard Mealing; rt-users@lists.bestpractical.com
Subject: Re: [rt-users] FW: Comments.

Richard,

Have you checked ALL scrips to see if there is one that is initiated by
comments? Although this is not normal, someone could have created such a
scrip.

Kenn
LBNL

Richard,

We do NOT have any notifications scrips conditioned on comments. We reserve
comments for AdminCc’s and Owners and sometimes Queue Cc’s. They already
have the rights to see a ticket so we don’t have to worry about that kind of
notification mess.

My advice would be to disable all those comment scrips and any customization
related to comments. We’re fairly restrictive on what we let people see/do
to tickets. Hope this helps.

Kenn
LBNLOn Mon, May 17, 2010 at 6:15 AM, Richard Mealing richard@fastnet.co.ukwrote:

Hi Kenn,

Hmm, I have this set –

8 On Comment Notify AdminCcs as Comment with template Admin
Comment

        On Comment Notify AdminCcs as Comment

9 On Comment Notify Other Recipients as Comment with template
Correspondence

        On Comment Notify Other Recipients as Comment

5 On Correspond Notify AdminCcs with template Admin Correspondence

        On Correspond Notify AdminCcs

7 On Correspond Notify Other Recipients with template
Correspondence

        On Correspond Notify Other Recipients

6 On Correspond Notify Requestors and Ccs with template
Correspondence

        On Correspond Notify Requestors and Ccs

1 On Correspond Open Tickets with template Blank

        On Correspond Open Tickets

3 User Defined Autoreply To Requestors with template Autoreply

        On Create Autoreply To Requestors

4 On Create Notify AdminCcs with template Transaction

        On Create Notify AdminCcs

2 On Owner Change Notify Owner with template Transaction

        On Owner Change Notify Owner

10 User Defined Notify Requestors with template Resolved

        On Resolve Notify Requestors

11 On Transaction Extract Subject Tag with template Blank

        On transaction, add any tags in the transaction's subject to

the ticket’s subject

I have it working whereby if you send a comment it goes off to the address
and does not send the comment to the requester, but when they reply that
goes to the requester, which is likely the 5th or 6th script, but when we
correspond obviously we need that to go to the requester.

Would you be so kind as to let me know how you do this?

Would it be better if I configured this via a subdomain, where I could tell
RT to only reply if it did not come from submail.mydomain.com but
otherwise reply?

All I want to achieve is somehow any forwards and comments and replies to
the forward and comments don’t get sent to the requester or anyone cc’d to
them.

However, I want the requester to get replies and an auto reply as soon as
they send a new request.

Many thanks,

Rich

From: Kenneth Crocker [mailto:kfcrocker@lbl.gov]
Sent: 14 May 2010 18:10
To: Richard Mealing; rt-users@lists.bestpractical.com
Subject: Re: [rt-users] FW: Comments.

Richard,

Have you checked ALL scrips to see if there is one that is initiated by
comments? Although this is not normal, someone could have created such a
scrip.

Kenn
LBNL

On Fri, May 14, 2010 at 2:59 AM, Richard Mealing richard@fastnet.co.uk wrote:

Hi everyone,

I’m having issues with comments on RT, whereby someone in our company that
does not use the system replies using the comment address and this comment
goes off to the requester still.

I have set-up a comment address and as far as I can see it’s working
correctly, but sometimes it goes off to the requester.

I have been testing and when I do it the comment does not come back to
my test address, but if a customer emails, we send a comment to the sales
team, they reply (using outlook) and the comment goes off back to the
customer.

Can someone tell me how to overcome this issue?

I have this set –

Set($CorrespondAddress , ‘help@mydomain.co.uk’);

Set($CommentAddress , ‘help-int@mydomain.co.uk’);

I also have this set in fetchmail –

less /usr/local/etc/fetchmailrc

poll mail.mydomain.co.uk proto pop3:

username help0x023box password blahblah mda “/usr/local/bin/rt-mailgate
–url http://rt.mydomain.co.uk --queue Help --action correspond --debug”

username richtesthelp password blahblah mda “/usr/local/bin/rt-mailgate
–url http://rt.mydomain.co.uk --queue Help --action comment --debug”

What other information do you need?

Richard

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com