"From" address for locally-created tickets; Slowness only upon "submit"

Hi,

I am so glad to have found this list! Having used RT in my
previous position, I insisted on having it installed at our present
company, and have never looked back! Thank you, Jesse!

I have a question - I’ve read all through the online manual, and
searched where I could - so if I overlooked this, I apologize!

We are having a situation where one of our users (logging in from
across the country) often finds things slow waaay down after she
"submits" - so everything else is fine, but when she clicks on submit,
it takes forever for it to go through, and sometimes it goes to a
"page not found" error. I actually experience the slowness problem
here, but it’s never gone to “page not found”. Does anyone have
any ideas as to what we should look at for this?

Thanks!

Anne

We are having a situation where one of our users (logging in from
across the country) often finds things slow waaay down after she
"submits" - so everything else is fine, but when she clicks on submit,
it takes forever for it to go through, and sometimes it goes to a
"page not found" error. I actually experience the slowness problem
here, but it’s never gone to “page not found”. Does anyone have
any ideas as to what we should look at for this?

Sounds as if the SQL statement is taking its time for the INSERTs.

Which database is this? Which version of RT?

Some SQL tuning/optimising might be needed. Can you see on the database
that it is busy processing your SQL when you are logged into it using a
web-based system or the command line?

Jeroen Ruigrok van der Werven <asmodai(at)wxs.nl> / asmodai / a capoeirista
PGP fingerprint: 2D92 980E 45FE 2C28 9DB7 9D88 97E6 839B 2EAC 625B
http://www.tendra.org/ | http://www.in-nomine.org/~asmodai/diary/
The Miracle of Love will take away your pain…

Dear Jeroen, et al:

We are having a situation where one of our users (logging in
from >across the country) often finds things slow waaay down after she
"submits" - so everything else is fine, but when she clicks on
submit, >it takes forever for it to go through, and sometimes it
goes to a >“page not found” error. I actually experience the slowness
problem >here, but it’s never gone to “page not found”. Does anyone
have >any ideas as to what we should look at for this?

Sounds as if the SQL statement is taking its time for the INSERTs.

Which database is this? Which version of RT?

The database is MySQL. the version of RT, according to the
login page, is 2.0.15.

Some SQL tuning/optimising might be needed. Can you see on the
database that it is busy processing your SQL when you are logged into
it using a web-based system or the command line?

I’ve asked our developer about this, and will let you know as soon
as I do!

Thanks!!

Anne

Hi again folks,

Perhaps this is related to our other problem (very slow submission
requests on part of one user) as it’s the same user…but…

We have a user with whom every ticket - instead of the text of
the body for each ticket being displayed in the main body of the
ticket, you have to click on “download” to see it (which is a pain in
the neck). This only happens with tickets she owns (interestingly,
once she owns them, they convert to that “format” even if before
they were not, and changing owners does not undo it.

Has anyone seen this problem before? I can’t find anything in the
docs, can’t find any unique setting for the user…we’re at a loss!

Thanks!

Anne

I’ve seen this. When a uses sends email as HTML only, RT won’t
automatically forward the attachment (HTML encoded message). If a user
sends an email as plain text & HTML you will receive the request and be
able to see the formatted HTML text when “download” is clicked within
RT. There is a script that will “NotifyWithAttachments”. -n8-----Original Message-----
From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com] On Behalf Of Anne P. Mitchell,
Esq.
Sent: Friday, March 07, 2003 10:21 AM
To: rt-users@lists.fsck.com
Subject: [rt-users] Some users tickets have all text hidden and must be
"downloaded"?

Hi again folks,

Perhaps this is related to our other problem (very slow submission
requests on part of one user) as it’s the same user…but…

We have a user with whom every ticket - instead of the text of
the body for each ticket being displayed in the main body of the
ticket, you have to click on “download” to see it (which is a pain in
the neck). This only happens with tickets she owns (interestingly,
once she owns them, they convert to that “format” even if before
they were not, and changing owners does not undo it.

Has anyone seen this problem before? I can’t find anything in the
docs, can’t find any unique setting for the user…we’re at a loss!

Thanks!

Anne

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

I’ve seen this. When a uses sends email as HTML only, RT won’t
automatically forward the attachment (HTML encoded message). If a user
sends an email as plain text & HTML you will receive the request and be
able to see the formatted HTML text when “download” is clicked within
RT. There is a script that will “NotifyWithAttachments”. -n8-----Original Message-----
From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com] On Behalf Of Anne P. Mitchell,
Esq.
Sent: Friday, March 07, 2003 10:21 AM
To: rt-users@lists.fsck.com
Subject: [rt-users] Some users tickets have all text hidden and must be
"downloaded"?

Hi again folks,

Perhaps this is related to our other problem (very slow submission
requests on part of one user) as it’s the same user…but…

We have a user with whom every ticket - instead of the text of
the body for each ticket being displayed in the main body of the
ticket, you have to click on “download” to see it (which is a pain in
the neck). This only happens with tickets she owns (interestingly,
once she owns them, they convert to that “format” even if before
they were not, and changing owners does not undo it.

Has anyone seen this problem before? I can’t find anything in the
docs, can’t find any unique setting for the user…we’re at a loss!

Thanks!

Anne

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

I’ve seen this. When a uses sends email as HTML only, RT won’t
automatically forward the attachment (HTML encoded message). If a user
sends an email as plain text & HTML you will receive the request and be
able to see the formatted HTML text when “download” is clicked within
RT. There is a script that will “NotifyWithAttachments”. -n8-----Original Message-----
From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com] On Behalf Of Anne P. Mitchell,
Esq.
Sent: Friday, March 07, 2003 10:21 AM
To: rt-users@lists.fsck.com
Subject: [rt-users] Some users tickets have all text hidden and must be
"downloaded"?

Hi again folks,

Perhaps this is related to our other problem (very slow submission
requests on part of one user) as it’s the same user…but…

We have a user with whom every ticket - instead of the text of
the body for each ticket being displayed in the main body of the
ticket, you have to click on “download” to see it (which is a pain in
the neck). This only happens with tickets she owns (interestingly,
once she owns them, they convert to that “format” even if before
they were not, and changing owners does not undo it.

Has anyone seen this problem before? I can’t find anything in the
docs, can’t find any unique setting for the user…we’re at a loss!

Thanks!

Anne

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

I’ve seen this. When a uses sends email as HTML only, RT won’t
automatically forward the attachment (HTML encoded message).

Thank you SO much! I had the user switch from I.E. to Netscape,
and the problem went away!

Anne