From address all screwy


#1

I just moved our RT instance to a new server. It works as it should
with one exception. It no longer sends email “from” the queue.
Instead, it is shown as coming from the apache user (wwwrun on
openSUSE). To be more specific, the Sender is listed as the apache user
but the From header is the person that sent the email.

“WWW daemon apache [wwwrun@company.com]; on behalf of; User Name via RT
[is@company.com]”

I’m using an identical Postfix config file and simply copied the
database over from the old server. I’ve found this to be the case in
both Outlook and Thunderbird. Also, I did some searching and the only
thing I could find that might fix the problem is setting up a trusted
user. The problem with that is Postfix doesn’t use trusted users.

Any thoughts on what I should be doing to fix this?

Mathew
Keep up with my goings on at
http://theillien.blogspot.com/feeds/posts/default.


#2

Also, I did some searching and the only
thing I could find that might fix the problem is setting up a trusted
user. The problem with that is Postfix doesn’t use trusted users.

This depends on your Postfix configuration. I have Postfix set up on our
filter server and have allowed certain senders to bypass most
restrictions.

You may want to post your issue with trusted users to the Postfix list.


#3

After posting to the postfix list like you suggested I was able to find
more information. I think it might be due to not using sendmailpipe as
the $MailCommand in RT_SiteConfig.pm. I made this change because I
didn’t find a command called sendmailpipe on the system. I’m now
wondering if this is a command at all since I asked a former colleague
at another company how they have things set up. They use sendmailpipe
with the -t option but when I set that server up I never verified the
existence of that command. Is sendmailpipe an RT internal thing or is
there a command which needs to be installed?

Mathew

Duane Hill wrote:> On Wed, 18 Jun 2008, Mathew Snyder wrote:

Also, I did some searching and the only
thing I could find that might fix the problem is setting up a trusted
user. The problem with that is Postfix doesn’t use trusted users.

This depends on your Postfix configuration. I have Postfix set up on our
filter server and have allowed certain senders to bypass most restrictions.

You may want to post your issue with trusted users to the Postfix list.

Keep up with my goings on at
http://theillien.blogspot.com/feeds/posts/default.


#4

After posting to the postfix list like you suggested I was able to
find
more information. I think it might be due to not using sendmailpipe
as
the $MailCommand in RT_SiteConfig.pm. I made this change because I
didn’t find a command called sendmailpipe on the system. I’m now
wondering if this is a command at all since I asked a former colleague
at another company how they have things set up. They use sendmailpipe
with the -t option but when I set that server up I never verified the
existence of that command. Is sendmailpipe an RT internal thing or is
there a command which needs to be installed?

None of those are system commands. They’re the names of RT mail
sending methods.


#5

That’s what I was thinking. I’ve changed the $MailCommand option back
to sendmailpipe and the $SendmailArguments back to “-oi -t”. This has
solved the problem.

Mathew

Jesse Vincent wrote:

After posting to the postfix list like you suggested I was able to find
more information. I think it might be due to not using sendmailpipe as
the $MailCommand in RT_SiteConfig.pm. I made this change because I
didn’t find a command called sendmailpipe on the system. I’m now
wondering if this is a command at all since I asked a former colleague
at another company how they have things set up. They use sendmailpipe
with the -t option but when I set that server up I never verified the
existence of that command. Is sendmailpipe an RT internal thing or is
there a command which needs to be installed?

None of those are system commands. They’re the names of RT mail sending
methods.

Mathew

Duane Hill wrote:

Also, I did some searching and the only
thing I could find that might fix the problem is setting up a trusted
user. The problem with that is Postfix doesn’t use trusted users.

This depends on your Postfix configuration. I have Postfix set up on our
filter server and have allowed certain senders to bypass most
restrictions.

You may want to post your issue with trusted users to the Postfix list.


Keep up with my goings on at
http://theillien.blogspot.com/feeds/posts/default.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Keep up with my goings on at
http://theillien.blogspot.com/feeds/posts/default.


#6

As far as I can tell, the ‘sendmailpipe’ reference in the RT config files
is simply an argument that tells the RT email functions how to call the
sendmail binary.

I think your problems will go away if you simply remove all your sendmail
configuration arguments from your RT_SiteConfig.pm file and just rely on
the defaults in RT_Config.pm.

James Moseley

         Mathew Snyder                                                 
         <mathew.snyder@gm                                             
         ail.com>                                                   To 
         Sent by:                  d.hill@yournetplus.com              
         rt-users-bounces@                                          cc 
         lists.bestpractic         rt Users                            
         al.com                    <rt-users@lists.bestpractical.com>  
                                                               Subject 
                                   Re: [rt-users] From address all     
         06/18/2008 10:32          screwy                              
         AM                                                            

After posting to the postfix list like you suggested I was able to find
more information. I think it might be due to not using sendmailpipe as
the $MailCommand in RT_SiteConfig.pm. I made this change because I
didn’t find a command called sendmailpipe on the system. I’m now
wondering if this is a command at all since I asked a former colleague
at another company how they have things set up. They use sendmailpipe
with the -t option but when I set that server up I never verified the
existence of that command. Is sendmailpipe an RT internal thing or is
there a command which needs to be installed?

Mathew

Duane Hill wrote:

Also, I did some searching and the only
thing I could find that might fix the problem is setting up a trusted
user. The problem with that is Postfix doesn’t use trusted users.

This depends on your Postfix configuration. I have Postfix set up on our
filter server and have allowed certain senders to bypass most
restrictions.

You may want to post your issue with trusted users to the Postfix list.

Keep up with my goings on at
http://theillien.blogspot.com/feeds/posts/default.
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com