Forwarding a ticket not creating a ticket in new queue


#21

I have already tried setting $RTAddressRegexp to undef, 1 and empty. Nothing is helping


#22

Have you tried setting $StoreLoops in your RT_SiteConfig.pm? That may at least get RT to try to store messages if it thinks they are actually being detected as part of a mail loop.

Failing that you might be reaching the point where you could consider paying Best Practical for some support/consultancy if you’re still struggling?


#23

What we need to set to the variable $Storeloop? What it actually does and will it be able to fix the problem?


#24

https://docs.bestpractical.com/rt/4.4.4/RT_Config.html#StoreLoops


#26

Hi,
It also did not help.


#27

Did you check if the forwarded emails were being stored? This is to confirm that RT is detecting a mail loop and that is why the emails are not being forwarded. Also just to confirm the user forwarding the ticket does have the CreateTicket right in the new queue?


#28

Hi Craig, How to check if it is getting stored or not?My s$Storedloop value is undef now in the RT_Config.pm file.

Actually the user is not forwarding the ticket t, It is being forwarded from one queue address to another queue mail address., that is forward screen in the from box there is a queue email adress and in to box there is another queue address.forwarding


#29

Does the user doing this action have the ability to create a ticket in the queue that they are forwarding to? Setting $Storedloop to undef means you are disabling the feature you should set it to 1. You should also not edit the RT_Config.pm file but instead the RT_SiteConfig.pm file.


#30

yes Craig, I have the admin access to RT so I have access to each queue.
So Could you please tell me, where to put the $Storedloop line, I mean what is the exact line I need to put on RT_SiteConfig.pm.


#31

Hi Craig,
I added this line in SiteCOnfig.pm
still it’s not working
Set($Storeloops, 1);


#32

This is only to test if you have a mail loop, can you check your RT logs again for a line like this:

 [critical]: RT Received mail (<rt-4.4.3 ) from itself. (/opt/rt4/sbin/../lib/RT/Interface/Email.pm:506)
 [crit]: RT Bounce: [MyRT #1598] Fwd: Subject: RT thinks this message may be a bounce (/opt/rt4/sbin/../lib/RT/Interface/Email.pm:705)

That is what I see when I try to forward a ticket to another RT email address, if you look at the code where that error message is generated you see this comment:

# Warn someone if it's a loop, before we drop it on the ground
    if ($IsALoop) {
        my $MessageId = Encode::decode( "UTF-8", $head->get('Message-ID') );
        $RT::Logger->crit("RT Received mail ($MessageId) from itself.");

So RT intentionally drops the email due to a loop being detected.


#34

Thanks Craig!!
I also get the same error. PFA screenshot (forwarding not working)for the reference. Please also find the second screenshot(forwarding working) for reference, where the forwarding functionality works that is when I forward the ticket to any different RT queue address I got a ticket in the other queue. I just have an old RT instance(4.0.5) where the forwarding functionality works. I just want to get the same feature in my new RT instance (4.4.4) where the functionality is not working.

Could you please let me know where I can change my code to get the same functionality.

1st screenshot:(forwarding not working.)

2nd screenshot:(forwarding working.)


#35

Have you got

Set($ForwardFromUser, 1);

in your RT_SiteConfig.pm? If not, try adding it, restarting your webserver and then rerun the tests.


#36

Hey, I have already tried doing the same. Still no result. The message in the log is “RT Bounce”. That’s the reason it is not creating ticket.