Firefox v17 doesn't seem to be able to see the main comment form field for typing in a new request/ticket as a regular user in rt 3.8.1

Hi all,

Anyone see this issue with rt 3.8.1 & firefox v17 on linux when trying
to create a new ticket or when replying to something through the rt
interface as a regular user, the “describe the issue below” form field
never appears?


Works fine with seamonkey , opera, chrome . Haven’t tried other rt
versions or other versions of firefox. Firefox doesn’t seem to be
loading anything and clicking in the area where the form input field
is supposed to be does nothing. This is probably a firefox problem but
just seeing if anyone else noticed this?

Thanks,
Sabuj

yes I did start firefox in safe mode, no luck.

Hi all,

Anyone see this issue with rt 3.8.1 & firefox v17 on linux when trying
to create a new ticket or when replying to something through the rt
interface as a regular user, the “describe the issue below” form field
never appears?

http://i.imgur.com/0zUsF.png

Works fine with seamonkey , opera, chrome . Haven’t tried other rt
versions or other versions of firefox. Firefox doesn’t seem to be
loading anything and clicking in the area where the form input field
is supposed to be does nothing. This is probably a firefox problem but
just seeing if anyone else noticed this?

Modern versions of Firefox don’t like the very old FCKEditor files that
shipped with RT 3.8.1. I believe removing the Unicode BOMs may solve
the issue, but there may also be other problems. Upgrading RT will fix
the problem. If you can’t upgrade RT, you can disable the rich text
editor and use the plain text editor either system-wide (in
RT_SiteConfig.pm) or on a per-user preference basis.

http://bestpractical.com/rt/docs/3.8/RT_Config.html#MessageBoxRichText

There are some previous threads on rt-users about this issue as well.