FC4 - You're almost there!

Please Reply!

I’m getting the login page, but when I login, I’m redirected to the
"You’re almost there!" page. I understand it has to do with the fastcgi
setup with apache.
I’ve searched (http://lists.bestpractical.com/search.html) and read all
the postings concerning the “You’re almost there!” page, but none has
helped.

I’ve already went to www.fastcgi.com for help.

Are there any log files that I can look at to see any errors to
trouble-shoot? The “You’re almost there!” page doesn’t provide much
information for trouble-shooting.

Using Fedora Core 4 distrubution.

more /proc/version

Linux version 2.6.11-1.1369_FC4smp
(bhcompile@decompose.build.redhat.com) (gcc version 4.0.0 20050525 (Red
Hat 4.0.0-9)) #1 SMP Thu Jun 2 23:08:39 EDT 2005

/etc/httpd/conf/httpd.conf
LoadModule fastcgi_module modules/mod_fastcgi.so
NameVirtualHost *:80
<VirtualHost *:80>
ServerName support.ladotek.com
DocumentRoot /opt/rt3/share/html/
ErrorLog /var/log/httpd-rt-error.log
CustomLog /var/log/httpd-rt.log common
AddHandler fastcgi-script .fcgi
Alias /rt/ /opt/rt3/share/html/
Alias /NoAuth/ /opt/rt3/share/html/NoAuth/
<Directory /opt/rt3/bin>
Order allow,deny
Allow from all

<Location /rt/NoAuth/images>
SetHandler default-handler


FastCgiIpcDir /tmp
FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120
ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi

RT_SiteConfig.pm
Set($WebPath , “/rt”);
Set($WebBaseURL , “http://support.ladotek.com:80”);
Set($WebURL , $WebBaseURL . $WebPath . “/”);

[Tue Jun 28 10:46:23 2005] [notice] suEXEC mechanism enabled (wrapper:
/usr/sbin/suexec)
[Tue Jun 28 10:46:24 2005] [notice] Digest: generating secret for digest
authentication …
[Tue Jun 28 10:46:24 2005] [notice] Digest: done
[Tue Jun 28 10:46:24 2005] [notice] LDAP: Built with OpenLDAP LDAP SDK
[Tue Jun 28 10:46:24 2005] [notice] LDAP: SSL support unavailable
[Tue Jun 28 10:46:24 2005] [notice] FastCGI: process manager initialized
(pid 13318)
[Tue Jun 28 10:46:24 2005] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 13319)
[Tue Jun 28 10:46:24 2005] [notice] mod_python: Creating 4 session
mutexes based on 256 max processes and 0 max threads.
[Tue Jun 28 10:46:24 2005] [notice] Apache/2.0.54 (Fedora) configured –
resuming normal operations

> Please Reply!

OK :wink:

I installed this two days ago on FC4 using:

http://wiki.bestpractical.com/index.cgi?RHEL4InstallGuide

and the went to (after following the above)

http://wiki.bestpractical.com/index.cgi?ManualInstallation

I just had some apache.apache permission errors, that was all.

I’m getting the login page, but when I login, I’m redirected to the
"You’re almost there!" page. I understand it has to do with the fastcgi
setup with apache.
I’ve searched (http://lists.bestpractical.com/search.html) and read all
the postings concerning the “You’re almost there!” page, but none has
helped.

What do these say:

ErrorLog /var/log/httpd-rt-error.log
CustomLog /var/log/httpd-rt.log common

Standard httpd logs and log/messages and fastcgi logs?

I had a very similar problem with CenOS/RHEL 4. The problem ended up being
a typo (and possibly a misconfiguration, but it works now so I’m not
complaining).

Going to “http://mysite.com/rt” gave me a login screen, after logging in I
received the “You’re almost there!” page.

Going to “http://mysite.com/rt/” gave me a login screen where logging in
actually worked.

I also went through several versions of httpd.conf., here is my
httpd.conf:

LoadModule fastcgi_module modules/mod_fastcgi.so

FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120
ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi

NameVirtualHost *:80
<VirtualHost *:80>
ServerAdmin root
DocumentRoot /opt/rt3/share/html/
#DocumentRoot /var/www/html/
# Adding the following for RT (the ticket tracker)
AddHandler fastcgi-script fcgi
<Directory “/opt/rt3/share/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

# Pass through requests to display images
Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/

Hope this helps.

david skrede
skrede@twt.com

----- Forwarded by David Skrede/MSN/TWT on 06/28/2005 02:38 PM -----

“David Doran” david.doran@ladotek.com
Sent by: rt-users-bounces@lists.bestpractical.com
06/28/2005 11:16 AMTo: rt-users@lists.bestpractical.com
cc:
Subject: [rt-users] FC4 - You’re almost there!

Please Reply!

I’m getting the login page, but when I login, I’m redirected to the
"You’re almost there!" page. I understand it has to do with the fastcgi
setup with apache.
I’ve searched (http://lists.bestpractical.com/search.html) and read all
the postings concerning the “You’re almost there!” page, but none has
helped.

I’ve already went to www.fastcgi.com for help.

Are there any log files that I can look at to see any errors to
trouble-shoot? The “You’re almost there!” page doesn’t provide much
information for trouble-shooting.

Using Fedora Core 4 distrubution.

more /proc/version

Linux version 2.6.11-1.1369_FC4smp
(bhcompile@decompose.build.redhat.com) (gcc version 4.0.0 20050525 (Red
Hat 4.0.0-9)) #1 SMP Thu Jun 2 23:08:39 EDT 2005

/etc/httpd/conf/httpd.conf
LoadModule fastcgi_module modules/mod_fastcgi.so
NameVirtualHost *:80
<VirtualHost *:80>
ServerName support.ladotek.com
DocumentRoot /opt/rt3/share/html/
ErrorLog /var/log/httpd-rt-error.log
CustomLog /var/log/httpd-rt.log common
AddHandler fastcgi-script .fcgi
Alias /rt/ /opt/rt3/share/html/
Alias /NoAuth/ /opt/rt3/share/html/NoAuth/
<Directory /opt/rt3/bin>
Order allow,deny
Allow from all

<Location /rt/NoAuth/images>
SetHandler default-handler


FastCgiIpcDir /tmp
FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120
ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi

RT_SiteConfig.pm
Set($WebPath , “/rt”);
Set($WebBaseURL , “http://support.ladotek.com:80”);
Set($WebURL , $WebBaseURL . $WebPath . “/”);

[Tue Jun 28 10:46:23 2005] [notice] suEXEC mechanism enabled (wrapper:
/usr/sbin/suexec)
[Tue Jun 28 10:46:24 2005] [notice] Digest: generating secret for digest
authentication …
[Tue Jun 28 10:46:24 2005] [notice] Digest: done
[Tue Jun 28 10:46:24 2005] [notice] LDAP: Built with OpenLDAP LDAP SDK
[Tue Jun 28 10:46:24 2005] [notice] LDAP: SSL support unavailable
[Tue Jun 28 10:46:24 2005] [notice] FastCGI: process manager initialized
(pid 13318)
[Tue Jun 28 10:46:24 2005] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 13319)
[Tue Jun 28 10:46:24 2005] [notice] mod_python: Creating 4 session
mutexes based on 256 max processes and 0 max threads.
[Tue Jun 28 10:46:24 2005] [notice] Apache/2.0.54 (Fedora) configured –
resuming normal operations

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Can you please email me your httpd.conf file?

I’ve copied this to the main list for others too.

This is the whole httpd.conf. I’ve not changed a lot of defaults so it’s not
properly optimised (apache, that is):

ServerTokens OS
ServerRoot "/etc/httpd"
PidFile run/httpd.pid
Timeout 300
KeepAlive Off
MaxKeepAliveRequests 100
KeepAliveTimeout 15

StartServers 8 MinSpareServers 5 MaxSpareServers 20 MaxClients 10 MaxRequestsPerChild 1000 StartServers 2 MaxClients 150 MinSpareThreads 25 MaxSpareThreads 75 ThreadsPerChild 25 MaxRequestsPerChild 0 NumServers 5 StartThreads 5 MinSpareThreads 5 MaxSpareThreads 10 MaxThreadsPerChild 20 MaxRequestsPerChild 0

Listen 80

LoadModule access_module modules/mod_access.so
LoadModule auth_module modules/mod_auth.so
LoadModule auth_anon_module modules/mod_auth_anon.so
LoadModule auth_dbm_module modules/mod_auth_dbm.so
LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule include_module modules/mod_include.so
LoadModule log_config_module modules/mod_log_config.so
LoadModule env_module modules/mod_env.so
LoadModule mime_magic_module modules/mod_mime_magic.so
LoadModule cern_meta_module modules/mod_cern_meta.so
LoadModule expires_module modules/mod_expires.so
LoadModule headers_module modules/mod_headers.so
LoadModule usertrack_module modules/mod_usertrack.so
LoadModule unique_id_module modules/mod_unique_id.so
LoadModule setenvif_module modules/mod_setenvif.so
LoadModule mime_module modules/mod_mime.so
LoadModule dav_module modules/mod_dav.so
LoadModule status_module modules/mod_status.so
LoadModule autoindex_module modules/mod_autoindex.so
LoadModule asis_module modules/mod_asis.so
LoadModule info_module modules/mod_info.so
LoadModule cgi_module modules/mod_cgi.so
LoadModule dav_fs_module modules/mod_dav_fs.so
LoadModule vhost_alias_module modules/mod_vhost_alias.so
LoadModule negotiation_module modules/mod_negotiation.so
LoadModule dir_module modules/mod_dir.so
LoadModule imap_module modules/mod_imap.so
LoadModule actions_module modules/mod_actions.so
LoadModule speling_module modules/mod_speling.so
LoadModule userdir_module modules/mod_userdir.so
LoadModule alias_module modules/mod_alias.so
LoadModule rewrite_module modules/mod_rewrite.so
LoadModule proxy_module modules/mod_proxy.so
LoadModule proxy_ftp_module modules/mod_proxy_ftp.so
LoadModule proxy_http_module modules/mod_proxy_http.so
LoadModule proxy_connect_module modules/mod_proxy_connect.so
LoadModule fastcgi_module modules/mod_fastcgi.so

Include conf.d/*.conf

AddType application/x-httpd-php .php .phtml
AddType application/x-httpd-php-source .phps

User apache
Group apache

ServerAdmin webmaster@suretecsystems.com

ServerName www.suretecsystems.com:80

UseCanonicalName Off

DocumentRoot “/var/www/html/suretecsystems”

Options FollowSymLinks AllowOverride None

<Directory “/var/www/html/suretecsystems”>

AllowOverride None
Order allow,deny
Allow from all

<LocationMatch "^/$>
Options -Indexes
ErrorDocument 403 /error/noindex.html

UserDir disable

DirectoryIndex index.html index.html.var

AccessFileName .htaccess

<Files ~ “^.ht”>
Order allow,deny
Deny from all

TypesConfig /etc/mime.types

DefaultType text/plain

MIMEMagicFile conf/magic

HostnameLookups On

ErrorLog logs/error_log
LogLevel warn
LogFormat "%h %l %u %t “%r” %>s %b “%{Referer}i” “%{User-Agent}i”"
combined
LogFormat “%h %l %u %t “%r” %>s %b” common
LogFormat “%{Referer}i -> %U” referer
LogFormat “%{User-agent}i” agent

CustomLog logs/access_log combined

ServerSignature Off

Alias /icons/ “/var/www/icons/”

<Directory “/var/www/icons”>
Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all

IndexOptions FancyIndexing VersionSort NameWidth=*

AddIconByEncoding (CMP,/icons/compressed.gif) x-compress x-gzip

AddIconByType (TXT,/icons/text.gif) text/*
AddIconByType (IMG,/icons/image2.gif) image/*
AddIconByType (SND,/icons/sound2.gif) audio/*
AddIconByType (VID,/icons/movie.gif) video/*

AddIcon /icons/binary.gif .bin .exe
AddIcon /icons/binhex.gif .hqx
AddIcon /icons/tar.gif .tar
AddIcon /icons/world2.gif .wrl .wrl.gz .vrml .vrm .iv
AddIcon /icons/compressed.gif .Z .z .tgz .gz .zip
AddIcon /icons/a.gif .ps .ai .eps
AddIcon /icons/layout.gif .html .shtml .htm .pdf
AddIcon /icons/text.gif .txt
AddIcon /icons/c.gif .c
AddIcon /icons/p.gif .pl .py
AddIcon /icons/f.gif .for
AddIcon /icons/dvi.gif .dvi
AddIcon /icons/uuencoded.gif .uu
AddIcon /icons/script.gif .conf .sh .shar .csh .ksh .tcl
AddIcon /icons/tex.gif .tex
AddIcon /icons/bomb.gif core

AddIcon /icons/back.gif …
AddIcon /icons/hand.right.gif README
AddIcon /icons/folder.gif ^^DIRECTORY^^
AddIcon /icons/blank.gif ^^BLANKICON^^

DefaultIcon /icons/unknown.gif

ReadmeName README.html
HeaderName HEADER.html

IndexIgnore .??* ~ # HEADER README RCS CVS *,v *,t

AddEncoding x-compress Z
AddEncoding x-gzip gz tgz

AddLanguage da .dk
AddLanguage nl .nl
AddLanguage en .en
AddLanguage et .et
AddLanguage fr .fr
AddLanguage de .de
AddLanguage he .he
AddLanguage el .el
AddLanguage it .it
AddLanguage ja .ja
AddLanguage pl .po
AddLanguage kr .kr
AddLanguage pt .pt
AddLanguage nn .nn
AddLanguage no .no
AddLanguage pt-br .pt-br
AddLanguage ltz .ltz
AddLanguage ca .ca
AddLanguage es .es
AddLanguage sv .se
AddLanguage cz .cz
AddLanguage ru .ru
AddLanguage tw .tw
AddLanguage zh-tw .tw
AddLanguage hr .hr

LanguagePriority en da nl et fr de el it ja kr no pl pt pt-br ltz ca es sv tw

ForceLanguagePriority Prefer Fallback

AddDefaultCharset ISO-8859-1

AddCharset ISO-8859-1 .iso8859-1 .latin1
AddCharset ISO-8859-2 .iso8859-2 .latin2 .cen
AddCharset ISO-8859-3 .iso8859-3 .latin3
AddCharset ISO-8859-4 .iso8859-4 .latin4
AddCharset ISO-8859-5 .iso8859-5 .latin5 .cyr .iso-ru
AddCharset ISO-8859-6 .iso8859-6 .latin6 .arb
AddCharset ISO-8859-7 .iso8859-7 .latin7 .grk
AddCharset ISO-8859-8 .iso8859-8 .latin8 .heb
AddCharset ISO-8859-9 .iso8859-9 .latin9 .trk
AddCharset ISO-2022-JP .iso2022-jp .jis
AddCharset ISO-2022-KR .iso2022-kr .kis
AddCharset ISO-2022-CN .iso2022-cn .cis
AddCharset Big5 .Big5 .big5

AddCharset WINDOWS-1251 .cp-1251 .win-1251
AddCharset CP866 .cp866
AddCharset KOI8-r .koi8-r .koi8-ru
AddCharset KOI8-ru .koi8-uk .ua
AddCharset ISO-10646-UCS-2 .ucs2
AddCharset ISO-10646-UCS-4 .ucs4
AddCharset UTF-8 .utf8

AddCharset GB2312 .gb2312 .gb
AddCharset utf-7 .utf7
AddCharset utf-8 .utf8
AddCharset big5 .big5 .b5
AddCharset EUC-TW .euc-tw
AddCharset EUC-JP .euc-jp
AddCharset EUC-KR .euc-kr
AddCharset shift_jis .sjis

AddType application/x-tar .tgz

AddHandler cgi-script .cgi

AddHandler imap-file map

AddHandler type-map var

AddOutputFilter INCLUDES .shtml

ErrorDocument 500 "Sorry, sorry sorry."
Alias /error/ “/var/www/error/”

AllowOverride None Options IncludesNoExec AddOutputFilter Includes html AddHandler type-map var Order allow,deny Allow from all LanguagePriority en es de fr ForceLanguagePriority Prefer Fallback
ErrorDocument 400 /error/HTTP_BAD_REQUEST.html.var
ErrorDocument 401 /error/HTTP_UNAUTHORIZED.html.var
ErrorDocument 403 /error/HTTP_FORBIDDEN.html.var
ErrorDocument 404 /error/HTTP_NOT_FOUND.html.var
ErrorDocument 405 /error/HTTP_METHOD_NOT_ALLOWED.html.var
ErrorDocument 408 /error/HTTP_REQUEST_TIME_OUT.html.var
ErrorDocument 410 /error/HTTP_GONE.html.var
ErrorDocument 411 /error/HTTP_LENGTH_REQUIRED.html.var
ErrorDocument 412 /error/HTTP_PRECONDITION_FAILED.html.var
ErrorDocument 413 /error/HTTP_REQUEST_ENTITY_TOO_LARGE.html.var
ErrorDocument 414 /error/HTTP_REQUEST_URI_TOO_LARGE.html.var
ErrorDocument 415 /error/HTTP_SERVICE_UNAVAILABLE.html.var
ErrorDocument 500 /error/HTTP_INTERNAL_SERVER_ERROR.html.var
ErrorDocument 501 /error/HTTP_NOT_IMPLEMENTED.html.var
ErrorDocument 502 /error/HTTP_BAD_GATEWAY.html.var
ErrorDocument 503 /error/HTTP_SERVICE_UNAVAILABLE.html.var
ErrorDocument 506 /error/HTTP_VARIANT_ALSO_VARIES.html.var

BrowserMatch “Mozilla/2” nokeepalive
BrowserMatch “MSIE 4.0b2;” nokeepalive downgrade-1.0 force-response-1.0
BrowserMatch “RealPlayer 4.0” force-response-1.0
BrowserMatch “Java/1.0” force-response-1.0
BrowserMatch “JDK/1.0” force-response-1.0

BrowserMatch "Microsoft Data Access Internet Publishing Provider"
redirect-carefully
BrowserMatch “^WebDrive” redirect-carefully

NameVirtualHost *:80

Suretec site

<VirtualHost *:80>
ServerAdmin support@suretecsystems.com
DocumentRoot /var/www/html/suretecsystems
AddDefaultCharset UTF-8
Options Indexes FollowSymLinks
AddHandler fastcgi-script fcgi
<Directory “/opt/rt3/share/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

Alias /NoAuth/ /opt/rt3/share/html/NoAuth/
ServerName www.suretecsystems.com
ServerSignature Off
ErrorLog logs/suretecsystems.com-error_log
CustomLog logs/suretecsystems.com-access_log common

FastCgiIpcDir /tmp
FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120 -processes 4
ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi

David
-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Gavin
Henry
Sent: Tuesday, June 28, 2005 11:31 AM
To: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] FC4 - You’re almost there!

Please Reply!

OK :wink:

I installed this two days ago on FC4 using:

http://wiki.bestpractical.com/index.cgi?RHEL4InstallGuide

and the went to (after following the above)

http://wiki.bestpractical.com/index.cgi?ManualInstallation

I just had some apache.apache permission errors, that was all.

I’m getting the login page, but when I login, I’m redirected to the
"You’re almost there!" page. I understand it has to do with the

fastcgi

setup with apache.
I’ve searched (http://lists.bestpractical.com/search.html) and read

all

the postings concerning the “You’re almost there!” page, but none has
helped.

What do these say:

ErrorLog /var/log/httpd-rt-error.log
CustomLog /var/log/httpd-rt.log common

Standard httpd logs and log/messages and fastcgi logs?

I’ve already went to www.fastcgi.com for help.

Are there any log files that I can look at to see any errors to
trouble-shoot? The “You’re almost there!” page doesn’t provide much
information for trouble-shooting.

Using Fedora Core 4 distrubution.

more /proc/version

Linux version 2.6.11-1.1369_FC4smp
(bhcompile@decompose.build.redhat.com) (gcc version 4.0.0 20050525

(Red

Hat 4.0.0-9)) #1 SMP Thu Jun 2 23:08:39 EDT 2005

/etc/httpd/conf/httpd.conf
LoadModule fastcgi_module modules/mod_fastcgi.so
NameVirtualHost *:80
<VirtualHost *:80>
ServerName support.ladotek.com
DocumentRoot /opt/rt3/share/html/
ErrorLog /var/log/httpd-rt-error.log
CustomLog /var/log/httpd-rt.log common
AddHandler fastcgi-script .fcgi
Alias /rt/ /opt/rt3/share/html/
Alias /NoAuth/ /opt/rt3/share/html/NoAuth/
<Directory /opt/rt3/bin>
Order allow,deny
Allow from all

<Location /rt/NoAuth/images>
SetHandler default-handler


FastCgiIpcDir /tmp
FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120
ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi

RT_SiteConfig.pm
Set($WebPath , “/rt”);
Set($WebBaseURL , “http://support.ladotek.com:80”);
Set($WebURL , $WebBaseURL . $WebPath . “/”);

[Tue Jun 28 10:46:23 2005] [notice] suEXEC mechanism enabled (wrapper:
/usr/sbin/suexec)
[Tue Jun 28 10:46:24 2005] [notice] Digest: generating secret for

digest

authentication …
[Tue Jun 28 10:46:24 2005] [notice] Digest: done
[Tue Jun 28 10:46:24 2005] [notice] LDAP: Built with OpenLDAP LDAP SDK
[Tue Jun 28 10:46:24 2005] [notice] LDAP: SSL support unavailable
[Tue Jun 28 10:46:24 2005] [notice] FastCGI: process manager

initialized

(pid 13318)
[Tue Jun 28 10:46:24 2005] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 13319)
[Tue Jun 28 10:46:24 2005] [notice] mod_python: Creating 4 session
mutexes based on 256 max processes and 0 max threads.
[Tue Jun 28 10:46:24 2005] [notice] Apache/2.0.54 (Fedora) configured

resuming normal operations


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Kind Regards,

Gavin Henry.
Managing Director.

T +44 (0) 1224 279484
M +44 (0) 7930 323266
F +44 (0) 1224 742001
E ghenry@suretecsystems.com

Open Source. Open Solutions™.

http://www.suretecsystems.com/

Hi all,
I wanted to know where the database operations like Insert, delete happens
in RT. I can see this package " DBIx::SearchBuilder::Record::Cachable"
being used in Record.pm. I am guessing that this is the place where the
insert operations to the different tables like Tickets, Groups etc.
happens. Can someone give me the location of this package since i cannot
find it.

Regards,
Ahalya Nathan
Senior Programmer / Analyst
Information Technology, Metropolitan Utilities District
(402) 449-8218 phone
(402) 449-8131 fax
ahalya_nathan@mudnebr.com

Thanks David Skrede and Gavin Henry for the help…

I have RT3 working with FC4 but only if I use trailing “/”. Just like you described, the following works:

	http://support/rt/

but not:
http://support/rt

I’ve been trying to find a work around for this problem but haven’t yet. For now, I’ll just use http://support/rt/

If anyone has a fix for this problem, please let me know.

Thanks,

David Doran-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Skrede@TWT.com
Sent: Tuesday, June 28, 2005 2:42 PM
To: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] FC4 - You’re almost there!

I had a very similar problem with CenOS/RHEL 4. The problem ended up being a typo (and possibly a misconfiguration, but it works now so I’m not complaining).

Going to “http://mysite.com/rt” gave me a login screen, after logging in I received the “You’re almost there!” page.

Going to “http://mysite.com/rt/” gave me a login screen where logging in actually worked.

I also went through several versions of httpd.conf., here is my httpd.conf:

LoadModule fastcgi_module modules/mod_fastcgi.so

FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120
ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi

NameVirtualHost *:80
<VirtualHost *:80>
ServerAdmin root
DocumentRoot /opt/rt3/share/html/
#DocumentRoot /var/www/html/
# Adding the following for RT (the ticket tracker)
AddHandler fastcgi-script fcgi
<Directory “/opt/rt3/share/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

# Pass through requests to display images
Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/

Hope this helps.

david skrede
skrede@twt.com

----- Forwarded by David Skrede/MSN/TWT on 06/28/2005 02:38 PM -----

“David Doran” david.doran@ladotek.com
Sent by: rt-users-bounces@lists.bestpractical.com
06/28/2005 11:16 AM

    To:        <rt-users@lists.bestpractical.com> 
    cc:         
    Subject:        [rt-users] FC4 - You're almost there!

Please Reply!

I’m getting the login page, but when I login, I’m redirected to the
"You’re almost there!" page. I understand it has to do with the fastcgi
setup with apache.
I’ve searched (http://lists.bestpractical.com/search.html) and read all
the postings concerning the “You’re almost there!” page, but none has
helped.

I’ve already went to www.fastcgi.com for help.

Are there any log files that I can look at to see any errors to
trouble-shoot? The “You’re almost there!” page doesn’t provide much
information for trouble-shooting.

Using Fedora Core 4 distrubution.

more /proc/version

Linux version 2.6.11-1.1369_FC4smp
(bhcompile@decompose.build.redhat.com) (gcc version 4.0.0 20050525 (Red
Hat 4.0.0-9)) #1 SMP Thu Jun 2 23:08:39 EDT 2005

/etc/httpd/conf/httpd.conf
LoadModule fastcgi_module modules/mod_fastcgi.so
NameVirtualHost *:80
<VirtualHost *:80>
ServerName support.ladotek.com
DocumentRoot /opt/rt3/share/html/
ErrorLog /var/log/httpd-rt-error.log
CustomLog /var/log/httpd-rt.log common
AddHandler fastcgi-script .fcgi
Alias /rt/ /opt/rt3/share/html/
Alias /NoAuth/ /opt/rt3/share/html/NoAuth/
<Directory /opt/rt3/bin>
Order allow,deny
Allow from all

<Location /rt/NoAuth/images>
SetHandler default-handler


FastCgiIpcDir /tmp
FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120
ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi

RT_SiteConfig.pm
Set($WebPath , “/rt”);
Set($WebBaseURL , “http://support.ladotek.com:80”);
Set($WebURL , $WebBaseURL . $WebPath . “/”);

[Tue Jun 28 10:46:23 2005] [notice] suEXEC mechanism enabled (wrapper:
/usr/sbin/suexec)
[Tue Jun 28 10:46:24 2005] [notice] Digest: generating secret for digest
authentication …
[Tue Jun 28 10:46:24 2005] [notice] Digest: done
[Tue Jun 28 10:46:24 2005] [notice] LDAP: Built with OpenLDAP LDAP SDK
[Tue Jun 28 10:46:24 2005] [notice] LDAP: SSL support unavailable
[Tue Jun 28 10:46:24 2005] [notice] FastCGI: process manager initialized
(pid 13318)
[Tue Jun 28 10:46:24 2005] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 13319)
[Tue Jun 28 10:46:24 2005] [notice] mod_python: Creating 4 session
mutexes based on 256 max processes and 0 max threads.
[Tue Jun 28 10:46:24 2005] [notice] Apache/2.0.54 (Fedora) configured –
resuming normal operations

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

I don’t know if this will solve your problem or not, since I don’t use
fastcgi, but I had a problem almost identical to yours and I found this
fixed it:

 RewriteEngine On
 RewriteRule ^(.*)/$ $1/index.html

Hope this helps,

Ray

David Doran wrote:

Thanks David Skrede and Gavin Henry for the help…

I have RT3 working with FC4 but only if I use trailing “/”. Just like you described, the following works:

  http://support/rt/

but not:
http://support/rt

I’ve been trying to find a work around for this problem but haven’t yet. For now, I’ll just use http://support/rt/

If anyone has a fix for this problem, please let me know.

Thanks,

David Doran

-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Skrede@TWT.com
Sent: Tuesday, June 28, 2005 2:42 PM
To: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] FC4 - You’re almost there!

I had a very similar problem with CenOS/RHEL 4. The problem ended up being a typo (and possibly a misconfiguration, but it works now so I’m not complaining).

Going to “http://mysite.com/rt” gave me a login screen, after logging in I received the “You’re almost there!” page.

Going to “http://mysite.com/rt/” gave me a login screen where logging in actually worked.

I also went through several versions of httpd.conf., here is my httpd.conf:

LoadModule fastcgi_module modules/mod_fastcgi.so

FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120
ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi

NameVirtualHost *:80
<VirtualHost *:80>
ServerAdmin root
DocumentRoot /opt/rt3/share/html/
#DocumentRoot /var/www/html/
# Adding the following for RT (the ticket tracker)
AddHandler fastcgi-script fcgi
<Directory “/opt/rt3/share/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

# Pass through requests to display images
Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/

Hope this helps.

david skrede
skrede@twt.com

----- Forwarded by David Skrede/MSN/TWT on 06/28/2005 02:38 PM -----

“David Doran” david.doran@ladotek.com
Sent by: rt-users-bounces@lists.bestpractical.com
06/28/2005 11:16 AM

    To:        <rt-users@lists.bestpractical.com> 
    cc:         
    Subject:        [rt-users] FC4 - You're almost there!

Please Reply!

I’m getting the login page, but when I login, I’m redirected to the
"You’re almost there!" page. I understand it has to do with the fastcgi
setup with apache.
I’ve searched (http://lists.bestpractical.com/search.html) and read all
the postings concerning the “You’re almost there!” page, but none has
helped.

I’ve already went to www.fastcgi.com for help.

Are there any log files that I can look at to see any errors to
trouble-shoot? The “You’re almost there!” page doesn’t provide much
information for trouble-shooting.

Using Fedora Core 4 distrubution.

more /proc/version

Linux version 2.6.11-1.1369_FC4smp
(bhcompile@decompose.build.redhat.com) (gcc version 4.0.0 20050525 (Red
Hat 4.0.0-9)) #1 SMP Thu Jun 2 23:08:39 EDT 2005

/etc/httpd/conf/httpd.conf
LoadModule fastcgi_module modules/mod_fastcgi.so
NameVirtualHost *:80
<VirtualHost *:80>
ServerName support.ladotek.com
DocumentRoot /opt/rt3/share/html/
ErrorLog /var/log/httpd-rt-error.log
CustomLog /var/log/httpd-rt.log common
AddHandler fastcgi-script .fcgi
Alias /rt/ /opt/rt3/share/html/
Alias /NoAuth/ /opt/rt3/share/html/NoAuth/
<Directory /opt/rt3/bin>
Order allow,deny
Allow from all

<Location /rt/NoAuth/images>
SetHandler default-handler


FastCgiIpcDir /tmp
FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120
ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi

RT_SiteConfig.pm
Set($WebPath , “/rt”);
Set($WebBaseURL , “http://support.ladotek.com:80”);
Set($WebURL , $WebBaseURL . $WebPath . “/”);

[Tue Jun 28 10:46:23 2005] [notice] suEXEC mechanism enabled (wrapper:
/usr/sbin/suexec)
[Tue Jun 28 10:46:24 2005] [notice] Digest: generating secret for digest
authentication …
[Tue Jun 28 10:46:24 2005] [notice] Digest: done
[Tue Jun 28 10:46:24 2005] [notice] LDAP: Built with OpenLDAP LDAP SDK
[Tue Jun 28 10:46:24 2005] [notice] LDAP: SSL support unavailable
[Tue Jun 28 10:46:24 2005] [notice] FastCGI: process manager initialized
(pid 13318)
[Tue Jun 28 10:46:24 2005] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 13319)
[Tue Jun 28 10:46:24 2005] [notice] mod_python: Creating 4 session
mutexes based on 256 max processes and 0 max threads.
[Tue Jun 28 10:46:24 2005] [notice] Apache/2.0.54 (Fedora) configured –
resuming normal operations


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Raymond Walters
Software Developer
Kiff Analytical, LLC
Office: 530.297.4800 ext.126

www.kiffanalytical.com
Leaders in Analytical Science and Service

What is your WebPath set to in RT_SiteConfig.pm?

Perhaps you a trailing slash there is causing the problem?

Mine is: Set($WebPath , “/support”);On Wed, 29 Jun 2005, Ray Walters wrote:

I don’t know if this will solve your problem or not, since I don’t use
fastcgi, but I had a problem almost identical to yours and I found this fixed
it:

RewriteEngine On
RewriteRule ^(.*)/$ $1/index.html

Hope this helps,

Ray

David Doran wrote:

Thanks David Skrede and Gavin Henry for the help…

I have RT3 working with FC4 but only if I use trailing “/”. Just like you
described, the following works:

  http://support/rt/

but not: http://support/rt
I’ve been trying to find a work around for this problem but haven’t yet.
For now, I’ll just use http://support/rt/

If anyone has a fix for this problem, please let me know.

Thanks,

David Doran

-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of
Skrede@TWT.com
Sent: Tuesday, June 28, 2005 2:42 PM
To: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] FC4 - You’re almost there!

I had a very similar problem with CenOS/RHEL 4. The problem ended up being
a typo (and possibly a misconfiguration, but it works now so I’m not
complaining).
Going to “http://mysite.com/rt” gave me a login screen, after logging in I
received the “You’re almost there!” page.
Going to “http://mysite.com/rt/” gave me a login screen where logging in
actually worked.
I also went through several versions of httpd.conf., here is my httpd.conf:
LoadModule fastcgi_module modules/mod_fastcgi.so
FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120 ScriptAlias
/rt /opt/rt3/bin/mason_handler.fcgi
NameVirtualHost *:80 <VirtualHost *:80> ServerAdmin root
DocumentRoot /opt/rt3/share/html/ #DocumentRoot /var/www/html/

Adding the following for RT (the ticket tracker) AddHandler

fastcgi-script fcgi <Directory “/opt/rt3/share/html”>
Options FollowSymLinks ExecCGI AllowOverride None
# Pass through requests to display images
Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/

Hope this helps.
david skrede skrede@twt.com
----- Forwarded by David Skrede/MSN/TWT on 06/28/2005 02:38 PM -----
“David Doran” david.doran@ladotek.com Sent by:
rt-users-bounces@lists.bestpractical.com 06/28/2005 11:16 AM
To: rt-users@lists.bestpractical.com cc:
Subject: [rt-users] FC4 - You’re almost there!

Please Reply!
I’m getting the login page, but when I login, I’m redirected to the
"You’re almost there!" page. I understand it has to do with the fastcgi
setup with apache. I’ve searched
(http://lists.bestpractical.com/search.html) and read all
the postings concerning the “You’re almost there!” page, but none has
helped.
I’ve already went to www.fastcgi.com for help.
Are there any log files that I can look at to see any errors to
trouble-shoot? The “You’re almost there!” page doesn’t provide much
information for trouble-shooting.

Using Fedora Core 4 distrubution.

more /proc/version

Linux version 2.6.11-1.1369_FC4smp
(bhcompile@decompose.build.redhat.com) (gcc version 4.0.0 20050525 (Red
Hat 4.0.0-9)) #1 SMP Thu Jun 2 23:08:39 EDT 2005

/etc/httpd/conf/httpd.conf
LoadModule fastcgi_module modules/mod_fastcgi.so
NameVirtualHost *:80
<VirtualHost *:80>
ServerName support.ladotek.com
DocumentRoot /opt/rt3/share/html/
ErrorLog /var/log/httpd-rt-error.log
CustomLog /var/log/httpd-rt.log common
AddHandler fastcgi-script .fcgi
Alias /rt/ /opt/rt3/share/html/
Alias /NoAuth/ /opt/rt3/share/html/NoAuth/
<Directory /opt/rt3/bin>
Order allow,deny
Allow from all

<Location /rt/NoAuth/images>
SetHandler default-handler


FastCgiIpcDir /tmp
FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120
ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi

RT_SiteConfig.pm
Set($WebPath , “/rt”);
Set($WebBaseURL , “http://support.ladotek.com:80”);
Set($WebURL , $WebBaseURL . $WebPath . “/”);

[Tue Jun 28 10:46:23 2005] [notice] suEXEC mechanism enabled (wrapper:
/usr/sbin/suexec)
[Tue Jun 28 10:46:24 2005] [notice] Digest: generating secret for digest
authentication …
[Tue Jun 28 10:46:24 2005] [notice] Digest: done
[Tue Jun 28 10:46:24 2005] [notice] LDAP: Built with OpenLDAP LDAP SDK
[Tue Jun 28 10:46:24 2005] [notice] LDAP: SSL support unavailable
[Tue Jun 28 10:46:24 2005] [notice] FastCGI: process manager initialized
(pid 13318)
[Tue Jun 28 10:46:24 2005] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 13319)
[Tue Jun 28 10:46:24 2005] [notice] mod_python: Creating 4 session
mutexes based on 256 max processes and 0 max threads.
[Tue Jun 28 10:46:24 2005] [notice] Apache/2.0.54 (Fedora) configured –
resuming normal operations


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com


Raymond Walters
Software Developer
Kiff Analytical, LLC
Office: 530.297.4800 ext.126

www.kiffanalytical.com
Leaders in Analytical Science and Service


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com