Fastcgi with rt3

Hi,

I’ve just installed request tracker 3.0.1 on Red Hat 7.3 but can’t get the
web interface going. I’m using mod_fastcgi-2.4.0 instead of mod_perl so as
to use DSO with rpm-installed apache-1.3.23. Postgresql 7.2.1 is my backend
database system.

This is the error I’m getting from apache’s error_log:

[Sat May 17 13:40:56 2003] [notice] Accept mutex: sysvsem (Default:
sysvsem) Insecure dependency in require while running setgid at
/opt/rt3/lib/RT/I18N.pm line 82.
Compilation failed in require at /opt/rt3/bin/mason_handler.fcgi line 28.

But I’ve already installed perl-suidperl to make setgid to work.

I think I’ve installed all the dependencies as the script
’rt-test-dependencies --with-postgres --with-fastcgi’ found all modules it
searched.

Here are the directives I’ve added to the default Red Hat httpd.conf:

LoadModule fastcgi_module /usr/lib/apache/mod_fastcgi.so
AddModule mod_fastcgi.c

AddHandler fastcgi-script fcgi fcg fpl

<VirtualHost 10.0.0.1>
ServerName myhost.digitaleyecandy.biz
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8
Options All

FastCgiServer /opt/rt3/bin/mason_handler.fcgi
Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/
ScriptAlias / "/opt/rt3/bin/"

What’s wrong with my setup?

Benj

Benjamin Oris Jr wrote:

I’ve just installed request tracker 3.0.1 on Red Hat 7.3 but can’t get the
web interface going. I’m using mod_fastcgi-2.4.0 instead of mod_perl so as

[Sat May 17 13:40:56 2003] [notice] Accept mutex: sysvsem (Default:
sysvsem) Insecure dependency in require while running setgid at
/opt/rt3/lib/RT/I18N.pm line 82.

Upgrade to 3.0.2, this is believed to have been corrected there.
�|� http://www.bestpractical.com/rt – Trouble Ticketing. Free.