FastCGI Install Info for RT 2.0.X series

Recently I switch from mod_perl to Mod_FastCGI for apache. For all of you
interested here is the config I used to get it all working.

The next two lines should go in your config anywhere after the
standard mod_fcgi load statements (if you load via a DSO) but before your
virtual host settings.

AddHandler fastcgi-script fcgi
FastCgiServer /usr/local/rt/bin/mason_handler.fcgi

Here is the only line you need to add to your virtual host config

ScriptAlias /rt2/ /usr/local/rt/bin/mason_handler.fcgi/

In the above example I am accessing RT via https://blah.com/rt2/ if you
want to use https://blah.com instead then your ScriptAlias line should
look like the one below…

ScriptAlias / /usr/local/rt/bin/mason_handler.fcgi/

Make sure to change any of the path statements to match where you installed
RT.

If you do not use the AddHandler and the FastCgiServer commands then
apache will not keep the mason_handler.fcgi program running between
requests. If the handler is not running between requests RT2 will run very
very slowly.

The config above worked very nicely for my install on Solaris 8 with
Apache 1.3.19/mod_perl/mod_php4/mod_ssl/+extra modules, YMMV.

FastCGI seems just as fast if not slightly faster than when we were using
mod_perl. The only problem I have seen so far with FastCGI is that the RT
logo does not show up however there have been a few posts to the rt-devel
list recently which should fix that, search the archives if you did not
see the posts.

-Sanity

Woo-hoo!

As it turns out, the delays I was experiencing with fast_cgi were due to
the missing “AddHandler” and “FastCgiServer” options. I guess
something can be said for RTFM afterall. :slight_smile:

With those in place, I am seeing rendering of < 1sec per page.

FastCGI definitely has a lot over mod_perl. :slight_smile:

Just an FYI, you can put the AddHandler and FastCgiServer options
within the VirtualHosts directive, but keep in mind that it would
restrict the FastCGI operation to only that VirtualHost…

-Rich

Sanity wrote:

Recently I switch from mod_perl to Mod_FastCGI for apache. For all of you
interested here is the config I used to get it all working.

The next two lines should go in your config anywhere after the
standard mod_fcgi load statements (if you load via a DSO) but before your
virtual host settings.

AddHandler fastcgi-script fcgi
FastCgiServer /usr/local/rt/bin/mason_handler.fcgi

Here is the only line you need to add to your virtual host config

ScriptAlias /rt2/ /usr/local/rt/bin/mason_handler.fcgi/

In the above example I am accessing RT via https://blah.com/rt2/ if you
want to use https://blah.com instead then your ScriptAlias line should
look like the one below…

ScriptAlias / /usr/local/rt/bin/mason_handler.fcgi/

Make sure to change any of the path statements to match where you installed
RT.

If you do not use the AddHandler and the FastCgiServer commands then
apache will not keep the mason_handler.fcgi program running between
requests. If the handler is not running between requests RT2 will run very
very slowly.

The config above worked very nicely for my install on Solaris 8 with
Apache 1.3.19/mod_perl/mod_php4/mod_ssl/+extra modules, YMMV.

FastCGI seems just as fast if not slightly faster than when we were using
mod_perl. The only problem I have seen so far with FastCGI is that the RT
logo does not show up however there have been a few posts to the rt-devel
list recently which should fix that, search the archives if you did not
see the posts.

-Sanity

Richard West $14.95 Registrations mailto:rwest@wesmo.com
Wesmo Computer Services .com .net .org .tv .cc http://www.wesmo.com
Full Domain & Web Hosting .BIZ .INFO & MORE!!

I realized that I have been doing the same thing (i.e., using the FastCGI
handler without the AddHandler and FastCgiServer directives specified for
Apache. But when I add them in, it breaks RT. I get the following message
in my Apache error_log file:

[Sun Oct 21 15:28:19 2001] [error] [client 63.205.xxx.yyy] (2)No such file
or directory: FastCGI: incomplete headers (0 bytes) received from server
"/usr/local/rt2/bin/mason_handler.fcgi"

About 1/4 of the time, I also get what should have been returned to the
web client (namely, the HTML login page) also in error_log. Usually the
"incomplete headers" business with FastCGI means that the client isn’t
correctly outputting HTTP headers, but that doesn’t appear to be the case
here. I have tried messing around with the various timeout settings for
the FastCGI directives in httpd.conf, but I’ve had no success. I’m using
the latest FastCGI (2.2.10) with Apache 1.3.19. I know that the FastCGI
mod works because I’m using a couple of other FastCGI apps with no
problems.

The “no such file or directory” bit of the error message has me confused,
too. I’m not sure which file or directory is being referenced. Maybe some
kind of permissions problem?

Any suggestions?

Thanks,

Jeremy.On Sun, 21 Oct 2001, Rich West wrote:

Woo-hoo!

As it turns out, the delays I was experiencing with fast_cgi were due to
the missing “AddHandler” and “FastCgiServer” options. I guess
something can be said for RTFM afterall. :slight_smile:

With those in place, I am seeing rendering of < 1sec per page.

FastCGI definitely has a lot over mod_perl. :slight_smile:

Just an FYI, you can put the AddHandler and FastCgiServer options
within the VirtualHosts directive, but keep in mind that it would
restrict the FastCGI operation to only that VirtualHost…

-Rich

Sanity wrote:

Recently I switch from mod_perl to Mod_FastCGI for apache. For all of you
interested here is the config I used to get it all working.

The next two lines should go in your config anywhere after the
standard mod_fcgi load statements (if you load via a DSO) but before your
virtual host settings.

AddHandler fastcgi-script fcgi
FastCgiServer /usr/local/rt/bin/mason_handler.fcgi

Here is the only line you need to add to your virtual host config

ScriptAlias /rt2/ /usr/local/rt/bin/mason_handler.fcgi/

In the above example I am accessing RT via https://blah.com/rt2/ if you
want to use https://blah.com instead then your ScriptAlias line should
look like the one below…

ScriptAlias / /usr/local/rt/bin/mason_handler.fcgi/

Make sure to change any of the path statements to match where you installed
RT.

If you do not use the AddHandler and the FastCgiServer commands then
apache will not keep the mason_handler.fcgi program running between
requests. If the handler is not running between requests RT2 will run very
very slowly.

The config above worked very nicely for my install on Solaris 8 with
Apache 1.3.19/mod_perl/mod_php4/mod_ssl/+extra modules, YMMV.

FastCGI seems just as fast if not slightly faster than when we were using
mod_perl. The only problem I have seen so far with FastCGI is that the RT
logo does not show up however there have been a few posts to the rt-devel
list recently which should fix that, search the archives if you did not
see the posts.

-Sanity

Jeremy M. Smith jeremy@ucdavis.edu
Technical Support Manager, Programmer
University of California, Davis
Languages and Literatures
Language Learning Center

Can you send your exact config lines? Note that the ScriptAlias line
needs a “/” after “.fcgi”.

Marc Hedlund
e: marc at precipice dot orgOn Sun, 21 Oct 2001, Jeremy M. Smith wrote:

I realized that I have been doing the same thing (i.e., using the FastCGI
handler without the AddHandler and FastCgiServer directives specified for
Apache. But when I add them in, it breaks RT. I get the following message
in my Apache error_log file:

[Sun Oct 21 15:28:19 2001] [error] [client 63.205.xxx.yyy] (2)No such file
or directory: FastCGI: incomplete headers (0 bytes) received from server
"/usr/local/rt2/bin/mason_handler.fcgi"

About 1/4 of the time, I also get what should have been returned to the
web client (namely, the HTML login page) also in error_log. Usually the
"incomplete headers" business with FastCGI means that the client isn’t
correctly outputting HTTP headers, but that doesn’t appear to be the case
here. I have tried messing around with the various timeout settings for
the FastCGI directives in httpd.conf, but I’ve had no success. I’m using
the latest FastCGI (2.2.10) with Apache 1.3.19. I know that the FastCGI
mod works because I’m using a couple of other FastCGI apps with no
problems.

The “no such file or directory” bit of the error message has me confused,
too. I’m not sure which file or directory is being referenced. Maybe some
kind of permissions problem?

Any suggestions?

Thanks,

Jeremy.

On Sun, 21 Oct 2001, Rich West wrote:

Woo-hoo!

As it turns out, the delays I was experiencing with fast_cgi were due to
the missing “AddHandler” and “FastCgiServer” options. I guess
something can be said for RTFM afterall. :slight_smile:

With those in place, I am seeing rendering of < 1sec per page.

FastCGI definitely has a lot over mod_perl. :slight_smile:

Just an FYI, you can put the AddHandler and FastCgiServer options
within the VirtualHosts directive, but keep in mind that it would
restrict the FastCGI operation to only that VirtualHost…

-Rich

Sanity wrote:

Recently I switch from mod_perl to Mod_FastCGI for apache. For all of you
interested here is the config I used to get it all working.

The next two lines should go in your config anywhere after the
standard mod_fcgi load statements (if you load via a DSO) but before your
virtual host settings.

AddHandler fastcgi-script fcgi
FastCgiServer /usr/local/rt/bin/mason_handler.fcgi

Here is the only line you need to add to your virtual host config

ScriptAlias /rt2/ /usr/local/rt/bin/mason_handler.fcgi/

In the above example I am accessing RT via https://blah.com/rt2/ if you
want to use https://blah.com instead then your ScriptAlias line should
look like the one below…

ScriptAlias / /usr/local/rt/bin/mason_handler.fcgi/

Make sure to change any of the path statements to match where you installed
RT.

If you do not use the AddHandler and the FastCgiServer commands then
apache will not keep the mason_handler.fcgi program running between
requests. If the handler is not running between requests RT2 will run very
very slowly.

The config above worked very nicely for my install on Solaris 8 with
Apache 1.3.19/mod_perl/mod_php4/mod_ssl/+extra modules, YMMV.

FastCGI seems just as fast if not slightly faster than when we were using
mod_perl. The only problem I have seen so far with FastCGI is that the RT
logo does not show up however there have been a few posts to the rt-devel
list recently which should fix that, search the archives if you did not
see the posts.

-Sanity

Jeremy M. Smith jeremy@ucdavis.edu
Technical Support Manager, Programmer
University of California, Davis
Languages and Literatures
Language Learning Center


rt-devel mailing list
rt-devel@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-devel