FastCGI Error * incomplete header

The other day my RT setup decided to stop working. My users were
complaining about Server Internal 500 errors. I looked through the logs
(rt_error, rt_access and my Apache logs) and saw a bunch of errors from
FastCGI. I searched through the mail list archive and found a lot of
messages just like mine which showed these errors:

[Mon Jun 04 11:30:14 2007] [error] [client 172.31.6.95] FastCGI:
incomplete headers (0 bytes) received from server
"/opt/rt3/bin/mason_handler.fcgi"
[Mon Jun 04 14:26:42 2007] [error] [client 172.31.6.95] FastCGI: comm
with server “/opt/rt3/bin/mason_handler.fcgi” aborted: idle timeout (305
sec)
[Mon Jun 04 14:26:43 2007] [error] [client 172.31.6.95] FastCGI:
incomplete headers (0 bytes) received from server
"/opt/rt3/bin/mason_handler.fcgi"

I set the idletimeout to 305 based on a reply from someone in the mail
archive. I also increased the processes to 15. But none of this has
worked yet. I can’t even get the login page to come up. When this fiasco
started I could at least get the login page up. like I said this
started the other day and after I stopped the web server a few times
things went back to normal until this morning when a user tried to
login.

I am running Fedora Core 4 and mysql 4.11 with RT 3.4.5.

Anyone have a pointer on where to check things out?

TIA

John J. Boris, Sr.
JEN-A-SyS Administrator
Archdiocese of Philadelphia

“Remember! That light at the end of the tunnel
Just might be the headlight of an oncoming train!”