FastCGI and OS X

Please forgive what may be a stupid question. I’m trying to get FastCGI to work
on Mac OS 10.2.3. I’ve gotten RT all installed, all the dependencies worked out,
and the virtual hosts configured with the following:

LoadModule fastcgi_module libexec/httpd/mod_fastcgi.so
AddModule mod_fastcgi.c
AddHandler fastcgi-script fcgi

DocumentRoot /opt/rt3/html AddHandler fastcgi-script fcgi fcp fpl ServerName rt SetHandler fastcgi-script FastCgiServer /opt/rt3/bin/mason_handler.fcgi ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/ Alias /NoAuth/images/ /opt/rt3/html/NoAuth/images/ ErrorLog /Users/josh/Documents/logs/rt.log

I installed FastCGI as a DSO, and placed it correctly. However, when I try to
load the RT web interface, I get this error:

FastCGI: comm with server “/opt/rt3/bin/mason_handler.fcgi” aborted: idle
timeout (30 sec)

I’ve searched up and down on this list’s archive, as well as others for FastCGI.
I’ve seen the problem mentioned twice, but never with an answer following. This
leads me to believe that there is something very simple I have missed.

Thank you for any help you can provide.

Mac OS X’s perl can’t handle setgid perl scripts.

make fixperms-nosetgid will leave your config file open to perusing by
local users. (It has your database password in it) but will let you run
RT.On Mon, Jan 13, 2003 at 05:55:03PM -0500, Josh Levinger wrote:

Please forgive what may be a stupid question. I’m trying to get FastCGI to work
on Mac OS 10.2.3. I’ve gotten RT all installed, all the dependencies worked out,
and the virtual hosts configured with the following:

LoadModule fastcgi_module libexec/httpd/mod_fastcgi.so
AddModule mod_fastcgi.c
AddHandler fastcgi-script fcgi

DocumentRoot /opt/rt3/html AddHandler fastcgi-script fcgi fcp fpl ServerName rt SetHandler fastcgi-script FastCgiServer /opt/rt3/bin/mason_handler.fcgi ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/ Alias /NoAuth/images/ /opt/rt3/html/NoAuth/images/ ErrorLog /Users/josh/Documents/logs/rt.log

I installed FastCGI as a DSO, and placed it correctly. However, when I try to
load the RT web interface, I get this error:

FastCGI: comm with server “/opt/rt3/bin/mason_handler.fcgi” aborted: idle
timeout (30 sec)

I’ve searched up and down on this list’s archive, as well as others for FastCGI.
I’ve seen the problem mentioned twice, but never with an answer following. This
leads me to believe that there is something very simple I have missed.

Thank you for any help you can provide.


rt-devel mailing list
rt-devel@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-devel

»|« http://www.bestpractical.com/rt – Trouble Ticketing. Free.

Jesse, thanks for your help, but I’m still experiencing the same problem. I’m
sure the fix you provided will fix some future problem I’ve yet to unearth.

Interestingly, if I try to run masonhandler.fcgi alone, it gives me a terse
"Abort."

Is this even worth the trouble, or should I set about recompiling Apache with
mod_perl statically linked? If I do that, will it still start from within System
Preferences, or will it require extra mojo?

Thanks.

Josh Levinger