Experiences with RT 3.0 and RTFM 2.0 beta

I’ve installed RT3.0 (Release version) with Apache 2 and mod_perl 2.0 on a
Red Hat 8 box. RT3.0 seems to work very well, although I had some problems
getting it to work. Here is a description of the problems:

  1. “[warning]: [Mason] Cannot resolve file to component:
    /var/www/error/HTTP_FORBIDDEN.html.var (is file outside component root?)”

RT3 was installed in /usr/local/rt3, but Apache’s home directory is
/var/www. When error messages have to be issued, RT can’t find the
/var/www/error directory because mason says it’s not within the scope of
ComponentRoot. I solved this by linking the error directory to
/usr/local/rt3/share/html/error, and copying the Apache options for that
directory into RT’s virtual host configuration. Even then, the error pages
do appear, but all languages at once, instead of just the current language.

  1. “Directory index forbidden by rule: /usr/local/rt3/share/html/”

The directory addresses (i.e. urls ending in /), where we expect Apache to
go to the index.html file, did not work. No matter what options I set,
Apache either gives “directory display not permitted” or it does a
directory display, which in neither case is the right thing. I finally
solved the problem by putting a redirect into the virtual host config, like
this:

    RedirectMatch permanent (.*)/$ http://myaddress.com$1/index.html

I don’t know why this happens, but I’ve seen other mentions of this kind of
problem. In any case, the redirect fix works ok.

  1. RT’s localization works quite well, at least so far. This was one of my
    reasons for wanting to switch to 3.0. I haven’t been able to figure out
    approvals yet, but that’s another feature that looks like a good thing to me.

  2. I’ve integrated the RTFM beta with RT, and there, there are a few problems:

  • If I go to RTFM from the main menu, the RT menu items disappear, and I’m
    only in RTFM. This makes it hard to get back to RT. I don’t really yet
    understand fully how to use RTFM, so this may be not a problem.
  • If I’ve switched languages, RT is in the expected language, but there
    seems to be no localization for RTFM, so its messages come out in english
    (except for the occasional message that’s identical to an RT message -
    those get translated).

If anyone has any ideas or comments, please…

Mike

Mike Schmidt Systèmes Scientifiques SEPIA/Intello
President SEPIA Scientific Systems/Intello
Tel: 450-358-2266 100 Richelieu, suite 2000
Fax: 450-358-2267 Saint-Jean-sur-Richelieu
e-mail: mike@sepia.com Québec, Canada J3B 6X3
cell: 514-835-9497
http://www.sepia.com http://www.intello.com

This email message is for the sole use of the intended recipient(s)
and may contain confidential and privileged information.
Any unauthorized review, use, disclosure or distribution is prohibited.
If you are not the intended recipient, please contact the sender by
reply email and destroy all copies of the original message.
To reply to our email administrator directly, select the following
mailto:postmaster@sepia.com

  1. I’ve integrated the RTFM beta with RT, and there, there are a few
    problems:
  • If I go to RTFM from the main menu, the RT menu items disappear, and I’m
    only in RTFM. This makes it hard to get back to RT. I don’t really yet
    understand fully how to use RTFM, so this may be not a problem.

There should be an “RT” or “RT Home” menu option at the top of RTFM’s
menu structure.

  • If I’ve switched languages, RT is in the expected language, but there
    seems to be no localization for RTFM, so its messages come out in english
    (except for the occasional message that’s identical to an RT message -
    those get translated).

RTFM hasn’t yet been internationalized

If anyone has any ideas or comments, please…

Mike


Mike Schmidt Syst�mes Scientifiques SEPIA/Intello
President SEPIA Scientific Systems/Intello
Tel: 450-358-2266 100 Richelieu, suite 2000
Fax: 450-358-2267 Saint-Jean-sur-Richelieu
e-mail: mike@sepia.com Qu�bec, Canada J3B 6X3
cell: 514-835-9497
http://www.sepia.com http://www.intello.com


This email message is for the sole use of the intended recipient(s)
and may contain confidential and privileged information.
Any unauthorized review, use, disclosure or distribution is prohibited.
If you are not the intended recipient, please contact the sender by
reply email and destroy all copies of the original message.
To reply to our email administrator directly, select the following
mailto:postmaster@sepia.com


http://www.bestpractical.com/rt – Trouble Ticketing. Free.

At 06:09 PM 30/03/2003 -0500, Jesse Vincent wrote:

There should be an “RT” or “RT Home” menu option at the top of RTFM’s
menu structure.

You’re absolutely right. I don’t know how I missed that. Thanks. Sorry I
mentioned it.

Mike

Mike Schmidt Systèmes Scientifiques SEPIA/Intello
President SEPIA Scientific Systems/Intello
Tel: 450-358-2266 100 Richelieu, suite 2000
Fax: 450-358-2267 Saint-Jean-sur-Richelieu
e-mail: mike@sepia.com Québec, Canada J3B 6X3
cell: 514-835-9497
http://www.sepia.com http://www.intello.com

This email message is for the sole use of the intended recipient(s)
and may contain confidential and privileged information.
Any unauthorized review, use, disclosure or distribution is prohibited.
If you are not the intended recipient, please contact the sender by
reply email and destroy all copies of the original message.
To reply to our email administrator directly, select the following
mailto:postmaster@sepia.com

“JV” == Jesse Vincent jesse@bestpractical.com writes:

JV> There should be an “RT” or “RT Home” menu option at the top of RTFM’s
JV> menu structure.

Is there some reason that RTFM needs to be installed into RT’s "local"
tree? How then would one alter the RTFM pages for local use?

Also, putting the pages there makes them not exist in the document
root, and then my speedy cgi config fails to run them since the file
doesn’t exist and cannot then be handed to mason…

Vivek Khera, Ph.D. Khera Communications, Inc.
Internet: khera@kciLink.com Rockville, MD +1-240-453-8497
AIM: vivekkhera Y!: vivek_khera http://www.khera.org/~vivek/

“JV” == Jesse Vincent jesse@bestpractical.com writes:

JV> There should be an “RT” or “RT Home” menu option at the top of RTFM’s
JV> menu structure.

Is there some reason that RTFM needs to be installed into RT’s "local"
tree? How then would one alter the RTFM pages for local use?

Not really. It seemed to make sense from a “code purity” standpoint, but
I’m willing to be swayed by rational arguments like yours.

Also, putting the pages there makes them not exist in the document
root, and then my speedy cgi config fails to run them since the file
doesn’t exist and cannot then be handed to mason…

Have a look at what I do in the fastcgi handler to handle that.

-j


=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Vivek Khera, Ph.D. Khera Communications, Inc.
Internet: khera@kciLink.com Rockville, MD +1-240-453-8497
AIM: vivekkhera Y!: vivek_khera http://www.khera.org/~vivek/


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

http://www.bestpractical.com/rt – Trouble Ticketing. Free.

“JV” == Jesse Vincent jesse@bestpractical.com writes:

Also, putting the pages there makes them not exist in the document
root, and then my speedy cgi config fails to run them since the file
doesn’t exist and cannot then be handed to mason…

JV> Have a look at what I do in the fastcgi handler to handle that.

It’s not the handler, it is the apache config… I can’t make apache2
just give all *.html files to a CGI-based handler no matter what I
try, so I just redefined the text/html content type handler. Since
the file doesn’t exist in the doc root, it won’t be handed to the
custom handler.

How do you set up the apache config for fast cgi? I didn’t see it
anywhere I looked on the web or the docs.

“JV” == Jesse Vincent jesse@bestpractical.com writes:

Also, putting the pages there makes them not exist in the document
root, and then my speedy cgi config fails to run them since the file
doesn’t exist and cannot then be handed to mason…

JV> Have a look at what I do in the fastcgi handler to handle that.

It’s not the handler, it is the apache config… I can’t make apache2
just give all *.html files to a CGI-based handler no matter what I
try, so I just redefined the text/html content type handler. Since
the file doesn’t exist in the doc root, it won’t be handed to the
custom handler.

That’s going to break for things like attachment display within RT. You
need to ScriptAlias everything under the rt root to your script.

How do you set up the apache config for fast cgi? I didn’t see it
anywhere I looked on the web or the docs.

Same as for RT 2.0. it’s in fsck.com/rtfm


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

http://www.bestpractical.com/rt – Trouble Ticketing. Free.

“JV” == Jesse Vincent jesse@bestpractical.com writes:

How do you set up the apache config for fast cgi? I didn’t see it
anywhere I looked on the web or the docs.

JV> Same as for RT 2.0. it’s in fsck.com/rtfm

Well, duh. I guess I also expected it in the install docs :wink:

Anyhow, revised SpeedyCGI configs. Only change is to the apache conf
for the virtual host from my earlier posting:

ServerName support.example.com
DocumentRoot "/usr/local/rt3/share/html"
AddDefaultCharset UTF-8

Alias /NoAuth/images /usr/local/rt3/share/html/NoAuth/images
<Directory /usr/local/rt3/bin>
 Options +ExecCGI
</Directory>
Alias / /usr/local/rt3/bin/mason_handler.scgi/

“JV” == Jesse Vincent jesse@bestpractical.com writes:

How do you set up the apache config for fast cgi? I didn’t see it
anywhere I looked on the web or the docs.

JV> Same as for RT 2.0. it’s in fsck.com/rtfm

Well, duh. I guess I also expected it in the install docs :wink:

There’s a reason the manual has a big 'ol “DRAFT” stamp on it.
Expect this to get fixed, along with better permissions documentation
fairly soon.

Anyhow, revised SpeedyCGI configs. Only change is to the apache conf
for the virtual host from my earlier posting:

ServerName support.example.com
DocumentRoot "/usr/local/rt3/share/html"
AddDefaultCharset UTF-8

Alias /NoAuth/images /usr/local/rt3/share/html/NoAuth/images
<Directory /usr/local/rt3/bin>
 Options +ExecCGI
</Directory>
Alias / /usr/local/rt3/bin/mason_handler.scgi/

http://www.bestpractical.com/rt – Trouble Ticketing. Free.