Errors in using rt2 .-(

Hi,

I just installed 1.3-105 .-)
And I think, I have made all important changes (httpd.conf and config.pm),
but I get an internal server error, and in error_log I found:

[error] Undefined subroutine &RT::Mason::handler called.

.-(

Anybody here, who has an idea whats going wrong or could be misconfigured?

TiA
\o/
Michael Thies

It sounds like you haven’t placed the proper “PerlRequire” line for webmux.pl
in your apache configuration file.On Fri, Jun 22, 2001 at 02:21:22PM +0200, Michael Thies wrote:

Hi,

I just installed 1.3-105 .-)
And I think, I have made all important changes (httpd.conf and config.pm),
but I get an internal server error, and in error_log I found:

[error] Undefined subroutine &RT::Mason::handler called.

.-(

Anybody here, who has an idea whats going wrong or could be misconfigured?

TiA

\o/
Michael Thies


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

jesse reed vincent – root@eruditorum.orgjesse@fsck.com
70EBAC90: 2A07 FC22 7DB4 42C1 9D71 0108 41A3 3FB3 70EB AC90

I’m reasonably sure that at least two of the electric blue kangeroos
I saw were real.

Hi Jesse,On Fri, Jun 22, 2001 at 12:47:06PM -0400, Jesse wrote:

It sounds like you haven’t placed the proper “PerlRequire” line for webmux.pl
in your apache configuration file.

hmpf
Nope. The PerlRequire line is set correct.

somehow something is going wrong with the
"PerlHandler RT::Mason"-line .-(

mod_perl is added.

I can’t get it .-(

any hints?

TiA
\o/
Michael Thies

hmpf
Nope. The PerlRequire line is set correct.

somehow something is going wrong with the
"PerlHandler RT::Mason"-line .-(

mod_perl is added.

For grins and chuckles, would you be willing to show us the relevant
portion of your httpd.conf? Also, do you have mod_perl compiled "into"
Apache or is it loaded as a DSO? (I was having very similar problems
until I did the merged-build Apache/mod_perl.)

Karel P Kerezman - IS Admin, Entercom Portland LLC -
http://zero.kgon.com
Serving donuts on another planet.
From the Canonical Fulldeckisms List: http://www.herbison.com/canon

mod_perl is added.

For grins and chuckles, would you be willing to show us the relevant
portion of your httpd.conf? Also, do you have mod_perl compiled "into"
Apache or is it loaded as a DSO?

AddModule mod_perl.c

lol
don’t think, I have to explain more?

although I determined, that it is an apache/1.3.3 .-( ouch
I will install a more recent version on that server.

(I was having very similar problems
until I did the merged-build Apache/mod_perl.)

maybe this (our) apache is very very too old and mod_perl currently
not really buildt.

If I still will have trouble with using rt (on that machine), I will ask
again.

Many thanks for opening my eyes.
\o/
Michael Thies

although I determined, that it is an apache/1.3.3 .-( ouch
I will install a more recent version on that server.

installed a 1.3.20 with mod_perl
started this apache and got:

Can’t locate Apache/DBI.pm in @INC (@INC contains: /usr/lib/perl5/5.00502/i586-linux /usr/lib/perl5/5.00502 /usr/lib/perl5/site_perl/5.005/i586-linux /usr/lib/perl5/site_perl/5.005 . /usr/ /usr/lib/perl) at (eval 3) line 2.

currently found DBI.pm under /usr/lib/perl5/site_perl/5.005/ at
Apache/Session/Store/DBI.pm
i586-linux/Bundle/DBI.pm
i586-linux/DBI.pm

and the apache isn’t started yet .-(

any hints again?
\o/
Michael Thies

Apache::DBI isn’t the same as DBI. This is mentioned in the README.

perl -MCPAN -e’install Apache::DBI’ will fix you right up.On Mon, Jun 25, 2001 at 12:09:41PM +0200, Michael Thies wrote:

On Sat, Jun 23, 2001 at 11:56:29PM +0200, Michael Thies wrote:

although I determined, that it is an apache/1.3.3 .-( ouch
I will install a more recent version on that server.

installed a 1.3.20 with mod_perl
started this apache and got:

Can’t locate Apache/DBI.pm in @INC (@INC contains: /usr/lib/perl5/5.00502/i586-linux /usr/lib/perl5/5.00502 /usr/lib/perl5/site_perl/5.005/i586-linux /usr/lib/perl5/site_perl/5.005 . /usr/ /usr/lib/perl) at (eval 3) line 2.

currently found DBI.pm under /usr/lib/perl5/site_perl/5.005/ at
Apache/Session/Store/DBI.pm
i586-linux/Bundle/DBI.pm
i586-linux/DBI.pm

and the apache isn’t started yet .-(

any hints again?

\o/
Michael Thies


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

jesse reed vincent – root@eruditorum.orgjesse@fsck.com
70EBAC90: 2A07 FC22 7DB4 42C1 9D71 0108 41A3 3FB3 70EB AC90

Pelcgb-serrqbz abj!

I am looking for help setting up QMail and RT.

-Rolf

For grins and chuckles, would you be willing to show us the relevant
portion of your httpd.conf? Also, do you have mod_perl compiled "into"
Apache or is it loaded as a DSO?

AddModule mod_perl.c

lol
don’t think, I have to explain more?

No, you don’t. And this is why it’s not working, you’re loading mod_perl
as an Apache module. Believe me when I tell you that this won’t fly.

although I determined, that it is an apache/1.3.3 .-( ouch
I will install a more recent version on that server.

What you want to do is to get the mod_perl and Apache sources, then
follow the instructions provided in the mod_perl source for building
mod_perl into Apache. Everything gets a whole lot better once you’ve
done so.

Karel P Kerezman - IS Admin, Entercom Portland LLC -
http://zero.kgon.com
All cassette, no tape.
From the Canonical Fulldeckisms List: http://www.herbison.com/canon

Apache::DBI isn’t the same as DBI. This is mentioned in the README.

ouch Yeah, sorry.
I got it working on monday .-)
Upgraded today on 2.0.0.
Now having a problem with the logout. .-(

I installed rt2 not as DocumentRoot of a server and had put it to
/rt2 with an Alias-Directive, configured config.pm this way.

I login to rt2 (mozilla0.9.1 or netscape 4.77 on a debian-system)
using it, perform a logout and get connected to the rt2 as the same user
again (automagically).
The only way to connect as an other user is, to close my browser and starting
a new instance .-(

TiA
\o/
Michael Thies

That sounds like an issue with your WebRT/sessiondata directory not
being properly writable or possibly your CGI::Cookie being out of date.On Wed, Jun 27, 2001 at 11:55:42AM +0200, Michael Thies wrote:

On Mon, Jun 25, 2001 at 09:06:52AM -0400, Jesse wrote:

Apache::DBI isn’t the same as DBI. This is mentioned in the README.

ouch Yeah, sorry.
I got it working on monday .-)
Upgraded today on 2.0.0.
Now having a problem with the logout. .-(

I installed rt2 not as DocumentRoot of a server and had put it to
/rt2 with an Alias-Directive, configured config.pm this way.

I login to rt2 (mozilla0.9.1 or netscape 4.77 on a debian-system)
using it, perform a logout and get connected to the rt2 as the same user
again (automagically).
The only way to connect as an other user is, to close my browser and starting
a new instance .-(

TiA

\o/
Michael Thies


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

jesse reed vincent – root@eruditorum.orgjesse@fsck.com
70EBAC90: 2A07 FC22 7DB4 42C1 9D71 0108 41A3 3FB3 70EB AC90

. . . when not in doubt, get in doubt. – Old Discordian Proveb

Hi,

we just installed perl 5.6.1, and I still have this Problem. .-(
curiously the sessiondata-dir is owned by user 42 after a restart of apache.
and it has groupid of nogroup (group running apache).
sessiondata-dir has file in it (owned by nobody:nogroup).
Doing a logout, I’m back logged in, as the last user .-(On Wed, Jun 27, 2001 at 08:49:45AM -0400, Jesse wrote:

That sounds like an issue with your WebRT/sessiondata directory not
being properly writable or possibly your CGI::Cookie being out of date.

the dir ist now (for testin purposes) chmod 777, nothing helped.
And the CGI::Cookie is Version 1.18.

I don’t get it .-(

Maybe anybody here, who could open my eyes again?

TiA
\o/
Michael Thies

hrm. Try commenting out the chown lines in webmux.pl and chowning the directory
for sessiondata manually?On Mon, Jul 02, 2001 at 12:33:09PM +0200, Michael Thies wrote:

Hi,

we just installed perl 5.6.1, and I still have this Problem. .-(
curiously the sessiondata-dir is owned by user 42 after a restart of apache.
and it has groupid of nogroup (group running apache).
sessiondata-dir has file in it (owned by nobody:nogroup).
Doing a logout, I’m back logged in, as the last user .-(

On Wed, Jun 27, 2001 at 08:49:45AM -0400, Jesse wrote:

That sounds like an issue with your WebRT/sessiondata directory not
being properly writable or possibly your CGI::Cookie being out of date.

the dir ist now (for testin purposes) chmod 777, nothing helped.
And the CGI::Cookie is Version 1.18.

I don’t get it .-(

Maybe anybody here, who could open my eyes again?

TiA

\o/
Michael Thies


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

jesse reed vincent – root@eruditorum.orgjesse@fsck.com
70EBAC90: 2A07 FC22 7DB4 42C1 9D71 0108 41A3 3FB3 70EB AC90

Transporters are so ungodly. if god had wanted us to travel great distances
instantaneously, he would have given us an internal
materialisation/dematerialisation control.
– Shoshe Cole

Hi all,On Mon, Jul 02, 2001 at 10:54:02PM -0400, Jesse wrote:

hrm. Try commenting out the chown lines in webmux.pl and chowning the directory
for sessiondata manually?

Done, but this fscking-Problem still is present.
OK, maybe we have to live with it, because I can perform a browser-shutdown,
if I have to really log out an log in with an other userid in rt.

Each Coworker has its own workstation, and can lock it if he has to.

Maybe some day, I get back at this problem, or we install it on a far more
up-to-date system.

Thanx.

Michael